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1. The User Interface

You can work with the ZWCAD window and its elements in a variety of ways. For example, you can
display and rearrange the toolbars, display the command bar, and enable the status bar. The toolbars
and command bar can also be floated anywhere on the screen or docked to the edges of the main

ZWCAD window. You can customize the menu bar at the top of the window.

The following contents include:

The Application Menu

e The Ribbon

e Quick Access Toolbar

e  Menus and Shortcut Menus
e Toolbars

e The Command Window

e Dynamic Input

e Customize the Drawing Environment

1.1. The Application Menu

Click the Application button to search for commands and have an access to tools used for creating,

opening and publishing a file.

1.1.1. Search for commands

Provide tools used for searching for commands quickly. You can search for commands on the Quick
Access toolbar, in the application menu, and on the ribbon. The search results will be directly displayed
in the application menu. You can enter any language for searching.
BEREREFY « - - @ 2D Drafting & Annotati » | Z
Solid Annotate Insert Views Tools Manage

sp\md

Matched wordsispline

—‘E_L'l Copy Edges

) /) Edit Spline
& /) Edit Spline
Q Snap, Tangent
% Spline

Viewport, Object

Input Zoom to check the matched word In the Application Menu
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1.1.2. Access frequently used tools

The frequently used buttons in the application menu include those common tools used for starting or
publishing a file, such as: New, Open, Etransmit, Save, Save as, Plot, Plot Preview, Close, Options, etc.
NOTE You can close ZWCAD by double-clicking the Application button.

1.1.3. Browse files

View the Recent Documents and Opened Documents lists, or view the thumbnail of an opened file.
- s - @ 2D Drafting & Annotati ~

Solid Annotate Insert Views Tools Manage

B Opened Documents

Smai 'rons -

me Drawing1.dwg

Browse files with Recent or Opened Documents buttons

You can sort the recently used files by the following four ways in the Recent Documents.

e By Ordered List

e By Access Data

e By Size

e By Type
You can display the list of the opened files by using the Large Icons and Small Icons in the Opened
Documents, or you can display the thumbnails of currently opened files by using the Large Images and
Small Images.

NOTE Only saved files can be displayed in the Opened Documents list.



ZWCAD User Guide

1.2. The Ribbon

1.2.1. Tabs and Panels

Under the 2D Drafting& Annotation working space, ribbon will be displayed when you open a file,
providing a tool desired for creating and modifying drawings. The ribbon consists of several panels,
which are organized into each tab according to their task label. The tools and controls in each panel are

also available in toolbars and dialog boxes.

If you click the arrow in the lower right corner of the panel, a dialog box related to this panel will be
opened. On the panel, multiple radio buttons can be collapsed into a single button. If you click the
arrow on the right or at the bottom of the button, all tool buttons in the list will be displayed in a
drop-down method. If you click the button in the list, the previous button will be replaced by this
EREEFE - - @

Home Solid

A Standard

Multiline Spelling
Text ~ 25

button. Lz

- @ 2D Drafting & Annotati ~ i

-t Home Annotate  Insert  Views  Tools  Manage
NG9 ¢ BT

B -0
C Polyline Madify

Line Polyline Circle  Arc Move Copy Stretch Fillet

Y e X

] Rectangle

O Polygon

.
C*u 3D Polyline

Click to launch a dialog box Radio buttons

- @ 2D Drafting & Annotati = ZWCAD 2021 Professional Edition - [Drawing1.dwg]
Solid Annotate Insert Views Toals Manage Export Express Online app+ | B

NCOroemIds e B 5

o [5]

Line Pcyline Cirde Arc Move Copy Stretch Fillet % Erase Multiline __ Layer
: i = = 3 - -0 =5 4

Text~ &2 "  Properties =

Draw Modify Annotation

The Ribbon tabs and panels

1.2.2. Contextual tabs

When you execute some commands or choose objects of a certain type, a special contextual ribbon tab
is displayed in the Ribbon interface instead of a toolbar or dialog box in the Classic interface. When

you end the command, the contextual tab is closed.
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EREFEET « - - @ 2D Drafting & Annotati * | ZWCAD 2021 Professional Edition - [Drawing1.dwg]

Home Solid Annotate Insert Views Tools Manage Export Express Online APP+

= i) = & f
LA |__|- Ed )
Edit Reference  Open Create Delete External
In-Place  Reference Clipping Clip Reference

Edit Block in-place Clip Options

External Reference contextual ribbon tab

1.2.3. Switch between Ribbon and Classic menu

Users can easily switch between the ribbon and classic menus through the button T i the status bar
at the bottom of the platform. The task-based workspace 2D Drafting & Annotation is defined by

default in ZWCAD 2020.

1.3. Quick Access Toolbar

Display the buttons of nine frequently used tools, which are: New, Open, Save, Save As, Plot, Plot
Preview, Undo, Redo and Help. And the workspace switch drop-down list.

EREFETE - - @ 2D Drafting & Annotati ~

Quick Access Toolbar

1.4. Menus and Shortcut Menus

1.4.1. Menus

You can use any of the options on the menu bar at the top of the ZWCAD drawing area in the Classic
interface. To press Alt and the Key for the underlined letter in the menu name to open the

corresponding menu item list, and then choose menu items from it.

For example, to edit the drawing file, press <Alt + E> to open the Edit menu.
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Jv IWCAD 2021 Professional Edition - [Drawinal.dwal

View |Insert Format Jools Draw Dimension Modify Express Window Help

Undo Gzl - |6 & G [DEE |0 & sex
a8 || W Bylayer v

QOops

7

Cut Ctrl+X
i Copy Ctrl+C
Copy with Base Point Ctrl+Shift+C

Paste Special...

Clear Del
Select All Ctrl+A

=&
O
(i
P
©
%]
=
O
&
Al

Menus

1.4.2. Shortcut Menus

Shortcut menus provide quick access to specific commands. A shortcut menu displays when you
right-click an object, toolbar, status bar, the Model tab name, or a Layout tab name. The selections

presented in the shortcut menu depend on what you clicked.

When you right-click a toolbar, the program displays a shortcut menu that lets you toggle the toolbars
on and off. If you select one or more objects and then right click, the program displays a shortcut menu

from which you can choose a command to modify the selected objects.

Nin Help

[ & st -2

peat RECTANG

Shortcut menus for toolbars Shortcut menus for entities

To quickly access the relevant commands currently performed, you can right-click on a different area
on the drawing window to display the different shortcut menu, with the shortcut menu you can speed

up the access.

10
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To display a shortcut menu from which you can choose an object snap and track, press and hold down

the Shift key, and then right-click anywhere within the drawing window.

— Temporary track point

i Erom
hdid Between 2 Paints

Point Filters

Quadrant
Tangent
Perpendicular

Parallel

Shift + right-click to display shortcut menus for snapping

1.4.3. LastInput

"Last Input" option is used for recording the recent manipulations, from the Last Input list on right
click menu, you can view the latest manipulations as well as the previous command options, and also

manipulate commands by directly selecting from the last input list.

11
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Pas

Isolate

Last Input shortcut menus

1.5. Toolbars

Toolbars partially contain buttons that start commands. When you move your mouse or pointing device
over a toolbar button, the tooltip displays the name of the button. The Standard toolbar at the top of the
drawing area is similar to that found in Microsoft® Office programs. It contains commonly used
ZWCAD commands such as COPY, PAN and ZOOM, as well as Microsoft Office standard commands

such as New, Open, and Save.

Standard

X

Standard toolbar

The ZWCAD classic menu initially displays several other toolbars by default:
e  Properties toolbar
e Styles toolbar
e  Modify toolbar
e  Draw toolbar

e Layers toolbar

Bylayer =
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Layer

== B Ral) f

The default toolbars

You can display or hide these toolbars and additional ones. Using CUSTOMIZE command, you can
also create your own toolbars. You can move the floating command window anywhere on the screen
and resize its width and height with the pointing device. Dock the command window by dragging it

until it is over the top or bottom docking region of the ZWCAD window, but you can't change its size.

1.5.1. Displaying and hiding toolbars

When you start ZWCAD classic interface at the first time, multiple toolbars are displayed. ZWCAD
provides more than a dozen toolbars, which you can customize by adding and deleting tools in both
classic and ribbon interfaces. You can also move and resize toolbars, and you can create new toolbars.

You can use a shortcut menu to display or hide toolbars.

To choose which toolbars to display

1. Execute TOOLBAR command to open the Select Toolbars dialog box.
2. Choose the toolbars you want to display, and then click OK.
TIP Right-click anywhere on a docked toolbar to display the toolbar shortcut menu, and then

choose Toolbars.

1.6. The Command Window

The command bar is a dockable window in which you can type ZWCAD commands and view prompts
and other program messages. You can move the command bar by dragging it. When the command bar
is floating, you can drag the top or bottom of the window to change the number of lines of text it

displays. You can dock the command bar at the top or bottom of the drawing.

Displaying and hiding the command line window

1. Please choose Tools->Command Line in Classic interface or
Tools->Palettes->Command Line on the ribbon.

2. You can execute COMMANDLINE/COMMANDLINEHIDE command to display or
hide the command line in both classic and ribbon interfaces.

3. Press ‘CtrI’+'9’ to display or hide it

13
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Properties Ctrl+1 Edition - [Drawingl.dwg]

Design Center Ctrl+2 nline  APP+

Tool Palett Fid o Ctrl+3 E (= Command Line
oo

Command Line Ctrl+8 £ Layer Froperties
Properties Design  Tool e
Dynamic Input Center Palettes [R] Quick Calc

Ciuick Calc 3 Palettes

Displaying and hiding the command line

1.6.1. Enter Commands on the Command Line

Type the full command name on the command line and press ENTER or SPACEBAR. Some

commands also have abbreviated names. Abbreviated command names are called command aliases.

Specify Command Options

Once you have entered a command on the command line, ZWCAD displays either a set of options or a
dialog box. To choose a different option, enter one of the options in the brackets (either uppercase or
lowercase letter is OK), and then press ENTER or SPACEBAR.

Execute Commands

To execute commands, press SPACEBAR or ENTER, or right-click your pointing device when the

command names have been entered or responsive to prompts.

polyline to edit er [Multiple]:

Enter an option [Edit vertices/Close/Decurwe/Fit/Join/Linetype-modefRewerse/Spline/Taper/Width/Undo] <eXits»: E

Enter an option [Next/Prewvious/Angle/Break/Insert/Move/Regen/SElect/Straighten/width/eXit] <Next>:

Enter and execute commands

Repeat and Cancel Commands

If you want to repeat a command that you have just used, press ENTER or SPACEBAR, or right-click

the drawing.

14
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Nesting a command

If you are working in the command bar, you can use another command from within a command, called
nesting. This kind of command is also known as a transparent command. To use a command inside an
active command, type an apostrophe before you type the command, such as ‘osnap. You can nest
commands indefinitely in ZWCAD. Many menu and toolbar macros work this way by default, such as

snap. When you have finished with the nested command, the original command resumes.

For example, you turn on the object snap while you are drawing a circle, thus you can setup Object
snap mode before continuing drawing.

Command: CIRCLE

Specify the center point of circle or [3P/2P/Ttr (tangency tangency radius)]: 'osnap

Resuming command: CIRCLE

Specify the center point of circle or [3P/2P/Ttr (tangency tangency radius)]:

Specify circle radius or [Diameter]:

1.6.2. Enter System Variables on the Command Line

System variables are available for controlling how certain commands work. For example, GRIDMODE
is used to control the status ON or OFF for “GRID” mode; sometimes you use a system variable in

order to change a setting. System variable can be used to display the current status as well.

1.6.3. Edit Within the Command Window

Navigating and Editing Within the Command Window

The standard keys below are provided for navigating and editing text in the command window to
correct or repeat commands.

e UPARROW (1), DOWN ARROW (|), LEFT ARROW («) and RIGHT ARROW (—)

e INS (Insert), DEL (Delete)

e PAGE UP, PAGE DOWN

e HOME, END

e BACKSPACE
Using UP ARROW (1), DOWN ARROW (]) and pressing ENTER, you can repeat any command used

in the current session by cycling through the commands in the command window.

By default, pressing CTRL+C copies highlighted text to the Clipboard. Pressing CTRL+V pastes text

from the Clipboard to the text window or the command window.

If you right-click on the command window or text window, ZWCAD displays a shortcut menu from

15
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which you can copy selected text or the entire command history, select those recently used commands,

paste text, and access the Options dialog box of the Command window.

wnandlineT)

Right click on the command line

In general, a command line with two or three lines of previous prompts is given to several commands,
called the command history, which is sufficient for viewing and editing. To see more than one line of
command history, you can scroll through the history or resize the command window by dragging its

border upwards, or you can press F2 to use the text window.

ommandl inshide

Command text window

The text window is a window similar to the command window in which you can enter commands and
view prompts and messages. With a complete command history for the current ZWCAD session
displayed, the text window can be used to view the lengthy output of commands such as LIST, which

displays detailed information about objects you select.

Docking and Resizing the Command Window

By default, the command window is docked. The docked command window is the same width as the
ZWCAD window. You can resize the window vertically by dragging the splitter bar, which is located
on the top edge of the window when it is docked on the bottom and at the bottom edge of the window
when it is docked at the top. Undock the command window by dragging it away from the docking
region. When you undock the window, the floating window is the size it was before. You can move the
floating command window anywhere on the screen and resize its width and height with the pointing
device. Dock the command window by dragging it until it is over the top or bottom docking region of
the ZWCAD window.
16



ZWCAD User Guide

Modifying a Command

If you are working in the command bar, there are several ways that you can modify a command as you
work. You can modify the active command using any of the following options:

e Object snaps — Type an object snap command, such as nearest or midpoint, to enable a
one-time object snap for a single selection. You can also use a one-time object snap to
override a running object snap.

e Extension snaps — Type int after selecting a command, such as Line or Circle, to enable a
one-time snap to the logical location where two objects would intersect if they were of infinite
length. Type app to enable a similar one time snap if the extensions would not intersect in

three-dimensional space but would intersect in the current view.

Using the Prompt History Window

The Prompt History window displays a history of the commands and prompts issued since you started
the current session of ZWCAD. By default, the program tracks up to 256 command lines.
There is no limit to the number of command lines you can track, but program performance may be

degraded if you choose to track an excessively high number of lines.

e To display or close the Prompt History window: Press F2.
e To view entries in the Prompt History window, do one of the following:
o Drag the scroll bars.
o Use the Up (1) and Down () arrows to display previously used commands.
e To copy or paste text in the Prompt History window, do one of the following to get the text
field that you want:
o Highlight text using your mouse.
o Press Ctrl + Shift + arrow keys to highlight the desired text.
o Right-click and choose whether to copy or paste in the pop-up shortcut menu.

TIP You can also copy the entire command history by choosing Copy History.

1.6.4. Switch between Dialog Boxes and the Command Line

Some functions are both provided similarly though the command line and from a dialog box. In many
cases, you can enter a hyphen in front of the command to suppress the dialog box and display prompts

on the command line instead.

For example, entering LINETYPE on the command line displays the Linetype Manager. Entering
-LINETYPE on the command line displays the equivalent command line options. There may be tiny
17
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differences between the options in the dialog box and those available on the command line.

The system variables below affect the display of dialog boxes as well:

e ATTDIA controls whether INSERT uses a dialog box for attribute value entry.

e EXPERT controls whether certain warning dialog boxes are displayed.

e FILEDIA controls the display of dialog boxes used with commands that read and write files.
For example, if FILEDIA is set to 1, OPEN displays the Open Drawing As dialog box. If
FILEDIA is set to 0, OPEN displays prompt on the command line. Even when you set
FILEDIA to 0, you can get a file dialog box displayed by entering a tilde (~) at the first
prompt.

1.7. Dynamic Input

Dynamic input provides a command tooltips box near the cursor. It provides another method to enter
commands and system variables. The tooltips box will automatically update information near the

cursor.

1.7.1. Enable or Disable Dynamic Input

The function is composed of three sub-functions: Pointer input, Dimension input, and Dynamic prompt.

+E . . .
On the status bar, right-click the Dynamic input button (.) and select Settings to display the Drafting

Settings dialog box, through which you can individually the three functional units in Dynamic Input
tab. Click the Dynamic input button on the status bar or press F12 key to temporarily enable or disable

dynamic input.
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'v Drafting Settings *
Snap and Grid  Object Snap 3D Settings  Polar Tracking  Dynamic Input  Selectior, 1 |+

Enable Dimengion [nput when pozzible

Dimenzion [nput

Settings... Seftings...

Dynamic Prompts

Show command prompting and
command input near the crozshairs

[iafting Tooltip Appearance...

Options. .. Cancel Help

Dynamic Input in Drafting Settings

1.7.2. Pointer Input

Enable pointer input, and the coordinate where the lhair located is displayed in the tooltip next to the
cursor. When the command prompts to specify the second point or next point, you can directly input at

the cursor position.

| ’320-. 0084 l

Pointer input

By default, the pointer input is displayed and inputting with the polar format and relative coordinates.
Use Pointer Input Settings to determine whether the coordinate is displayed in polar format or
Cartesian format, with relative or absolute coordinate. You can also switch between polar format and
Cartesian format with an angel symbol(<) or a comma(,), switch between relative coordinate and

absolute coordinate with a pound sign(#) or an at sign(@).
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1.7.3. Dimension Input

Enable dimension input, when the command prompts to specify the second point, a distance and angel

dimension input is displayed in the tooltip.

85. 8357

Dimension input

When using grip editing to stretch an object, the available dimension input includes:
e Resulting Dimension
e Angel Change
e Length Change
e Arc Radius
e Absolute Angel

iy

| 244, 3646

A: Resulting Dimension; B: Angle Change; C: Length Change; D: Absolute Angle

You can switch between these dimension fields with the TAB key. If only some of the dimension fields

are needed, you can set it in Dimension Input Settings.

For dimension input, after entering one field and press TAB key, if there still other fields to be
specified, a sign will be displayed behind the one already entered, and the cursor is constrained to
move in a specified range. As shown below, after specifying the angle field, the endpoint of the line is

limited to move in the direction of 45 degrees.
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Angle field is locked

1.7.4. Dynamic Prompt

Enable dynamic prompt, the command prompt is displayed near the cursor, and you can respond at the
cursor just as that on the command line. Dynamic prompt has no effect on command line input, you can
still response and input on the command line. When using dynamic input, press Down key to see the
options in command prompt, and a black dot is displayed in front of the selected option, and you can
input it by press ENTER key.

1.8. Customize the Drawing Environment

In ZWCAD, many elements of the working environment can be customized to fit your needs.

1.8.1. Set Interface Options

In the Options dialog box, you can change many of the settings that affect the ZWCAD interface and

drawing environment.

Settings of modifying the interface

e Automatic Save (Open and Save tab) — Save your drawing at specified time intervals. To use
this option, in the Options dialog box, Open and Save tab, select Automatic Save and enter the
interval in minutes.

e  Color Scheme (Display tab): Change interface theme from dark to light.

e Color (Display tab) — Specify the background colors used in the layout and Model tabs and

the color used for prompts and crosshairs.
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e  Grip color (Selection tab): Change color of different types of grip.

e Font (Display tab) — Change the fonts used in the ZWCAD window and in the text window.
This setting does not affect the text in your drawings.

e Search Path (Files tab) — Set the search path ZWCAD uses to find drawing support files such

as text fonts, drawings, linetypes, and hatch patterns.

Controlling size and position of each toolbar or window

After starting ZWCAD, you can fix or adjust position and size of each toolbar or window by dragging.
Software interface includes toolbar, command window, "Properties" palette, "Quick Calculator"

window, "Design Center" window, and so on.

Toolbars can be floating or fixed. The floating toolbar locates in an arbitrary location of the drawing
area of ZWCAD window, can be dragged to its new location, adjust its size or fixed. Fixed toolbar
attaches to any of the edges in the drawing area. Once the toolbar is fixed, its size can't be adjusted.

You can remove the fixed toolbar by dragging it to a new fixing position.

When dragging the command window, "Properties" palette and "DesignCenter" window, buoys will be
displayed in the corners and center position of the drawing area. If not select buoys but dragging the
selected window to an arbitrary position of the drawing area, the window will be on floating state,
which users can adjust the size of the window based on the actual needs. When clicking on one of the
anchored floats in the process of dragging, the location of the window will be fixed to the top, bottom
and left side or right side of a fixed region of ZWCAD window. At this time, the size of the window

can be adjusted in only one direction.

Displaying commands on a shortcut menu

Shortcut menus provide quick access to specific commands. A shortcut menu displays when you
right-click an object, toolbar, status bar, the Model tab name, or a Layout tab name. The selections

presented in the shortcut menu depend on what you clicked.

When you right-click a toolbar, the program displays a shortcut menu that lets you toggle the command
bar, status bar, and various toolbars on and off. If you select one or more objects and then right click,
the program displays a shortcut menu from which you can choose a command to modify the selected
objects. To display a shortcut menu from which you can choose an object snap, press and hold down

the Shift key, and then right-click anywhere within the drawing window.

Using the command bar

The command bar is a dockable window in which you type ZWCAD commands and view prompts and
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other program messages. To display the command bar, choose Tools > Command Line. You can move

the command bar by way of dragging.

When the command bar is floating, you can drag the top or bottom of the window to change the

number of lines of text it displays. You can dock the command bar at the top or bottom of the drawing.

Using the status bar

If you elect not to use the command bar, the status bar displays information about the selected
command or tool. It also displays the current cursor coordinates, mode settings, and other information

about current settings.

In addition to displaying information, the status bar is a quick way to access many features.
You can click status bar items to make changes, and right click items to display shortcut menus that

allow you more choices.

118.5185, -9.153%, 0.0000

Status bar

From left to right :

1. Cursor Coordinates (X,y,z).
Snap Mode.
Grid Display.
Ortho Mode.
Polar Tracking.
Object Snap.
Object Snap Tracking.
Dynamic UCS.
Dynamic input.
Show/Hide Lineweight.
11. Cycle select.

e T A

._
e

12. Model or Paper space.

1.8.2. Save and Restore Profiles

Creating profiles for different users or projects and sharing profiles by importing and exporting profile
files are enabled in ZWCAD.

By default, your current options are stored in a profile named Default. The current profile name, as
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well as the current drawing name, is displayed in the Options dialog box in ZWCAD.

ZWCAD stores the profile information in the system registry and saves it as a text file (an ARG file).
ZWCAD also organizes essential data and maintains changes in the registry as required. If you make
changes to your current profile during a ZWCAD session and you want to save those changes in the
ARG file, you must export the profile. When you export the profile with the current profile name,
ZWCAD updates the ARG file with the new settings. You can re-import the profile into ZWCAD to

update your profile settings.

1.8.3. Customization for User Interface

Abundant customization is provided for users included following elements:

*  Workspaces

*  Quick Access Toolbars

. Ribbon
. Toolbar
o Menus

. Shortcut Menus
*  Keyboard Shortcuts
. LISP Files

. Partial Customization Files

Input ‘CUI’ command to access the Customize User Interface and make relevant modification base on
user’s preference. For example customize a brand new toolbar only with functions you need, change

icon of a function, add or reduce features on the ribbon.

2. Create and Save a Drawing

2.1. Create a New Drawing

When the system variables FILEDIA and STARTUP are set to 1, typing NEW opens New Drawing

dialog box, from which you can use Default Setting, Template or Wizard to create a new drawing.
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MNew Drawving
b |

G| ]

Default Settings

‘ Default Seftings

(1 English [feet and inches)

@ Metric

Tip

Usze the default metric settings.

[¥] Show this dialag when starting up l ] ] | Caticel

A new drawing dialog box
When the FILEDIA and STARTUP are set to 1 and 0 separately, typing NEW opens Select Template
dialog box, from which you can select the desired one or use the default template by clicking the

AIDIMFLIPARROW head button next to the Open button.

/v Select File x
Look in: Template V| = W Yiew *  Tools ¥
B ENETE Tile BIocK (portrat).dwt Preview
= v ANSI B Title Block.dwt
) L2 DIN A0 -Color Dependent Plot Styles.dwt
2 L DIN A1 -Color Dependent Plot Styles.dwt
L- /. DIN A2 -Color Dependent Plot Styles.dwt
/v DIN A3 -Color Dependent Plot Styles.dwt
s+ DIN A4 -Color Dependent Plot Styles.dwt
Deesln 7150 A0 -Color Dependent Plot Styles.dwt
7150 A1 -Color Dependent Plot Styles.dwt
= 7150 A2 -Colar Dependent Plot Styles.dwt
M Dt [ 1SO A3 -Color Dependent Plot Styles.dwt
1 150 A4 -Color Dependent Plot Styles.dwt
3 /v ZWCAD - Named Plot Styles.dwt
o 7o zwead dut
. L ZWCADISO - Named Plot Styles.dwt
Favarites . 2
/v zweadiso.dwt
™
Mehiark
File pams: [MST A Title Block (portrait). et - Open |

File typs: Drawing Template (% dvt) - Cancal

Select template file dialog box

The default drawing template file can be set in the Template Drawing File Path from the Files tab in the
Options dialog box.
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Template drawing file path

2.1.1. Start a Drawing from Scratch

You can select either imperial or metric units for the new drawing if you choose Start from Scratch in

the New Drawing dialog box. The setting you select determines default values which are used for many

system variables controlling text, dimensions, grid, snap, and the default linetype and hatch pattern file.

e Imperial. A new drawing with the imperial measurement system. The drawing uses internal
default values, and the default boundary is 12 x 9 inches.

e Metric. A new drawing with the metric measurement system. The drawing uses internal

default values, and the default boundary is 420 x 297 millimeters.

When you start ZWCAD, there are three options for choosing to draw. You can start from scratch using
default settings, you can start from a template file with a preset environment, or you can use a wizard
to step you through the process, in each case, you can choose the conventions and defaults you want to

use.

To start a drawing from scratch

1. Onthe File menu, click New. (STARTUP=1)
2. Inthe New Drawing dialog box, click Default Settings.
3. Under Default Settings, click either English (feet and inches) or Metric.
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2.1.2. Use a Setup Wizard

From the New Drawing dialog box, you can select "Use a SetupWizard" tab to create a new drawing by
the wizard. There are two wizard options illuminated as follows:
e  Advanced Setup Wizard
From this option, you can set units of measurement, the precision of displayed units, and grid
limits. Also specify angle settings such as units of measurement style, precision, direction, and
orientation based on template zwcadiso.dwt.
e Quick Setup Wizard
From this option, you can specify units of measurement, the precision of displayed units, and

grid limits based on template zwcadiso.dwt.

To begin a new drawing using a wizard

On the File menu, click New.
In the New Drawing dialog box, click Use a Setup Wizard.
Click Quick Setup Wizard or Advanced Setup Wizard.

P w e

Complete the wizard pages using the Next and Back buttons to move forward and
backward.

5. On the last page, click Finish.

2.1.3. Use a Template File

Drawing template files contain standard settings and have a ".dwt" file extension. There are two
methods provided for creating a new drawing when the system variable FILEDIA is set to 1. When the
STARTUP is set to 1, typing NEW opens New Drawing dialog box, from which you can select the

desired template to create a new drawing if you click Use a Template tab.

When the STARTUP is set to 0, typing NEW opens Select Template dialog box, from which you can

select the desired template to create a new drawing.

The changes made to a new drawing based on an existing template file do not affect the template file.

Create a Drawing Template File

When you need to create several drawings with the default settings, you can save time by creating a
template file designed to create the same drawing files so that you do not need to specify default
settings each time you start. Conventions and settings commonly stored in template files include:

e  Unit type and precision
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e Title blocks, borders, and logos
e Layer names

e Snap, Grid, and Ortho settings
e  Grid limits

e Dimension styles

e  Text styles

e Linetypes

Recover the default drawing template file

If you have changed the settings in the template file zwcad.dwt or zwcadiso.dwt, you can reset them by
creating a new drawing with no template and then saving the drawing as a drawing template file in

order to replace zwcad.dwt or zwcadiso.dwt.
When the STARTUP is set to 0, you can also create a new drawing with the original defaults by

clicking the arrowhead next to the Open button to select one of the No Template options from the

Select Template dialog box.

To start a drawing by selecting a template file

1. Onthe File menu, click New.

2. In the Select Template File dialog box, select a template from the list and click
Open.

3. ZWCAD opens the drawing as drawingl.dwg. The default drawing name changes
to reflect the number of new drawings that have been opened. For example, if
you open another drawing from a template, the default drawing name is

drawing2.dwg.

2.2. Open an Existing Drawing

You can open drawing (.dwg) files, Drawing Exchange Format (.dxf) files and drawing template (.dwt)

files. You can also open and check drawings that you suspect are damaged.

To open an existing drawing

On the File menu, click Open.
In Files of Type, choose the type of file you want to open.

Choose the folder containing the desired file.

P w N e

Choose the drawing you want to open, and then click Open. Or double-click the
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drawing you want to open.

TIP You can also open drawings while browsing files on your computer using programs that came
with your operating systems, such as Windows File Explorer or My Computer. Just double-click the
file to get it open in ZWCAD. Easily find the drawing you want by viewing thumbnail images of the

drawing files as you browse them.

TIP To quickly open a drawing file that you recently used, choose File > <file name> from the main

menu.

2.2.1. Find and Open a Drawing File

You can search for a drawing using the name, location, and date filters or properties such as keywords

that you added to the drawing.

Open drawing

Uses Open on the File menu or Standard toolbar to open Select File dialog box, from which you can
select the desired file. You can also open a drawing by dragging a drawing into anywhere outside(apart
from) the drawing area. However, if you drag a drawing into the drawing area of an open drawing, the

new drawing is inserted into the open drawing as a block reference instead of opening it.

You can also double-click drawing to launch ZWCAD program to open it. If ZWCAD is running, the

drawing opens in the current session.

Change the default drawing folder

Each time you launch ZWCAD, the path you specified to open the latest drawing is displayed in each
standard file selection dialog box. You can also specify a default path to ZWCAD by changing the
default drawing folder.

Find a drawing file

Clicking Tools > Find button from the Select File dialog box displays Find dialog box, from which you
can search drawing by name, location and date filters.

You can preview the selected drawing in the Select File dialog box. When the system variable
RASTERPREVIEW is on, a preview image with BMP format is generated and saved with the drawing.
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op
Set the search path

The Files tab of Options dialog box is used by ZWCAD to search drawing support files. The support
files include text fonts, drawings, linetypes and hatch patterns. The system variable
MYDOCUMENTSPREFIX is designed to store the location of My Documents folder for the current

user.

You can also specify the location of temporary files on the Files tab of the Options dialog box.
Temporary files are created on the specified path and then deleted when you exit ZWCAD program.
The default temporary folder is specified for the location that Microsoft Windows uses.

You should specify another location for temporary files when you run ZWCAD in a write-protected
director (for example, if you are working on a network or open files on a CD). The director must not be

written-protected and can provide enough disk space for the temporary files.

Add identifying information to drawings

You can find the specified drawings more easily by adding keywords or other information to them in
the Drawing Properties dialog box opened from the File menu. The drawing properties such as title,
author, subject, keyword or other important information can help identify drawings more easily. You
can also assign hyperlink addresses and multiple custom properties to your drawings.

The Drawing Properties dialog box contains the following drawing information:

e  General. It contains the drawing type, location, size and other information. This information
is stored by the operating system and can be read-only. You can change these values only
through Windows Explorer.

e  Summary. This tap contains the drawing properties such as author, title, and subject.

e  Statistics. The drawing size, created date and latest modified date and other information are
displayed in this tap.

e Custom. Specifies the custom file properties.

2.2.2. Work with Multiple Open Drawings

You can open multiple drawings at one time in ZWCAD. There are several methods for switching a
drawing to another.
e  Acting the drawing by clicking it.
e  Uses shortcut keys of <Ctrl+F6> or <Ctrl+Tab>.
e You can change the display styles to Cascade, Tile Vertically or Tile Horizontally from the
Window menu. You can also use Arrange Icons to align icons if there are several minimum
drawings.
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e  You can quickly reference other drawings to copy and paste between drawings. You can also
use Match command to copy properties from objects in one drawing to objects in another
drawing. Object snaps, the Copy with Basepoint (COPYBASE) command, and the Paste to
Original Coordinates (PASTEORIG) command is used to ensure accurate placement,

especially when copying objects from one drawing to another.

2.2.3. Recover a Damaged File

You can recover some or all of data by reverting to a backup file or using commands to find and correct
errors if a drawing file is damaged. A drawing file may be damaged by a hardware failure, power

outage, and system crash. You can minimize loss by saving files frequently.
ZWCAD can recover a slightly damaged drawing file while opening it.

If a drawing is damaged, you can use RECOVER command to check and attempt to open it. Then uses

AUDIT command to find and correct errors.

Though ZWCAD can recover a damaged drawing file, it is not sure that the recovery drawing is the
same exactly as the original one. You had better create a backup file if the drawing is important. On the
Open and Save tab of Options dialog box, you can specify the backup file are created when you save
drawings and set the proper interval time for saving. Then a backup copy file with a ".bak" extension is
created when you save the named drawing once again. After that, a backup file is always updated while
you executing the command SAVE or SAVEAS.

If ZWCAD exits unexpectedly, it attempts to rename the current backup file in order to avoid covering

the original one.
You can recover a drawing file by saving a ".bak" file to a ".dwg" file.

Files can become damaged for many reasons. For example, if you are working on a drawing during a
power outage, a system crash, or a hardware failure, your drawing file may become damaged. ZWCAD

allows you to open and check damaged files to attempt file recovery.

Recovering a file attempts to open one of the following file types:

e Standard drawing files with a ".dwg" extension.

e Drawing Exchange Format files with a ".dxf" file extension.

e Drawing templates with a ".dwt" file extension.
You can also audit any open file to check it for errors. You specify whether you want ZWCAD to fix
any errors that are found automatically. ZWCAD fixes as many errors as possible and any errors that

cannot be fixed are reported as "Ignored" in the Prompt History window.
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To open a damaged file

Choose File > Drawing Utilities > Recover from the main menu
In Files of Type, choose the type of file you want to recover.
Choose the directory containing the damaged file.

Choose the damaged file you want to recover.

Click Open.

vk W e

To check errors for a drawing file

1. To choose from the opened drawing, click on File > Drawing Utilities > Audit from
the main menu.

2. InputY or N to determine whether to fix the errors that are automatically found
by ZWCAD.

Drawing Recovery

Once terminated by hardware problems, power failure or software problems, the application is capable
of backup the opened drawing file. At the next startup, the program starts "Drawing Recovery"
manager in which all of the auto-backup drawing files that have been closed accidentally will be
displayed. You can open the file of your demand by double-clicking at the Backup File list on the
"Drawing Recovery" if there is any damage to the file, the system attempts to recover the drawing in

process of backup.

When program or system stopped by accident, the drawing files need to recover are sorted into the
following types.

e Recovered drawing file saved when the program fails (DWG)

e Autosaved file, so-called "auto-save" file (zw$)

e Backup file (BAK)

e Source drawing file (DWG)

2.3. Save a Drawing

You save drawing files for later use just as you do with other Microsoft Windows applications. You can

also set up automatic saving and backup files and save only selected objects.

The file extension for drawing files is ".dwg", and unless you change the default file format in which

drawings are saved, drawings are saved in DWG 2013 file format.
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After you have saved your drawing for the first time, you can save it with a new name. In addition to
drawing (.dwg) files, you can also save a drawing in a Drawing Exchange Format (.dxf) file or a

drawing template (.dwt) file.

If you created your drawing using a template, saving the drawing does not alter the original template.

To save a drawing

1. Choose File > Save from the main menu.

TIP

1. When you save a drawing the first time, the program displays the Save Drawing As dialog box so
that you can choose a directory and type a name for the drawing.

2. DWG 2018 format is perfectly compatible with ZWCAD now.

2.3.1. Save Your Drawing Automatically

You can specify to save drawing files automatically in order to minimize the lost data once a problem

occurs.

If you start the automatic save option, your drawing is saved at specified time intervals. By default,
system assigned the name filename.zw$ for temporarily saved files, filename here refers to current

drawing name.
The temporary files are removed automatically when a drawing closes normally. However, these files
are not deleted if there is a program failure or power failure. You can recover the drawing by reverting

to a previous version of your drawing from the automatically saved file. In order to do that, you have to

rename the file using a ".dwg" extension.

2.3.2. Use Backup Files

ZWCAD creates a backup file with the current drawing name and a ".bak" extension to save the

previous version of the current drawing when launching "backup automatically” option.

You can revert to the previous version of your drawing anytime using a ".dwg" extension in place of

the .zw$ extension.
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2.3.3. Save Part of a Drawing File

You can use WBLOCK command to create a new drawing from part of an existing drawing. You can
select entities or a block definition in your current drawing and save them in a new drawing file. The

description also can be saved in the new drawing.

2.3.4. Save to a Different Type of Drawing File

Choose the format from Files Type in the Save Drawing As dialog box, you can save a drawing to an
earlier version of the drawing format (DWG) or drawing interchange format (DXF), or save a drawing

as a template file.

You can save a drawing with a new name and in any of the following file formats:
e Standard drawing files with a ".dwg" extension. You can choose a DWG file format that is
compatible with various versions of AutoCAD.
e Drawing Exchange Format files with a ".dxf" file extension. You can choose a DXF file
format that is compatible with various versions of AutoCAD.
e Drawing templates with a ".dwt" file extension. Drawing templates allow you to easily create

new drawings that reuse your drawing settings and entities.

To save a drawing with a new name or file format

1. Choose File > Save As from the main menu.

2. Inthe Save Drawing As dialog box, under Files of Type, choose the file format.
3. Specify the name of the file you want to create.

4. Click Save.

TIP You can also export drawing files to various file formats.

2.3.5. Reduce the Time Required to Save a Drawing File

In order to reduce the time of saving a drawing file, you can specify the incremental save percentage on
the Open and Save tab of Options dialog box or from the ISAVEPERCENT system variable.

The incremental save updates only the portions of the saved drawing file you changed. Drawing files
will contain a percentage of potentially wasted space when you use incremental saves. This percentage
increases after each incremental save until it reaches the specified maximum value, and then a full save

is performed.

When the ISAVEPERCENT system variable is set to 0, all saves are full saves. This option required
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more time to save a drawing file but can reduce the size of drawing files. It is recommended you

perform a full save before transmitting or archiving a drawing.

2.4. Crash Report

An error report module will intercept any unhandled exception generated by ZWCAD, build a

complete debug report, and optionally send a crash report.

Sending crash report may help assess the stability of ZWCAD software while working in the user
environment, and improve the quality of our product. When errors are encountered in the procedure of
some programs, a dialog box pops up for the user to record the cause of the error and send crash report
automatically created by the software to the assigned email address so as to help us diagnose the cause

of the error and improve our software.

Once the software encounters exceptional shutdown, a folder named BugReport will be automatically
generated under the catalog C:\Users\<Current
User>\AppData\Roaming\ZWSoft\ZWCAD\<Version>\<Language>\CrashReport. If your operating
system is Microsoft Windows 7, the catalog will be X:\Documents and Settings\Current
Usen\Application Data\CrashReport.

One more thing, if your operating system is Microsoft Windows XP, in which all of the compressed
packages generated for the exceptional situations are contained with *.ZCR, *.DMP, * REG as well as
error drawing files included in each package. Here DMP file shares the same name with the

compressed package automatically generated.

2.4.1. Describe Error Contents

When errors occur in the program, a dialog box prompts "ZWCAD.EXE has encountered a problem
and needs to close, we are sorry for the inconveniences" for the user to input descriptions of the
problem in the text window showing "Describe what you were doing when the error occurred",

whereas it is an optional requirement.

2.4.2. View Contents of Error Report Files

Generally, the software generates four error reporting files, individually named as *.ZCR, *.DMP,
* REG and the crashed drawing file itself. In this error report dialog box, you can see the contents of
error reports by clicking on the "Click here" link. You can optionally select a file in the "Error Report

Contents" dialog box, or double-click a file to view its contents.
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2.4.3. Send Error Report

Clicks on "Send Error Report" button on the Error Reporting dialog box, then you can send the

information of assigned error reports to CrashReport@zwcad.com as well as its problem descriptions.
If the network isn't connecting, a prompt box pops up telling you that "The error report wasn't sent,
please send the file to CrashReport@zwcad.com". From this prompt box, you can see the name of error

report file together with its saving path.

Don't Send

Additionally, the user can choose not to send an error report.
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3. Control the Drawing Views

3.1. Redraw and Regenerate a Drawing

As you work on a drawing, visual elements may remain after the completion of a command. You can

remove these elements by refreshing, or redraw, the display.

To redraw (refresh) the current window display

1. Choose View > Redraw from the main menu.

Information about drawing entities is stored in a database as floating point values, ensuring a high level
of precision. Sometimes a drawing must be recalculated, or regenerated, from the floating point
database to convert those values to the appropriate screen coordinates. This occurs automatically. You

can also manually initiate a regeneration. When the drawing is regenerated, it is also redrawn.

To regenerate the current window, type REGEN on the command line. If more than one window is

displayed, type REGENALL to regenerate all the windows.

3.2. Magnify a View (Zoom)

You can use ZOOM command to zoom in or zoom out the drawing view to meet your need. ZOOM
does not change the absolute size of objects in the drawing; it changes only the magnification of the

view.

With this zooming feature, you can change the magnification of your drawing at any time. The cursor
changes to a magnifying glass when a zoom tool is active. Zoom out to reduce the magnification so
you can see more of the drawing, or zoom in to increase the magnification so you can see a portion of

the drawing in greater detail.
NOTE If you are working in a layout viewport and cannot zoom, the layout viewport may be locked.

The scale and view do not change in model space while panning or zooming in a locked layout

viewport.
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3.2.1. Zooming in and out

One of the easiest ways to change the magnification of the drawing is to zoom in or out by a preset
increment. On the Zoom toolbar, the Zoom In tool doubles the current magnification of the drawing.
The Zoom Out tool reduces the magnification of the drawing by half. The portion of the drawing

located at the center of the current viewport remains centered on the screen as you zoom in and out.

Zoom out zoom in

3.2.2. Zooming methods

To zoom, you can use any of the following methods:
e To define the portion of the drawing to zoom, create a window.
e To zoom in real time, use the Zoom Real-time tool on the Standard toolbar.

e Rotate the mouse wheel to zoom in and out.

Zoom to Magnify a Specified Rectangular Area

You can specify a rectangular area defined by two corners to display the objects within that area as

large as possible.

The lower-left corner of the specified area becomes the lower-left corner of the new view.

Zoom in using Window
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To zoom into an area using a window

1. Choose View > Zoom > Window from the main menu.
2. Select one corner of the window around the area you want to magnify.

3. Specify the opposite corner of the window around the area you want to magnify.

Zoom in Real Time

With the Real-time option, you zoom dynamically by moving your pointing device up or down. By

right-clicking, you can display a shortcut menu with additional viewing options.

To zoom in real time

1. Choose View > Zoom > Realtime from the main menu.

2. Hold the left mouse button, then drag the cursor.

3. To zoom in, move the cursor up the screen; to zoom out, move the cursor down
the screen.

4. To stop zooming, release the mouse button.

To zoom using a mouse with a wheel

1. Rotate the wheel away from you to zoom in or toward you to zoom out.
2. Each rotation of the wheel away from you zooms out .8 times; each rotation

toward you zooms in 1.25 times.

3.2.3. Displaying the previous view of a drawing

After you zoom in or pan to view a portion of your drawing in greater detail, you may want to zoom
back out to see the entire drawing. On the View > Zoom menu, the Previous tool lets you restore the
previous view. Selecting this tool repeatedly steps back through up to 25 successive zoomed or panned

views.

3.2.4. Zooming to a specific scale

You can increase or decrease the magnification of your view by a precise scale factor measured relative
to the overall size of the drawing or in relation to the current display. When you change the

magnification factor, the portion of the drawing located at the center of the current viewport remains
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centered on the screen.

To change the magnification of the view relative to the overall size of the drawing, type a number
representing the magnification scale factor. For example, if you type a scale factor of 2, the drawing
appears at twice its original size. If you type a magnification factor of .5, the drawing appears at half its

original size.

You can also change the magnification of the drawing relative to its current magnification by adding an
x after the magnification scale factor. For example, if you type a scale factor of 2x, the drawing
changes to twice its current size. If you type a magnification factor of .5x, the drawing changes to half

its current size.

To zoom to a specific scale relative to the current display

1. Choose View > Zoom > Scale from the main menu. Or

On the Zoom toolbar, click the Zoom Scale. Or

Type ZOOM in the command line, choose the Scale option and then press Enter.
2. Type the scale factor, followed by an x (such as 2x).

3. Press Enter.

3.2.5. Combining zooming and panning

With the Center option, you can scale objects and specify a new view center. You can specify the scale

factor relative to paper space unit or to the current view.

To change the center of the current view

1. Choose View > Zoom > Center from the main menu.
2. Select the point you want to be located at the center of the new view.

3. Specify the zoom scale factor or the height of the drawing in drawing units.

3.2.6. Displaying the entire drawing

ZOOM Extents displays a view that includes all of the objects in the drawing as large as possible. The

view can display the objects on layers that are turned off but do not include objects on frozen layers.

ZOOM All displays all of the objects within either the user-defined limits or the drawing extents,

whichever view is larger.
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You can use the Zoom All tool on the zoom toolbar to display an entire drawing. If you have drawn any
entities outside the defined limits of the drawing, the extents of the drawing are displayed. If you drew

all entities within the limits of the drawing, the drawing is displayed all the way to the drawing limits.

The Zoom Extents tool on the zoom toolbar displays the drawing to its extents, making the image fill

the display to the greatest possible magnification.

3.3. Pan aView

Use PAN command or use the window scroll bars to shift the location of your view.

With the Real-time option of PAN, you pan dynamically by moving your pointing device. Like panning
with a camera, PAN does not change the location or magnification of objects on your drawing; it
changes only the view. By right-clicking, you can display a shortcut menu with additional viewing

options.

You can move the view of a drawing displayed in the current viewport by scrolling, panning, or
rotating the view. Doing this changes the portion of the drawing you are viewing without changing the
current magnification. Scrolling lets you move around in the drawing horizontally and vertically.
Panning lets you move the drawing in any direction. Rotating lets you view your drawing from any

angle.

3.3.1. Using scroll bars

To assist you in navigating within a drawing, horizontal and vertical scroll bars are available in each
drawing window. The size of the scroll box in relation to the scroll bar indicates the current level of
drawing magnification. The position of the scroll box in relation to the scroll bar indicates the location
of the center of the drawing in relation to the extents of the drawing (the smallest rectangle containing

all the entities in the drawing).

3.3.2. Using the Pan command

You can move the drawing in any direction using the pan command. Panning shifts or slides the view
of the drawing horizontally, vertically, or diagonally. The magnification of the drawing remains the

same, as does its orientation in space. The only change is the portion of the drawing displayed.

To pan, you can use any of the following methods:

e  For precise panning, specify two points defining the magnitude and direction of the pan. The
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first point, or base point, indicates the starting point of the pan. The second point indicates the
amount of pan displacement relative to the first point.
e To pan in real time, use the Pan Real-time tool on the Standard toolbar.

e If you have a mouse with a wheel, press and hold the wheel, and then move the mouse.

To pan in real time

1. Choose View > Pan > Realtime from the main menu.
2. Move the cursor in the direction you want to pan.

3. To stop panning, press Enter, ESC or choose Exit from the shortcut menu.

To pan using a mouse with a wheel

1. Press and hold the wheel, and then move the mouse in the direction you want to
pan.
(The MBUTTONPAN system variable controls this feature.)

3.4. Display Multiple Views in Model
Space

Model space viewport is the drawing area that you can divide them into one or more adjacent
rectangular views on the Model tap. Among multiple viewports, you have to make one view current for

executing view commands.

When you begin a new drawing, it is displayed in a single window. You can view the drawing in a
second window, or you can divide one window into multiple windows. You can also open and display

multiple drawings.

3.4.1. Set Model Space Viewports

In large or complex drawings, displaying different views reduces the time needed to zoom or pan in a
single view. Also, errors you might miss in one view may be apparent in the others.

Viewports created on the Model tab completely fill the drawing area and do not overlap. As you make
changes in one viewport, the others are updated simultaneously. Three model space viewports are

shown in the illustration.
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Model space viewports

Use Model Space Viewports

You can do the following operations at the model space viewport:
e Set Grid, and UCS icon modes; Pan; Zoom; and restore named views.
e Save orientations of UCS with individual viewports.
e  When executing a command, you can draw from one viewport to another.
e Name a viewport arrangement in order so you can reuse it on the Model tab or insert it on a
layout tab.
e  When you work on 3D models, it is much help that setting up different UCS in individual

viewports.

Split and Join Model Space Viewports

From the separated viewport, you can continue to split or join them.

The illustrations below show several default model space viewport configurations.
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Horizontal Vertical

Below

Select and Use the Current Viewport

To make the desired viewport the current viewport, you click on it through the existing viewports.
When the cursor stays at the current viewport, it is displayed as crosshairs instead of an arrow. You

cannot change the current viewport when a view command is in progress.

Working with Multiple Views of a Single Drawing

You can open and work with several views of the same drawing simultaneously.

After you divide a single window into multiple windows, you can control each window separately. For
example, you can zoom or pan in one window without affecting the display in any of the other
windows. You can control the grid, snap, and view orientation separately for each window. You can
restore named views in individual windows, draw from one window to another, and name window

configurations individually so you can reuse them later.

As you draw, any changes you make in one window are immediately visible in the others. You can
switch from one window to another at any time, even in the middle of a command, by clicking the

window's title bar.

You can divide a single drawing window into multiple tiled windows (called viewports) on the Model
tab. You can control the number of windows created and the arrangement of the windows. You can also
save and restore named window configurations and display a list of the current and saved window

configurations.

To create multiple views

1. Choose View > Viewports from the main menu.
2. Inviewports menu, choose 1, 2, 3, or 4 viewports.
3. Type h if you want the horizontal orientation, or type v if you want the vertical
orientation.
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To join two views

1. Choose View > Viewports > Join from the main menu.
2. Click anywhere inside the window you want to keep.

3. Click anywhere inside the adjacent window you want to join to the first window.

To restore a named window configuration

1. Type -VPORTS and press ENTER.
2. Onthe command line, type Restore.

3. Type the name of the window configuration you want to restore.

3.5. Work with Multiple Drawings

With the multiple document interface (MDI) feature, you can open more than one drawing in ZWCAD.
Because you can open and work on several drawings at one time, you can copy, cut, or paste an entity

from one drawing to another.

Each drawing appears in a drawing window, which has the following advantages:
¢  You can see two or more drawings side by side.

¢  You can easily copy entities from one drawing to another.

Under the Window menu, the following three methods that determine how drawings are arranged are
provided for user's choice.

e Cascade

e Tile Horizontally

e Tile Vertically
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Tile Vertically

When you work with more than one drawing open in its own window, you can easily, cut, copy, and
paste in between drawings. If you copy an entity from one window to another and then want to undo
that action, you must undo it from the drawing into which you copied the entity. If you cut and paste an

entity and then want to undo that action, you must undo it in both drawings.

3.5.1. Save and Restore Views

You can save views by name and restore them for plotting or when you need to refer to specific details.
A named view is comprised of specific magnification, location, and orientation.

You can also restore up to 10 previous views. When you end drawing, the previous views cannot be
restored. If you want to restore views among sessions, you have to save the drawing along with views

by name.

When you restore views, you can view all saved views along with their information. You can delete

views when you do not need them. A drawing can be saved along with unlimited views.

Save a View

When you name and save a view, the following settings are saved:
e Magnification, center point, and view direction
e The location of the view: the Model tab or a specific layout tab

e Layer visibility in the drawing at the time the view is saved
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e  User coordinate system

e 3D perspective and clipping
If you have divided the drawing window into multiple views, you can save the current window
arrangement so that you can recall it to the screen later. The number and placement of the windows are

saved exactly as they are currently displayed. The settings for each window are also saved.

Restore a Named View

With the -VIEW Restore, you can restore a named view to the current view.
Named views can be used to do the following:
e Restore views on the model space viewport or layout viewport.
e Specify the area to the plot.
e Determined which model space view is displayed when opening the drawing.
You can specify a layout view when you open the drawing only if you save the drawing from that

specified layout tab.

3.6. Specify a 3D View

You can set a 3D view to facilitating verifying the 3D effects of the drawing, constructing and

visualizing 3D models.

An isometric view is a typical viewpoint that helps you create a 3D view which reduces the number of
visually overlapping objects. You can specify a new viewpoint to create new objects or modify the

existing objects.

3.6.1. View a Parallel Projection in 3D

You can view a parallel projection of 3D models at any location in model space.

To determine the angle or viewpoint, you can:
e Select a preset 3D view from the View toolbar.
e Type angles or coordinate that represents the viewing location in 3D.
e  Modify a view of the current UCS, the WCS or a saved UCS.

e  Change the 3D view dynamically using pointing device.

Viewing 3D model is available only in model space. If you are working in paper space, the 3D viewing
commands such as VPOINT and PLAN cannot be used to define paper space views. The view in paper

space is always a plane view.
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The plane view is a view that you look at the origin (0, 0, 0) from a point at the positive Z axis. This
method results in a view of the XY plane. You can restore the view and coordinate system that is the
default for most ZWCAD drawings by setting the UCS orientation to World and then setting 3D views

to Plan View.

3.6.2. Setthe Viewing Direction

You view three-dimensional drawings by setting the viewing direction. The viewing direction
establishes the viewing position, the Cartesian coordinate corresponding to the viewpoint looking back
at the origin point, the 0,0,0 coordinate. When you view a drawing from the default viewpoint (0,0,1),

you see a plan view of the drawing.

You can change the viewing direction to look at the drawing from a different vantage point or to work

on a three-dimensional model from a different orientation.

To set a new viewing direction

Choose View > 3D Views > Viewpoint from the main menu.
Click the preset button.

Click the preset view you want to use.

P w N e

You can set the current viewing direction to the plan view of the current user
coordinate system (UCS), a previously saved UCS, or the World Coordinate System
(WCs).

To dynamically set a view direction

Choose View > 3D Views > Viewpoint from the main menu.
Click the appropriate tools to dynamically change the viewpoint.

To complete the command, click OK.

P w N e

You can dynamically rotate the viewpoint within the XY plane and relative to the
XY plane, and you can pan and zoom the drawing. As you change the viewpoint,

the drawing display automatically updates.

To display a plan view of the current drawing

1. Choose View > 3D Views > Plan View from the main menu.
2. It concludes three plan views: Current UCS, World UCS, and Named UCS. Choose

one what you want.
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3.6.3. Isometric

Choose Preset 3D Views

You can define perspective views of a model to create realistic effects.

Select predefined standard orthographic and isometric views by name or description. These views
represent commonly used options: Top, Bottom, Front, Left, Right, and Back. In addition, you can set
views from isometric options: SW (southwest) Isometric, SE (southeast) Isometric, NE (northeast)

Isometric, and NW (northwest) Isometric.

To understand how the isometric views work, imagine you are looking down at the top of a box. If you
move toward the lower-left corner of the box, you are viewing the box from the SW Isometric View. If

you move toward the upper-left corner of the box, you are viewing it from NW Isometric View.

Draw 2D Isometric Views

With Isometric Snap, you can create 2D objects that appear to be 3D solids.

By setting Isometric Snap on the Draft Settings dialog box and turning on Snap and Grid, you can
easily align objects along one of three isometric planes. However, although the isometric drawing looks
like 3D, it is actually a 2D representation. Therefore, you cannot extract distance and areas, display

objects from different viewports, or delete hidden lines automatically.

Set Isometric Grid and Snap

By aligning along three major axes, isometric drawing simulates a 3D drawing from a specified
viewpoint.
When the snap angle is set to 0, the axes of the isometric plane are 30 degrees, 90 degrees, and 150

degrees.
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With Isometric Snap-on, you can work on any of three isometric planes, each with a pair of associated
axes.
e  Left. The left isometric plane defined by a pair of 90- and 150-degrees axes. The snap and
grips align along the 90- and 150-degree axes.
e Top. The top isometric plane defined by a pair of 30- and 150-degrees axes. The snap and
grips align along the 30- and 150-degrees axes.
e Right. The right isometric plane defined by a pair of 90- and 30-degrees axes. The snap and
grips align along the 90- and 30-degrees axes.

S0 degrees

a0 degrees 150

deqrees

In addition to using ISOPLANE command to switch isometric planes, you can also use shortcut key F5
or CTRL+E. specifying one of the three isometric planes results in Ortho and crosshairs to be aligned

along the corresponding isometric axes.

For example, when Ortho is on, the points you specified align along the simulated plane you are
working on. Therefore, you can draw the top plane first, and switch to the left plane to draw another

side, and then switch to the right plane to complete the drawing.

top plane left plane right plane

Draw Isometric Circles

You can create an isometric circle on the current isometric plane using Ellipse Isocircle. The Isocircle

option is available only when the Isometric Snap is on.
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3.6.4. Define a 3D View with Coordinate Values or Angles

You can define a viewing direction by typing the coordinate values of a point or two rotation angles

(angle from the XY plane and angle from the X-axis).

The specified point indicates your position in 3D space when you view the model while looking toward
the origin (0, 0, 0). The viewpoint coordinate values are relative to the WCS unless you modify the
system variable WORLDVIEW.

The conventions for defining standard views are different among different industries. In architectural
(ARC) design, the perpendicular plane of XY plane is the top view or plan view; in mechanical design,

the perpendicular view is the front view.

DDVPOINT is designed to rotate views to specify a viewing direction.
The following illustration shows a view defined by two angles relative to the X-axis and the XY plane
of the WCS.

z viewpoint  wiew direction

%
| %’/Langlefmm}{‘r plane

—d———angle from X axis
><

¥

3.6.5. Change a 3D View Dynamically

You can view objects from any viewing direction by holding down the mouse or other pointing devices
and moving dynamically. With dynamic viewing, you can display the effects of changing viewpoint

while you change the view.
You can execute move or zoom operations as the 3D Orbit is active.

When the 3D Orbit is active, you are not allowed to modify objects. To close 3D Orbit, press Enter,

ESC or choose Exit from the shortcut menu.

3.6.6. Hide Lines or Shade 3D Objects

Hides or shapes for 3D objects in the current drawing suppresses the display of the objects (partly or
entirely) that are located behind other objects or generates a simply shaded image displayed in the
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current view.

Hide Lines

You can suppress the objects (partly or entirely) that are located behind other objects using Hide.
The system generates wireframe representations including hidden lines when you use VPOINT or
VIEW command to create objects in 3D view. You can use HIDE command to remove the hidden lines

to verify the current placement of these surfaces.

When you view or plot wireframes, complex drawings usually appear too cluttered to convey accurate

information.

Hiding background objects that in reality would be obscured by objects in the front background

simplifies the display of the drawing and clarifies the design. Shown in the following picture:

Before hide Hide
Hiding background lines makes the display much clearer, but you cannot modify hidden-line or render
views. It may take a long time to calculate and obscure hidden lines if the drawing is complex.
However, you can speed up the process in the several ways. For example, you can avoid drawing
details that will not be visible at the scale at which you are displaying or plotting the drawing. You can

also exclude objects from the hiring process by zooming into a part of the drawing.

Remove hidden lines on one or more selected objects to improve performance.

When the system variable DISPSILH is set to 1, HIDE command displays only the silhouette lines of
the objects. It does not display the inside edges generated by a nested face of an object.

When the current view is shaded, hiding lines on solid objects also suppresses drawing the mesh image
and instead displays the objects using wireframe representation with the back lines hidden.
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Add Simple Shading to 3D Objects

Although hiding lines can enhance the drawing and clarifies the design, shading produces a more

realistic image of your model.

You can modify shaded objects as you normally would. When a shaded object is selected, the

wireframe and grips appear on top of the shading.
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4. Precision Tools and the Properties

of Drawing

4.1. Specify Units, Angles, and Scale

Specify the units of measurement you want to use, their format, and other conventions.

4.1.1. Determine Units of Measurement

When you start drawing, you specify the units of measurement, their formats as well as the number of

the decimal fraction.

Drawing Units 7
Length Aingle
Tuvpe: Type:
c i | Decimal degrees VJ
Precision: Precisior:
| 0.0000 - [o ~|
[] Clackwise

Ingertion scale

nits ta scale inzerted content:

Millimeters hd ]

Sample output

1.5.2.0039.0

3450

[ QK ] ’ Cahcel ] [ Liirection... | | Help |

Set the Units Format

You can set the display format of the unit. These formats include scientific, decimal, engineering,
architectural and fractional notation. To enter architectural feet and inches format, you can indicate feet
using the prime symbol ('), for example, 72'3. You do not need to specify inches by entering quotation

marks (").

You can set the unit type and precision in the Quick Setup wizard, the Advanced Setup wizard, or the
Units Control dialog box. These settings control how your coordinate, offset, and distance entries are

interpreted, and how coordinates and distances are displayed.
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The input format of three-dimension coordinates is the same as the input format of the two-dimension

coordinates: scientific, decimal, engineering, architectural and fractional notation.

The unit format for creating and listing objects, measuring distance and displaying coordinate locations

is different from the dimension units setting used in creating dimension values.

With ZWCAD, you typically draw at full size (1:1 scale), and then set a scale factor when you print or
plot your drawing. Before you begin drawing, however, you need to determine the relationship between

drawing units and real-world units.

For example, you can decide whether one linear drawing unit represents an inch, a foot, a meter, or a
mile. In addition, you can specify the way the program measures angles. For both linear and angular
units, you can also set the degree of display precision, such as the number of decimal places or smallest
denominator used when displaying fractions. The precision settings affect only the display of distances,
angles, and coordinates. ZWCAD always stores distances, angles, and coordinates using floating point

accuracy.

Convert Drawing Units

When you create a new drawing in one system of measurement (imperial or metric) and then change to
the other system, use SCALE to scale the model geometry by the appropriate conversion factor to
obtain correct distances and dimensions. The conversion is shown as follows:

For example, to convert inches to centimeters, you scale the drawing by a factor of 3.25. To convert

from centimeters to inches, the scale factor is 1/3.25 or about 0.3077.

4.1.2. Set Angle Conventions

You can specify the location for angle 0 and the positive direction for the angle measurement:
clockwise or counterclockwise. You can also specify the format and the number of the decimal

fraction.

Specify the measurement unit and precision. The units include decimal degrees, deg/min/sec, gradians,

radians, and surveyor’s units.

Specify where the angle measurement starts from: east, west, south, north or others. For example, to
enter a coordinate relative to the current coordinate for a property line that is 54 feet, 7 inches long with
a bearing of 60 degrees north, 12 minutes, 6 seconds east, enter @54'7"<n60d12'6"e.

Specify the positive direction: counterclockwise or clockwise. The angle 0 can be set to any location.
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4.1.3. Setting scale factors

Instead of drawing to a particular scale, you draw everything full size in the program. Although it's a
good idea to keep your scale factor in mind when setting up a drawing, you don't need to set the scale
until you print it. For example, when you draw a mechanical part 40 inches in length with ZWCAD,
you actually draw it as 40 inches, rather than applying a scale factor as you draw. When you print your

drawing, you can assign the scale at which the drawing is to print.

Scale, however, does affect the way a few elements such as text, arrows, or linetypes print or plot in
your drawing. For these, you can make adjustments when you first set up your drawing so that they
print or plot at the correct size. For example, when you draw text, you need to determine the text size

so that when you print it later at a particular scale, the text height is correct.

After you determine the eventual scale of your finished drawing, you can calculate the scale factor for
the drawing as a ratio of one drawing unit to the actual scale unit represented by each drawing unit. For
example, if you plan to print your drawing at 1/8" = 1'-0", your scale factor ratio is 1:96 (1/8" = 12" is
the same as 1 = 96). If you want your printed scale to be 1 inch = 100 feet, your scale factor ratio is
1:1200.

The following table shows some standard architectural and engineering scale ratios and equivalent text
heights required to create text that measures 1/8 inch high when you print the drawing at the specified

scale.

Standard scale ratios and equivalent text heights

Scale Scale factor Text height
/16" =1'-0" 192 24"
1/8"=1'-0" 96 12"
3/16" = 1'-0" 64 8"
1/4"=1'-0" 48 6"
3/8"=1'-0" 32 4"
12"=1-0" 24 3"
3/4"=1'-0" 16 2"
"=1-0" 12 1.5"
112"=1-0" 8 "
3"=1-0" 4 0.5"
1"=10 120 5"
1"=20' 240 30"
1"=30 360 45"
1" =40 480 60"
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1" =50 600 75"
1" =60 720 90"
1"=100' 1200 150"

You can use these scale factors to predetermine the size of your drawing to make sure that it fits on a
specific size paper when you print it. You control the size of your drawing by the drawing limits. To
calculate the drawing limits to match the size of your paper, multiply the dimensions of your paper size

by your scale factor.

For example, if the paper you use to print measures 36 inches x 24 inches and you print your drawing
at 1/8" = 1'-0" (in other words, using a scale factor of 96), the size of your drawing measured in
drawing units is 36 x 96 (or 3,456 units) wide and 24 x 96 (or 2,304 units) high.

Keep in mind that you can print the finished drawing at any scale, regardless of the scale factor you
calculate. You can also print on paper of a different size and use the Layout tabs to create different
views of your drawing and to position and scale those views differently. The scaling factor is not
related to the size of the entities you draw; it simply provides a preliminary guide to help you establish
the text height and drawing limits when you begin your drawing. You can change the text height and

draw limits at any time.

Apply scale factors

You can set the following factor to determine whether the drawing is plotted on the model space or
paper space.

e  Text. Sets text height in the text style (STYLE) or in the process of creating text. The text
plotted height should be set in proportion to scale factor in model space. The text created on
the layout should be set at 1:1.

e Dimension. Sets dimension scale in the dimension style (DIMSTYLE) or through system
variable DIMSCALE.

e Linetype. To plot objects from the Model tap, use system variables CELTSCALE and
LTSCALE to set the scale for non-continuous lines. To plot objects from a layout (paper
space), use system variable PSLTCALE.

e Hatch. Sets hatch scale in the Hatch and Gradient dialog box or through system variable
HPSCALE.

e  View. When you plot a drawing from a layout, you may need to use ZOOM XP command,

where XP is a ratio that is relative to the paper size (scale factor of reciprocal).

Setting the text height

The text height setting controls the height of the text, measured in drawing units. Set this value initially
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so that text used for your most common annotations, when scaled to the size at which you will print a

drawing, measures 1/8-inch high on the printed drawing.

For example, if you plan to print your drawing at 1/8" = 1'-0" and you want your text to be 1/8-inch
high in the final drawing, create that text 1 foot high (in your real-world drawing units) so that when

you print it, it appears 1/8-inch high on the paper.

You must create text 4 feet high that you want to print 1/2-inch high.

To set the text height

1. Choose Format > Text Style from the main menu.
2. Type avalue in the Fixed Text Height under Text Measurements.

3. Press OK to save the current settings.

NOTE The default text height applies only if the current text style height is 0.0. Otherwise, the text

height for the current style takes precedence.

4.2. Drawing Limits

You can specify the drawing limits that form an invisible boundary around your drawing. You can use
the drawing limits to make sure that you do not create a drawing larger than can fit on a specific sheet

of paper when printed at a specific scale.

For example, if you plan to print your drawing at 1/8" = 1'-0" (in other words, using a scale factor of 96)
on a sheet of paper measuring 36 inches x 24 inches, you can set drawing limits to 3,264 units wide
(that is, 34 x 96) and 2,112 units high (22 x 96), which allows a 1-inch margin around the edges of the

printed image.

To set the drawing limits

1. Choose Format > Drawing Limits from the main menu.
2. Specify the x-coordinate and y-coordinate of the upper right drawing limit and the
lower left drawing limit. You can also click Select to specify the drawing limits by

selecting points in the drawing.

4.3. Grid and Grid Snap

The grid is a rectangular pattern comprised of cells that extends over the area you specify as the grid

limits. Displaying grids and using grids snap improve the performance of regenerating.

58



ZWCAD User Guide

Using the grid is like placing a sheet of coordinate paper under a drawing. The grid is not plotted.
When you turn Snap mode on, the cursor adheres or snaps to the invisible grids. Therefore, you can

specify precise points with the arrow keys, mouse or other pointing devices.
Grid and snap settings are effective tools to use in your drawing to ensure accuracy.

Although many users find it convenient to match grid points to snap settings, they are independent of
each other and should not be confused. Grid points are for visual reference only; they do not affect
your drawing and they do not print. Snap points are, by themselves, not visible; however, when set,

they constrain the creation of new entities.

In addition, the cursor can be restricted to move orthogonally only or guides can display on the screen

automatically at specified polar angle increments.

4.3.1. Change Grid and Snap Spacing

You can turn Grid and Snap-on and off and specify their spacing on the Snap and Grid tab at the
Drafting Settings dialog box. Grid spacing does not have to match snap spacing. A wide grid spacing

can be used as a reference while a closer grid spacing helps you specify points accurately.

4.3.2. Setting color for grid line.

Grid major/minor lines can be switched to different color base on your preference. Open ‘Options’
dialog box— ‘Display’ — ‘Color’—‘2D model space’— ‘Grid major/minor lines’ . You can choose

color from index color, true color or color books.

4.3.3. Setting a reference grid

A reference grid displays as a pattern of regularly spaced cells. You can turn the display on and off, and

you can specify how far apart the cells are spaced.

The reference grid extends only to the limits of the drawing, helping you to visualize the boundary of
your drawing and to align entities and visualize distances between entities. You can turn the grid on and

off as needed. You can also change the spacing of the grid at any time.

To turn the grid on and set the grid spacing

1. Choose Tools > Drafting Settings from the main menu.
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2. Click the Snap and Grid tab.
Click the Grid On box.

4. Under Grid tab, input a value in the Grid X Spacing field and Grid Y Spacing field
separately.

5. Click OK.

Status bar Right-click on the Grid Display button to choose Settings.
TIP To toggle the grid display on and off at any time, click the Grid Display button on the status bar, or
press F7.

4.3.4. Setting snap spacing

Another way to ensure drawing accuracy is to turn on and set snap spacing. When snap is turned on,
the program restricts the selection points to predetermined snap intervals. Although it is often helpful

for snapping by means of matching the snap spacing with grid spacing, the setting is not required.

To turn snap settings on and set snap spacing

Choose Tools > Drafting Settings from the main menu.

Click the Snap and Grid tab.

Click the Snap-On box.

Under Snap tab, input a value in the Snap X Spacing field and Snap Y Spacing field
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separately.
5. Click OK.
Status bar Right-click on the Snap Mode button to choose Settings.
TIP To toggle snap settings on and off at any time, click the Snap Mode button on the status bar, or
press F9.

4.3.5. Usingisometric snap

You can use the Isometric Snap option to create two-dimensional isometric drawings. With the
isometric option, you are simply drawing a simulated three-dimensional view on a 2D plane, much the
same as you might draw on a piece of paper. Do not confuse isometric drawings with

three-dimensional drawings. You create three-dimensional drawings in three-dimensional space.
The isometric option always uses three preset planes, which are denoted as left, right, and top.

You cannot alter the arrangement of these planes. If the snap angle is 0, the three isometric axes are 30

degrees, 90 degrees, and 150 degrees.
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When you check the Isometric Snap option and select an isometric plane, the snap intervals, grid, and
crosshairs align with the current plane. The grid is always shown as isometric and uses y coordinates to
calculate the grid spacing. If you click the Draw Orthogonal check box, the program restricts the

drawing of entities to the current isometric plane.

To turn the Isometric Snap And Grid option on

1. Choose Tools > Drafting Settings from the main menu.
2. Click the Snap and Grid tab.

3. InSnap Type tab, select the Isometric Snap check box.
4. Click OK.

Tip To choose a different isometric plane and toggle between three isometric planes, press F5.

g T

Isometric planes left (A), right (B, tap (C)

4.4. Use Object Snaps

Object snaps enable you to quickly select exact geometric points on existing entities without having to
know the exact coordinates of those points. With object snaps, you can select the endpoint of a line or
arc, the center point of a circle, the intersection of any two entities, or any other geometrically
significant position. You can also use object snaps to draw entities that are tangent or perpendicular to

an existing entity.

You can use object snaps whenever the program prompts you to specify a point, for example, if you are
drawing a line or other object. To turn on the ESNAP mode, any of the following ways are available:
e  Choose Tools > Drafting Settings from the main menu to open the Drafting Settings dialog
box, toggle to Object Snap tab, and then tick the Object Snap On checkbox.
e  Press F3.
e Click the Object Snap button on the status bar.

When using object snaps, the program recognizes only visible objects or visible portions of objects.

You cannot snap to objects on layers that have been turned off or to the blank portions of dashed lines.

61



ZWCAD User Guide

When Object Snaps is turned on, a marker and a tooltip are displayed when you move the cursor over

an object snap location on an object.

4.4.1. Setting object snaps

You can set object snaps using any of the following methods:
e  Choose Tools > Drafting Settings > Object Snap, and then click one of the object snap tools.
e On the Object Snap toolbar, click one of the object snap tools
e  On the status bar, right-click on the Object Snap button to choose Settings.
e  Press and hold down the Shift key while right-clicking anywhere within the drawing window

to display the object snap shortcut menu, and then choose the object snap you want to set.

4.4.2. Object Snap settings

If you need to use one or more object snaps repeatedly, you can turn on running object snaps on the
Grid and Snap tab of Drafting Settings dialog box. The object snap mode keeps on unless you turn it

off. For example, you can use an object snap to draw a line to the center of a circle.

If several objects snap on, the system chooses automatically the most suitable object snap. If there are
two possible object snaps at the selection area, the system chooses the one that is closer to the center of

target box.

If you turn several object snaps on, you need to check which one is in effect when you specify a point.
If several object snaps are eligible at a given location, press the TAB key to cycle through the
possibilities before you specify the point.

4.4.3. Object Snap Restrictions

With the object snap on, you can snap objects only visible on the screen, including objects on locked
layers, layout viewport boundaries, and polyline segments. You cannot snap to objects that are not
visible, including objects that are not displayed, objects on turned-off or frozen layers, or the blank

portions of dashed lines.

The object snap is available only when you are prompted to specify a point. There isn't any information

about object snap displayed if you try to use an object snap at the Command prompt.
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4.4.4. AutoSnap Tools

The automatic snap tool is a visual aid tool for snapping that help you see and use object snaps more
efficiently. When any object snap is on, the system displays a marker and a tooltip when you move
your cursor on over a snap point. AutoSnap turns on automatically when an object snap is on. By
default, AutoSnap marker, tooltip and magnet are on. You can change the settings of AutoSnap on the

Options dialog box.

AutoSnap consists of the following snap tools:

e  Marker. The object snap location is displayed when the cursor moves over or near an object.
Marker shape is determined by the snap it is marking.

e  Tooltip. Indicates which part of the object you are snapping to in a flag at the cursor location.

e  Magnet. Attracts and locks the cursor onto the nearest detected snap points. Provides a visual
that is similar to snapping to a grid.

e  Aperture box. Surrounds the crosshairs and defines an area within which, when you move the
cursor, the system evaluates objects for object snaps. You can determine the aperture box is

displayed or not, and the aperture box size can be changed too.

To change the size of the object snap target box

Choose Tools > Options from the main menu.
Switch to the Drafting tab.

Under Aperture Size, slide to adjust the desired size.
Click OK.
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4.5. Use Polar Tracking and Object Snap
Tracking

Auto tracking includes polar tracking and object snap tracking. You can turn them on and off by
repressing POLAR and OTRACK button on the Status Bar.

When the polar tracking mode is on, the cursor moves along the specified angle. When the object snap

tracking is on, the cursor moves along an alignment path based on the snap point.

4.5.1. Polar Tracking

When polar tracking is turned on, guides display on the screen automatically at the polar angle
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increment that you specify. For example, if you draw a line with polar tracking turned on with angle

increment set as 65 degrees, the rubber-banding line displays at 65-degree increments.

Polar tracking and orthogonal locking cannot be used at the same time-turning one option on turns the

other option off.

To enable polar tracking and specify the polar angle increment

1. Choose Tools > Drafting Settings from the main menu.
On the Object Snap toolbar, click the Object Snap Settings button.
Type DSETTINGS on the command line and then press Enter.

2. Switch to the Polar Tracking tab.

3. Select the Polar Tracking On checkbox.

To specify the polar angle increments:

1. Select an angle from the Increment Angle drop-down list.
2. Mark the Additional Angles checkbox and click New to define a custom angle
increment.
3. Click OK.
TIP To toggle polar tracking on and off at any time, click the Polar Tracking button on the status bar or
press F10.

To draw objects using polar tracking

1. Turn on polar tracking and start a drawing command, such as ARC, CIRCLE, or LINE.
You can also use polar tracking with editing commands, such as COPY and MOVE.

2. As you move your cursor to specify points, notice the dotted polar tracking line
that appears at the tracking angles you specified. Points you specify while the line

is displayed conform to the polar tracking angle.

Z-Tracking

Polar tracking on Z-Axis is available now in 3D design. You can draw lines parallel to Z Axis easily

without any other construction lines.
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Polar: 381.6715 < +Z

Automatically snap grip in Z axis direction

Specify Polar Angles

You can set a polar increment angle to polar tracking. The default angle includes 90, 45, 30, 22.5, 18,
15, 10 and 5 degrees. You can also type a desired angle in the Additional Angles textbox. The value is
stored in the system variable POLARANG. The orientation of angle 0 and the direction of object snap
are dependent on your settings in the Drawing Settings dialog box (UNITS).

The following illustration shows the alignment paths displayed as you move your cursor 90 degrees

with the polar angle increment set to 30 degrees.

[ Folar: 20200

Paolar: 15=E0

Polar: 12=30

To set polar tracking angles

1. Choose Tools > Drafting Settings from the main menu.

2. Inthe Drafting Settings dialog box, on the Polar Tracking tab, select Polar Tracking
On.
From the Increment Angle list, select the desired angle.

4. To set additional tracking angles, select Additional Angles. Then click New and
enter the angle value in the text box.

5. Under Polar Angle Measurement, specify whether polar tracking increments are
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based on the UCS or relative to the last object you created.
6. Choose OK.

Specify Polar Distances

AutoSnap restricts cursor movement to increments of a polar distance you specified on the Snap and
Grid tab of Drafting Settings dialog box. For example, if you specify a length of 6 units, the cursor
snaps the length specified to lengths of 0, 6, 12, 18, 24, and so on.

When you move the cursor, a tooltip displays the nearest PolarSnap increment. Only when polar

tracking and snap mode are on, you can restrict point entry to polar distance.

To set polar snap distance

1. Choose Tools > Drafting Settings from the main menu.

2. Inthe Drafting Settings dialog box, on the Snap and Grid tab, select Snap-On.

3. InSnap Type, select PolarSnap.

4. Under Polar Spacing, enter the polar distance.

5. Choose the Polar Tracking tab and select Polar Tracking On.

6. Select an angle from the Increment Angle list. You can specify your own angles by
choosing Additional Angles and then New.

7. Choose OK.

4.5.2. Object Snap Tracking

You must set an object snap and turn the object snap model on before you can track from an existing

object's snap point.

Object snap tracking can track along alignment paths that are based on object snap points and display
tooltips at the acquired points. After you acquire a point, horizontal, vertical and polar alignment paths
relative to the point are displayed when the cursor moves over their drawing path. For example, you
can specify a point along a path that is based on an object endpoint or midpoint or an intersection

between objects.
In the following picture, the Endpoint object snap is on. You create a line by clicking its start point (1),

move the cursor over another line's endpoint (2) to acquire it, and then move the cursor along the

horizontal alignment path to locate the endpoint you want for the line you are drawing.
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By default, the object snap tracking is set to Orthogonal. Alignment paths and tooltips are displayed at
0, 90, 180, and 270 degrees from acquired object points. However, you can use polar tracking angles

instead on the Polar Tracking tab in the Drafting Settings dialog box.

You can also use system variable TRACKPATH to control the display of polar and object snap tracking

alignment paths.

4.5.3. Tips for Using Object Snap Tracking

With AutoTrack is on, you may try the following techniques:

e  When you set Perpendicular, Endpoint, and Midpoint object snap and turn on object snap
tracking mode, you can easily draw to point perpendicular to the end or midpoint of an object.

e  Object snap tracking works in conjunction with temporary tracking points. At a point prompt,
enter it and specify a temporary tracking point. A small + is displayed at the point. When you
move the cursor, the tracking alignment paths are displayed relative to the temporary point. To
delete this point, move the cursor back over the +.

e After acquiring a point, you can specify a point at precise distances along alignment paths
from the acquired point.

e  You can use the Automatic and Shift to acquire options set on the Drafting tab of the Options
dialog box to manage point acquisition. By default, point acquisition is set to Automatic.

When working in close quarters, you can press SHIFT to temporarily avoid acquiring a point.

4.6. Use Orthogonal Locking (Ortho
Mode)

You can restrict cursor movement to the current horizontal and vertical axes so that you can draw at
right angles, or orthogonally. For example, with the default 0-degree Orientation (angle 0 at the "three
o'clock" or "east" position), when the Draw Orthogonal option is enabled, lines are restricted to 0
degrees, 90 degrees, 180 degrees, or 270 degrees. As you draw lines, the rubber banding line follows
either the horizontal or vertical axis, depending on which axis is farthest from the cursor. When you
enable the isometric snap and grid, cursor movement is restricted to orthogonal equivalents within the

current isometric plane.
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Ortho mode and polar tracking cannot be on at the same time. Turning on Ortho turns off polar
tracking.

To enable orthogonal drawing

4.7. Work with Linetypes

ZWCAD provides simple and complex linetypes:
e A simple linetype consists of a repeating pattern of dots, dashes, or blank spaces.
e A complex linetype contains the embedded shape and text objects along with dots, dashes, and
spaces.
You can use different linetypes to represent specific kinds of information. For example, if you are
drawing a site plan, you can draw roads using a continuous linetype, a fence using a linetype of dashes

with square posts, or a gas line using a complex linetype showing the text "GAS".
By default, every drawing has at least three linetypes: CONTINUOUS, BYLAYER, and BYBLOCK.

You cannot rename or delete these linetypes. Your drawing may also contain an unlimited number of

additional linetypes. You can load more linetypes into the program from a linetype library file.

4.7.1. Load and Use Linetypes

A linetype is a repeating pattern of dashes, dots, and blank spaces displayed in a line or a curve. Loads

linetype from a drawing to be reused when needed.

Work with Linetypes

You can assign linetypes to objects by layer, or by specifying the linetype explicitly. Besides choosing
linetype, you can specify its scale to control the size of dashes and spaces, and create your own custom

linetypes.
NOTE You should not confuse these linetypes with the hardware linetypes provided by some plotters.

Both linetypes of dashes produce the similar effects. However, if you use both linetypes at the same

time, the results can be unpredictable.

Load Linetypes

ZWCAD includes the linetype definition files zwcad.lin and zwcadiso.lin. zwcad.lin is used in the
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imperial system, and zwcadiso.lin is used in the metric system. If you select zwcadiso.lin, you can use

ISO pen-width option when you plot.

If you want to know what linetypes are already available, you can display a list of linetypes that are
loaded in the drawing or stored in a LIN (linetype definition) file. Both linetype definition files contain

several complex linetypes.

You can remove unreferenced linetype information with PURGE or by deleting the linetype from the
Linetype Manager. BYBLOCK, BYLAYER, and CONTINUOUS linetypes cannot be removed.

4.7.2. Change the Linetype of an Object

You can change the linetype of an object by changing the linetype of the layer the object is on,

reassigning the object to another layer, or by specifying a linetype for the object directly.
Set the Current Linetype

By default, all objects are created using the current linetype, which is displayed in the Linetype Control
on the Properties toolbar. To modify this current linetype, you can select a linetype and make it current
in the Linetype Manager dialog box. You can also do this setting using the Linetype option on the

Properties palette.

If the current linetype is BYLARER, objects are created using the linetype assigned to the current
layer.
If the current linetype is BYBLOCK, objects are created using CONTINOUS linetype until they are

grouped into a block. When you insert the block, it acquires the current linetype setting.

If you do not want to use the linetype assigned to the layer, you can specify a different linetype
explicitly.
ZWCAD does not display the linetype of certain objects: text, points, viewports, hatches, and blocks.

To make the linetype current

Select a linetype from the Linetype Control pull-down list on the Properties toolbar, which is set to the

current linetype.

Change the Linetype of an Object

To change the linetype of an object, you can use following methods:
e If the linetype of an object is set to BYLARE, and the object is assigned to another layer, it
acquired its linetype from the new layer.
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e If the linetype of an object is set to BYLAYER when you change the linetype assigned to a
layer, the objects on that layer which are assigned the BYLAYER linetype are updated
automatically.

e Specify a linetype for an object to override the linetype of the layer. You can specify different
linetypes for each object. If you want to specify a different linetype to override the
player-determined linetype of an object, change an existing object's linetype from BYLAER
to a specific linetype, such as DASHED.

e If you want to set a linetype for a subsequently created object, you can change the current

linetype BYLAYER to a specific one in the Linetype Control on the Properties toolbar.

4.7.3. Control Linetype Scale

You can set global or individual scales for objects to control the display of linetypes.

By default, the global and individual linetype scales are set to 1.0. The smaller the scale, the more
repetitions of the pattern are produced per drawing unit. For example, if the scale is set to 0.2, five

repetitions of the pattern in the linetype definition are displayed for each drawing unit.

When short segments are too short to display one full linetype pattern, it is displayed as continuous.
When the lines are too short to display even one dash sequence, you need to specify a smaller linetype

scale. Otherwise, the linetype is displayed as continuous shown in the following illustration:

< pAmmemm-

For polylines, you can use system variable PLINEGEN to control whether a linetype pattern is

centered on each segment or is continuous across vertices throughout the entire length of the polyline.
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The Global Scale Factor and Current Object Scale are displayed in the Linetype Manager.

The Global Scale Factor and Current Object Scale are displayed in the Linetype Manager. The Global

Scale Factor value is stored in the system variable LTSCALE, which changes the linetype scale
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globally for new and existing objects. The Current Object Scale is stored in the system variable
CELTSCALE, which specifies the linetype scale for new objects. You can get the displayed linetype
scale by multiplying the CELTSCALE value with the LTSCALE value. The linetype scales in the

drawing can be changed easily either individually or globally.

In a layout, you can use system variable PSLTSCALE to adjust the linetype scale in different

viewports.

NOTE Setting the linetype scale too large or too small may result in a line pattern looking like a solid

line, depending on what the scale view is or at what scale the drawing is printed.

You can control a new entity's individual linetype scale factor as well as the overall or global scale

factor applied to all the entities in the drawing.

To set the current individual linetype scale

1. Choose Format > Linetype from the main menu.

2. Click the Show Details button.

3. In the Current Object Scale field, type the linetype scale that you want to make
current.

4. Click OK.

To change the global linetype scale

1. Choose Format > Linetype from the main menu.

2. Click the Show Details button.

3. In the Global Scale Factor field, type the global linetype scale that you want to
change.

4. Click OK.

4.8. Work with Layers

Layers are like transparent overlays on which you organize and group different kinds of drawing

information.

4.8.1. Overview of Layers

Layers in ZWCAD are like the transparent overlays you use in manual drafting. You use layers to

organize different types of drawing information. In ZWCAD, each object in a drawing exists on a layer.
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When you draw an object, it is created on the current layer.

You can control the visibility of layers in individual viewports. When you turn a layer off, objects
drawn on that layer are no longer visible, and they do not print. Although a layer may be invisible, you
can still select it as the current layer, in which case new objects are also invisible until you turn the
layer back on. Objects on invisible layers can also affect the display and printing of objects on other
layers. For example, entities on invisible layers can hide other objects when you use the Hide

command to remove hidden lines.

You can also freeze and thaw layers. Objects drawn on frozen layers do not display, do not print, and
do not regenerate. When you freeze a layer, its objects do not affect the display or printing of other
objects. For example, objects on frozen layers do not hide other objects when you use the Hide
command to remove hidden lines. In addition, you cannot draw on a frozen layer until you thaw it, and

you cannot make a frozen layer current.

You cannot freeze the current layer. If you attempt to freeze the current layer, a dialog box prompting
"Cannot freeze the current layer" appears. You also cannot freeze or thaw a viewport layer unless you

are working on a Layout tab.

You can lock or unlock layers. The objects on a locked layer are still visible and will print, but you

cannot edit them. Locking a layer prevents you from accidentally modifying objects.

Each layer has its own color, linetype, and lineweight. For drawings that use named print styles, layers
can also have their own print style. Objects you draw on a particular layer are displayed in the color,

linetype, and lineweight associated with that layer unless you override these settings.

4.8.2. Create and Name Layers

You can create an unlimited number of layers in every drawing and use those layers for organizing
information. When you create a new layer, it is initially assigned the color white (or black, depending

on your system settings) and the linetype CONTINUOUS. By default, a new layer is also visible. After
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you create and name a layer, you can change its color, linetype, visibility, and other properties.

Layers can have alphanumeric names up to 255 characters long.

In many cases, the layer names you choose are dictated by corporate, industry, or client standards.

The Layer Properties Manager sorts layers alphabetically by name.

To create a new layer

1. Choose Format > Layer from the main menu.
2. Click the New Layer button.
3. Type a name for the new layer.
4. Click OK.

To change a layer name in the current drawing

1. Choose Format > Layer from the main menu.
2. In the Layer Properties Manager dialog box, click the name of the layer you want
to change.

3. Type a new name and click OK.

NOTE You cannot rename the 0 layer.

Setting the current layer

When you start a drawing, objects are created in the current layer. By default, the layer O is set to the
current layer, but you can also create a new one and make it current. Either frozen or xref-dependent
layer cannot be set to the current layer. Any subsequent objects you create are associated with the

current layer and use its color and linetype.

To make a layer current

1. Choose Format > Layer from the main menu.

2. In the Layer Properties Manager dialog box, select a layer and then click the Set
Current button to make the layer current.

3. Clicks OK.
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Remove Layers

You can remove unused layers from your drawing with PURGE or by deleting the layer from the Layer

Properties Manager.

4.8.3. Change Layer Settings and Layer Properties

Everything in a drawing is associated with a layer, in the course of creating a drawing, you can modify
what you draw by renaming layer name, modifying the properties of a layer (color and linetype), or

placing objects from one layer to another.

If you create an object on a wrong layer, you can reassign it to another layer. Unless the linetype, color
or other properties of the object has been specified explicitly, the object acquires the properties of the

new layer.

You can change layer properties in the layer control on the Layers toolbar or in the Layer Properties
Manager. Click the icons to change settings. However, layer names and colors can be changed only in

the Layer Properties Manager.
Controlling layer visibility

A layer can be visible or invisible. Objects on invisible layers are not displayed and do not print. By
controlling layer visibility, you can turn off unnecessary information, such as construction lines or

notes. By changing layer visibility, you can put the same drawing to multiple uses.

For example, if you are drawing a floor plan, you can draw the layout of light fixtures on one layer and
the location of plumbing lines on another. By selectively turning layers on and off, you can print the
electrical engineering drawings and the plumbing drawings from the same drawing file. For even more
convenience, you can control the visibility of layers within individual viewports, so that layers that

display in one viewport are invisible in other viewports in the same drawing.

When you turn a layer off, objects drawn on that layer are no longer visible. When you turn the layer

back on, the objects on that layer are redisplayed.

To turn layers on or off

1. Choose Format > Layer from the main menu.
2. Click the icon under "On" tab in the layer list.
3. Click OK.

74



ZWCAD User Guide

Freeze or thaw layers

You can also freeze layers to improve the performance of operations such as zooming and panning or
producing hidden lines or shaded images. When a layer is frozen, objects drawn on that layer are no

longer visible.

To freeze or thaw layers

1. Choose Format > Layer from the main menu.
2. Click the icon under "Freeze" tab in the layer list.
3. Click OK.

Locking and unlocking layers

Locking a layer makes it easy to refer to information contained on the layer, but prevents you from
accidentally modifying its objects. When a layer is locked (but visible and thawed), its objects remain
visible, but you cannot edit them. If you lock the current layer, you can still add new objects to it. You

can also change the linetype and color associated with a locked layer.

Unlocking a layer restores full editing capabilities.

To lock or unlock layers

1. Choose Format > Layer from the main menu.
2. Click the icon under "Lock" tab in the layer list.
3. Click OK.

Controlling layer printing

Controlling layer printing is another way you can specify which objects print in your drawing.

By controlling layer printing, you can turn off unnecessary information during printing. For example, if
you are drawing a floor plan, you can draw the layout of light fixtures on one layer and the location of
plumbing lines on another. By selectively turning layers on and off when you print, you can print the
electrical engineering drawings and the plumbing drawings from the same drawing file. By changing

layer printing, you can put the same drawing to multiple uses.

When you turn off printing for a layer, objects drawn on that layer are still visible, but they do not print.

If you turn off a layer's visibility, objects drawn on that layer do not display or print.

Controlling layer printing can be especially helpful if you want layer visibility on, but do not want to
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print objects on that layer.

To turn layer printing on or off

1. Choose Format > Layer from the main menu.
2. Click the icon under "Plot" tab in the layer list.
3. Click OK.

Setting the layer color

Each layer in a drawing is assigned a color. ZWCAD uses the BYLAYER color as the default color
setting for object creation so that new objects are drawn in the color of the layer on which they are

inserted.

To change the layer color

1. Choose Format > Layer from the main menu.

2. Click the icon under "Color" tab in the layer list to open Select Color dialog box,
from which, you can specify the desired color.

In the Select Color dialog box, select a color from one of the following tabs:

4. Index Color — Click BYBLOCK, BYLAYER, or one of the 255 index colors. You can
also type the color number in the Color box.

5. True Color — Click a basic color in the left color panel, and then move the slider to
the right to specify a color. There are more than 16 million true colors from which
you can choose.

6. Color Books — Select a color book from the Color Book pull-down list, and then
click a desired color from the options displayed.

7. Click OK.

NOTE You can also assign a specific color to an object, which overrides the layer's color setting.

When you create a new object, use the Format > Color menu option to change the current color. For an

existing object, double-click this object and then change the object's color on the Properties palette that
pops up.

Setting a layer's linetype

Each layer uses a default linetype (a repeating pattern of dashes, dots, or blank spaces). Linetype

determines the appearance of objects both on the screen and when printed.

It's a good idea to assign the BYLAYER linetype to any objects that you draw on that layer.

ZWCAD uses the BYLAYER linetype as the default linetype setting for Object Creation.
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NOTE Only those linetypes already set in the drawing can be assigned to layers.

To change the linetype assigned to one or more layers

1. Choose Format > Layer from the main menu.

2. Click the Linetype name in the layer list to open Select Linetype dialog box, from
which, you can specify the desired linetype.

3. Click OK.

NOTE You can also assign a specific linetype to an object, which overrides the layer's linetype setting.
When you create a new object, use the Format > Linetype menu option to change the current linetype.
For an existing object, double-click this object and then modify the object's linetype on the Properties
palette that pops up.

Setting a layer's lineweight

Each layer uses a default lineweight. Lineweights determine the thickness of objects both on the screen

and when printed.

All new layers are assigned the DEFAULT lineweight, which is .25 millimeters or .01 inches.

If you want a different lineweight assigned to a layer, you can easily change it using Layer Properties
Manager. For example, you may want different lineweights on each layer of your drawing to show
separate elements, such as walls, dimensions, structural steel, and electrical plans. Changing the
lineweight assigned to a layer changes the lineweight of all objects drawn on that layer with the
BYLAYER lineweight.

When you create new objects, it's a good idea to assign the BYLAYER lineweight to any objects that
you draw on that layer, unless you want to override the layer lineweight. ZWCAD uses the BYLAYER

lineweight as the default lineweight setting when you create objects.

To change the lineweight assigned to one or more layers

1. Choose Format > Layer from the main menu.

2. Click the Lineweight name in the layer list to open Lineweight dialog box, from
which, you can specify the desired lineweight.

3. Click OK.

NOTE You can also assign a specific lineweight to an object, which overrides the layer's lineweight
setting. When you create a new object, use the Format > Lineweight menu option to change the current
lineweight. For an existing object, double-click this object and then modify the object's lineweight on

the Properties palette that pops up.
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Setting a layer's print style

If your drawing uses named print style tables, you can specify a print style for each layer.

Named print style tables contain print styles that you set up to control what objects look like when they

print, without actually changing the objects in the drawing.

If your drawing uses color-dependent print style tables, you cannot specify a print style for a layer.
These types of print style tables automatically determine printing requirements by the color assigned to

a layer or an object.

In drawings that use named print style tables, the default print style is Normal for all new layers. If
desired, you can assign a print style using Layer Properties Manager. Changing the print style assigned

to a layer changes the print style of all objects drawn on that layer with the BYLAYER print style.

When you create new objects, it's a good idea to assign the BYLAYER print style to any objects that
you draw on that layer, unless you want to override the layer print style. ZWCAD uses the BYLAYER

print style as the default print style setting when you create objects.

To change the print style assigned to one or more layers (only in a drawing that

uses named print style tables)

1. Choose Format > Layer from the main menu.

2. Click the name of Plot Style in the layer list to open Select Plot Style dialog box,
from which, you can specify the desired plot style.

3. Click OK.

4.8.4. Filter and Sort the List of Layers

Limits the display of layer name listed in the Layer Properties Manager and sorts them by name or by

properties, such as color and visibility.
You can use a layer filter limits the display of layer names in the Layer Properties Manager.

The following properties can be included in the filter definition:
e Whether layers are set to be plotted
e Layer names, colors, linetypes, lineweights, and plot styles
e Whether layers are locked or unlocked
e Whether layers are turned on or off

e Whether layers are frozen or thawed in the current viewport or all viewports
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When setting filter conditions, you can also use wild-card characters to filter names by name. For
example, typing nare* displays layer name preceded with nare, just click Add button if the filter name

has been specified.

You can also use invert filter to display layer names that do not be included filter definition. For
example, if all the site plan information of a drawing is contained in multiple layers, which include the
word lite as part of the layer name, you should first define the filter by way of specifying filter name
and inputting *lite* in layer name option, and then click Invert Filter option to display all the

information excluded from the site plan information.

Name Layer Filters lists default filters and other saved filters created in the current drawing. The three
default filters are shown as follows:

e Show all layers.

e Show all used layers.

e Show all Xref dependent layers.
The newly created filters are displayed in the Name Layer Filters at the Layer Properties Manager.

These filters are saved with the drawing.
Sort Layers

From the Layer Properties Manager, you can click the column heading to sort layers by their properties
in that column. The properties include layer name, visibility, color, lineweight, plotted style and

linetype. And layer names can be sorted in descending or ascending alphabetical/numerical order.

4.8.5. Save and Restore Layer Settings

You can save the current layer settings in a drawing and restore them later.
Save Layer Settings

Layer settings include:
e Layer states, such as on, frozen, locked, plot and freeze automatically in a new viewport.

e Layer properties, such as color, linetype, lineweight and plot style.

You can save layer settings alternatively. For example, you can choose to save only Frozen/Thawed
settings of the layers in a drawing, ignoring all other settings. When you restore the layer states, all

settings remain as they are currently set except whether each layer is frozen or thawed.

You can export named layer states to a LAS file for use in other drawings using the Layer States
Manager. The layer states of xref cannot be exported.
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Restore Layer Settings

You can not only restore the saved settings but also edit, rename or delete named settings. Using Layer

States Manager, you can import named layer states that were previously export to LAS files.

Whatever layer states come from the drawing or LAS files, only saved settings can be restored and the

unspecific layer settings remain the original settings.

4.9. Work with Colors

An entity's color determines how it is displayed and, if you are using a color printer, how it prints.

Entities are created in the current color specified for the drawing.

Layers can also control the color of entities. When you open a new drawing, entities are created in the
color BYLAYER, which adopts the color of the current layer. Initially, layer 0 is both the only layer

and the current layer. Its default color is white, so your entities appear as white.

For entities and layers in ZWCAD, there are three different types of colors:
¢ Index colors
e True colors

e Color books colors

You can choose colors by selecting them from the Select Color dialog box. In the command bar or in

some dialog boxes, you specify a color either by name or by number.

All objects are created with the current color, which is displayed in the Color Control on the Properties

toolbar. With the Color Control or the Select Color dialog box, you can also set the current color.

Objects are created with the color assigned to the current layer. If the current color is set to BYLAYER.
If the current color is not expected to be the color assigned to the current layer, you can specify another

color instead.

If the current color is set to BYBLOCK, objects are created using color 7 (white or black) until these
objects are grouped into a block. Once the block is inserted into a drawing, it uses current color settings

instead.

4.9.1. Use Index Colors

There are 255 standard index colors and two additional color properties that are often referred to as
colors (BYLAYER and BYBLOCK). You can use seven of the 255 standard index colors by name: red,

yellow, green, cyan, blue, magenta, and white. (Numbers eight and nine are not named.) Each index
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color has a unique number from 1 to 255. The two additional color properties are BYLAYER and
BYBLOCK. These color properties cause an entity to adopt the color either of the layer or of the block
in which it is a member. BYLAYER is color number 256, and BYBLOCK is color number 0. In all
commands for which you would use a color, you can indicate BYLAYER and BYBLOCK as well as
by numbers 256 and 0, respectively.

To select an index color

1. Click Select Color in the desired dialog box, such as Layers, Properties, or Multiline
Text. The Select Color dialog box opens.

2. Click the Index Color tab.
Click the color of your choice, or type the color number in the Color box.

4. Click OK.

4.9.2. Use True Colors

There are more than 16 million true colors from which you can choose. True colors are defined using
24-bit color.

Even with so many colors available, you can quickly choose a color from the display of basic colors or
by clicking the color palette. Alternatively, if you know the values used to define the desired color, you
can enter the Hue, Saturation, and Luminance (HSL) values, or you can enter the Red, Green, Blue
(RGB) values.

To select a true color

1. Click Select Color in the desired dialog box, such as Layers, Properties, or Multiline
Text. The Select Color dialog box opens.

Click the True Color tab.

Select one of the following two color models:

HSL color model

RGB color model

Specify the desired color.

Click OK.

No v bk wnN

4.9.3. Use Color Books

ZWCAD uses color books to store collections of colors. For example, you can store a unique color
scheme for a client in a color book and then use colors only from that color book for the client's

drawings.
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You may have a color book given to you by a client, developed by a third party, or you can create your
own. Each color book has a .acb extension and is saved in Extensible Markup Language (XML) format.

By default, color books are stored in the ...Support\color folder under ZWCAD installation directory.

To create a color book

1. Startan XML editor program.

2. Create a new XML file using the format below as a guide.

<colorBook>

<bookName>Color

book sample</bookName>

<colorPage>
<pageColor><RGB8><red>0</red><green>0</green><blue>0</blue></RGB8>
</pageColor><colorEntry>

<colorName>Orange</colorName>
<RGB8><red>255</red><green>128</green><blue>0</blue></RGB8>
</colorEntry>

<colorEntry>

<colorName>Light

Green</colorName>
<RGB8><red>128</red><green>192</green><blue>128</blue></RGB8>
</colorEntry>

<colorEntry>

<colorName>Gray</colorName>
<RGB8><red>128</red><green>128</green><blue>128</blue></RGB8>
</colorEntry>

</colorPage>

</colorBook>

3. Save the color book in XML format and with a .acb extension.

NOTE Your color book can contain an unlimited number of colors using the <colorEntry> and

</colorEntry> tags.

To load a color book

1. Save the color book in the folder where ZWCAD searches for color books. By
default, this is the same folder where you installed ZWCAD.

2. To select a color book color

3. Click Select Color in the desired dialog box, such as Layers, Properties, or Multiline
Text. The Select Color dialog box opens.

4. Click the Color Books tab.

Select a color book from the list.
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6. Click the desired color.
7. Click OK.

4.10. Control Lineweights

You can further differentiate objects in your drawing by controlling their lineweights both in the

drawing display and in plotting.

4.10.1. Overview of Lineweights

Lineweights help differentiates the purpose of one line from another. Lineweights determine how thick

or thin entities appear both on the screen and when printed.

By default, each drawing has three main lineweights: DEFAULT, BYLAYER, BYBLOCK, and many

additional lineweights in millimeters (or you can use inches).

When you create an entity, it is created using the current lineweight. By default, the current lineweight
for a new entity is BYLAYER. This means that the entity lineweight is determined by the current layer.
When you assign BYLAYER, changing a layer's lineweight changes the lineweight of all the entities
assigned that layer (if they were created using the lineweight BYLAYER).

You can also select a specific lineweight (or DEFAULT) as the current lineweight, which overrides the
layer's lineweight setting. Entities are then created using that lineweight (or the DEFAULT lineweight),

and changing the layer lineweight has no effect on them.

As a third option, you can use the lineweight BYBLOCK property, in which case new entities are

drawn using the DEFAULT lineweight until you group them into a block.
The entities then inherit the block's lineweight setting when you insert the block into a drawing.

If you choose a lineweight that is less than .025 millimeter, it displays as one pixel when you create
your drawing. When you print your drawing, it prints at the thinnest lineweight that is available for
your printer.

You cannot assign lineweights to planes, points, TrueType fonts, or raster images.

4.10.2. Display Lineweights

Display lineweights in both of model space and layer space. Lineweights are displayed differently in

paper space layout than model space. Lineweights are useful for graphical representations of different
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objects and information.
Display Lineweights in Model Space

In model space, a 0-value lineweight is displayed as a pixel, and other lineweights are displayed with a

pixel width proportional to their real-unit value.

In model space, the lineweight display does not change with the zoom factor. A lineweight value that is
represented by a width of several pixels is always displayed using the same number of pixels. Unless
you use LWEIGHT command to open Lineweight Settings dialog box and change the display scale, the
lineweight display scale keeps unchanged. In addition, the lineweight display scale does not affect the

lineweight plotting value.

Lineweight that are represented more than one pixels increase regeneration time. Turning off the

display of lineweight optimizes the performance of the program.

In model space, press LWT button on the status toolbar to turn the lineweight display on and off.
Display Lineweights in Layouts

In paper space (layout tab), lineweights are displayed in exact plotting width.

In plot preview and paper space, lineweights are displayed in real-world units and lineweight changes
with the scale factor. From the Plotting Scale tab of Plot dialog box, you can control the lineweight

plotting and scale in a drawing.

In paper space, press LWT button on the status toolbar to turn the lineweight display on and off. This
change does not affect the lineweight plotting.

4.10.3. Change the Lineweight of an Object

You can change the current lineweight of an object by reassigning the object to another layer, by
changing the lineweight of the layer the object is on, or by specifying a lineweight for the object
explicitly.

Set the Current Lineweight

All objects are created in a drawing using the current lineweight. You can change the lineweight in the

Lineweight control on the Properties toolbar, or in the Lineweight Settings dialog box.
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If the current lineweight is set to BYLAYER, objects are created in a drawing using the lineweight

assigned to the current layer.

If the current lineweight is set to BYBLOCK, objects are created using the default lineweight, until the
objects are grouped into a block. When the block is inserted into a drawing, it acquires the current

lineweight setting.

To specify a lineweight for the current layer that is different from the current lineweight, open the

Layer Properties Manager and give a specific value.

By default, the lineweight of an object is set to BYLAER, and the lineweight of a layer is set to
DEFAULT. Lineweight that is assigned to objects is displayed as a solid fill drawn in the object's

assigned color.

To set the current lineweight

1. Choose Format > Lineweight from the main menu.
2. From the Lineweight list, choose the lineweight that you want to make current.
3. Click OK.

TIP On the status bar, click the LWT button to toggle the display of lineweights on and off.

NOTE To see lineweights in your drawing, you may need to turn on lineweights.

Change the Lineweight of an Object

There are three choices for changing the lineweight of an object:

e If the lineweight of an object is set to BYLAYER, and you reassign the object to a different
layer, the object acquires its lineweight from the new layer.

e If the lineweight of an object is set to BYLAYER, you can change the lineweight of the layer
the object is on, and all objects assigned to BYLAYER on that layer are updated
automatically.

e Specify a lineweight for an object to override the layer's lineweight. If you want to specify a
lineweight to override the player-determined lineweight of an object, change an existing

object's lineweight from BYLAYER to a specific lineweight.

In order to create subsequent objects using a new lineweight, you have to change the lineweight setting

on the Properties toolbar from BYLAER to the specific one.
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4.11. Control the Display of Overlapped
Objects

Control how overlapping objects and some other objects are displayed and plotted.

4.11.1. Polylines, Hatches, Gradient Fills, Lineweights, and Text

You can simplify the display of certain kinds of objects, such as wide polylines, donuts, solid-filled
polygons (2D solids), hatches, gradient fills and text, to improve the display performance and speed up

of creating test plots.
Turning Fill on and off

You can reduce the time it takes to display or print a drawing by turning off the display of solid fill.
When Fill is turned off, all filled entities, such as wide polylines and planes, display and print as

outlines. When you turn Fill on or off, you must redraw the drawing before the change is displayed.

To turn Fill on or off

Choose Tools > Options from the main menu.
Click the Display tab.

Under Display Performance, select or clear the Apply Solid Fill checkbox.

e

Choose View > Redraw from the main menu.

fill mode an fill mode off

Use Quick Text

If a drawing contains a lot of text using complex fonts, only a rectangular frame defining the text is

displayed or plotted when you turn on Quick Text mode.
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Text entities require a considerable amount of time to display and print. You can reduce the time it
takes to display or print a drawing by enabling Quick Text. For example, if you're doing a preliminary
check print of a drawing, you may want to turn Quick Text on to speed up printing. When Quick Text is
enabled, text entities are replaced by rectangular boxes that indicate the outline of the area occupied by
the text. When you turn Quick Text on or off, you must regenerate the drawing before the change is

displayed.

To turn Quick Text on and off

1. Choose Tools > Options from the main menu.

2. Click the Display tab.

3. Under Display Performance, select or clear the Show Text Boundary Frame Only
check box.

4. Click OK.

To regenerate your drawing, do one of the following:

1. Choose View > Regen from the main menu.

2. Type REGEN on the command line and then press Enter.

Controlling the display of lineweights

You can reduce the time it takes to display a drawing by turning off the display of lineweights.

When you turn off lineweights, all entities display as outlines. You can also specify a lineweight scale.
Specify a smaller scale to display thinner lines; specify a larger scale to display thicker lines. For
example, a scale factor of 0.5 would display a .80 millimeter lineweight as .40 millimeter; a scale
factor of 2 would increase the same lineweight to display at 1.6 millimeters. This can help you
differentiate various lineweights that display in a drawing. Adjusting the lineweight display scale

affects how the lineweights appear on your screen, not how they appear when printed.
NOTE Setting the lineweight scale too high may result in slower system performance.

You can also adjust the units for measuring lineweights and the default lineweight.
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To control the display of lineweights

1. Choose Format > Lineweight from the main menu.

2. In Units for Listing, choose Millimeters or Inches.

3. In Default, select the lineweight assigned to layers and entities that use the
Default lineweight.

4. In Adjust Display Scale, move the slider to the scale you want. By default, the
slider begins at 1.00.

5. Click OK.

TIP On the status bar, click the Show/Hide Lineweight button to turn the display of lineweights on or
off.
Update the Display

New objects automatically apply the current settings to displays of solid fill and text. Except for
lineweights, you must use the REGEN command to update the display of existing objects.

4.11.2. Control How Overlapping Objects Are Displayed

By default, newly created objects are in front of existing objects; all objects are displayed in the order
they are created. To change the draw order, use DRAWORDER command.

Note changing draw order is available only within the same space.

4.12. Extract and Calculate Geometric
Information from Objects

Information about objects in your drawing is allowed to inquire by means of performing inquiry and
calculation commands, you can also make useful calculations, such as area and circumference

calculation.

4.12.1. Calculate Areas

You can calculate the area and perimeter of a polygon based on a series of points you specify or
enclose with a circle or closed polyline. You can also determine the area of several combined objects

and add or subtract the area of one or more objects from a total combined area.

88



ZWCAD User Guide

Calculating areas defined by points

You can find the area and perimeter of any closed region by specifying a series of points. The program
calculates the area and perimeter of the space that is enclosed by an imaginary polygon consisting of

straight line segments connecting each point.

To calculate the area defined by points you specify

1. Choose Tools > Inquiry > Area from the main menu.

2. Specify the first point.

3. Specify the second point.

4. Continue specifying points in sequence to define the perimeter of the area you
want to measure.

5. Tocomplete the selection, press Enter.

6. The area and perimeter of the region you defined are displayed.

c

Select the points (A, B, C) that form a polygon. The area and perimeter of the region are then calculated.

Calculating areas of closed objects

You can find the area of any closed object. In addition, the program calculates either the circumference

or the perimeter of the object, depending on the type of object you select.

To calculate the area of a closed object

1. Choose Tools > Inquiry > Area from the main menu.
2. Onthe command line, type o (object).

3. Select the closed object.

Calculating combined areas

You can find the total area of several combined regions by specifying points or by selecting objects.

You can also subtract the areas of objects or polygons from a running total.
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To add areas to calculate a combined area

Choose Tools > Inquiry > Area from the main menu.
On the command line, type a (add).
Using one of the following methods, identify the first area:

Specify points defining a polygon, and then press Enter.

vk W e

Type o (object), select the objects you want to add and then press Enter to
complete the selection.

6. To complete the command, press Enter.

To subtract areas when calculating a combined area

Choose Tools > Inquiry > Area from the main menu.
On the command line, type a (add).
Using one of the following methods, identify the first area:

Specify points defining a polygon, and then press Enter.

vk W e

Type o (object), select the objects you want to add and then press Enter to
complete the selection.

On the command line, type s (subtract).

Using one of the following methods, identify the area to be subtracted:

Specify points defining a polygon, and then press Enter.

w R N O

Type o (object), select the objects you want to subtract and then press Enter to
complete the selection.

10. To complete the command, press Enter.

A E-
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To calculate the area of the gasket using the Area command, first, add the area of the entire gasket (A), and then

subtract the areas of the two circles (B and C)

4.12.2. Calculate Distances and Angles

You can calculate the distance between any two points you select. The following information is
displayed:

e The distance between the points, measured in drawing units.

e  Their angle in the xy plane.

e  Their angle measured from the xy plane.

e The change (delta) in the X, y, and z distances between the two points.
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To calculate the distance between two points and their angle

1. Choose Tools > Inquiry > Distance from the main menu.
2. Specify the first point.
3. Specify the second point.

Use the Distance command to calculate the distance (A) between two points (B and C), the angle in the xy plane (D),

the angle from the xy plane, and the delta x (E), delta y (F), and delta z distance between the two points.

TIP To use specific points on selected objects, use object snaps to select the precise points on the

objects.

4.12.3. Display Information about Your Drawing

You can display a variety of information about a drawing and the objects it contains, including:
e Information in the drawing database about selected objects.
e The current drawing status.
e  The time spent working on the drawing.

e This information is displayed in the Prompt History window and in the command bar.
Displaying information about objects

You can display information about the selected objects. The information varies, depending on the type
of objects you select. All of the listings display the following information:
e  Object type.

e Layer.
e Color.
e Linetype.

e The location of the object (its XYZ coordinates relative to the current user coordinate system
[UCSD).
e The current space (model space on the Model tab or paper space on a Layout tab).

e The size of the object (the information varies, depending on the object type).

To display information about an object
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1. Choose Tools > Inquiry > List from the main menu.
2. Select one or more objects.

3. Press Enter.

TIP To return to the drawing window, press F2.

Displaying the drawing status

You can display information about the current status of a drawing, including:
e Drawing name.
e Limits.
e Insertion base point.
e Snap and grid settings.
e  Current layer, color, and linetype.

e  Current settings for various modes (fill, grid, orthogonal, snap, blips, and so on).

To display the drawing status

1. Choose Tools > Inquiry > Status from the main menu.

Tracking time spent working on a drawing

You can display information about the amount of time you have spent working on a drawing,
including:

e The date and time the drawing was created.

e The date and time the drawing was most recently saved.

e  The total amount of time spent working on the drawing.

e The time spent working on the drawing during the current editing session. You can turn the

elapsed time timer on and off or reset it to zero.

To display the timer information

Choose Tools > Inquiry > Time from the main menu.
You can do one of the following:

Type on to turn the elapsed the timer on.

Type off to turn the elapsed the timer off.

Type “d” (display) to redisplay the timer information.
Type
Press Enter to exit the command.

“w.n
r

(reset) to reset the elapsed timer to zero.

N o v ks wN e
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4.13. Specify Intervals on Objects

You can divide a line, arc, circle, polyline, ellipse, or spline into a number of equal segments or mark
off intervals of a specific length along an object. (Note that divide is not the same as break.) For
example, you may want to place station-point markers every 50 feet along the centerline of a roadway
or divide the plan view of a window into three equal width sections of glass, placing a mullion at each

division point.

To specify measurements and divisions, use these commands:
e  For the length of the segments, use the Measure command.

e For the number of equal length segments, use the Divide command.

You can measure or divide arcs, circles, lines, polylines, ellipses, and splines. With either command,
you can identify the segments by placing either a block or point object at the end of each interval. If
you use points, you can snap to the ends of intervals using the point object snap. The appearance of the
point object is determined by the current point display type, which you control in the Point Style dialog

box of Format menu.

To use a block as the marker, the block must already be defined in the current drawing. You can further
indicate whether to rotate the block to align perpendicularly to the object you are measuring or

dividing.

Block not aligned with object Block aligned with the object

ZWCAD begins measuring or dividing based on the point at which you select the object and the type
of object with which you are working. For most objects, measuring starts from the endpoint closest to

the point you used to select the object.

The starting point for measurements or divisions depends on the selected object type. Generally, it
includes the following cases:
e For lines or open polylines, the starting point is the endpoint that is closest to the selection
point.
e For closed polylines, the starting point is the polyline start point.
e For circles, it is at the angle from the center point which is equivalent to the current snap angle.
For example, if the snap angle is set to 0, the circle starts at the three o'clock position and

continues counterclockwise.

By default, the point marker is displayed as a single dot, and you may not be able to the measured
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intervals. You can change the appearance of point markers using system variable PDMODE. In
addition, you can change the style of point markers in the Point Style dialog box with the DDPTYPE

command. And the system variable PDSIZE controls the size of point markers.

4.13.1. Divide an Object into Equal Segments

Places point markers on selected objects. The markers divide the selected objects into a specified
number of equal lengths. The objects that can be separated include lines, arcs, circles, ellipses, splines,
and polylines. Actually, this operation does not separate the object; it only identifies the location of

divisions so that you can use them as geometric reference points.

7y

ohject selected hlocks indicating ohiect selected hlocks indicating
five division divisions

To divide an object into segments and mark them using point objects

1. Choose Draw > Point > Divide from the main menu.
2. Select the object.

3. Specify the number of segments, and then press Enter.

TN AN

Left: When you select the object by pointing, divisions are marked beginning from the end closest to the point at

which you select the object (A)

Right: Blocks or point objects (B) are placed along the object to mark it in equal intervals

To divide an object into segments and mark them using blocks

Choose Draw > Point > Divide from the main menu.
Select the object.
On the command line, type b (block).

Type the name of the block you want to insert as the marker.

vk W e

Enter y to align the blocks with the measured object. Enter n to use a rotation
angle of 0 degrees.

6. Specify the number of segments, and then press Enter.
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4.13.2. Specify Measured Intervals on Objects

Use MEASURE to mark an object at specified intervals with either points or blocks. The last segment

of a measured object may be shorter than the interval you specify.

ohject selected hlocks at measured
interals

To measure intervals along an object and mark them using point objects

1. Choose Draw > Point > Measure from the main menu.
2. Select the object.
3. Specify the segment length, and then press Enter.

ﬂ—-l- B-l

W3¢

Left: When you select the object by pointing, intervals are measured from the end closest to the point at which you
select the object (A)

Right: Blocks or point objects (B) are placed along the object at the specified interval

To measure intervals along an object and mark them using blocks

Choose Draw > Point > Measure from the main menu.
Select the object.
On the command line, type b (block).

Type the name of the block you want to insert as the marker.

vk W e

Enter y to align the blocks with the measured object. Enter n to use a rotation
angle of 0 degrees.

6. Specify the segment length, and then press Enter.
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5. Coordinates and Coordinate

System

5.1. Coordinates

When a command prompts you for a point, you can specify a point in a drawing using a mouse or other
pointing devices, or you can enter a coordinate value at the command prompt. Coordinate values
include 2D coordinate and 3D coordinate values. You can type 2D coordinate as either Cartesian (X, Y)

or polar coordinates. You can also locate points with Cartesian, cylindrical or spherical coordinates.

A Cartesian coordinate system has three axes of X, Y, and Z. Different coordinate systems (2D or 3D)
determine different coordinate representation ((X, y) or (X, y, z)). A coordinate value indicates the
point's distance (in units) and its direction along the X, Y and Z axes relative to the coordinate system
origin (0, 0) or (0, 0, 0). In addition, you can type a relative coordinate by moving the cursor to specify

a direction and then entering a distance directly.

With both polar and Cartesian coordinates, you can type absolute coordinates based on the origin, or
relative coordinates based on the last point specified.

The coordinate can be measured in scientific, decimal, engineering, architectural, or fractional notation.
And the angle can be measured in grads, radians, surveyor's units, or degrees, minutes, and seconds.

You can control these unit formats in "Drawing Units" dialog box.

5.1.1. Display Coordinates on the Status Bar

ZWCAD displays the current cursor location as a coordinate on the status bar at the bottom of the
ZWCAD window.

System variable COORDS controls the types of coordinate display.
e  When COORDS is set to 0, updates only when you specify a point.
e  When COORDS is set to 1, updates as you move the cursor.
e  When COORDS is set to 2, updates absolute coordinate as you move the cursor, and displays
the angle from the last point when prompt for distance and angle; this option is available only

when you create lines or other objects that prompt for more than one point.
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5.1.2. Dynamic Input

Dynamic input provides a command interface near the cursor in the drawing area, it consist of pointer
input, dimension input, and dynamic prompts When the dynamic input is turned on, a tooltip displays
dynamically updated information near the cursor. You can specify options and values in the tooltip box

when a command is in progress.

Dynamic Input

5.1.3. Enter 2D Coordinates

When working in two dimensions, you specify points on the xy plane. You can specify any point as an
absolute coordinate (or Cartesian coordinate), using the exact x coordinate and y coordinate locations
relative to the origin (the (0,0) coordinate point at which the two axes intersect), or as a relative
coordinate in relation to the previous point. You can also specify points using relative or absolute polar

coordinates, which locate a point using a distance and an angle.

Entering absolute Cartesian coordinates

The 2D plane is an XY plane, also called construction plane. The 2D plane is similar to a flat sheet of
grid paper. If you want to use Cartesian coordinate values to specify a point, enter an X value and Y
value separated by a comma (X, Y). The X value of a Cartesian coordinate is the positive or negative
distance, in units, along with the X-axis. The Y value of a Cartesian coordinate is the positive or
negative distance, in units, along with the Y-axis. The origin (0, 0) indicates where the X, Y axes

intersect.

To enter absolute Cartesian coordinates, type the coordinate location of the point in the command bar.
For example, to use absolute Cartesian coordinates to draw a line from the origin (0,0) to a point 3
units to the right and 1 unit above the origin, start the Line command and respond to the prompts as

follows:
Specify the first point: 0,0

Specify the next point or [Angle/Length/Undo]: @3, 1
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Y 3
(0, 0)
e
X | .--'""}]I X
I
=

Drawing a line using the absolute Cartesian coordinate method.

Entering relative Cartesian coordinates

Another simpler method is to use relative Cartesian coordinates: you specify a location in the drawing
by determining its position relative to the last coordinate you specified. To use relative Cartesian
coordinates, type the coordinate values in the command bar, preceded by the at symbol (@). The
coordinate pair following the @ symbol represents the distance along the x-axis and the y-axis to the
next point. For example, to draw an 8.5 unit square with its lower left corner at (4,5) using relative

Cartesian coordinates, start the Line command, and then respond to the prompts as follows:
Specify the next point or [Angle/Length/Undo]: @8.5,0
Specify the next point or [Angle/Length/Undo]: @0, 8.5

Specify the next point or [Angle/Length/Close/Undo]: @-8.5,0

Specify the next point or [Angle/Length/Close/Undo]: C
Y -« @-850
1+
i f
l @0, 8.5
T (4
(4.5) @8.56—»
0,0
e UL —x
Y 4 12

Drawing a square using the relative Cartesian coordinates method; enter C to close.

The first relative coordinate (@8.5,0) locates the new point 8.5 units to the right (along with the x-axis)
from the previous point of (4,5); the second relative coordinate (@0,8.5) locates to the next point 8.5
units above (along with the y-axis) the previous point, and so on. Entering C (for Close) draws the final

line segment back to the first point specified when you started the Line command.
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Entering polar coordinates

Using relative polar coordinates makes drawing a square tilted at a 45-degree angle a simple task. Polar
coordinates base the location of a point on a distance and angle from either the origin (absolute

coordinate) or from the previous point (relative coordinate).

To specify polar coordinates, type a distance and an angle, separated by the open angle bracket (<). For
example, to use relative polar coordinates to specify a point 1 unit away from the previous point and at

an angle of 45 degrees, type @1<45.

To draw the square from the example in the previous section, "Entering relative Cartesian coordinates",
this time tilted at a 45-degree angle, start the Line command, and then respond to the prompts as

follows:
Specify the next point or [Angle/Length/Undo]: @4, 5
Specify the next point or [Angle/Length/Undo]: @8.5<45
Specify the next point or [Angle/Length/Close/Undo]: @8.5<315
Specify the next point or [Angle/Length/Close/Undo]: @8.5<225

Specify the next point or [Angle/Length/Close/Undo]: C

@8.5<315

&8.5<225

X :
R E

Drawing a tilted square using the relative polar coordinates method; enter C to close.

X

NOTE Angles increase counterclockwise or decrease clockwise. Thus, an angle of 315 degrees is the

same as 45 degrees.

5.1.4. Use Three-dimensional Coordinates

Specifying coordinates in three-dimensional space is similar to working in two dimensions, except that
you also use the z-axis to locate coordinates. Three-dimensional coordinates are represented in the

format x,y,z (2,3,6).
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Using the right-hand rule

To visualize how ZWCAD works with three-dimensional space, use a technique known as the
right-hand rule. Hold up your right hand in a loose fist with your palm facing you. Extend your thumb
in the direction of the positive x-axis and your index finger upward in the direction of the positive
y-axis. Then extend your middle finger straight toward you in the direction of the z-axis. These three

fingers are now pointing in the positive X, y, and z directions, respectively.

You can also use the right-hand rule to determine the positive rotation direction. Point your thumb in
the positive direction of the axis about which you want to rotate, and then curl the rest of your fingers

toward your palm. These fingers are curling in the positive rotation direction.

Y

QS
X C 5\ j

The right-hand rule helps you determine the positive direction of the x, y, and z-axes and the positive rotation

direction.

Entering x,y,z coordinates

When working in three dimensions, you can specify x,y,z coordinates as absolute distances in relation
to the origin (the (0,0,0) coordinate point at which the three axes intersect) or as relative coordinates
based on the last point selected. For example, to specify the coordinate (3,4,2), just specify a point 3

units along the positive x-axis, 4 units along the positive y-axis, and 2 units along the positive z-axis.

Entering spherical coordinates

When working in three-dimensional space, you can use spherical coordinates to specify a
three-dimensional point by entering its distance from either the origin (absolute distance) or the last
point (relative distance), along with its angle in the xy plane and its angle up from the xy plane. In
spherical format, you separate each angle with the open angle bracket (<). You can enter the coordinate

values using the following format: X < [angle from X axis] < [angle from XY plane]

Thus, to draw a line from the origin to a point 10.2500 drawing units away, at an angle of 45 degrees
from the x-axis and 35 degrees from the xy plane, start the Line command, and then respond to the

prompts as follows:
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Command: LINE
Specify the first point: 0,0,0

Specify the next point or [Angle/Length/Undo]: 10.2500<45<35

When you draw a line from a start point (A) to an endpoint (B) using spherical coordinates, you specify its length (C,
in this case, 10.2500 units), the angle in the xy plane (D, in this case, 45 degrees), and the angle from the xy plane (E,

in this case 35 degrees).

Entering cylindrical coordinates

When working in three-dimensional space, you can also use cylindrical coordinates to specify a
three-dimensional point. You specify a point by entering its distance from either the origin (absolute

distance) or the last point (relative distance), its angle in the xy plane, and its z coordinate value.

In cylindrical format, you separate the distance and angle with the open angle bracket (<) and separate
the angle and z value with a comma. For example, to draw a line from the last point to a point 7.4750
units away, at an angle of 27 degrees from the x-axis in the xy plane and 3 units up in the z-direction,

start the Line command, and then respond to the prompts as follows:
Specify the first point: Press ENTER

Specify the next point or [Angle/Length/Undo]: @7.4750<27, 3

When you draw a line from a start point (A) to an endpoint (B) using cylindrical coordinates, you specify its length (C,
in this case 7.4750), the angle in the xy plane (D, in this case 27 degrees), and the distance in the z-direction (E, in

this case 3 units).
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5.1.5. Use Coordinate Filters

Point filters provide a method of locating a point in a drawing relative to another point without
specifying the entire coordinate. Using a point filter, you can enter partial coordinates, and then the
program prompts you for the remaining coordinate information. To use XYZ point filters, respond to

the prompt for a coordinate with a filter in the following form:

.coordinate

Where coordinate is one or more of the letters x, y, and z. The program then prompts you for the
filtered coordinate(s). For example, if you type .xy, the program prompts you to select a point whose xy
coordinate you want and then prompts you for the z coordinate. The filters .x, .y, .z, .Xy, .xz, and .yz are
all valid filters.

Using point filters in two dimensions

You can use point filters when you work in two dimensions to locate points in relation to existing
entities. For example, to draw a circle centered in a rectangle, start the Circle command, and then

respond to the prompts as follows:

CIRCLE

Specify the center point of circle or [3P/2P/Ttr (tangency tangency radius)]: .y
Select Y of: mid

MidPoint

Still need XZ of: mid

MidPoint

Specify circle radius or [Diameter]:

igge |

-

You can use point filters to center the circle by separately selecting the midpoints of two sides of the rectangle (A

and B) and then specifying its radius.
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Using point filters in three dimensions

You can use point filters when you work in three-dimensional space to locate points in two dimensions
and then specify the z coordinate as the elevation above the xy plane. For example, to begin drawing a
line from a point with a z coordinate 3 units above the center of a circle, insert the circle, and then start

the Line command and respond to the prompts as follows:

Command: C

CIRCLE

Specify the center point of circle or [3P/2P/Ttr (tangency tangency

radius) ]: . xy

Select XY of: cen

CenterPoint

Still need Z of: 3,17.6273
B
T

— L
A

You can use point filters to draw a line by first selecting a point in the xy plane (A), specifying the z coordinate (B),

and then specifying the length of line (C).

5.2. Control the User Coordinate System

Coordinate System

Many commands in ZWCAD require that you specify points as you draw or modify entities.

You can do so by selecting points with the mouse or by typing coordinate values in the command bar.

The program locates points in a drawing using a Cartesian coordinate system.
Understanding how coordinate systems work

The Cartesian coordinate system uses three perpendicular axes—x, y, and z—to specify points in
three-dimensional space. Every location in a drawing can be represented as a point relative to a (0,0,0)

coordinate point, referred to as the origin. To draw a two-dimensional entity, you specify horizontal
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coordinate positions along the x-axis and vertical coordinate positions along the y-axis. Thus, every
point on a plane can be represented as a coordinate pair composed of an x coordinate and a y
coordinate. Positive coordinates are located above and to the right of the origin; negative coordinates

are located to the left and below the origin.

The three perpendicular axes of the Cartesian coordinate system

When you work in two dimensions, you need enter only the x and y coordinates; the program assumes
that the z-axis value is always the current elevation. When you work in three dimensions, however, you
must also specify the z-axis value. When you look at a plan view of your drawing (a view from above,
looking down), the z-axis extends straight up out of the screen at a 90-degree angle to the xy plane.

Positive coordinates are located above the xy plane, and negative coordinates are below the plane.

All ZWCAD drawings use a fixed coordinate system, called the World Coordinate System (WCS), and
every point in a drawing has a specific x,y,z coordinate in the WCS. You can also define arbitrary
coordinate systems located anywhere in three-dimensional space. These are called user coordinate

systems and can be located anywhere in the WCS and oriented in any direction.

You can create as many user coordinate systems as you want, saving or redefining them to help you
construct three-dimensional entities. By defining a UCS within the WCS, you can simplify the creation

of most three-dimensional entities into combinations of two-dimensional entities.

To help you keep your bearings in the current coordinate system, the program displays a coordinate
system icon. When you begin a new drawing, you are automatically in the WCS, indicated by the letter
W in the icon. When you display a drawing in plan view, you see the coordinate system icon from the
top, with the z-axis directed straight toward you. When you display a three-dimensional drawing in a

view other than plan view, the coordinate system icon changes to reflect your new viewpoint.

TIP The visible portions of the axes are the positive directions.
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b Y Z

X X % Y

WCS icon Plan UCS icon 3D View WCS icon
Understanding how coordinates are displayed

The current position of the cursor is displayed as x,y,z coordinates in the status bar and, by default,
updates dynamically as you move the cursor. You can toggle the coordinate display to the static mode

by pressing F6 so that it updates only when you select a point in the drawing.

5.2.1. Control the User Coordinate System in 3D

When working in three-dimensional space, you can define a UCS with its own (0,0,0) origin and
orientation separate from the WCS. You can create as many user coordinate systems as you want and

then save and recall them as you need them to simplify the construction of three-dimensional entities.

For example, you can create a separate UCS for each side of a building. Then, by switching to the UCS
for the east side of the building, you can draw the windows on that side by specifying only their x and
y coordinates. When you create one or more user coordinate systems, the coordinate entry is based on
the current UCS.

UCS aligned with the front wall of the house

To define a UCS, you can use any of the following methods:
e Specify a new origin and points on the positive x and y-axes.
e Specify a new origin and point on the positive z-axis.
e  Align the UCS with an existing entity.
e Rotate the current UCS around any of its axes.
e  Align the UCS with its z-axis parallel to the current viewing direction.
e  Align the UCS xy plane perpendicular to the current view.

e  When you define a new UCS, the UCS icon changes to indicate the origin and orientation of
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the new UCS.

To define a UCS by specifying a new origin and points on the positive x and

y-axes

Choose Tools > New UCS > 3 Point from the main menu.
Specify a new original point.

Specify a point on the positive x-axis.

P w N e

Specify a point on the positive y-axis.

IR

B

Define the new UCS by selecting the origin (A), a point on the positive x-axis (B), and a point in the positive y

direction (C)

5.2.2. Define and Name User Coordinate Systems

A drawing can contain as many coordinate systems as you want and can be named appropriate names

so you can remember how they are used in your drawing for recalling them later.

NOTE Coordinate system names created or renamed in ZWCAD can have up to 31 characters and
cannot include spaces. ZWCAD will, however, display longer coordinate system names and names

containing spaces.

Define new user coordinate systems

1. Choose Tools > New UCS from the main menu.
2. Choose which type for creating UCS.
3. Create UCS depending on the prompts.

To change a user coordinate system name in the current drawing

1. Choose Tools > Named UCS from the main menu.

2. Right-click the desired UCS name, and then select Rename from the shortcut
menu that pops up.
Type a new name.

4. Click OK.
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5.2.3. Set the Current User Coordinate System

When you draw new objects, they are created in relation to the current coordinate system.

Set the current UCS

1. Choose Tools > Named UCS from the main menu.
2. Select the desired UCS, and then click the Set Current button.
3. Click OK.

5.2.4. Use UCS Presets

ZWCAD lets you select a preset UCS. The six planes defined by looking along the x,y, z-axes align the
UCS with the top, left, front, bottom, right, or back, based on either the WCS or the current UCS in
effect when you select the tool. You can also select the previous UCS, align the UCS to the current
view, or select the WCS.

When you select a UCS, the cursor orientation and UCS icon change to reflect the new UCS.

The display does not change, however, unless you select the Change View To Plan View Of The
Selected UCS check box.

After you align the UCS to a preset UCS, you can use "Named UCS" from the Tools menu to save the
current UCS.

To select a preset UCS

1. Choose Tools > Named UCS from the main menu.

2. Switch to Orthographic UCS tab, select the desired UCS, and then click the Set
Current button.

3. Click OK.

5.2.5. Control the User Coordinate System
You can use the user coordinate system for convenient coordinate entry and establish drawing planes.
Control the User Coordinate System (UCS) in 2D

In ZWCAD, there are two coordinate systems: world coordinate system (WCS) and user coordinate
system (UCS). WCS is a fixed coordinate system, where the X axis is horizontal and the Y axis is

vertical. The origin (0, 0) is the intersection of the X and Y axes in the lower-left corner of the drawing.
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You can define a UCS based on a WCS. UCS can be moved, which helps you modify particular
sections of your drawing easily. At the same time, you can rotate UCS to specify points in 3D or

rotated views. When you rotate UCS, Snap, Grid, and Ortho modes all rotate in line with the new UCS.

Actually, you enter a coordinate value in the current UCS. There are several methods for relocating
UCS, shown as follows:

e Move the UCS by defining a new origin.

e  Align the UCS with an existing object or with the current viewing direction.

e Rotate the current UCS around any of its axes.

e Restore a saved UCS.

You can name a defined UCS and then restore it when needed. The UCS Previous option can reverse

up to last 10 coordinate systems in the current session. You can delete a named UCS whenever you do
not need it. A UCS can also be restored to coincide with the WCS.

Use World and User Coordinate Systems in 3D

It is helpful for creating a 3D model by controlling the UCS.

Use World and User Coordinate Systems

In 3D space, there is both a fixed WCS and a movable UCS.

When you work in 3D, the movable UCS can help you enter coordinate, establish drawing planes, and
set views easily. Neither moving nor rotating UCS changes your viewport. The only changes are the

orientation and tilt of the coordinate system.

When you work in 3D, you can simplify the creation of 3D objects by relocating the UCS. To relocate
the UCS, change the location of the origin point and the orientation of the XY plane and the Z axis. In

3D space, you can locate and orient a UCS anywhere.

Only one UCS can be made the current coordinate system at any given time, and all coordinate input
and display are relative to the current UCS. If you open multiple viewports, the current UCS applies to
all of them. If the system variable UCSVP is on, you can save a UCS along with a viewport, and

automatically restore the UCS each time when you make the viewport current.

To draw in 3D space, you need to specify X, Y, and Z coordinate value in either the WCS or UCS. The
following figure displays the X, Y, and Z axes of the WCS.
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WS arigin
point

Generally, the WCS and the UCS are coincident with each other, which means that their axes and
origin points are overlapped exactly. No matter how many times you relocate the UCS, you can always
use the World option of the UCS command to make it coincident with the WCS.

Control the User Coordinate System in 3D

You can relocate the UCS by changing the location of the origin point and the orientation of the XY
plane and the Z axis. In 3D space, you can locate and orient a UCS anywhere. In addition, you can
define, save, and recall as many UCSs as you like. Both entering coordinate and drawing are processed
in the current UCS.

With the UCS's relocation, you can acquire the exact placement of a 3D point by aligning the

coordinate system with existing geometry.

In the current session, if multiple viewports are active, you can assign a different UCS to each viewport.
If the system variable UCSVP is on, you can save a UCS along with a viewport, and automatically
restore the UCS each time when you make the viewport current. When the system variable UCSVP is

on, each UCS may have a different origin and orientation dependent on the construction.

Define the UCS Location

You can define a UCS in several ways:
e Specify a new origin, new XY plane, or new Z axis.
e  Align the new UCS with an existing object.
e  Align the new UCS with the current viewing direction.
e Rotate the current UCS around any of its axes.
e Apply anew Z-depth to an existing UCS.
e Apply a UCS by selecting a face.
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Use UCS Presets

On the Orthographic UCS tab of the UCS dialog box, the system lists several preset coordinate systems,

from which you can choose the desired one.

After specifying a UCS, you can control whether choosing a preset option shifts the UCS relative to the
current UCS orientation or relative to the default WCS. If you use the Restore, World, or Previous

option of the UCS command, the settings you made are not available.

Change the Default Elevation

The CHANGE command is used to specify an elevation and thickness of extrusion for a new object.
You can define a drawing plane of the current UCS by establishing the current elevation, which can be
applied to individual viewports in conjunction with the system variable UCSVP. Whether a UCS is
saved or restored in each viewport are determined by this variable. When UCSVP is set to 1, the
different UCS settings are saved in individual viewports, and the elevation settings are saved along

with each viewport both in model space and in paper space layouts.

Generally, the elevation is set to 0, and you can control the XY plane of the current UCS using UCS

command.

Change the UCS in Paper Space

Just as you define a new UCS in model space, you can also define a new UCS in paper space; however,
the UCSs in paper space is only available for 2D manipulation. Although you can enter 3D coordinates

in paper space, 3D viewing commands are not available, such as PLAN and VPOINT.

The system can store the last 10 coordinate systems that were created in model space and the last 10 in

paper space, and you can restore to the desired one using the Previous option of the UCS command.

Save and Restore UCS Locations by Name

You can save named UCS locations, each having a different origin and orientation, for various

construction requirements. You can relocate, save, and recall as many UCS orientations as you require.

Assign User Coordinate System Orientations to Viewports

You can create multiple viewports to display different views of your model. For example, you can
specify top, front, right side, and isometric views for viewports. You can also define a different UCS
for each view to facilitate modifying objects in different views. When you make a viewport current,

you can use the same UCS you used the last time that the viewport was current.
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The system variable UCSVP controls the UCS in each viewport. When UCSVP is on in a viewport, the
system saves the viewport with the UCS last used in that viewport and restores the UCS as the
viewport is made current again. When UCSVP is set to 0 in a viewport, its UCS is coincident with the

UCS in the current viewport.

For example, you can set up three viewports: a top view, front view, and isometric view. If UCSVP is
set to 0 in the isometric viewport, the Top UCS can be applied to both the top viewport and the
isometric viewport. When the top viewport is made current, the isometric viewport's UCS reflects the
UCS top viewport. Likewise, if you make the front viewport current, the isometric viewport's UCS is

switched to match that of the front viewport.

The following figure indicates the instance illustrated above. In which the drawing 1 reflects isometric

viewport of top-left or top viewports in current UCS.

1]
top wiesenort is current LICEVP=0, UCS ican reflects
g P LICE of current wiewport

The second figure shows the change that occurs when the lower-left, or front, the viewport is made

current. The UCS in the isometric viewport is updated to reflect the UCS of the front viewport.
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]
frontwiewpart is current LICEYP=0, LUCE icon reflects
LICS aof current wiewport

Control the Display of the User Coordinate System Icon

By default, the UCS icon is displayed in the lower-left corner of the current viewport, which indicates
the location and orientation of the current UCS. You can also control whether the UCS icon is

displayed at the origin point. There are two types of UCS icons: 2D icon and 3D icon.

Z
A
—-.
§> b &
2D LICS icon 30 LZS jcon

Displaying 2D or 3D UCS icon is controlled by the UCSICON command. You can display the UCS
icon at the UCS origin point to indicate the origin and orientation of the current UCS using the

UCSICON command.

A cross is displayed in the icon if the UCS icon is displayed at the corner of the current UCS; otherwise,

there is no cross in the icon.

If the drawing area has multiple viewports, each viewport displays its own UCS icon.

There are various ways of displaying the UCS icon, shown as follows, which help you visualize the

orientation of the drawing plane.
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The UCSICON can also change the size and color of the UCS icon.
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6. Create Objects

6.1. Draw Linear Objects

Draw linear objects, like a line, the most basic object, can be one segment or a series of connected

segments.

6.1.1. Lines

A line consists of two points: a start point and an endpoint. You can connect a series of lines, but each

line segment is considered a separate line object.

To draw a line

1. Choose Draw > Line from the main menu.

2. Specify the start point.

3. Complete the first line segment by specifying the endpoint. To undo the previous
line segment during the Line command, enter u (undo) and then press ENTER.
Specify the endpoints of any additional line segments.

4. Press Enter to complete the command.

To start a new line at the endpoint of the last line drawn, start the Line command

again and press Enter directly at the "Specify first point:" prompt.

B-\ +
A

\

Start point (A) and endpoint (B).

If the last object you drew was an arc, you can also draw a line connect to and starting from the

endpoint of the arc.

To draw a line as a continuation from the end of an arc

1. Choose Draw > Line from the main menu.
2. Take the end of an arc as the start point of the line.

3. Specify the length of the line.
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The endpoint of the previous arc (A) and length of the line (B).

6.1.2. Rays

A ray is a line in three-dimensional space that starts at a point and extends to infinity. Because rays

extend to infinity, they are not calculated as part of the drawing extents. The default method for

drawing a ray is to select the start point of the ray and then specify its direction.

To draw a ray

Choose Draw > Ray from the main menu.
Specify the start point.
Specify the direction.

P w N e

To complete the command, press Enter.

"

Start point (A) and direction (B).

6.1.3. Construction Lines

A construction line is a line through a given point, oriented at a specified angle in three-dimensional

space and extending to infinity in both directions. Because construction lines extend to infinity, they

are not calculated as part of the drawing extents.

The default method for drawing a construction line is to select a point along the line and then specify

the direction of the line. You can draw a construction line in any of the following ways:

Horizontal draws the construction line parallel to the x-axis of the current UCS.
Vertical draws the construction line parallel to the y-axis of the current UCS.
Angle draws the construction line parallel to a specified angle.

Bisect draws the construction line perpendicular to an existing object.

Parallel draws the construction line parallel to an existing object.

To draw a construction line
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Choose Draw > Construction Line from the main menu.
Specify a point along the line.

Specify the direction.

P w DN e

To complete the command, press Enter.

A+

K B.

The point along the infinite line (A) and the direction (B)

You can also draw a construction line at a specific angle or at an angle relative to an existing object.

6.1.4. Multiple-Line Objects

Multilines consist of several parallel lines, called elements.

You can determine the position of elements by specifying offset from the origin of each element. By
default, multiline objects contain two elements. You should create and save new multiline styles by

yourself or modify existing mline styles.

four
Blermerts

threea

elements
e HH

elements

endcaps—w

4

Create Multiline Styles

While creating new mlines, you can specify names of the new style together with inherited properties,
and set the amount and properties such as color, linetype, offset and so on for each element directly.
Meanwhile, take into account on whether to fill the background and endcaps. Both lines and arcs are

available for specifying endcaps.

Use Existing Multiline Styles

When you start drawing a multiline, you can use the default style, which has two elements or specifies
a style you created previously. The default style is the multiline style last used, or the STANDARD
style if MLINE hasn't been used.

116



ZWCAD User Guide

You can also change the justification and scale of the multiline before you draw it.

Justification determines whether the multiline is drawn below or above the cursor, or with its origin

centered on the cursor. The default is below (top justification).

Scale controls the overall width of the multiline using the current units.

If you draw a multiline with the scale of 2, then the width is twice of that defined by the multiline style.
If the scale is set to minus, then draw the multiline in order of reversal offset line: the multi-line with
the largest offset is drawn at the bottom in the way of left-to-right drawing. And the multi-line will be

turned into single line once the scale is set to 0.

If you are changing the multiline scale, you might need to make equivalent changes to linetype scale to

prevent dots or dashes from being disproportionately sized.

The multiline scale does not affect the linetype scale.

To draw a multi-line

Choose Draw > Multiline from the main menu.
Specify the start point.
Specify the endpoint.
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Press Enter to complete the command.

6.1.5. Polylines

With ZWCAD, a polyline is a connected sequence of arcs and lines that are treated as a single object.
You can draw a polyline with any linetype and use a width that either remains constant or tapers over
the length of any segment. When editing a polyline, you can modify the entire polyline or change

individual segments.

After you specify the start point of a polyline, the command line prompts several options as you draw,
such as Arc, Halfwidth, Length, Undo, and Width. You can specify different starting and ending widths

to create a tapered polyline segment.

After you draw at least one polyline segment, you can use the Undo tool in right click menu to remove
the previous segment. After you draw two or more polyline segments, you can type ¢ (close) in the
command line to complete the command by drawing a segment that ends at the start point of the first

polyline segment you drew.
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Curved polyline with tapered width. Polyline with straight segments Closed polyline

To draw a polyline with straight segments

Choose Draw > Polyline from the main menu.
Specify the start point.

Specify the endpoint of each segment.

P w N e

Press Enter to end or enter c (close) to close the polyline.
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Polyline start point (A) and segment endpoints (B).

With the Draw Arc option, you can continually draw arc segments until you select the Draw Line
option to go back to drawing line segments. When you draw arc segments, the first point of the arc is
the endpoint of the previous segment. By default, you draw arc segments by specifying the endpoint of
each segment. Each successive arc segment is drawn a tangent to the previous arc or line segment. If

you type c (close) while in the Draw Arc option, the closing segment is created as an arc.

You can also specify the arc using any of the following methods:
e  Start point, center point, included angle
e Start point, center point, chord length
e Start point, center point, endpoint
e  Start point, endpoint, included angle
e Start point, endpoint, direction
e  Start point, endpoint, radius
e  Center point, start point, endpoint
e Center point, start point, included angle
e  Center point, start point, chord length
With more unique functions, editing the polyline is different from that of single lines, such as adjusting
width and curvature of polylines; the additional functions are shown as follows:
e Edit it with PEDIT command
e Use EXPLODE to convert it to the individual line and arc segments
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e Use SPLINE to convert a spline-fit polyline into a true spline
e Use closed polylines to create a polygon

e Create a polyline from the boundaries of overlapping objects

Draw a line and arc combination polyline

Polylines consist of multiple lines and arcs. When drawing a polyline, use the endpoint of the previous
line segment as the start point of next arc segment. You can specify angle, center, direction, and radius

of the circle for drawing arcs, and specify a center point and an endpoint as well.

To draw a line segment followed by an arc polyline segment

Choose Draw > Polyline from the main menu.
Specify the start point.

Specify the endpoint.

At the command prompt, choose Arc.

Specify the endpoint of the arc segment.

I AR o

To complete the command, Press ENTER.

‘g—ﬂt S

Pobyline start point (&), line endpaint’arc start point (B), and arc endpaint (C).

You can edit entire polylines and individual segments using the Edit Polyline tool on the Modify II
toolbar. You can convert polylines into arc and line entities using the Explode tool on the Modify

toolbar.

Create Closed Polylines

When creating polylines with PLINE command, the Close option is only available if no less than two
line or arc segments are drawn. A closed polyline object is drawn if you connect the start point of the

polyline to the endpoint of the last line or arc segment with a line or arc.

Create Wide Polylines

You can draw polylines of various widths by using the Width and Halfwidth options of PLINE
command. The Width and Halfwidth options set the width of the next polyline segments you draw. You

can set the width of individual segments and make them taper gradually from one width to another.
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Zero (0) width produces a thin line. Widths greater than zero produce wide lines, which are filled if Fill
mode is on and outlined if Fill mode is off. The Halfwidth option sets width by specifying the distance

from the center of the wide polyline to an outside edge.

wanving width unifarm width

If you chose Width option, prompts in command line require you to enter starting width and ending
width. While entering different value results in a varying width from the start point to its end. Both the

start point and endpoint are located at the center of the Wide polyline.

6.1.6. Create Polylines from the Boundaries of Objects

You can create a polyline from the boundaries of overlapping objects that form a closed area. A
polyline created using the boundary method is a separate object, distinct from the objects used to create

it. You can edit it using the same methods used to edit other polylines.

To expedite the boundary selection process in large or complex drawings, you can specify a group of
boundary candidates, called a boundary set. You create this set by selecting the objects you want to use

define the boundary.

irternal poirt selected  houndany

With the Boundary command, you can designate a specific area of a drawing for operations such as
hatching and dimensioning. You create a boundary polyline by selecting an area inside a closed loop.

The area you select can be bounded by a single closed object or by multiple objects that intersect.

In cases where objects intersect, ZWCAD interprets the boundary as the closed loop closest to the point
specifying the area. In the following figure, for example, the area point selected in the rectangle results
in a boundary consisting of the closed loop nearest the point selection, as opposed to the closed loop

formed by the rectangle itself.
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Selected point (A) Resulting boundary (B)

To make boundaries more specific, you can create a boundary set. A boundary set specifies which
objects are considered in determining the boundary path. This can make creating the boundary polyline

faster if you are working with a complex drawing.

In the following figure, the circle and triangle are the selected objects. If you select an area anywhere

inside the circle or the triangle, the result is a polyline that bounds the shaded area.

Ao
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Left: Selected objects (A and B)

Right: Point specified in the selected area (C), which results in a new boundary around the shaded area.

To draw a boundary polyline

1. Choose Draw > Boundary from the main menu.

2. Specify the objects that you want to be made available for the boundary polyline
by doing one of the following:

3. Current viewport - Define a boundary set with all entities in the current
viewport. In addition, if this option is selected, any boundary set currently used
will be canceled.

4. Existing set - Click New button to switch to the drawing area, and prompt users to
select objects for defining boundary sets. Press Enter to return to the dialog box
after selection. This option is only available after selecting objects by using the
New button.

Select the Island Detection option.
Click Pick Points.

In the drawing, click inside the area whose closed perimeter forms the boundary,
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not on the polyline itself. If desired, continue clicking inside additionally closed
perimeters.
8. Tocomplete the selection, press Enter.

In the Boundary Creation dialog box, click OK.

6.1.7. Polygons

Creating polygons is a simple way to draw squares, equilateral triangles, octagons, and so on. Polygons
are closed polylines with between 3 and 1,024 equal-length sides.

However, you should keep one thing in mind that rectangles are created by RECTANG command
rather than POLYGON.

Variety of ways can be used for creating a polygon, for example, specify the center point or one of its
edges to define a polygon after you have determined the edges of the polygon. If you want to draw a
polygon based on another object, the following methods are provided with some given qualifications:
e Specifying the radius of an inscribed circle if the distance between the center of the polygon
and the endpoint of each side (inscribed) is known
e Specifying the radius of a circumscribed circle if the distance between the center of the
polygon and the midpoint of each side (circumscribed) is known

e Specifying the length of an edge and where you want to place it

To draw a polygon by vertex

Choose Draw > Polygon from the main menu.
Type 5 to specify five sides of the polygon.
Specify the center of the polygon.
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Specify the vertex of the polygon.
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The center (A) and vertex (B) Resulting polygon

6.1.8. Rectangles

With ZWCAD, rectangles are closed polylines with four sides. You draw a rectangle by specifying its
opposite corners. The rectangle is normally aligned parallel to the current snap and grid alignment, but

you can use the Rotated option to align the rectangle to any angle.

To draw a rectangle
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1. Choose Draw > Rectangle from the main menu.
2. Specify one corner of the rectangle.

3. Specify the opposite corner of the rectangle.

e ‘\Ii__a,

Opposite corners (A and B) Resulting rectangle

You can edit each side of a rectangle individually using the Edit Polyline tool on the Modify II toolbar.

You can convert the sides into individual line objects using the Explode tool on the Modify toolbar.

TIP To control the line width of the rectangle, type “w” in the command line, then type the desired
value of line width. After you change the width of the line, the new width setting remains in effect for

subsequent rectangles until you change it again.

6.1.9. Points

You can draw a point object formatted as either a single dot or as one of 19 other possible display
styles.

To draw a point

1. Choose Draw > Point > Single Point from the main menu.

2. Specify the location of the point.

To draw several points

1. Choose Draw > Point > Multiple Point from the main menu.

2. Specify the location of each point.

Changing the size and appearance of point objects

Changing the size and appearance of point objects affects all point objects already in the drawing, as
well as all points that you subsequently draw. Positive values represent the absolute size of the point
object measured in drawing units. Negative values represent a percentage relative to the drawing screen
so that points retain their visual size as you use the Zoom command to change the magnification of the

drawing.

To change the size and appearance of point objects
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1. Choose Format > Point Style from the main menu.
2. Under Point Style, select the style you want.
3. Under Point Size, specify the point size, or choose one of the options.
4. Click OK.
When you regenerate the drawing, all point objects change to reflect the new size and appearance

settings.

6.1.10. Traces

Creating traces using the TRACE command.

The endpoints of a trace are on the center line and are always cut square. TRACE automatically

calculates the correct levels for connection to adjacent segments.

Traces appear solid filled if Fill mode is on. When Fill mode is off, only the outline of a trace is

displayed.

6.1.11. Freehand Sketches

A freehand sketch consists of many straight line segments, created either as individual line objects or as
a polyline. Before you begin creating a freehand sketch, you must set the length, or increment, of each
segment. The smaller the segments, the more accurate your sketch, but segments that are too small can

greatly increase the file size.

After you specify the length of the sketch segments, move a pointing device to the drawing area on the

screen and then right-click or enter p (pen) to begin sketching.

Your freehand sketch is not added to the drawing until you "Record" the sketch into your drawing. This
means that you temporarily save the segment that you've drawn and the segment length, and you can't

continue sketching until you select eXit or press Enter.

sketch lines

0)

Create Sketches

The SKETCH command controls the pen using the mouse or the Pen option at the command prompt.
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Move a pointing device to the drawing area on the screen and then right-click or enter p (pen) to begin

sketching. Right-click or enter p (pen) again to lift the pen up and stop drawing.

You set the minimum length or increment of the segments.

Before sketching, check the CELTYPE system variable to make sure the current linetype is BYLAYER.
If you use a linetype with dots or dashes and set the sketch line segment shorter than the spaces or

dashes, you won't see the spaces or dashes.

To create a freehand sketch

1. Onthe command line, enter SKETCH and press Enter.
2. Atthe "Record increment" prompt, enter the minimum line segment length.
3.  Move the cursor to the drawing area, and then right-click or enter p (pen) to begin
sketching. When you move the pointing device, ZWCAD draws temporary freehand line
segments of the length you specified. The sketch doesn't accept coordinate input.
During the command, freehand lines are displayed in a different color.
4. Right-click or enter p (pen) again to lift the pen up and stop drawing, so that you
can move the cursor around the drawing area without drawing.
5. Enter R (Record) at any time to write into the drawing the line you're drawing and
those already drawn. If the pen is moved, you can continue drawing after writing. If the
pen is up, click to resume drawing.

6. Press Enter to complete the sketch and write all lines into the drawing.

Erasing freehand sketch lines

You can erase temporary freehand sketch lines that have not yet been written into the drawing by
choosing the Erase option at the command prompt. Those lines can be erased by moving the pen along

the path they were drawn.

Once you record freehand lines, you can't edit them or erase them with the Erase option of SKETCH.
Use the ERASE command if you have finished sketching.

To erase freehand sketch lines

1. While running the SKETCH command, enter E. If the pen was down, it moves up.

2. Move the cursor to the end of the line you drew last and then move it back as far
along the line as you want to erase.

3. To end the erasure and return to the sketch Command prompt, enter E. If you
want to change the current viewport while sketching, make sure the pen is up and

all lines were written into the drawing.
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6.2. Draw Curved Objects

6.2.1. Arcs

An arc is a portion of a circle. The default method for drawing an arc is to specify three points—the
start point, a second point, and the endpoint. You can draw arcs using any of the following methods:

e  Three points on an arc

e  Start point, center point, endpoint

e  Start point, center point, included angle

e Start point, center point, chord length

e  Start point, endpoint, included angle

e  Start point, endpoint, starting direction

e  Start point, endpoint, radius

e Center point, start point, endpoint

e Center point, start point, included angle

e Center point, start point, chord length

e As atangent continuation of the previous arc or line

e Draw Arcs by Specifying Three Points

You can draw an arc by specifying three points, which are separately the start point of the arc, a point
anywhere on the arc and the endpoint of the arc. In the following example, the start point of the arc

snaps to the endpoint of a line. The second point of the arc snaps to the middle circle in the illustration.

1 3

drame an arc by specifying
three points

To draw an arc by specifying three points

Choose Draw > Arc > 3 Points from the main menu.
Specify the start point.
Specify the second point.
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Specify the endpoint.
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Start point (A), the second point (B), and endpoint (C)

Draw Arcs by Specifying Start, Center, End

Under command line prompts for drawing an arc, draw an arc by specifying center, start point, and

endpoint.

3 P

2 1

start{1) s center(2) s end(3)  center(l) s starti2), end(3)

To draw an arc by specifying its start point, center point, and endpoint

1. Choose Draw > Arc > Start, Center, End of the main menu.
2. Specify the start point.

3. Specify the center point.

4. Specify the endpoint.

Start point (A), the center point (B), and endpoint (C)

Draw Arcs by Specifying Start, Center, Angle

Under command line prompts for drawing arcs, draw an arc by specifying a start point and included an

angle.
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inzluded angle

The included angle determines the endpoint of the arc. Use the Start, End, Angle method when you

know both endpoints but cannot snap to a center point.

3 ) P9

start. center. angle  certer. start. angel start. end. andle

To draw an arc by specifying two points and an included angle

Choose Draw > Arc > Start, End, Angle from the main menu.

Specify the start point.

Specify the endpoint.

Specify an included angle. To draw an arc in a counterclockwise direction, enter a

P w N e

positive value for the included angle. To draw an arc in a clockwise direction,

enter a negative value for the included angle.

A O
Cen, J
, B: i
A
1
o Cr Lol

Start point (A), endpoint (B), and included an angle (C)

Draw Arcs by Specifying Start, Center, Length
Draw an arc by specifying the center of the arc after picking the start point of the arc, then specify the

length of the arc. Or using the center, start, Length either, which is actually equal to specifying the

included angle.
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Draw Arcs by Specifying Start, End, Direction/Radius

Draw an arc by specifying start, end radius/Direction, enter a length or click a line segment using any
pointing device either clockwise or counterclockwise. If using the second way, move the cursor to
direct the arc upwards or downwards. As the following picture shows, move the cursor downwards to
draw an arc up concaved.

directiohs
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start. end. radius start. end. directions

Draw Contiguous Arcs and Lines

Immediately after you complete an arc, you can start a line tangent to the arc at an endpoint by
executing the LINE command. Conversely, if you perform the ARC command after you completed a

line, you can start an arc tangent to the line at an endpoint.

arc start point resulting

line

L arc
endpoint

You can connect sequentially drawn arcs in the same way. To create connected arcs using a menu, click
Arc from the Draw menu, and then click Continue. In both cases, the resulting object is tangent to the

previous one. You can use the shortcut menu to repeat the Continue option.

To draw an arc tangent to an arc or line

1. Choose Draw > Arc > Continue from the main menu.

2. Specify the endpoint of the tangent arc.
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Endpoint (A)

6.2.2. Circles

The default method for drawing a circle is to specify a center point and radius.

You can draw circles using any of the following methods:
e  (Center, Radius
e (Center, Diameter
e Two points
e  Three points
e Tangent, Tangent, Radius

e Tangent, Tangent, Tangent

| radius
radiug| 4T o .
.. 1 Faiiidas 2
certer | oo argent
_/ [ ohject
center. radius tweo points three points targent.
defining defining targent. radius

diameter circumference

To draw a circle by specifying its center and radius

1. Choose Draw > Circle > Center, Radius from the main menu.
2. Specify the center point.
3. Specify the radius of the circle.

Center point (A) and radius (B)
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Draw a Circle Tangent to Other Objects

The tangent point is a point where an object touches another object without intersecting it. To create a

circle that is tangent to other objects, select the objects and then specify the radius of the circle.

You can also turn on the Object Snap mode to set the snap point as Tangent, thus you can create circles

that are tangent with other objects easily, three points method is available for creating circles with three

tangent points.

In the illustrations below, the red circle is the one being drawn, and points 1 and 2 select the objects to

which it is tangent.
1.
{
. 3
radius of new radius of new radius of new
circle=1 circle=2 circle=3

To draw a circle tangent to existing objects

Choose Draw > Circle > Tan, Tan, Radius from the main menu.
Select the first tangent point on the object to be tangent with the circle.

Select the second tangent point on the object to be tangent with the circle.

P w N e

Specify the radius of the circle.
C-
AT
1

The radius of the circle (A) and tangent lines (B) and (C)

6.2.3. Ellipses and Ellipse Arcs

Drawing ellipses

The default method for drawing an ellipse is to specify the endpoints of one axis of the ellipse, and

then specify a distance representing half the length of the second axis. The endpoints of the first axis

determine the orientation of the ellipse. The longer axis of the ellipse is called the major axis, and the
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shorter one is the minor axis. The order in which you define the axes does not matter. The program

determines the major and minor axes based on their relative lengths. You can draw ellipses using any of

the following methods:

e C(Center

e Axis, End

To draw an ellipse by specifying the axis and endpoints

P w N e

Choose Draw > Ellipse > Axis, End from the main menu.

Specify the first endpoint.

Specify the second endpoint.

Drag the pointing device away from the midpoint, and click to specify a distance

for half the length of the second axis.

A " Ed'

L. "3

First axis endpoint (A), second axis endpoint (B), and half-length of another axis (C)

Drawing elliptical arcs

An elliptical arc is a portion of an ellipse. The default method for drawing an elliptical arc is to specify

the endpoints of one axis of the ellipse, and then specify a distance representing half the length of the

second axis. Then you specify the start and end angles for the arc, measured from the center of the

ellipse in relation to its major axis.

To draw an elliptical arc by specifying the axis endpoints

IR o

Choose Draw > Ellipse > Arc from the main menu.
Specify the first endpoint.

Specify the second endpoint.

Specify the half-length of the other axis.

Specify the start angle of the arc.

Specify the end angle.

NOTE ZWCAD draws elliptical arcs in the direction you specify. Go to Format > Units menu option,

under Angle tab, the default setting is counterclockwise.
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First axis endpoint (A), second axis endpoint (B), half-length of another axis (C), start angle of arc (D) and end angle

(E)

6.2.4. Splines

The spline is a smooth curve that passes through a series of control points. You can control the fit
tolerance among the curve and points, and apply the fitness to drawing irregular curves. A NURBS

curve produces a smooth curve between control points.

A NURBS curve produces a smooth curve between control points.

Multiple points are required for drawing irregular splines and you can close the spline so that the start

and end points are coincident and tangent.

Tolerance in command line prompts describes how precisely the spline fits the set of fit points you
specify. The lower the tolerance, the more closely the spline fits the points. If the value is set to 0, the

spline curve passes through the fit point.

If you set the tolerance value greater than 0, the spline will go through a fit point within the specified

tolerance range.

Usually, two ways of creating splines are provided:
e Create a spline converted from a polyline using Spline option of PEDIT command.

e Create a spline using SPLINE command, that is NURBS curve.

To draw a spline

Choose Draw > Spline from the main menu.
Specify the first point of the spline.
Specify the second point of the spline.

P w N e

Specify as many more points as you want.
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5.  When you have finished, press Enter.

You can add tangents to the spline, which are lines that give it shape.

1. To add tangents to a spline
2. Specify the starting tangent point.
3. Specify the ending tangent point.

~

Left: Spline

o

A B

Right: Spline with starting tangent point (A) and ending tangent point (B)

Specifying fit tolerance

By default, a spline passes through all of the control points. When you draw a spline, you can change
this by specifying the fit tolerance. The fit tolerance value determines how closely the spline fits the set
of points you specify. For example, a spline fit tolerance value of 0 causes the spline to pass through
the control points. A value of 0.01 creates a spline that passes through the start and endpoints and

within 0.01 units of the intermediate control points.

To specify the fit tolerance

Choose Draw > Spline from the main menu.
Specify the first point of the spline.
Specify the second point of the spline.

P w e

To accept the default of 0.0000, press Enter. To specify a different fit tolerance,
enter F and press Enter, and then specify a new fit tolerance.

5. Specify the additional points you need to draw a spline or a closed spline.

Drawing a closed spline

You can draw a closed spline, which is a spline for which the start point and endpoint are the same.

Because the spline is closed, you specify only one tangent.

To draw a closed spline
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Choose Draw > Spline from the main menu.
Specify the first point of the spline.

Specify the second point of the spline.
Specify as many more points as you want.

When you have finished, on the command line, type C, and press Enter.

I AR S

To complete the command, specify the tangent point.

L

The start point and endpoint (A) of a closed spline.

6.2.5. Donuts

Donuts are solid, filled circles or rings created as closed, wide polylines. You can draw a donut using
several ways. The default method is to specify the inside and outside diameters of the donut and then
specify its center. You can then create multiple copies of the same donut by specifying different center

points until you press Enter to complete the command.

Similar to the way of drawing circle, donuts are closed polylines with certain width with or without fill.
The system variable FILLMODE controls whether to fill the donut or not.

If system variable FILLMODE is set to 1, to create filled donuts; if system variable FILLMODE is set

to 0, to create donuts without filling.

To create a donut, you specify its inside and outside diameters and its center. You can continue creating
multiple copies with the same diameter by specifying different center points. To create solid-filled

circles, just assign the same value for the inside radius and outside radius.

donut

solid filled
circle

filled ring

To draw a donut

1. Choose Draw > Donut from the main menu.

2. Specify the inside diameter of the donut.

3. Specify the outside diameter of the donut.
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4. Specify the center of the donut.
Specify the center point to draw another donut, or press Enter to complete the

command.

Inside diameter (A) and outside diameter (B)

6.3. Create 3D Objects

With 3D models, you can

View entities in three dimensions.
Create three-dimensional entities.

Edit entities in three-dimensional space.
Edit three-dimensional solids.

Display hidden-line and shaded views of three-dimensional entities.

ZWCAD supports three types of 3D modeling: wireframe, surface, and solid. Each type has its own

creation and editing techniques.

Wire-frame models, which consist of lines and curves that define the edges of a
three-dimensional entity. You can create a wire-frame model by drawing lines, arcs, polylines,
and other two-dimensional entities anywhere in three-dimensional space. Wire-frame models
have no surfaces; they always appear as outlines. Because you must individually draw and
position each entity that makes up a wire-frame model, creating one can be exacting and
time-consuming.

Surface models, which consist of both edges and the surfaces between those edges. You can
create a surface model by applying elevation and thickness to two-dimensional planar entities
or by using specific three-dimensional entity-creation commands. Surface models consist of
individual planes forming a faceted, polygonal mesh.

3D solids, which are three-dimensional ACIS entities that consist of faces and edges. 3D
solids appear to have volume and are easier to work with than wireframe and surface models.
ZWCAD supports viewing and limited editing of 3D solids, including moving, rotating and

scaling.
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I0 wireframe salid

You should notice that different editing manipulations result in different visual effects because of
various model and creating methods. You should avoid mixing the models of a different type when
creating 3D objects. Limits are also applied to the conversion of model types, only solid-curve and

curve--wireframe conversions are available.

6.3.1. Set 3D Thickness and Elevation

By default, the program creates new two dimensional objects with a zero elevation and thickness. The
easiest way to create a three-dimensional object is to change the elevation or thickness property of an

existing two-dimensional object.

The elevation of an object is its z coordinate position in relation to the xy plane in which the object is
drawn. An elevation of 0 indicates that the object is drawn on the xy plane of the current UCS. Positive

elevations are above this plane; negative elevations are below it.

The thickness of an object is the distance it is extruded above or below its elevation. A positive
thickness extrudes the object upward in the positive z-direction of the object; a negative thickness
extrudes it downward in the negative z-direction. The thickness is applied uniformly to the entire object.
You can extrude any two-dimensional object into a three-dimensional object by changing the thickness
of the object to a nonzero value. For example, a circle becomes a cylinder, a line becomes a

three-dimensional plane, and a rectangle becomes a box.

O
>

Two-dimensional entities Two-dimensional entities with thickness added

You can create three-dimensional objects using any of the following methods:

Draw two-dimensional objects in three-dimensional space.
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e Convert two-dimensional planar objects into three-dimensional objects by applying elevation

and thickness.

e Convert two-dimensional planar objects into three-dimensional objects by revolving or
extruding.

e C(Create three-dimensional objects, such as boxes, cylinders, cones, domes, spheres, and

wedges.

You can change the default elevation and thickness values to create new objects with an elevation and

thickness already applied.

To set the current elevation

1. Type CHANGE on the command line, and then press Enter after selecting
three-dimensional objects.

2. Enter P (Properties) and press Enter.

3. Enter E (Elev) and press Enter.

4. Specify a new elevation, and then press Enter.

To set the current thickness

1. Choose Format > Thickness from the main menu.

2. Enter a new value for thickness, and then press Enter.

6.3.2. Create Wireframe Models

A wireframe model is an edge or skeletal composition of lines and curves that are used to define 3D

objects.

Tips for Using Wireframe Models

For the objects that are used to construct wireframe are required to be individually created and located,
creating 3D wireframe models can be more difficult and time-consuming than creating their 2D views.

The following tips are provided to help you work more effectively:

Plan and organize models on layers so as to reduce the visual complexity of the model. Specifying
different color for each layer can help with differentiating between objects in various views.

Create construction geometry to define the basic shape of the model.

Use multiple views, especially isometric views, to facilitate visualizing the model and selecting
objects.
To be adept at manipulating the UCS in 3D. Use the XY plane of the current UCS as a work plane to

orient planar objects such as circles and arcs. The UCS is also used as the plane for trimming and
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extending, offsetting, and rotating objects.
Use object snaps and grid snap carefully to ensure the precision of models.

Use coordinate filters to drop perpendiculars and easily locate points in 3D based on the location of

points on other objects.

Create Wireframe Models

You can create wireframe models by positioning any 2D planar object anywhere in 3D space, using the
following methods:

e Specifying the 3D coordinate, which is X, Y, and Z location of the object.

e Setting the default work plane (the XY plane of the UCS) on which you will draw the object.

e Positioning an object by moving or copying to its proper 3D location after you create it.

6.3.3. Create Surfaces

3D meshes use planar embedded surfaces as its surface. Defined from the vertex position of initial
mesh network-axis and secondary network-axis (the direction of M and N), in which Vertex of initial
mesh network-axis points to the M direction, and N direction points to secondary network-axis. Similar
to the function of X and Y axis on XY plane, M and N are designated individually to the vertex

position of row and column, Meshes are available both in 2D and 3D spaces, mainly used in 3D spaces.

Meshes can help solving the problem of using features like hiding, shade and render other than
physical properties (weight, quality, the center of gravity) that is unavailable in using wireframe. You
can also create irregular geometric drawings with meshes, such as a 3D topographical model of

mountainous terrain.

Either closed or open meshes can be created, the following pictures show each meshes open or closed

individually in M and N direction:

Various methods are used for creating a mesh, both using keyboard way to specify mesh parameter or
operating 3D command to draw the planar mesh, the size of M and N of a mesh determines the number

of lines drawn on each direction.
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Create 3D surfaces

You can create a three-dimensional face, which consists of a section of a plane in three-dimensional
space. You define a three-dimensional face by specifying the x,y,z coordinates of three or more corners.
After you specify the fourth point, the program continues to prompt you for additional faces by
alternating prompts for the third point and fourth point to allow you to build a complex
three-dimensional object. Each three or four-sided plane is created as a separate three-dimensional face

object.

To create a three-dimensional face

Choose Draw > Surfaces > 3D Face from the main menu.
Specify the first point of the three-dimensional face.
Specify the second, third, and fourth points.

Specify the third and fourth points for additional faces.

ok W e

To complete the command, press Enter.

TIP Any or all edges of a three-dimensional face can be invisible to allow you to more accurately
model objects with holes in them. As the program prompts you for the corner points, in the prompt box,

choose Invisible to make the next edge invisible.

An example of a three-dimensional model created using three-dimensional faces.

Create 3D Meshes

The 3D command is widely used for creating objects as boxes, cones, dishes, meshes, pyramids,

spheres, donuts, and wedges. Before hiding 3D entities, all the meshes are displayed in wireframe.
Use VPOINT to view the entity once you have created a 3D entity, or performed View-3D Orbit from

View menu options to view the 3D entity in full perspective. The following picture displays entities as

meshes with specified vertexes.
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Creating rectangular meshes

You can create a three-dimensional rectangular mesh consisting of four-sided polygons. You determine
the size of the mesh by specifying the number of vertices along the primary (M direction) and

secondary (N direction) mesh axes and then specifying the coordinates for each vertex.

To create a rectangular mesh

Choose Draw > Surfaces > 3D Mesh from the main menu.
Specify the number of vertices along the primary mesh axis.
Specify the number of vertices along the secondary mesh axis.

Specify the coordinates for each vertex.

vk W e

Specifying the coordinates for the last vertex completes the mesh and ends the

command.
TIP Although creating rectangular meshes manually can be exacting, they are useful for representing

complex surfaces such as three-dimensional terrain models. The 3D Mesh tool is most useful when

combined with scripts or LISP programs that mathematically calculate the coordinates of the vertices.
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An example of a three-dimensional terrain model created using rectangular meshes.

The following picture shows the polygon mesh with coordinates specified for each vertex.
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Create Polygon Meshes

You can create a polygon mesh consisting of faces connecting three or more vertices.

You first determine the coordinates of each vertex and then define each face by entering the vertex
numbers for all the vertices of that face. As you create each face, you can control the visibility and

color of each edge and assign each edge to specific layers.

When creating meshes, a positive vertex means an invisible edge. The system variable SPLFRAME
controls whether to show the invisible edges or not. If set SPLFRAME on, any assumed surfaces and

invisible edges are displayed as those visible meshes.

To create a Polyface mesh

1. Type PFACE and then press Enter.

2. Specify the coordinates of each vertex.

3. After each vertex that you specify, the next vertex number is displayed, and you
are prompted for the coordinates of the vertex. Specify the coordinates, and then

press Enter. Continue to specify the coordinates for each numbered vertex.
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4. To finish specifying vertex coordinates, press Enter.
Specify the vertex numbers that define the first face. You specify the face by
entering the vertex numbers that were defined when you specified coordinates in
step 2. Each face can be composed of three or more numbered vertices.
To finish defining the first face, press Enter.
Specify the next face by entering its vertex numbers.

To complete the command, press Enter.

TIP To make an edge invisible, type the vertex number as a negative value.

Create Ruled Surface

RULESUREF creates a polygon mesh representing the ruled surface between two curves. The entities
you select define the edges of the ruled surface. The entities include the point, line, spline, circle, arc or
polyline. If the first entity is a closed one, the other one must be closed two or a point. If the first entity
is a point, the other one should be a closed or open entity. There is only one point as a boundary curve

on a ruled surface.

L
g | Q
curves defined result

If you select a closed polyline, the ruled surface begins at the last vertex and proceeds backward along
the polyline segments. If you select open curves, selecting objects at the same side of the two objects to
create a ruled surface, selecting objects at the different side of the two objects to create crossed ruled

surface, shown as follows:

specified paints an result
correspaonding sides
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specified points on result
opposite sides
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To create a ruled surface mesh

1. Choose Draw > Surfaces > Ruled Surface from the main menu.
2. Select the first defining object.
3. Select the second defining object.

C D S

Select the first (A) and second (B) defining objects The resulting ruled surface mesh

Create Tabulated Surface

Creates a polygon mesh defined by a path and a direction vector. The path curve defines the surface of
the polygon mesh. The objects like a line, arc, circle, ellipse, or 2D or 3D polyline can be used as
outline curves for defining polygons. Both lines and open 2D or 3D polylines are used as the direction

vector.

Tabulated surface meshes are used as a serial of a paralleled polygon on the specified path, you should

draw direction vector and original object before creating a Tabulated Surface.

T

NN

ohject specified  directionwector  result
specified

To create an extruded surface mesh

1. Choose Draw > Surfaces > Tabulated Surface from the main menu.
2. Select the object to extrude.

3. Select the extrusion path.

AAJ' J

Select the object to extrude (A) and the extrusion path (B) The resulting extruded surface mesh
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NOTE An extruded mesh is different from an extruded solid. If you want to extrude an object and

convert it to a three dimensional solid, use the Extrude command.
Create Revolved Surfaces

Use REVSURF command to create a surface of revolution by rotating a profile of the object about an
axis. The object to be revolved can be a line, arc, circle, ellipse, elliptical arc, closed polyline, polygon,

closed spline or torus. REVSUREF is useful for surfaces with rotational symmetry.

B

1l &=

profile specified  axis of rewolution  result
specified

You can create a surface of revolution, which is a three-dimensional polygon mesh that approximates
the surface generated by rotating a two-dimensional profile around an axis. You select the two objects
that define the profile and the axis. You also specify the starting angle and the number of degrees to

revolve the profile.

Revolving the profile 360 degrees creates a closed three-dimensional mesh. The Number Of M
Direction Surfaces value determines the mesh density (the number of mesh segments) in the M
direction (around the axis of revolution). The N Direction Mesh Density value determines the mesh

density (the number of mesh segments) in the N direction (along with the axis of revolution).

To create a revolved surface mesh

Choose Draw > Surfaces > Revolved Surface from the main menu.
Select the object to revolve.
Select the object to be used as the axis of revolution.

Specify the starting angle.

vk W e

Specify the number of degrees to revolve the object.
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Select the object to be revolved (A) and the axis of revolution (B) The resulting revolved surface mesh

Create Edge-Defined Surface Meshes

You can create a surface called a Coons surface patch, a mesh connecting four edges. You select the
entities that define the edges. Edge entities can be arcs, lines, or polylines. The four edge entities must
form a closed loop and share endpoints. A patch is a bicubic surface (one curve extends in the
M-direction and the other in the N-direction) interpolated between the four adjoining edges. You can

select the edges in any order. The first edge you select determines the M-direction of the mesh.
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four edyes selected result

To create an edge defined Coons surface patch mesh

1. Choose Draw > Surfaces > Edge Surface from the main menu.
2. Select the first edge.
3. Select the second, third, and fourth edges.

L
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Select the objects to be used as the four edges (A, B, C, and D) The resulting Coons surface patch mesh

6.3.4. Create 3D Solids

Creates 3D solids in a drawing. A solid object represents the entire volume of an object. Complex solid

shapes are also easier to construct and edit than wireframes and meshes.

You can use the following methods to create solids:
e Combines one of the basic solid shapes such as a box, cone, cylinder, sphere, torus, and wedge
or by extruding a 2D object along a path or revolving a 2D object about an axis.

e Once you have created a solid in this manner, you can create more complex shapes by
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combining solids. You can join solids, subtract solids from each other, or find the common
volume (overlapping portion) of solids. Solids can be further modified by filleting, chamfering,
or changing the color of their edges.

e Solids are displayed as wireframes until you hide, shade, or render them. Additionally, you
can analyze solids for their mass properties (volume, moments of inertia, the center of gravity,
and so on). You can break a solid into mesh and wireframe objects using explode command.

e The ISOLINES system variable controls the number of tessellation lines used to visualize
curved portions of the wireframe. The FACETRES system variable adjusts the smoothness of

shaded and hidden-line objects.

Create a Solid Box

You can create rectangular boxes or cubes. A box consists of six rectangular surface planes. The base of
the box is always parallel with the xy plane of the current UCS. You position the box by specifying
either a corner or the center of the box. You determine the size of the box by either specifying a second
corner and the height; defining the box to be a cube and then providing its length; or specifying the
length, width, and height.

The length of the box is mapping to X-axis of current UCS, and its width maps to the Y axis, and
height maps to the Z axis.

RECTANG or PLINE command creates a rectangle or closed polyline from which you can create a box

using EXTRUDE. The 3D command creates a box shape defined by surfaces only.

To create a box

Choose Draw > Solids > Box from the main menu.
Specify the first corner of the base.

Specify the opposite corner of the base.

P w N e

Specify the height.
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First corner of the base (A), the opposite corner of the base (B), and the height (C)

To create a box as a three-dimensional surface

Choose Draw > Surfaces > 3D Surfaces from the main menu.
On the command line, type B (Box).
Specify the first corner of the base.

Specify the opposite corner of the base.

vk W oe

Specify the height.

Create a Solid Cone

Draw a solid cone in current drawing using CONE command. By default, the cone's bottom lies on the
XY plane of the current UCS. The cone height is parallel to the Z-axis. The apex determines the height

and orientation of the cone.

You can draw a 2D circle and then use EXTRUDE to taper the circle at an angle along the Z axis to

create a solid cone.

To complete the truncation, you can subtract a box from the tip of the cone with the SUBTRACT

command. The 3D command creates a conical shape defined by surfaces only.

To create a cone

Choose Draw > Solids > Cone from the main menu.
Specify the center of the base of the cone.

Specify the radius or diameter.

P w e

Specify the height.
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Center of the base (A), the radius of the base (B), and the height (C)

To create a cone as a three-dimensional surface

Choose Draw > Surfaces > 3D Surfaces from the main menu.
On the command line, type C (Cone).
Specify the center of the base of the cone.

Specify the radius or diameter.

vk W e

Specify the height.

Create a Solid Cylinder

You can create cylinders defined by a circular base. The base of a cylinder is always parallel with the
xy plane of the current UCS; the height of a cylinder is always parallel with the z-axis. You position a
cylinder by specifying the center of the base. You determine the size of a cylinder by specifying either

the radius or diameter of the base and the height.

2

You can draw a circle and then use EXTRUDE to create a solid cylinder. To construct a cylinder with
special detail, such as grooves along its sides, you can create a 2D profile of its base with a closed
PLINE and then use EXTRUDE to define its height along the Z-axis.

To create a cylinder

Choose Draw > Solids > Cylinder from the main menu.
Specify the center of the base of the cylinder.

Specify the radius or diameter.

P w e

Specify the height.
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Center of the base (A), the radius of the base (B), and the height (C)

To create a cylinder as a three-dimensional surface

1. Choose Draw > Surfaces > 3D Surfaces from the main menu.

2. Onthe command line, type L (cyLinder).
3. Specify the center, radius, and height as described previously.

Spheres

You can create spheres. The latitude lines of a sphere are always parallel with the xy plane of the
current UCS; the central axis is always parallel with the z-axis. You position a sphere by specifying its

center point. You determine the size of a sphere by specifying either its radius or its diameter.

2

To create a dome or dish, combine a sphere with a box and use SUBTRACT. If you want to create a
spherical object with additional details, create a 2D profile and use REVOLVE to define a rotation

angle about the Z axis. The 3D command creates a spherical shape defined by surfaces only.

To create a sphere

1. Choose Draw > Solids > Sphere from the main menu.
2. Specify the center of the sphere.
3. Specify the radius or diameter.
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Center (A) and radius (B) of the sphere The resulting sphere

To create a sphere as a three-dimensional surface

Choose Draw > Surfaces > 3D Surfaces from the main menu.
On the command line, type S (Sphere).
Specify the center of the sphere.

Specify the radius or diameter.

vk W e

Specify the number of longitudinal sections that are perpendicular to the xy
plane.

6. Specify the number of latitudinal sections that are parallel to the xy plane.

Dishes

You can create a three-dimensional dish. The latitude lines of a dish are always parallel with the xy
plane of the current UCS; the central axis is always parallel with the z-axis. You position a dish by
specifying its center point. You determine the size of a dish by specifying either its radius or its

diameter.

To create a dish as a three-dimensional surface

1. Choose Draw > Surfaces > 3D Surfaces from the main menu.
2. Onthe command line, type DI (DlIsh).

3. Specify the center and radius or diameter as described previously.

Domes

You can create a three-dimensional dome. The latitude lines of a dome are always parallel with the xy
plane of the current UCS; the central axis is always parallel with the z-axis. You position a dome by
specifying its center point. You determine the size of a dome by specifying either its radius or its

diameter.
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To create a dome as a three-dimensional surface

1. Choose Draw > Surfaces > 3D Surfaces from the main menu.
2. Onthe command line, type DO (DOme).

3. Specify the center and radius or diameter as described previously.

Torus

You can create a three-dimensional donut or ring-shaped object known as a torus. The diameter of a
ring is always parallel with the xy plane of the current UCS. A torus is constructed by revolving a circle
about a line drawn in the plane of the circle and parallel with the z-axis of the current UCS. You
position a torus by specifying its center point. You determine the size of a torus by specifying its

overall diameter or radius and the diameter or radius of the tube (the circle being revolved).

You can draw a torus with no center hole called self-intersecting torus because the radius of the tube is
greater than the radius of the torus. To create a bipolar-depression solid, specify a positive tube radius

greater than the radius of the torus. The 3D command creates a toroidal shape defined by surfaces only.

To create a torus

Choose Draw > Solids > Torus from the main menu.
Specify the center of the whole torus.

Specify the radius or diameter of the whole torus.
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Specify the radius or diameter of the body of the torus.

Center (A) and radius of the whole torus (B), and the radius of the body (C)

To create a torus as a three-dimensional surface

1. Choose Draw > Surfaces > 3D Surfaces from the main menu.
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Wedges

You can create three-dimensional wedges consisting of five surface planes. The base of the wedge is

always parallel with the xy plane of the current UCS with the sloped face opposite the first corner. The

height is

center of

height; defining the wedge based on a cube having a given length; or specifying the length, width, and

height.

On the command line, type T (Torus).
Specify the center of the whole torus.
Specify the radius or diameter of the whole torus.

Specify the radius or diameter of the body of the torus.

o Uk W

plane.

7. Specify the number of latitudinal sections that are parallel to the xy plane.

always parallel to the z-axis. You position the wedge by specifying either a corner or the

the wedge. You determine the size of the wedge by either specifying a second corner and the

To create a wedge

Specify the number of longitudinal sections that are perpendicular to the xy

Choose Draw > Solids > Wedge from the main menu.
Specify the first corner of the base.

Specify the opposite corner of the base.
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Specify the height.

™

B
o

First corner of the base (A), the opposite corner of the base (B), and the height (C)

To create a wedge as a three-dimensional surface

1. Choose Draw > Surfaces > 3D Surfaces from the main menu.
2. Onthe command line, type W (Wedge).
3. Specify the first corner of the base.
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4. Specify the opposite corner of the base.
5. Specify the height.

Helix

When you create a helix, you can specify the following:

*  Base radius

e Top radius

¢ Helix height

e  Number of turns

e Turn height

e Twist direction

You can use a helix as a path along which to sweep an object to create an image as follows, sweeping a

circle along a helix path to create a solid model of a spring.

Pyramid

Create a 3D solid pyramid.
By default, a pyramid is defined by the center of the base of the point, a point on the middle of the edge,

and another point that determines the height.

Solids Extrude

EXTRUDE extrudes the profiles of the selected object along the chosen path to create solids.
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The entities you can extrude are planar 3D faces, closed polylines, polygons, circles, ellipses, closed
splines, donuts, and regions. You cannot extrude objects contained within a block or polylines that have

crossing or self-intersecting segments.
To extrude the objects that are lines or arcs intersect with polylines, you can use Join option of PEDIT
command to convert them into multiple single polyline objects or convert them into regions before

using PEDIT command.

When an arc is part of a tapered extrusion, you need to set a small value to the angle of the arc, because

larger angle may cause the outline to become a point before it attaches to the specified height.

O @\

original object  extruded object

To create an extruded solid

1. Choose Draw > Solids > Extrude from the main menu.
2. Select the object to extrude.

3. Select the extrusion path, or specify the height.

A—l ,_IJ}

b

Select the object to extrude (A) and the extrusion Path (B) The resulting extruded surface mesh

Solids Revolve

REVOLVE command revolves a 2D object to the specified certain angle to form solids. The revolving

axis can be X, Y axis of current UCS as well as lines, polylines.

Similar to EXTRUDE, the REVOLVE command easily helps drawing the details of a drawing that is

hard to implement by the common outline.

To revolve the objects that are lines or arcs intersect with polylines, you can use Join option of PEDIT
command to convert them into multiple single polyline objects, and then perform REVOLVE

command.
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Objects can be revolved are closed polylines, polygons, rectangles, circles, ellipses, regions and so on.
On the contrary, the objects can't be revolved are 3D objects, objects that are included in a block,

polylines with intersections and transections or unclosed polylines.

ariginal polyline revolved about ¥ axis  revolved about Y axis

15
I_—LI

ohjectto revalve axis selected result
celected

To create a revolved solid

Choose Draw > Solids > Revolve from the main menu.

Select the object to revolve.

Do one of the following to define the axis of revolution:

Specify a start point and an endpoint.

Type o and press Enter to select an object that determines the axis.
Type x and press Enter to select the x-axis.

Type y and press Enter to select the y-axis.
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Specify the angle of revolution.

F . Sy
A — —

Left: Select the object to revolve (A) and the axis (B) about which to revolve it, followed by the angle of revolution

Right: The resulting revolved solid

Mirror3D

Creates a mirrored copy of selected 3D objects across a mirroring plane.
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You can specify the mirroring plane the following:

*  Object: Uses the plane of a selected planar object

e Last: Mirrors the selected objects about the last defined plane

* 7 Axis: Defines the plane by a point on the plane and a point normal to the plane

*  View: Aligns the plane with the viewing plane of the current viewport through a point
e XY/YX/ZX: Aligns the plane with one of the standard planes through a specified point
* 3 Points: Defines the plane by three points

Creating composite solids

You can create composite three-dimensional solids by combining, subtracting, and finding the

intersection of two or more solids.

With UNION command, you can combine the total volume of two or more solids or two or more

regions into a composite object.

ohjectsto he comhined result

To combine solids
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1. Choose Modify > Solids Editing > Union from the main menu.

2. Select the objects to combine.

Select the objects to combine (A and B) The resulting combined solid

Use SUBTRACT to remove the common area of one set of solids from another.

gl hiects to subtract from

7 1

t &
1S |

[
ohjectsto subtract
selected

select ohjects result

To subtract solids

1. Choose Modify > Solids Editing > Subtract from the main menu.

2. Select the objects to subtract from one another.

LN

Select the objects to subtract (A and B) The resulting solid

INTERSECT command creates a composite solid from the common volume of two or more
overlapping solids. The common volume is used to create composite solid and the non-overlapping

portions will be removed.
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ohjects to intersect selected result

Unlike INTERSECT command, INTERFERE compares the objects between two selected sets and
creates a composite entity with the common volume of two or more solids without removing the

original objects.

To intersect solids

1. Choose Modify > Solids Editing > Intersect from the main menu.

2. Select the objects to intersect.

Select the objects to combine (A and B) The resulting combined solid

6.4. Create Regions

You can convert a closed object into a two-dimensional region. After you create a region, you can
modify it using the various three-dimensional tools. For example, you can create a region from a

square, and then extrude the square to create a three-dimensional cube.

You can create regions from closed objects, such as polylines, polygons, circles, ellipses, closed splines,

and donuts.

Creating regions typically has no visible effect on a drawing. However, if the original object had a

width or lineweight, that information is lost when you create the region.

Regions can be used for applying hatching and shading and extracting design information, such as the

centroid, and using MASSPROP to analyze properties, such as area.
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shapesthat can form regions

Besides using closed 2D objects, you also have various options to create a region, such as connecting
multiple loops or endpoints of open curves. However, the closed area inside the unclosed objects will

not form regions. For example, crossed arcs or intersected curves.

BOUNDARY creates region by specifying inner points of the closed area, to form a boundary with
existing objects. If the objects are intersected with each other, ZWCAD takes the closed area nearest to

the selected points as a boundary.

Meanwhile, a combined region is created through the union, subtract or intersect among several areas.
When using a union, subtract or intersect for complex regions, you can fill the area and analyze its arca
as well. The following region objects show combined areas of the union, subtract or intersect orderly:
Objects combined using UNION:

e
i 2
4
[
selected regions result

Objects combined using SUBTRACT:

1

= =
v
2
[~

‘G’

selected regions result-a composite
region

Objects combined using INTERSECT:

A

A

selected intersecting  result
regions
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To create a region

Choose Draw > Region from the main menu.
Select the objects to create the region.

Press Enter.
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The command bar displays a message that describes how many regions were

created.

6.5. Create Revision Clouds

REVCLOUD creates a polyline of sequential arcs to form a cloud-shaped object. Revision Cloud helps

mark your drawings by highlighting some important parts when reviewing or redline drawings.

You can create a revision cloud from scratch, or you can convert objects, such as a circle, ellipse,
polyline, or spline, to a revision cloud. If DELOBJ is set to 1 (the default), the original object is deleted

once you convert an object to a revision cloud.

You can set the minimum and maximum default values for the arc lengths of a revision cloud. You
should notice that the maximum arc length can't be more than 3 times as big as the minimum arc length.
REVCLOUD stores the last used arc length as a multiple of the DIMSCALE system variable to

provide consistency among drawings with different scale factors.

Make sure that the entire area to be outlined with REVCLOUD before using the command.

REVCLOUD can't be transparent used and real-time panning and zooming.
(&) ‘”j X

6.6. Create Break Lines

Creates a polyline and inserts the breakline symbol. Options are provided to control the relative size
and appearance of the breakline symbol and an extension of the polyline beyond the selected start and

end points.

To use your own block for the breakline symbol, make sure that the block contains two point objects on
the Defpoints layer. Those point objects determine the placement of the symbol and how the line will
be broken.
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NOTE Current settings of DIMSCALE are capable of controlling the terminal size of break line
flexibly.

6.7. Create Wipeouts

Wipeouts are unique entities that can help you hide areas of your drawing. They display with the

current background color, so the details behind the wipeout do not display or print.

Wipeouts are similar to other entities — you can copy, mirror, array, erase, rotate, and scale them, and

they can be used in both model space and paper space.

If you want to print the wipeout entities located in a drawing, you must print to a raster-capable printer.
Note that in some cases you may have unexpected results when printing drawings that contain wipeout

entities, for example, if printing on colored paper.
Drawing wipeouts using polygons and polylines

Wipeouts are created using existing polygons, closed zero-width polylines made up of only line

segments, or new polylines that you draw while using the WIPEOUT command.

To draw a wipeout

Choose Draw > Wipeout from the main menu.
Specify the start point.

Specify the endpoint of each segment.
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After specifying the last endpoint, press Enter.
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v
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Drawing without wipeout Drawing with wipeout

To create a wipeout using an existing polygon or polyline
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1. Choose Draw > Wipeout from the main menu.
2. Choose P (Polyline).
3. Select the closed polyline to use for the wipeout.
4. Choose one of the following:
Yes — Creates the wipeout and deletes the polyline used to create the wipeout.

No — Creates the wipeout and keeps the polyline used to create the wipeout.

Turning wipeout frames on or off

Each wipeout has a frame along its boundary. Wipeout frames can be turned on or off for any drawing.
When wipeout frames are on, you can select and modify wipeouts. You may want to turn off wipeout

frames when it's time to print.

To turn wipeout frames on or off

1. Choose Draw > Wipeout from the main menu.
2. Choose F (Frames).
3. Choose On or Off.

v v
Ko O

Wipeout frames turned on Wipeout frames turned off
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7. Modify Objects

7.1. Select Objects

You can create a selection set that consists of one or more objects before you modify them.

Use any of the following methods to create a selection set:
e Choose a command or tool first, and then select objects.
e Select objects first, and then choose a command or tool (most objects).

e Select objects by pointing, and then use grips to modify them.

7.1.1. Select Objects Individually

You can select one or more objects under the prompt of Select objects on the command line. The

selected highlights on the screen and could be removed from the selection set.
Select objects with pickbox

You can select objects using a mouse or another pointing device. The mouse or other pointing device is
represented of square pickbox on the drawing area. When selecting an object, the cursor square
pickbox should be in the position of an object but not inside it. The size of pickbox can be changed on

the Selection tab of Options dialog box.
Remove Selection from Objects

If an object is no longer needed in a selection set, you can deselect it to remove it from the selection
set.

To remove an object from the selection set: Press Shift, and then select the object again.

NOTE Pressing Shift while selecting objects using a crossing window removes all objects from the

specified selection set.

To remove all objects from the selection set

1. Press Escape.
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Prevent Objects from Being Selected

You can prevent objects from being selected by locking the layer. Because locking layer means that
you can do any operations except for editing objects on this layer. You can set the locked layer as the

current layer and add objects as well as using requiring command (such as LIST) and Objects Snap.

You can control whether you select objects first or type a command first, whether the selected objects

are highlighted, how to define the selection area, how to create a selection set.
Select Objects First

You can select objects first and then choose how to modify them. As you select each object, it is

highlighted with small squares called grips, which appear at strategic points on the object.

The locations of the grips depend on the type of object selected. For example, grips appear at the
endpoints and midpoint of a line, at the quadrant points and the center point of a circle, and at the

endpoints, midpoint, and center of an arc.

/1D O

Examples of grip locations.

After you select one or more objects, you can choose an object modification command, such as Copy
or Move, from the Modify menu or toolbar. You can also click the right mouse button to display a
shortcut menu containing the object modification commands appropriate for the selected objects, and

then choose the command from the menu.

Select a Command First

After typing a command, the cursor becomes a pickbox and prompts you to select objects. There are
several methods for selecting objects:
e Select objects using a mouse or another pointing device.
e Click on the drawing area and drags the cursor to define a square selection area.
e Entering interrogation? displays all selection methods, from which, you can specify the
desired one.
e  Use multiple methods together. For example, to select most of the objects on the drawing, you

can select all objects and then remove the undesired ones.

When you choose an object-modification tool or command, the program prompts you to select objects.

165



ZWCAD User Guide

Typing ? and pressing ENTER, you can choose a selection method. You can select individual objects or

use other techniques such as selection windows to select multiple objects.

When you select objects, you add them to the selection set. After you select at least one object, you can
remove objects from the selection set. To finish adding objects to the selection set, press Enter. Most

object-modification commands then act on the entire selection set.

Control the highlight of selected objects

You can specify whether to display selected objects highlighted, which makes the selection set easier to

see. By default, the highlighting feature is turned on.

Setting system variable HIGHLIGHT 0 turns off the highlighting feature, which can improve the

computer's performance. The operation does not affect grips.

Objects selection methods

When you choose a command that requires you to select objects (when you're deleting or changing
object properties, for example), you can use any of the following selection methods by choosing them
at the command line prompt or entering them in the command bar:

e Window Selects objects contained entirely within a rectangular selection window.

e Last Selects the last selected object.

e Crossing Selects all objects contained within or crossing the boundary of a rectangular

selection window.

e BOX Selects all objects inside or crossing a rectangle defined by two points.

e ALL Selects all objects in the current drawing.

¢ Fence Selects all objects crossing a selection box.

e  WPolygon Selects all objects inside a defined polygon.

e CPolygon Selects all objects within or crossing a polygon defined by specifying points.

e Group Selects all objects in the specified group.

e Add Adds one or more objects to the selection set.

¢ Remove Removes one or more objects from the selection set.

e  Multiple Selects multiple objects and highlights them.

e Previous Selects the previous selection set.

e Auto Switches to the "Auto" mode. Pointing to an object means selecting the object.

e Slngle You can only select an object for each time.

Cycle Select

When you want to select something behind other objects, Cycle Select can help you easily pick
whatever you want. Click “Cycle Select” button on the status bar or hold <Shift+Space> to turn on the
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Cycle Select mode, and then click the object you want to select. After that, you will see the currently
selected object being highlighted. If it’s not the one you want, just keep clicking your mouse, then it
will switch among overlapped objects until you find the correct one and press Enter or Space to

confirm.

7.1.2. Select Multiple Objects

You can select multiple objects at one time using rectangular area or fence.
Specify a Rectangular Selection Area

You can select all objects inside the rectangular selection area. When specifying the first corner, there
are two methods to define a rectangular selection window:
e Drags the cursor from left to right to create an enclosed window selection. The objects entirely
contained in the rectangular selection area are selected only.
e Drags the cursor from right to left to create a crossing selection. The objects contained or

passing through the rectangular selection area are selected.

The selected objects must be entirely contained in the window selection area when you use Window
Selection. However, if the non-continuous (dash) linetype is only partially visible in the viewport and

all of the visible vectors of the linetype are inside of the selection window, the entire object is selected.

To create a Window

1. Click to select a point in the drawing.

2. Click to the right of the first point to select a second point in the drawing.
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Window by selecting the first (A) and second (B) points. Resulting selection

To create a Crossing Window

1. Click to select a point in the drawing.

2. Click to the left of the first point to select a second point in the drawing.
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Crossing Window by selecting the first (A) and second (B) points Resulting selection

In addition to a rectangular window, you can define a selection window using other shapes such as a

polygon, circle, or fence (a multi-segmented line that selects objects it crosses).

Specify an Irregularly Shaped Selection Area

You can select objects with an irregularly shaped area defined by the specified points. Under the
prompt of SELECT command, you can select objects entirely enclosed by the selection area with the

WPolygon, or the objects enclosed or crossed by the selection area with the CPolygon.
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To select objects using WPolygon

Activate an object modification command.
On the command line, type WP (WPolygon).
Specify the vertices of the polygon.

P w e

To complete the selection polygon, press Enter.
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Window Polygon by specifying the vertices of the polygon (A, B, and C) Resulting selection

Specify a Selection Fence

It could be much easier to select objects in a complex drawing by using a selection fence. A selection

fence appears like a polyline and chooses only the objects it passes through.

To select objects using Fence

Activate an object modification command.
On the command line, type F (Fence).

Specify the endpoints of the Fence segments.

P w e

To complete the Fence, press Enter.
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Fence by specifying the endpoints of the fence segments (A, B, and C) Resulting selection
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Use Other Selection Options

Typing SELECT and entering? displays all selection options, from which, you can choose a proper one.

Remove Selection from Multiple Objects

Under the prompt of Select objects, you can type R and choose a selection to remove objects from the

selection set. You also can enter A to add objects to the selection set.

169



ZWCAD User Guide

Holding down SHIFT and selecting objects again, the selected objects would be removed from the

selection set.

7.1.3. Quick Selection

You can use QSELECT to create a selection set includable or exclusive of the objects which are accord
with the filtering criterion. The selection set created by the QSELECT command can be applied to the

entire drawing and replaces or appends to the current selection set.

You can enter QSELECT on the command line or click Quick Select button from the Properties palette
to open Quick Select dialog box. With the specified filtering condition, you can quickly define the

selection set.

7.1.4. Group Objects

A group is a saved set of objects which you can choose and modify together or separately as needed.
Groups provide an easy way to edit the drawing units as a unit. You can add or remove objects to or

from the groups as needed.

The objects within a group can be edited as a unit, which resembles blocks. However, the groups are
saved from session to session. And you can easily edit individual objects in groups, but in blocks, you

have to explode blocks before you edit them. Groups cannot be shared with other drawings.
Create Groups

Entering GROUP command opens the Group dialog box, from which, you can give a name and
description to create a group. If you copy a group, the default name is *Ax, and it is considered

unnamed. When you select Display Unnamed Groups, the list displays all the unnamed groups.

When you select an object from a group, the other objects of this group are also selected at the same
time. The objects can be members of more than one group, and the group can be nested in another

group. You can restore a nested group to the original group configuration by ungrouping it.

The named groups are not available when you insert a drawing as an external reference or a block.

However, it is available if your band and then explode the external reference or explode the block.

A group containing too many objects can degrade the performance of the system.

To create a group

1. Onthe command line, type GROUP.
2. Under Create New Group, enter the name and description of the group.
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3. Click Selectable if you want all entities in the group to be selected when you
select one entity of the group in the drawing.

4. Click Select Entities and Create Group.
Select the objects for the group, and then press Enter.

6. Inthe Group dialog box, click OK.

Select Objects in Groups

You can type a group name to select a group at the prompt of Select entities. If the system variable
PICKSTYLE is set to 1 or 3, you can select any objects of the group.
When you select an object that is a member of more than one groups, all the objects from that groups

containing the selected object are selected.

Edit Groups

You can add or remove group members and rename groups in the Group dialog box. You can also do

the operation such as copy, mirror and arrange as well as giving a description.

You can remove members of a group from selecting objects on the drawing by clicking the Remove
entities from Group button. If a group member is included in a deleted block, the object is removed
from the drawing and also from the group. The group maintains defined even all the group members

are removed.

To modify a group and its objects

On the command line, type GROUP.

Select the group you want to modify.

Under Modify Selected Group, do one or more of the following:
Enter a new name, and then click Rename Group.

Enter a new description, and then click Change Group Description.

Select whether you want the group to be selectable in the drawing.
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Click Add Entities to Group, select the objects to add to the group, and then press
Enter.

8. Click Remove Entities from Group, select the objects to remove from the group,
and then press Enter.

9. Inthe Group dialog box, click OK.

You can delete group definition by clicking Un-group entities button. The group is also removed from

the drawing; however, the group members remain in the drawing.

To ungroup objects
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On the command line, type GROUP.

Select the group to delete.

Under Modify Selected Group, click Un-group Entities.
Click OK.
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Exploding a group deletes it from a drawing; however, objects that were part of the group remain in the

drawing.

The group's member order can be changed (the order in which the objects were selected). There are two

ways to reorder group members.

Change the serial number of individual members or arranges of group members.
Reverse the ranking of all members. The number of the first object in each group starts from 0

rather than 1.

To change the order of objects in a group

1. Onthe command line, type group.

2. Under Modify Selected Group, click Reorder Entities.

3. Inthe Reorder Grouped Entities dialog box, select the group you want to reorder.

4. To see the order of objects in the group, click Highlight. Follow the prompts that
display to view the objects one by one.

5. Toreverse the order of all objects in the group, click Reverse Order.

To change the order of specific objects or a range of objects:

1. In Remove from Position, enter the current position of the object.
2. In Place to Position, enter the new position of the object.
3. In Number of Objects, enter the number of objects or range of objects to reorder.
For example, if you are changing the order of only one object, enter 1.
4. Click Reorder.
NOTE The objects in a group are numbered 0, 1, 2, 3, and so on.
5. Click OK, and then click OK again.

7.2. Modify Objects

7.2.1.

Remove Objects

Removes objects using one of the following methods:

Delete objects with ERASE command.
Cut the selected objects to the clipboard.
Press DELETE to remove the selected objects.

You can use ERASE command to delete objects, whatever the methods you use to select
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objects.

e To restore the deleted objects, use UNDO command.

e OOPS, the command can restore objects deleted with the ERASE, BLOCK or WBLOCK
command.

e To delete mark of plus sign (point mark), perform REDRAW command to refresh the screen.

e To delete unused named objects, such as block definition, dimension style, layer, linetype and

text style, perform PURGE command.

7.2.2. Copy Objects

You can copy one or more entities, making one copy or multiple copies within the current drawing.

You can also copy entities between drawings.

You can duplicate objects within the current drawing. The default method is to create a selection set

and then specify a base point, and a displacement point, for the copy.

While specifying two points, you can enter two coordinates to copy objects with the relative distance.
The location of copies is determined by the relative coordinate. You do not have to enter coordinate

with the @ as the relative coordinate is assumed.

To copy objects at the specified distance, you can specify the distance directly when the Ortho Mode or

Polar Tracking is on.

Create only one copy of object one time

Choose Modify > Copy from the main menu.
Select the objects, and then press Enter.

On the command line, type O (mOde).

On the command line, type S (Single).
Specify the base point.
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Specify the displacement point.
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Object to copy (A), base point (B), and displacement point (C) Result

You can copy objects more than one time until you press ENTER to exit COPY operation.

Create multiple copies for selected object one time

173



ZWCAD User Guide

Choose Modify > Copy from the main menu.
Select the objects, and then press Enter.

On the command line, type O (mOde).

On the command line, type M (Multiple).
Specify the base point.

Specify the displacement point of the first copy.
Specify the displacement point of the next copy.

Continue specifying displacement points to place additional copies.
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To complete the command, press Enter.
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Left: To make multiple copies of an object, select the object to copy (A), specify the base point (B), and then specify

the displacement points (C, D, and E)
Right: Result

7.2.3. Mirror Objects

You can specify a baseline to create a mirror image using MIRROR command. The mirror image is
symmetrical with the original one. So if you want to create a symmetrical object, you only need to

draw a half one, then create a full one using MIRROR command.

When creating mirror objects using MIRROR command, you should specify a mirror line around
which the mirror object is created. In the 3D space, this mirror line must be perpendicular to the XY
plane in which the mirror line is included. The mirror line can be determined by specifying two points,
while you creating mirror objects, you can optionally choose to remove or retain the source entity as
you need once the mirror objects are created. Like the picture is shown below. Additionally, you should

notice that mirror is only effective to such plans that parallel to XY plan of current UCS.
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System variable MIRRTEXT affects texts created with MIRROR command. When MIRRTEXT is on,
the copy of text object is displayed in mirroring way as other objects do. When MIRRTEXT is off, the

direction of text objects remains unchanged. Displaying as follows:
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By default, the MIRRTEXT is on. It affects text objects created with TEXT, ATTDEF, METEXT
command as well as attribute definition and variable attribute. Text, as well as constant attributes that

are included in an insert block, are mirrored together with the block while mirroring.

To mirror objects

Choose Modify > Mirror from the main menu.
Select the object, and then press Enter.
Specify the first point of the mirror line.

Specify the second point of the mirror line.
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On the command line, if you want to retain the original objects, type N; if you

want to delete the original objects, type .
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Left: To mirror an object, select it (A), and then specify the first point (B) and second point (C) of the mirror line

Right: Result

Mirror in 3D

You can create a mirror image of selected objects in three-dimensional space. You mirror the objects
about a mirror plane that you define by either specifying three points; selecting an existing
two-dimensional planar object; aligning the plane parallel with the xy, yz, or xz plane of the current

UCS; or aligning the plane with the current view. You can delete or retain the original objects.

To mirror an object about a three-dimensional plane

1. Choose Modify > 3D Operation > 3D Mirror from the main menu.

2. Select the objects, and then press Enter.
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At command line prompt, choose 3points, or press Enter to select the default.
Specify the first point on the mirror plane.

Specify the second and third points on the plane.

At command line prompt, choose one of the following:

Yes, Delete the original objects.
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No, Retain the original objects.
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Left: Select the object to mirror (A), and then specify the first point (B), the second point (C), and third point (D)
defining the mirror plane

Right: The resulting mirrored object

7.2.4. Offset an Object

You can use the offset feature to copy selected objects and align them offset to the original objects at a
specified distance. You can make offset objects using arcs, circles, ellipses, elliptical arcs, lines,

two-dimensional polylines, rays, and infinite lines.

Making offset copies of curved objects creates larger or smaller curves, depending on which side of the
original object you place the copy. For example, placing an offset copy of a circle outside the circle
creates a larger concentric circle; positioning the copy inside the circle creates a smaller concentric
circle.

You can perform TRIM or EXTEND command while the OFFSET command is active. The result is as

follows:

—

offzet trim and extend the offset lines result
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If the objects to offset are 2D polyline or spline, the system trims them automatically when the

specified distance is larger than can otherwise be accommodated. Displaying as follows:

offset automatic trim

To make an offset copy by specifying the distance

Choose Modify > Offset from the main menu.

Specify the distance by selecting two points or by entering a distance.
Select the object to offset.

Specify on which side of the object to place the parallel copy.
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Select another object to offset, or press Enter to complete the command.

To make a parallel copy, specify the distance between copies by entering a distance or selecting two points (A and B),

select the object to copy (C), and specify on which side to place the copy (D)

To make an offset copy passing through a point

Choose Modify > Offset from the main menu.
On the command line, type T (Through).

Select the object to offset.

Specify the point for the object to pass through.
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Repeat steps 3 and 4, or press Enter to complete the command.

=

To make a parallel copy passing through a point, select the object to copy (A) and then specify the through point (B)

+
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7.2.5. Create an Array of Objects

You can create copies of objects that array in the rectangular or polar pattern.

For rectangular arrays, you can specify the number of rows and columns as well as the interval; for
polar arrays, you can specify the number of copies of the objects and determine whether the copies are

rotated.

distance hetween
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Create Rectangular Arrays

You should specify the number of rows and columns, offset distance and angle before you create

rectangular arrays.

To create a rectangular array

Choose Modify > Array from the main menu.
In the Array dialog box, click Rectangular Array.

Click the Select Objects button, and then select objects to array in your drawing.
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In the Array dialog box, specify the row and column offset distance and angle of
offset.
5. Click OK.
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To create a rectangular array, select the object to copy (A), type the number of rows and columns, and then specify

the distance between each row (B) and column (C)
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Create Polar Arrays

You can specify a center or base point to copy the selected objects to create a polar array. The polar

array is drawn clockwise or counterclockwise depending on whether you type a positive or negative

value. The radius is determined by the distance between the specified center point and a reference or

base point on the last selected object.

To create a polar array

ok W oe

Choose Modify > Array from the main menu.
In the Array tab, click Polar Array.
Click the Select Objects button, and then select objects to array in your drawing.

In the Array dialog box, choose Method and values you desired.

e
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To create a polar array, select the object to copy (A), specify the center point of the array (B), and then specify the

number of items to the array, the angle the array is to fill, and whether to rotate the items

Array in 3D

The 3DARRY command is designed to create 3D arrays in the 3D space. The arrays include both

rectangular and polar array. Besides specifying the number of rows (X direction) and columns (Y

direction), you have to give the number of layer (Z direction).

To create a three-dimensional rectangular array
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Choose Modify > 3D Operation > 3D Array from the main menu.
Select the objects, and then press Enter.
At command line prompt, choose Rectangular.
Type the number of rows in the array.
Type the number of columns.
Type the number of levels.
Specify the vertical distance between the rows.
Specify the horizontal distance between the columns.
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9. Specify the depth between the levels.
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To create a three-dimensional rectangular array, select the object to copy (A), type the number of rows, columns,

and levels, and then specify the distance between each row (B), column (C), and level (D)

To create a three-dimensional polar array

Choose Modify > 3D Operation > 3D Array from the main menu.
Select the objects, and then press Enter.
At command line prompt, choose Polar.

Type the number of copies to make, including the original selection set.
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Specify the angle the array is to fill, from 0 to 360 degrees. The default setting for
the angle is 360 degrees. Positive values create the array in a counterclockwise
direction; negative values create the array in a clockwise direction.

6. Atcommand line prompt, choose one of the following:
Yes, Rotate objects as they are arrayed.
No, Do not rotate to retain the original orientation of each copy as it is arrayed.

7. Specify the center point of the array.

8. Specify a second point along the central axis of the array.
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To create a three dimensional polar array, select the object to copy (A), type the number of items to array, specify
the angle the array is to fill (B), and then specify the center point of the array (C) and a second point along the

central axis of the array (D)

Limit the Size of Arrays

If there are a large number of rows and columns for a rectangular array, the system takes a long time to
create the copies. By default, the number of array elements generates by one command is not over
100,000. The value is stored in the system variable MaxArray. It ranges from 100 to 10000000. If you

want to change the value of MaxArray, you must type MaxArray with the capitalization shown.

7.2.6. Move Objects

You can move objects to a new place without changing the objects. You can type a coordinate value for

the new position in the Properties palette.

The following image shows how to move an object. Perform MOVE command and then select an
object (1) to move; specify a base point (2) and Displacement point (3). The object is moved from

point 2 to the point 3.
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In addition to specifying a base point or displacement point on the drawing, you can also type

coordinate value on the command line. The Vector option is also used to define a new position.

To move entities

Choose Modify > Move from the main menu.
Select the objects, and then press Enter.

Specify the base point.
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Specify the displacement point.

N®.

To move an object, select it (A), and then specify the base point (B) and the displacement point (C)

You can also move objects using grips. To move an object through dragging its grips, select the object
to get its grips highlighted, and then click the desired grip and drag it to a new position. The grip you
select depends on the type of object you're moving. For example, to move a line object, select the
midpoint grip. To move a curved object, such as an arc, circle, or ellipse, select the center point grip.

Not all objects can be moved using grips.

To move an object using grips

Select the object.
Click a grip to select it.

Drag the object to where you want to relocate it.
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Click to release.

When all endpoints of selected objects are within a selection window, the STRETCH command is
equivalent to the MOVE command. The Ortho or Polar Tracking can help you move objects along to

the exact direction.
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ohiects selected with  objects dragged with result
crossing selection Crtho mode on

From the picture above, the Door is contained entirely in the selection window, so the door can be

moved to the specified location. And the wall lines are only partially within the selection area, as a
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result, the door moves with the wall.

You can specify the distance the objects to move while the Ortho or Polar Tracking mode is on.

7.2.7. Rotate Objects

You can rotate the selected objects around a specified point.
You can specify the rotated angle by specifying a point on the drawing or entering the angle value

directly. The direction that objects rotate depends on the value you enter is positive or negative. The

rotated plane and direction of zero angles is determined by the azimuth of UCS.
Rotate an Object by a Specified Angle

You can rotate objects by specifying a base point or an angle.

To rotate objects

Choose Modify > Rotate from the main menu.
Select the objects, and then press Enter.

Specify the base point.
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Specify the rotation angle.
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To rotate an object, select the object to rotate (A), and then specify base point (B) and the rotation angle (C)

Rotate an Object to an Absolute Angle

You can also rotate objects by specifying an absolute angle.

To rotate a selection set in reference to an Absolute Angle

Choose Modify > Rotate from the main menu.
Select the objects, and then press Enter.
Specify the base point.

On the command line, type R (Reference).
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Specify the reference angle.
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6. Specify the new angle.
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To rotate an entity in reference to a base angle, select the entity (A), specify base point (B), select the reference
angle and pick point (B) again (or type the @ symbol), specify the second point (C), and then specify the point

representing the new angle (D)

Rotate an Object in 3D

With the ROTATE command, you can rotate 2D objects. The rotation direction is determined by the
current UCS. The ROTATE3D command is used to rotate objects in the 3D space.

With the use of ROTATE3D, you can define the rotation axis by specifying two points; X, Y, Z axis; or
the Z direction of the current view. The 3D objects can be rotated with either the ROTATE command or
ROTATE3D command.

To rotate an object about an axis in three dimensions

1. Choose Modify > 3D Operation > 3D Rotate.
2. Select the objects to rotate, and then press Enter.

3. Choose one from the following options: Object, Last, View, X-axis, Y-axis, Z-axis,

2points.
4. Specify the rotation angle.
B
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Select the objects to rotate (A), specify the endpoints of the axis of rotation (B and C), and then specify the rotation

angle (D)
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7.2.8. Align Objects

You can align objects with another through move or rotation. The following picture shows how to align

the piping using Align command.
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Aligning in three dimensions

You can align selected objects with other objects in three-dimensional space. You select the objects you

want to align and specify one, two or three pairs of points to align the selected objects.

To align an object with another

Choose Modify > 3D Operation > Align from the main menu.
Select the objects, and then press Enter.
Specify the first source point.

Specify the first destination point.
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Specify additional source and destination points if desired (up to three pairs).

Select the objects to align, and then specify the first source point (A), the first destination point (B), the second

destination point (C), and the second destination point (D)
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You can specify up to three pairs of source/destination points.

7.2.9. Scale Objects

You can use SCALE command to zoom the selected objects. You can type a scale factor or specify a
base point and distance to zoom objects. A scale factor that is greater than 1 enlarges the object, and a

scale factor that is smaller than 1 shrinks the object.

ahject selected ohject scaled by result
factorof 0.5

You can also scale objects by comparing the basic scale and new scale. The objects become larger if

the new scale is large than the basic scale.

The dimension will be scaled along with the object to scale.

To scale a selection set by a scale factor

Choose Modify > Scale from the main menu.
Select the objects, and then press Enter.

Specify the base point.
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Specify the scale factor.
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To scale an object by a scale factor, select the object (A), and then specify the base point (B) and the scale factor

You can also scale some objects using grips. To scale an object, you select the object and then click a
grip. You then change the size of the object by moving the grip. The grip you select depends on the

type of object you're modifying. For example, to scale a circle, select a quadrant point grip.

To scale an object using grips

1. Select the object.
2. Click a grip to select it.
3. Dragthe grip.
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4. Click to release.
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To scale using grips, select the object (A), click a grip (B), and scale the object by dragging the grip to its new

location (C)

7.2.10. Lengthen Objects

You can change the length of entities or the included angle of arcs. The results are similar to extending

and trimming.
This command does not affect the closed entities.

Use any of the following methods to change the length of an entity:
e Dynamically drag the endpoint or angle.
e Specify an incremental length or angle measured from an endpoint.
e Specify the new length as a percentage of the total length or angle.
e Specify a new length or included an angle.

e  You can change the length of arcs, lines, open polylines, ellipse arc and open spline.

To change the length of an object by dragging

Choose Modify > Lengthen from the main menu.
On the command line, type DY (DYnamic).

Select the object you want to change.
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Specify the new endpoint or included an angle.
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Select the object (A), and then select the new endpoint (B)
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7.2.11. Stretch Objects

You can change the size of objects by stretching them. When you stretch objects, you must select the
objects using either a crossing window or a crossing polygon. You then specify a displacement distance
or select a base point and a displacement point. Objects that cross the window or polygon boundary are

stretched; those completely within the crossing window or crossing polygon are simply moved.

STRETCH stretches arcs, elliptical arcs, lines, polyline segments, 2D solids, rays, traces, and splines

that cross the selection window.

STRETCH moves only endpoints within the selection window, leaving those outside unchanged. The
polyline is treated as the composition of line straight and arc when being stretched. STRETCH does not

affect 3D solids, polyline width, tangent or curve-fitting information.

When stretching objects, you have to specify a base point and displacement point. You should use
crossing selection to select the desired objects. With using grip edition, you can also stretch objects.
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To stretch an object

1. Choose Modify > Stretch from the main menu.

2. Select the objects using either a crossing window or a crossing polygon, and then
press Enter.
Specify the base point.

4. Specify the second point of displacement.
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To stretch objects, select them using a crossing window (A) or crossing polygon, and then specify the base point (B)
and displacement point (C)
To stretch an object using grips, you select it to display its grips and then select a grip to make it the

active grip. This becomes the base point. Then you move the active grip to a new location. The grip
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you select depends on the type of object you're modifying. For example, to stretch one corner of a

rectangle, select the corner point grip.

To stretch a line, select an endpoint grip. Not all objects can be stretched using grips.

To stretch an object using grips

Select the object.
Click a grip to activate it.
Drag the grip.
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Click to release.
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To stretch an object using grips, select the object (A), select a grip (B), and drag the grip to its new location (C)

7.2.12. Trim or Extend Objects

You can connect edges of objects through trimming or extending.

When trimming or extending objects, you have to specify cutting edges or boundary to extend, then
you can select objects to cut or extend. Pressing ENTER at the prompt of selecting entities, all entities

are the possible boundaries, which call hidden selection.

If you want to select blocks as cutting edges, you can only use the single selection, Crossing, Fence,

and Select All options.
Trim Objects

You can clip, or trim, objects so they end at one or more implied cutting edges defined by other objects.
You can also trim objects to the point at which they would intersect an implied cutting edge. When
trimming objects, you first select the cutting edges and then specify the objects to trim, selecting them

either one at a time or using the fence selection method.

You can trim arcs, circles, lines, unclosed polylines, and rays. In which, arcs, circles, lines, polylines,
rays, infinite lines, and viewports on a Layout tab can act as cutting edges.
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select all ohjects to trim selected result

To trim an object

1. Choose Modify > Trim from the main menu.
2. Select one or more cutting edges, and then press Enter.
3. Select the object to trim.
4. Select another object to trim, or press Enter to complete the command.
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To trim objects, select the cutting edge (A), and then select the objects to trim (B)

Holding down SHIFT while selecting objects, the system extends the object to the nearest boundary

instead of trimming selecting an object.

In this example, you clean up the intersection of two walls smoothly by trimming.
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cutting edges ahjectto trim

selected with a selected result

crossing selection

Using variable selection methods while trimming several objects can help you select edges or objects

more easily.

In the following example, the cutting edges are selected using crossing selection.

edges selected with  objectsto trim selected  result
crossing selection
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To trim several objects using the fence selection method

On the command line, type F (Fence).
Specify the first point of the fence.

Specify the second point of the fence.
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Choose Modify > Trim from the main menu.

Select one or more cutting edges, and then press Enter.

Specify the next fence point, or press Enter to complete the command.
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Select the boundary edge (A), and then specify the first point (B) and second point (C) of the fence

You can trim objects to the nearest point of other objects. Selecting objects and clicking objects to trim,

the system specifies the nearest objects as the cutting edges. The following picture shows that the

crossing boundary is smooth after trimming.
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You can extend objects so that they end at a boundary defined by other objects. You can also extend

objects to the point at which they would intersect an implied boundary edge. When extending objects,

you first select the boundary edges and then specify the objects to extend by way of selecting them one

by one or using the fence selection method.

You can extend arcs, lines, two-dimensional polylines, and rays. Arcs, circles, ellipses, lines, splines,

polylines, rays, infinite lines, and viewports on a Layout tab can act as boundary edges.

In this example, you extend the lines precisely to a circle, which is the boundary edge.
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houndary selected  ohjects to extend selected result

To extend an object

Choose Modify > Extend from the main menu.
Select one or more objects as boundary edges, and then press Enter.

Select the object to extend.
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Select another object to extend, or press Enter to complete the command.

To extend objects, select the boundary edge (A), and then select the objects to extend (B)

To extend an object to an implied boundary

Choose Modify > Extend from the main menu.

Select one or more boundary edges, and then press Enter.
On the command line, type E (Edge).

On the command line, type E (Extend).

Select the object to extend.
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Select another object to extend, or press Enter to complete the command.
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Select the boundary edge (A), and then select the objects to extend (B)

To extend several objects using the fence selection method
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Choose Modify > Extend from the main menu.

Select one or more boundary edges, and then press Enter.
On the command line, type F (Fence).

Specify the first point of the fence.

Specify the second point of the fence.
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Specify the next fence point, or press Enter to complete the command.
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Select the boundary edge (A), and then specify the first point (B) and second point (C) of the fence

TRIM can also be used to extend objects. At the prompts of selecting entities, holding down SHIFT

and selecting objects to extend. As a result, the objects are extending instead of trimming.

Trim and Extend Wide Polylines

The system processes the center line if the object is 2D wide polyline. If the polyline is a pyramid, the

width of cutting edge keeps unchanged after trimming.

When you extend a wide polyline, its centerline intersects the boundary edge. Because the end of the
polyline is always cut at a 90-degree angle, part of the polyline may extend past the boundary edge. A
tapered polyline continues to taper until it intersects the boundary edge. If this would result in a

negative polyline width, the ending width changes to 0.
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A tapered polyline (A) continues to taper until it intersects the boundary edge (B)

The ends of wide polylines are always square. Trimming a wide polyline at an angle leads to portions
of the end to extend beyond the cutting edge. Trimming a spline-fit polyline deletes curve-fit

information and converts spline-fit segments to ordinary polyline segments.
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Trim or Extend in 3D

You can trim or extend objects even the objects are in the different planes in 3D space.
The system variable PROJMODE and EDGEMODE control the following project models:
e XY plane of the Current UCS.
e  Current view plane.

e 3D realty space (not projection).

Attentively, when you trim or extend objects 3D space, the objects to cut or extend must be intersected
with the boundary of the 3D boundary. The objects to trim or extend may not conclude exactly if they

do not intersect with each other when you work at the XY plane of the current UCS.

7.2.13. Create Breaks

You can break arcs, circles, ellipses, lines, polylines, rays, and infinite lines. When breaking entities,
you must specify two points for the break. By default, the point you use to select the entity becomes the
first breakpoint; however, you can use the First breakpoint option to select a breakpoint different from

the one that selects the entity.

5 :
first break point second hreak point result

To break an object

1. Choose to Modify > Break from the main menu.
2. Select the object.
3. Specify the second break point.

3 ~

Select the object (A), and then specify the second break point (B)

To select an object and then specify the two break points

1. Choose to Modify > Break from the main menu.
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Select the object.
On the command line, type F (First point).
Specify the first break point.

A

Specify the second break point.

C.
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Select the object (A), and then specify the first (B) and second (C) breakpoints

TIP To break an object in two without removing a portion of the object, specify the same point for the
first and second break points by typing the at sign (@) and pressing enter instead of specifying the

second break point.

7.2.14. Create Chamfers

You can connect two nonparallel objects by extending or trimming them and then joining them with a
line to create a beveled edge. You can chamfer lines, polylines, rays, and infinite lines. When creating a
chamfer, you can specify how far to trim the objects back from their intersection (distance method), or
you can specify the length of the chamfer and the angle it forms along the first object (distance angle
method).

When chamfering a polyline, you can chamfer multiple segments between two selected polyline

segments, or you can chamfer the entire polyline.

If two objects to chamfer on the same layer, the chamfer line lies on the layer as the object does;
otherwise, the chamfer line lies on the current layer which controls the properties of the line. The

multiple options can help you chamfer multiple objects at one time.

ariginal okbjects  chamfer distance  chamfer distance
ZEern NoONZero

Chamfer by Specifying Distances

The chamfer distance is the amount each entity is trimmed or extended to meet the chamfer line or to
intersect the other. If both chamfer distances are 0, chamfering trims or extend the two entities until

they intersect instead of creating a chamfer line.
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The default setting for the first distance is the last one you have specified, and the second distance is

the same as the first one. However, you can reset the desired chamfer distance.

To chamfer two objects using the distance-distance method

Choose Modify > Chamfer from the main menu.
On the command line, type D (Distance).
Specify the first chamfer distance.

Specify the second chamfer distance.

Select the first object to chamfer.
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Select the second object to chamfer.
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Left: Select the first (A) and second (B) objects

Right: The chamfer is drawn, based on the first (C) and second (D) chamfer distances

Trim and Extend Chamfered Objects

If the objects to chamfer are two intersecting lines, and you select the Trim option to chamfer objects,
the system automatically trims lines to the endpoint of the chamfered line. If the selected lines are not

intersecting with each other, the system extends them to get intersectant.

If you select No Trim, the system creates chamfer directly and not to trim.

Chamfer by Specify Length and Angle

You can chamfer objects by specifying a start point and an angle.

To chamfer two objects using the distance-angle method

Choose Modify > Chamfer from the main menu.
On the command line, type A (Angle).

Specify chamfer length on the first line.

Specify chamfer angle from the first line.

Select the first object to chamfer.

S A T o o

Select the second object to chamfer.
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Left: Select the first (A) and second (B) objects
Right: The chamfer is drawn, based on the distance (C) and the angle (D)

Chamfer Polylines and Polyline Segments

You can create a chamfer line for two segments of a polyline that are adjacent or separated by no more
than one arc segment. As shown in the illustration, if they separated by an arc segment, the arc is

deleted and replaced with a chamfer line.
palyline arc seament
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first polyline secaond polyline result-charnfar line
segment selected  seament selected replaces polyline arc
To chamfer selected vertices in a polyline

1. Choose Modify > Chamfer from the main menu.
2. Select the polyline along the segment where you want to begin the chamfer.

3. Select the polyline along the segment where you want to end the chamfer.

A,

Select the polyline along the (A) and (B) segments

Chamfer an Entire Polyline

You can use Polyline option to create chamfer lines for each intersection of an entire polyline. To get

the best results keeps the first and second chamfer distance equal.

To chamfer all vertices in a polyline
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1. Choose Modify > Chamfer from the main menu.
2. Onthe command line, type P (Polyline).
3. Select the polyline.

Original polyline Result after chamfering

When chamfering an entire polyline, only accommodated chamfer distance can create a chamfer line.

As shown in the illustration, some segments are too short to create a chamfer line.

segments too short
to chamifer

L1
:I—charrrr ar
segments

palyline selected result

7.2.15. Create Fillets

You can create a fillet using FILLET command. This command can apply to the objects such as arcs,
circles, ellipses, lines, polylines, rays, splines or construction lines as well as 3D solids. A fillet is an
arc that connects two objects smoothly and has a specified radius. An inside corner is called a fillet; an

outside corner is called around.

To fillet two objects

Choose Modify > Fillet from the main menu.
On the command line, type R (Radius).
Specify the fillet radius.

Select the first object.
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Select the second object.

Ul

5

Select the first (A) and second (B) objects
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Using FILLET command can help you create an arc that is tangent to the selected objects easily. You

can also use Polyline option to create fillets for each corner of a polyline.
When the objects to fillet are on the same layer, the fillet arc is created on that layer; otherwise, the

fillet arc is created on the current layer that affects the properties of objects such as color and linetype.

The Multiple options can create fillets for more than one set of objects until you exit the command.
Set the Fillet Radius

You can specify the radius of a fillet arc connecting two objects. The latest value is always the current
radius value. This setting is only available when you create a new fillet arc. When the radius is set to 0,

the objects to fillet are trim or extend to get intersecting, but not create a fillet arc.

two lines hefore  two linesfilleted  two lines filleted
fillet with radiug with zero radius

Trim and Extend Filleted Objects

While performing fillet, you can select Trim option to decide whether the selected edges are extended
to the endpoints of fillet arcs. By default, all objects except circles, ellipses, closed polylines and

splines are trimmed or extended when performing filleting.

When system variable TRIMMODE is set to 1, FILLET trims the intersecting lines to the endpoint of

the fillet arc. If the lines do not get intersecting, the system extends or trims them to get intersecting.

two linesfilleted with  two lines filleted with
Trirm ortion set Mo Trim option set

Specify the Location of the Fillet

When the objects to fillet are a line and an arc or a circle, there are several potential fillets and system
creates the fillet with the endpoint of arc at the nearest the selected point. The location of fillets

depends on the place of the objects you specify. As shown in the following picture:
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Select objects (A and B)

Fillet Line and Polyline Combinations

If the objects to fillet are a line and a polyline, the line or its extension must be intersecting with one of
the polyline segments. With the Trim option on, the filleted objects join with the filleted arc to form a

new polyline.

AR 2l
( 3 | 1
palyline selected line selected result

Fillet an Entire Polyline

You can use Polyline option to create fillets for each corner of a polyline.

To fillet an entire polyline

1. Choose Modify > Fillet from the main menu.
2. Onthe command line, type P (Polyline).
3. Select the polyline.
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I

Select the polyline (A)

Before creating fillets, you should ensure the distance between each vertex is long enough to

accommodate the fillet radius in order to insert a fillet arc.

palyline line segments

long enough to fillet
palyline line segments
too short to fillet

palyline selected result
for filleting

The fillet arcs replace arc segments when the fillet radius is greater than the radius of the arc. As shown

in the illustration:

palyline arc segment

fillet arc
palyline line
segment
paolyline selected resuli-fillet arc replaces

for filleting arc segment

When the fillet radius is set to 0, no fillet arcs are inserted. If two polyline segments are separated by

one arc segments, the system deletes this arc segment and extends the lines to intersect with each other.

To fillet selected vertices in a polyline

1. Choose Modify > Fillet from the main menu.
2. Select the polyline along the segment where you want to begin the fillet.

Select the polyline along the segment where you want to end the fillet.

Ty

Select the polyline along the (A) and (B) segments
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Fillet Parallel Lines

You can fillet parallel lines, rays, and infinite lines. The first entity must be a line or ray, the second
entity can be a line, ray, or infinite line. The diameter of the fillet arc is always equal to the distance

between the parallel entities. The current fillet radius is ignored.

- -4

- -

Original entities Result after filleting

7.3. Modify Compound Objects

7.3.1. Disassociate Compound Objects

You can convert a complex entity, such as a block or polyline, from a single entity into its component
parts. Exploding a polyline, rectangle, donut, polygon, dimension, or leader reduces it to a collection of
individual line and arc entities that you can then modify individually. Blocks are converted to the

individual entities, possibly including other, nested blocks that composed the original entity.

With the following exceptions, exploding an entity usually has no visible effect on a drawing:
e If the original polyline had a width, the width information is lost when you explode it. The
resulting lines and arcs follow the centerline of the original polyline. If you explode a donut,
its width becomes 0.
e If you explode a block containing attributes, the attributes are lost, but the original attribute
definitions are retained. The colors and linetypes of objects in exploded block references can

be modified individually.

Colors, linetypes, lineweights, and print styles assigned BYBLOCK may be different after exploding
an entity because they will adopt the default color, linetype, lineweight, and print style until inserted

into another block.
Explode Polylines

You can explode polylines into simple line segments and arc segments, which neglects the width of a
polyline. The exploded lines and arcs are placed along to the center line of the polyline. To be taken as
a polyline object, the donut would be changed into two arcs that form a circle (with width as 0) after

exploding.
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Explode Dimensions and Hatches

You can explode a dimension or a hatch into individual objects (such as lines, texts, points and 2D

solids). All associativity is lost after exploding.

Explode Block References

You can explode a block reference into individual objects. If a block to be exploded contains attributes,
the attribute values are lost and leaving attribute definition. If you explode a block that contains

polyline objects, you have to explode the polyline separately.

To explode a block

1. Choose Modify > Explode from the main menu.
2. Select the block.

3. Press Enter.
Explode External References

You can not explode external references or the dependent blocks as they are linked or attached to

another drawing.

7.3.2. Modify Polylines

You can modify any type of two dimensional or three-dimensional polyline. Objects such as rectangles,
polygons, and donuts, as well as three-dimensional objects such as pyramids, cylinders, and spheres,

are all editable polylines

You can edit a polyline by opening or closing it, by changing its overall width or the widths of
individual segments, and by converting a polyline with straight line segments into a flowing curve or
an approximation of a spline. In addition, you can use the Edit Polyline tool to edit individual vertices,
adding, removing, or moving vertices. You can also add new segments to an existing polyline, change

the linetypes of a polyline, and reverse the direction or order of the vertices.

To modify a polyline, you first select the polyline and then select a polyline editing option. The
available options vary depending on whether the selected polyline is a two dimensional or
three-dimensional object. If the selected object is not a polyline, the Edit Polyline tool provides the
option of turning it into one. You can convert only arcs and lines into polylines. If several arcs or lines

are joined endpoint to endpoint, they can all be selected and turned into one polyline.

To convert an object into a polyline

203



ZWCAD User Guide

Choose Modify > Object > Polyline from the main menu.
Select the object.

On the command line, type Y.

P w DN e

On the command line, type another option, or press Enter to complete the

command.

Joined Polyline Segments

If the ends of a line or arc are connected or are close to each other, you can join them to an open

polyline by trimming or extending.

Modify Properties of Polylines

If the properties of several objects being joined into a polyline are different, such as color and linetype,
the new polyline inherits the properties of the first object that you selected. You can also set properties

of the new polyline in the Properties palette.

Close

When you close a polyline, the program draws a straight polyline segment from the last vertex of the
polyline to the first vertex. The system considers the polyline open unless you close it using the Close

option.

To close an open polyline

1. Choose Modify > Object > Polyline from the main menu.
2. Select the polyline.
3. Onthe command line, type C (Close).
4. On the command line, type another option, or press Enter to complete the

command.

Closing an open polyline adds a straight polyline segment between the first (A) and last (B) vertices
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Open

If the polylines to be edited is closed, you can convert it into an open one by using the OPEN option to

delete the latest drawn segments of the polyline.

Join

You can add an arc, line, or polyline object to an existing open polyline, forming one continuous
polyline object. To join an object to a polyline, that object must already share an endpoint with an end

vertex of the selected polyline.

When you join an object to a polyline, the width of the new polyline segment depends on the width of
the original polyline and the type of object you are joining to it:
e A line or an arc assumes the same width as the polyline segment for the end vertex to which it
is joined.
e A polyline joined to a tapered polyline retains its own width values.
e A polyline joined to a uniform-width polyline assumes the width of the polyline to which it is

joined.

To join an arc, line, or polyline to an existing polyline

Choose Modify > Object > Polyline from the main menu.
Select the polyline.
On the command line, type J (Join).

Select the arc, line, or polyline to join.

vk W e

On the command line, type another option, or press Enter to complete the

command.

Width

Specifies the uniform width for all segments of selected polylines. Using Width option while

performing "Edit vertex", you can specify the width of the start point and end point.

palyline selected segments with
different starnt and
end widths

You can change the width of an entire polyline, applying a uniform width to the polyline or assigning

tapering width with gradient size.
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To apply a uniform width to an entire polyline

vk W e

Choose Modify > Object > Polyline from the main menu.

Select the polyline.

On the command line, type W (Width).

Specify the new polyline width.

On the command line, type another option, or press Enter to complete the

command.

To apply a tapering width to a polyline

I AR S

Edit vertex

Choose Modify > Object > Polyline from the main menu.

Select the polyline.

On the command line, type T (Taper).

Specify the starting width.

Specify the ending width.

On the command line, type another option, or press Enter to complete the

command.

You can use the Edit Vertices option to modify individual polyline vertices. When you select this

option, the program switches into a special vertex editing mode and places an x on the first vertex. The

x indicates the vertex you are editing. The Next and Previous options move the x to the next or

previous vertex. You can edit only one vertex at a time.

When editing vertices, you can modify the polyline in the following ways:

Convert a polyline segment into a curve by specifying a new tangent angle.

Break a polyline into two separate polylines.

Insert a new vertex after the current vertex.

Move the current vertex.

Straighten the polyline segment between two vertices.

Change the width of the polyline segment between two vertices.

To move a polyline vertex

P WD e
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Choose Modify > Object > Polyline from the main menu.

Select the polyline.

On the command line, type E (Edit vertex).

On the command line, type N (Next). Repeat until the X maker reaches the vertex
you want to move.

On the command line, type M (Move).

Specify the new location for the made vertex.
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7. On the command line, type another option, or type Exit to complete the
command.
8. On the command line, type another option, or press Enter to complete the

command.

Select the polyline (A), move the current vertex marker to the vertex you want to move (B), and then specify the

new vertex location (C)

To taper the width of an individual polyline segment

Choose Modify > Object > Polyline from the main menu.
Select the polyline.

On the command line, type E (Edit vertex).

P w N e

On the command line, type N (Next). Repeat until the X maker reaches the first
vertex of the segment you want to taper.

On the command line, type W (Width).

Specify the starting width.

Specify the ending width.

© N o v

On the command line, type another option, or type Exit to complete the
command.
9. On the command line, type another option, or press Enter to complete the

command.

A—l ‘_/B

Select the polyline (A), move the current vertex marker to the first vertex of the segment you want to taper (B), and

then specify the new starting and ending widths for that segment.

Fit

You can create an arc-fit polyline, a smooth curve joining each pair of vertices. The curve passes

through all vertices of the polyline.

To fit a curve to a polyline
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Choose Modify > Object > Polyline from the main menu.
Select the polyline.
On the command line, type F (Fit).

P w DN e

On the command line, type another option, or press Enter to complete the

command.

Spline

Converts a polyline into a spline. Specifies the vertices of the selected polyline as the control points or
frame of a curve approximating a B-spline. The curve passes through the first and last control points

unless the polyline is closed.

Original polyline After applying Fit curve After applying Spline
Decurve
Straights splines fit curves with Fit option or splines created with Spline option.
Ltype gen

Changes the linetype of a polyline. When this option is off, linetypes are generated starting and ending

with a dashed line at each vertex.

7.3.3. Modify Multilines

You can use the methods such as common editing commands, a multiline editing command and

multiline styles to edit multiline or their elements.
Add and Delete Multiline Vertices
You can use MLEDIT to add or delete vertices for a multiline. As shown in the illustration.
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Edit Multiline Intersections

You can control the way two multiline intersect using MLEDIT. The ways include cross and T shape

that can be closed, open or merged.

closed cross metged cross open t

Edit Multiline Styles

You can use MLSTYLE to add multiline style or set multiline from the existing multiline style, such as
the number of elements, color, linetype, lineweight and the offset of each element. You can also edit the

end caps and background fill.

The element and multiline properties of the STANDARD multiline style are not allowed to modify.
The current multiline style already used in the drawing is not allowed to modify too. You should edit

multiline style before using it.

If you create a new style without saving the previous one, the properties of the previous one are lost. To
maintain the properties, you have better to save each multiline style to an MLN file before creating a

new one.

7.4. Use Grips to Edit Objects

Grips are small squares displayed at the strategic points on objects while you selecting objects.

As you select each entity, it is highlighted with small squares called grips, which appear at strategic

points on the entity.

The locations of the grips depend on the type of object selected. For example, grips appear at the
endpoints and midpoint of a line, at the quadrant points and the center point of a circle, and at the
endpoints, midpoint, and center of an arc.
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Examples of grip locations

To use grips for editing, you select an object to display the grips, and then click a grip to make it active.
The grip you select depends on the type of object you're modifying and the editing operation you're

performing. For example, to move a line object, drag it by its midpoint grip.

To stretch the line, drag one of the endpoint grips. You do not need to enter a command when using

grips.
7.4.1. Control Status and Displaying of Grips

You can turn the use of grips on and off and control the size and color of grips under a different status.

To change grip settings

Choose Tools > Options from the main menu.

In the Options dialog box, click the Selection tab.
In the Grip Size, specify the size.

In the Grips, click Enable grips.
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Set the Unselected grip color, Selected grip color and Hover grip color separately,
to assign colors for grips under a different status.
6. Click OK.

You can use grips to modify objects, such as move, stretch, scale, and copy. With the Grips on, the

location of grips depending on the type of objects are displayed as follows:
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ling polyline spline
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fhilock circle text

When you perform quadrant grips on circles, the distance is measured from the center point, but not the
selected grip. For example, in Stretch mode, you can select a quadrant grip to stretch a circle, and then
specify a distance at the prompt of "New circle radius". The distance is measured from the center point,
but not the selected quadrant. If you select the center point, the circle moves.
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When a 2D solid is not lie on the current UCS, the object is stretched on the plane that the object is

created, but not on the plane of the current UCS.

The system variable GRIPOBJLIMIT is used to control the number of grips displayed on the selected
object. The value of GRIPOBJLIMIT is not available when you add an object to the current selection
set.

Control Grips in Blocks

The system variable GRIPBLOCK is used to control whether the inserted block displays a single grip
or all of the grips.

)

grips within blocks grip s within
turned off blocks turned an

7.4.2. Grip Edit Mode

One type of edit mode called grip mode is to perform manipulations such as stretch, move, rotate, scale
or mirror by dragging grips on entities. Stretch is the default grip edit mode, select the grips to edit
when you want to stretch the selected entity, the grip is displayedd in selected grip color, and then

right-click to select from manipulations menu.

If you press ENTER or SPACE key after selecting grips, all the grip modes display from which you can

choose to perform one of the grip editing manipulations.

7.4.3. Grip Stretch Mode

Stretch mode is the default mode for grip editing. Once you have selected entities, click the grips on

entities to display command line prompt as follows:
Specify the stretch point or [Base point/Copy/Undo/eXit]:

Under the prompt, you can specify a new position in the drawing area where the grip is expected to be
stretched. You should notice that when stretching grips on the selected grips such as single text point,
insertion point of block reference, the midpoint of a line, the center of circle and grips on point object,
the whole entity will be moved without changing the size and shape of grips. The type of entities
determines whether the grips are capable of being stretched. For example, to stretch a corner of a
rectangle, select the corner grips, to stretch a line, select the endpoint grips. Not all of the objects are

enabled grip stretching.
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Stretch Entities using Grip Stretch

1. Select entities to stretch.
2. Click on grips of the entity to highlight the selected grip and activate the grip
mode as Stretch.
3. Dynamic input box displayed on screen showing the following manipulations:
Specify "B(Base point)" option to locate the grip.
Specify "C(Copy)" option to create a copy of the entity being stretched.
Specify "U(Undo)" option to abort the last stretch.
Specify "X(eXit)" option to exit stretch manipulation.
Specify target location for stretching directly.
4. Move the pointing device to specify target location, the selected grip on entities

will be stretched based on itself (or the new base point).
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To stretch an object using grips, select the object (A), select a grip (B), and drag the grip to its new location (C).

Grip Move Mode

With grip move mode, you can move selected entities by moving its grips. The entity with specified

grips will be highlighted and moved according to the specified orientation and position.

Objects of various types need to be moved through different grips. For example, to move a line, use the
midpoint as grip, to move curve objects, like arc, circle or ellipse, select center point or grip. Not all the

entities are enabled grip moving.

If you press ENTER or SPACE key after selecting grips, all the grip modes are displayed, choose to

Move and then command line prompts as follows:

Specify the move point or [Base point/Copy/Undo/eXit]:

Move one or more Entities

1. Select entities to move.

2. Click on grips of the entity to highlight the selected grip and activate the grip
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mode as Stretch.
3. Press ENTER to iterate grip mode until Move appears in command line. Dynamic
input box displayed on screen showing the following manipulations:
Specify "B(Base point)" option to locate the grip.
Specify "C(Copy)" option to create a copy of the entity being moved.
Specify "U(Undo)" option to abort last moving.
Specify "X(eXit)" option to exit move manipulation.
Specify target location to grips directly.
4. Move the pointing device to specify target location, the selected grip on objects
will be moved towards the orientation and displacement along the connecting
line of the selected grip and the target point (or create a copy of the entity after

moving).

Grip Rotate Mode

With grip rotate mode, you can rotate selected entities around the base point, .or rotate by the angle

specified for rotating either.

If you press ENTER or SPACE key after selecting grips on entities, choose Rotate from the grip editing

mode and then command line prompts as follows:
Specify the rotation angle or [Base point/Copy/Undo/Reference/eXit]:

Rotate Entities Using Grips

1. Select entities to rotate.
2. Click on the grip of the entity to highlight the selected grip and activate the grip
mode as Stretch.
3. Press ENTER to iterate grip mode until Rotate appears in command line. Dynamic
input box displayed on screen showing the following manipulations:
Specify "B(Base point)" option to select a base point for rotating.
Specify "C(Copy)" option to create a copy of the entity being rotated.
Specify "U(Undo)" option to abort last rotating.
Specify "X(eXit)" option to exit Rotate manipulation.
Specify "R(Reference)" option to assign reference angle for rotation. (Final rotation
angle=reference angle subtract from input angle. For example: reference angle = 20,
input angle= 80, final rotation angle = 80 - 20 = 60).
4. Specify rotation angle for grips directly.
5. Move the pointing device and specify rotation angle, the entities rotate centered

by the selected grip (or create a copy of the entity after rotation).
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Grip Scale Mode

With grip scale mode, you can scale selected entities relative to the base point. Drag the entity
outwards the base grip to enlarge its size, and drag inwards to decrease the size. You can also specify a

scale factor to scale selected entities.

Grips are selected depending on the type of entity. For example, to scale a circle, use the quadrant point

as a grip.

If you press ENTER or SPACE key after selecting grips, all the grip modes are displayed, choose Scale

and then command line prompts as follows:
Specify the scale factor or [Base point/Copy/Undo/Reference/eXit]:

Scale Entities Using Grips

1. Select entities to scale.
2. Click on grips of the entity to highlight the selected grip and activate the default
grip mode as Stretch.
3. Press ENTER to iterate grip mode until Scale appears in command line. Dynamic
input box displayed on screen showing the following manipulations:
Specify "B(Base point)" option to relocate the base grip for scaling.
Specify "C(Copy)" option to create a copy of the entity being scaled.
Specify "U(Undo)" option to abort the last scaling.
Specify "X(eXit)" option to exit scale manipulation.
Specify "R(Reference)"option to assign reference scale factor. (For example, input scale
factor as 5, to scale the entity to five-times that of its original size). Then dynamic input
box displays on the screen, in which you are prompt to enter new length (if input 3, the
entity will be scaled at factor 3/5).
4. Specify scale factor for grips directly.
5. Move the pointing device to specify target grips, the entity will be scaled based on
the selected grips with the factor you specified (or create a copy of the entity

after scaling).

A..
4 ~
/ B~
0
\"‘* /;’ C.
e __n_,.-

To scale using grips, select the object (A), click a grip (B), and scale the object by dragging the grip to its new
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location (C).

Grip Mirror Mode

With grip mirror mode, you can create mirrored copies of selected entities along temporary mirror line.

If you press ENTER or SPACE key after selecting grips, all the grip modes are displayed, choose

Mirror and then command line prompts as follows:

Specify the second point or [Base point/Copy/Undo/eXit]:

Create Mirrored Copies Using Grips

1. Select entities to mirror.
2. Click on grips to highlight the selected grip and activate the default grip mode as
Stretch.
3. Press ENTER to iterate grip mode until Mirror appears in command line. Dynamic
input box displayed on screen showing the following manipulations:
Specify "B(Base point)" option to relocate the base grip.
Specify "C(Copy)" option to create a copy of the entity being mirrored.
Specify "U(Undo)" option to abort the last mirroring.
Specify "X(eXit)" option to exit mirror manipulation.
4. Move the pointing device to specify second mirror point, the entity will be
mirrored along the line connecting the selected grip on objects and the second

mirror point (or create a copy of the entity after mirroring).

7.4.4. Multi-Grips Edit Mode

It's also enabled to manipulate grip edit mode using multiple grips. You can press SHIFT to select

multiple grips. Once you have selected multiple entities (called hot multi-grip selection), the part of

entities among grips will not change.

Using Multi-Grips edit mode is sorted into the following two cases:

To move, rotate, scale or mirror entities, using multiple grips on them equals to use the last
selected grip as a base point (base grip or newly selected base point).

To stretch entities, multi-grips are selected depending on the type of entities, when you
selected single text point, insertion point of block reference, the midpoint of a line, the center
of circle and grips on a point object as hot grips, the entities will be moved rather than
stretched.
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Multi-Grips Stretch Mode

Select multiple grips of different entities to stretch separately depend on the entity types.

Stretch Lines, Polylines, and Dimensions Using Multiple Grips

Select line, polyline and dimension entities to stretch.

Press SHIFT while selecting grips on entities, the selected grips will be highlighted.
Release SHIFT and click on one of the selected grips to use it as base grip and
activate the default grip mode as Stretch. Dynamic input box displayed on screen

showing the following manipulations:

Specify "B(Base point)" option to locate the grip for stretching.

Specify "C(Copy)" option to create a copy of the entity being stretched.

Specify "U(Undo)" option to abort the last stretch.

Specify "X(eXit)" option to exit stretch manipulation.

Specify target location for stretching directly.

4.

Move the pointing device to specify target grips, the selected grips on entities will
be stretched or moved towards the direction pointing from the base grip to the
target location (single text point, insertion point of block reference, the midpoint

of a line, the center of circle and grips on point object).

Multi-Grips Move Mode

Move entities with multiple grips mode, use the last grip (base grip or reselected base point) as a base

point.

Move Lines, Polylines, and Dimensions Using Multiple Grips
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Select line, polyline and dimension entities to move.

Press SHIFT while selecting grips on entities, the selected grips will be highlighted.
Release SHIFT and click on one of the selected grips to use it as a base grip.

Press ENTER to activate the default grip mode as Stretch. Iterate grip mode until
Move appears in command line. Dynamic input box displayed on screen showing

the following manipulations:

Specify "B(Base point)" option to locate the base point for moving.

Specify "C(Copy)" option to create a copy of the entity being moved.

Specify "U(Undo)" option to abort last moving.

Specify "X(eXit)" option to exit move manipulation.

Specify target location for moving directly.

5.

Move the pointing device to specify target location, the selected grips on entities
will be moved at a specified displacement towards the direction pointing from the
base grip to the target location.
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Multi-Grips Rotate Mode

Rotate entities with multiple grips mode, use the last grip (base grip or reselected base point) as a base

point.

Rotate Lines, Polylines and Dimensions Using Multiple Grips

Select line, polyline and dimension entities to rotate.
Press SHIFT while selecting grips on entities, the selected grips will be highlighted.

Release SHIFT and click on one of the selected grips to use it as a base grip.
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Press ENTER to activate the default grip mode as Stretch. Iterate grip mode until
Rotate appears in command line. Dynamic input box displayed on screen showing
the following manipulations:
Specify "B(Base point)" option to locate the grip for rotating.
Specify "C(Copy)" option to create a copy of the entity being rotated.
Specify "U(Undo)" option to abort last rotation.
Specify "X(eXit)" option to exit rotate manipulation.
Specify "R(Reference)" option to assign reference angle for rotation. (Final rotation
angle=reference angle subtract from input angle. For example: reference angle = 20,
input angle= 80, final rotation angle = 80 - 20 = 60).
Specify rotation angle for grips directly.

5. Move the pointing device to specify rotation angle, the entities will be rotated

based on the selected grip (or create a copy of the entity after rotation).

Multi-Grips Scale Mode

Scale entities with multiple grips mode, use the last grip (base grip or reselected base point) as a base

point.

Scale Lines, Polylines, and Dimensions Using Multiple Grips

Select line, polyline and dimension entities to scale.
Press SHIFT while selecting grips on entities, the selected grips will be highlighted.

Release SHIFT and click on one of the selected grips to use it as a base grip.
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Press ENTER to activate the default grip mode as Stretch. Iterate grip mode until
Scale appears in command line. Dynamic input box displayed on screen showing
the following manipulations:

Specify "B(Base point)" option to locate the grip for scaling.

Specify "C(Copy)" option to create a copy of the entity being scaled.

Specify "U(Undo)" option to abort the last scaling.
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Specify "X(eXit)" option to exit scale manipulation.
Specify "R(Reference)"option to assign reference scale factor. (For example, input scale
factor as 5, to scale the entity to 5 times of its original size). Then dynamic input box
displays on the screen, in which you are prompt to enter new length (if input 3, the
entity will be scaled with the factor 3/5).
Specify scale factor for grips directly.

5. Move the pointing device to specify target grips, the entity will be scaled based on

the selected grips with the factor you specified (or create a copy of the entity

after scaling).

Multi-Grips Mirror Mode

Mirror entities and create their copies with multiple grips mode, use the last grip (base grip or

reselected base point) as a base point.

7.5.

7.5.1.

Mirror Lines, Polylines, and Dimensions Using Multiple Grips

Select line, polyline and dimension entities to mirror.
Press SHIFT while selecting grips on entities, the selected grips will be highlighted.

Release SHIFT and click on one of the selected grips to use it as a base grip.
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Press ENTER to activate the default grip mode as Stretch. Iterate grip mode until
Mirror appears in command line. Dynamic input box displayed on screen showing
the following manipulations:
Specify "B(Base point)" option to relocate the base grip.
Specify "C(Copy)" option to create a copy of the entity being mirrored.
Specify "U(Undo)" option to abort the last mirroring.
Specify "X(eXit)" option to exit mirror manipulation.

5. Move the pointing device to specify second mirror point, the entity will be
mirrored along the line connecting the selected grip on objects and the second

mirror point (or create a copy of the entity after mirroring).

Modify the Properties of Objects

Overview of Object Properties

You can display information about the selected entities. The information varies, depending on the type

of entities you select. All of the listings display the following information:

Entity type.
Layer.
Color.

Linetype.

218



ZWCAD User Guide

The location of the entity (its XYZ-coordinates relative to the current user coordinate system [UCS]).

The size of the entity (the information varies, depending on the entity type).

The layer, color, linetype are the common properties that most of the objects possess. There are a few
properties that some individual objects possess, such as radius and area of a circle, length, and angle of

a line.
Most of the properties can be applied to an object by layer or applied to an object directly.

If value BYLAYER is set to the property value, the object has the same value as the layer on which it is
drawn. For example, if you set Yellow to the layer 0 and assign value BYLAYER to the lines that were

drawn on the layer 0, its color is yellow too.

You can also specify a new value to overwrite the layer's value. For example, yellow is assigned to the

layer 0 and the value of lines is set to blue, the color of lines is blue.

You can use the following methods to display or modify the object properties:
e  View or change properties in the Properties palette.
e View or modify layer controls on the Layer Properties Manager dialog box, might change
Color, Linetype, Lineweight at the Properties toolbar as well.
e Use command LIST to view the information in the text window.

e Use command ID to display the coordinate of the specified point
Properties palette

The Properties palette shows all properties of the specified object. You can change them in this palette.
When selecting multiple objects, the Properties palette shows the command properties of the selected

objects.

If none of the objects is selected, the Properties palette displays the general properties of the current

layer, View properties as well as the UCS information.

By default, double-click an object opens Properties palette if the Properties palette is hidden. This
operation is not available when the objects are block, hatch pattern, text, multiline, external reference

or gradient fill.

7.5.2. Change the Properties of Objects

You can change the layer, thickness, linetype, color, and linetype scale of one or more entities.
Depending on the type of entity or entities you select, you can also change other properties, such as the

start point and endpoint of lines, the center point and radius of circles, and the vertices of polylines.
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You can modify all the properties of all entities simultaneously. For example, using the select command

and the Select by Properties option, select all blue entities and change their color to green.

In the Properties dialog box, changes that you make in the Layer, Color, Thickness, Lineweight,

Linetype and Linetype Scale affect all selected entities.

To modify properties of objects

1. Choose Tools > Properties from the main menu.
2. Select the objects.

3. Inthe Properties palette, change the desired properties.

NOTE The Properties palette settings that display when no objects are selected determine the

properties of new objects when you draw them.

7.5.3. Copy Properties Between Objects

Using Match Properties, you can copy some or all properties of one object to other objects.

The types of properties that can be copied include, but are not limited to:

e color
e layer
e linetype

e linetype scale
e lineweight

e 3D thickness

By default, all applicant properties are copied along with the objects. You can also specify the desired
properties to copy at the Property settings dialog box by typing MATCHPROP.

T

source ohject seleted  destination object{s) selected result

7.6. Modify 3D Solids

You can edit three-dimensional solids in several unique ways, including chamfer, fillet, section, and
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slice. You can also modify individual faces and edges of solids, as well as imprint, separate, shell, and
check solids. You can edit three-dimensional ACIS solids, including boxes, cones, cylinders, dishes,

domes, spheres, torus, and wedges.

7.6.1. Fillet and Chamfer

You can chamfer or fillet a three dimensional solid much like you chamfer or fillet a two-dimensional

object.

Create fillers

You can create fillets for the specified edges of 3D objects. At first, you need to specify the fillet radius,

and then choose one method to create fillets.

If you choose Edge, the system creates fillets for the two selected edges. If you select three or more
edges which were around a vertex, the system creates a spheral vertex if the three fillets have the same
radius.

After specifying an arc radius, the system creates a sequence of fillets for the tangential sequence of

edges, when you use Loop option and select an edge.

In 3D space, as the selected objects are coplanar and the extrusion direction is not parallel with the Z
axis, you can create a fillet. If the objects are on the same plane, there are two kinds of extrusion
direction shown as follows:

e [fthe objects are on the same plane with the same extrusion direction normal to that plane, the
fillet arc is on that plane and has the same extrusion direction.

e For objects on the same plane with opposite or different extrusion directions, the fillet arc is
located on that object plane with an extrusion direction normal to the object plane and inclined
towards the positive Z direction of the current UCS. For example, we assume two arcs A and
B are on the same plane in 3D space but have opposite extrusion directions (0,0.65,0.86) and
(0,-0.65,-0.86) relative to the current UCS. The fillet arc adopts the extrusion direction
(0,0.65,0.86).

To fillet a solid

Choose Modify > Fillet from the main menu.
Select the edge of the solid to fillet.
Specify the fillet radius.
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Select additional edges to fillet, and press Enter to fillet.

Create chamfer

Using CHAMFER creates chamfers for the adjacent planes. While creating fillets, the system prompts
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you to specify a distance for the first and second object. The first object is the base plane and the

second one is another plane.

After specifying the chamfer distance, you have to select edges to fillet. You can select all edges of the

base plane by selecting an edge using Loop option. Get more details from the CHAMFER command.

To chamfer a solid

1. Choose Modify > Chamfer from the main menu.

2. Select the edge of the base surface to chamfer.

3. Do one of the following:
To select a different surface, type N (Next) and press Enter.
To use the current surface, press Enter.

4. Specify the distance on first entity.

5. Specify the distance between second entity.

6. Do one of the following:

7. Specify the edges to chamfer.

8

To select all edges around the base surface, type L (Loop) and press Enter.

7.6.2. Section and Slice

You can section or slice a three dimensional solid.
Section

You can create a region using the intersection of solid objects and a plane with the SECTION
command. After selecting objects, the system creates a region on the current layer and inserts them into

the location of the section.

Methods to define a section:
e Specifies three points to define a sectioning plane.
e  Align the sectioning plane with a circle, ellipse, arc, 2D spline or 2D polyline object.
e Specifies a point lied on the sectioning plane and a point lied on the normal of the defined
section.
e  Align the sectioning plane with the plane of the current view.
e Specifies a point to determine the location of the sectioning plane on the XY, YZ or ZX plane,

and aligns the sectioning plane with the XY, YZ, or ZX plane of the current UCS.

To section an object

1. Choose Draw > Solids > Section from the main menu.
2. Select the objects to cross section.

3. Do one of the following:
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Slice

Specify three points to define the cross-section plane. (The first point defines the origin,
while the second point defines the X-axis and the third point defines the Y axis.)
Type O and press Enter to select an object that defines the cross-sectional plane.

Specify an axis by typing Z and pressing Enter.

You can use SLICE command to slice a solid with a plane and retain the specified part or the entire

solid. The sliced solids retain the layer and color's properties of the original ones. To slice a solid, you

have to define a cutting plane, then select which part to retain.

Methods to define a cutting plane:

7.6.3.

Specifies three points to define a cutting plane.

Align the cutting plane with a circle, ellipse, arc, 2D spline or 2D polyline object.

Specifies a point lied on the cutting plane and a point lied on the normal of the defined
section.

Align the cutting plane with the plane of the current view.

Specifies a point to determine the location of the cutting plane on the XY, YZ or ZX plane,
and aligns the cutting plane with the XY, YZ, or ZX plane of the current UCS.

To slice a solid

Choose Draw > Solids > Slice from the main menu.
Select the objects to slice.

Do one of the following:
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Specify three points to define the cross-section plane. (The first point defines the

origin, while the second point defines the x-axis and the third point defines the

y-axis.)

5. Type O and press Enter to select an object that defines the cross-sectional plane.
Specify an axis by typing Z and pressing Enter.

7. Specify which side to retain, or type B to retain both sides.

Modify Faces of 3D Solids

You can modify faces of 3D solids by extruding, moving, rotating, offsetting, tapering, delete, copying

or changing the color of the selected faces.

Extrude Faces

You can extrude one or more faces of 3D solids at the specified height and path.
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Negative value extrudes faces along to the positive normal; positive value extrudes faces along to the
negative normal. After specifying the height, the system prompts you to specify the angle of taper for
extrusion. If you specify the angular value is greater than 0, the plane tapers in from the base object; if
the value is negative, the face tapers out. By default, the value is of 0, which extrudes the face

perpendicular. The extrusion stops when the tapered face shrinks to a point.

If you select Path option, the selected face extrudes at the specified line or curve objects. The objects
that can be specified as an extrusion path contains line, circle, arc, ellipse, ellipse arc, polyline, and
spline. These objects should not be coplanar with the object, nor should have areas of high curvature.
Generally, one of the endpoints of the selected extrusion path should lie in the center of the face to

extrude, if not, the system will do it.

To extrude a solid face

Choose Modify > Solids Editing > Extrude Faces from the main menu.
Select the face(s) to extrude, and press Enter.

Do one of the following:

Specify the height of extrusion.

Type P and press Enter to select a path for extrusion.

S A T o o

If you specified a height, specify a taper angle.
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Left: Select the entity to extrude, and then specify the face(s) to extrude (A), and the height of extrusion or path
Right: The resulting entity with the face extruded to position (B)

Move Faces

Moves face of a 3D solid at the specified distance. This command only changes the location of the face,

leaving the direction unchanged. Using object snap help you specify the location exactly.

To move a solid face
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Choose Modify > Solids Editing > Move Faces from the main menu.
Select the face(s) to move, and press Enter.

Specify a base point.
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Specify an endpoint.

Left: Specify the face(s) to move(A), the base point (B), and the endpoint (C)

Right: The resulting object with the face moved to the new position

Offset Faces

You can scale faces of 3D solids with the specified offset. Positive value enlarges objects; negative
value shrinks objects. For example, you can enlarge or shrinks an aperture using offset. In addition to

entering the distance, you can also drag the cursor to determine the distance.

To offset a solid face

1. Choose Modify > Solids Editing > Offset Faces from the main menu.
2. Select the face(s) to offset, and press Enter.

3. Specify an offset distance.

Left: Specify the face(s) to offset (A) and the distance to offset
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Right: The resulting object with the face offset to position (B)

Delete Faces

You can use SOLIDEDIT to delete the selected faces or fillets of 3D solids.

To delete a solid face

1. Choose Modify > Solids Editing > Delete Faces from the main menu.

2. Select the face(s) to delete, and press Enter.
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Left: Specify the face(s) to delete (A)
Right: The resulting entity with the face deleted

Rotate Faces

You can use SOLIDEDIT to rotate the selected face of the specified 3D solid around a rotation axis.
You can specify two points on the drawing or select an existing line as the rotation axis. X, Y or Z axis,

as well as the Z direction of the current view, could be used as the rotation axis too.

The system rotates faces at the specified angle on the current UCS, which the angle direction is stored

in the system variable ANGDIR.

To rotate a solid face

Choose Modify > Solids Editing > Rotate Faces from the main menu.
Select the face(s) to rotate, and press Enter.
Specify a base point.

Specify another point on the rotation axis.

vk W e

Specify the rotation angle.
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Left: Specify the face(s) to rotate (A), the base point (B), the second point on tapered the rotation axis (C), and a

Taper Faces

rotation angle.

Right: The resulting object with the face to position (D)

You can taper the selected face at the specified angle around a baseline. The rotation direction depends

on the sequence of specifying the base point.

Positive angle tapers faces in and negative angle tapers faces out. The angle should not be too large in

order to the tapered face shrinks to a point before reaching the specified height.

To taper a solid face
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Choose Modify > Solids Editing > Taper Faces from the main menu.
Select the face(s) to taper, and press Enter.

Specify a base point.

Specify another point along the axis.

Specify a taper angle.
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Left: Specify the face(s) to taper (A), a base point(B), a second point along the taper axis(C), and a taper angle
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Right: The resulting entity with the face tapered to position(D)

Color Faces

You can assign a color to the faces of 3D solids. The specified color of faces overwrites the color of the

layer on which the faces are drawn.

To color a face

1. Choose Modify > Solids Editing > Color Faces from the main menu.
2. Select the face(s) to color, and press Enter.

3. Specify a color.

Specify the face(s) to color (A) The resulting entity with the face colored

Copy Faces

You can copy faces of 3D solids to the specified location. The selected faces are seen as an independent
region or solid object. After creating copies, you can perform one of the following methods:
e Basepoint: You must specify two points on the drawing. The first one is a base point; the other
one determines the location of the copy.
e  Vector: You need to specify a point to determine the location of the copy. The base point is the

original point (0,0,0).

To copy a solid face

Choose Modify > Solids Editing > Copy Faces from the main menu.
Select the face(s) to copy, and press Enter.

Specify a base point.
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Specify an endpoint.
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Left: Specify the face(s) to copy (A), the base point (B), and the endpoint(C)
Right: The resulting entity with the face copied

7.6.4. Modify Edges of 3D Solids

You can copy edges of 3D solids to become an independent object or change its color.
Copy Edges

Copying edges of 3D solids are similar to copying faces of 3D solids. All edges are copied as the
independent lines, arcs, ellipses or spline objects. However, the properties keep the same as the current
layer. After you specify the location of placing the copy, you can perform one of the following
methods:
e Basepoint: You must specify two points on the drawing. The first one is a base point; the other
one determines the location of the copy.
e  Vector: You need to specify a point to determine the location of the copy. The base point is the

original point (0,0,0).

To copy an edge

Choose Modify > Solids Editing > Copy Edges from the main menu.
Select the edge(s) to copy, and press Enter.

Specify a base point.
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Specify an endpoint.

229



ZWCAD User Guide

Left: Specify the edge(s) to copy (A), the base point (B), and the endpoint(C)
Right: The resulting entity with the edge copied

Color Edges

You can assign a color to the edges of 3D solids. The specified color of edges overwrites the color of

the layer on which the edges are drawn.

To color an edge

1. Choose Modify > Solids Editing > Color Edges from the main menu.
2. Select the edge(s) to color, and press Enter.

3. Specify a color.

7.6.5. Imprint, Separate, Shell, Check and Clean 3D Solids

You can change the appearance of 3D objects, separate or create shells at the specified thickness for 3D
objects by imprinting, separating or shelling. You can remove redundant edges, points, imprinted and
unused objects through cleaning them. You can also check to see the selected objects are the available
3D solids.

Imprint

You can create a new face of a solid face by executing imprinting operation. The following objects can
be imprinted: arc, circle, line, 2D/3D polyline, ellipse, spline, region, 3D solid. To ensure the
imprinting successfully, the objects to be imprinted must be intersected with one or more faces. For
example, when a rectangular intersects with a 3D solid, you can imprint the intersecting curve. Then

determine whether the original objects are removed or not.

To imprint a solid objects
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1. Choose Modify > Solids Editing > Imprint from the main menu.
2. Select the solid object you want to imprint.

3. Select the object you want to imprint on the solid.

Separate

You can separate the selected composed 3D solid into the several 3D solids with the unconnected
objects. The composed 3D solid cannot share the common areas or cubage. The separated solids still lie
on the original layer and keep the color unchanged. All nested objects are separated into the simplest

objects.

To separate solids

1. Choose Modify > Solids Editing > Separate from the main menu.

2. Select the solid you want to separate.

Shell

You can create a shell at the specified thickness. One 3D solid only create a shell, and the system has to
move away from the existing face before creating a new face. The tangent faces are seen as a face

while moving.

To shell a solid

1. Choose Modify > Solids Editing > Shell from the main menu.
2. Select the object you want to shell.
3. Remove any faces you don't want to include.
4. Specify an offset distance.
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Select the entity, and then select faces to remove (A) and (B), then specify an offset distance
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Check

You can check whether a selected object is a valid three-dimensional ACIS solid. If it is a valid 3D
solid, you can modify the object using the 3D solid editing commands; if not, you cannot edit the

object using these commands.

To check a solid

1. Choose Modify > Solids Editing > Check from the main menu.
2. Select the objects to check.

Clean

You can remove redundant edges or vertices from solids when they are not needed.

To clean a solid

1. Choose Modify > Solids Editing > Clean from the main menu.

2. Select the object you want to clean.

7.7. Use Windows Cut, Copy, and Paste

You can use the Clipboard to cut or copy objects from one drawing to another. Cutting removes the
selected objects from a drawing and stores them on the Clipboard. Copying duplicates the selected

objects from a drawing and places them on the Clipboard.

7.7.1. Cut Objects

You can use Window commands such as Cut, Copy and Paste to move or copy objects. With using the
Cut command, the objects on the clipboard can be pasted to a document or drawing as an OLE object.
See more from the PASTECLIP and PASTESPEC command. The links are not available after

executing the Cut command.

To cut objects to the Clipboard

1. Select the objects you want to cut.

2. Choose Edit > Cut from the main menu.

7.7.2. Copy Objects

You can copy the objects on the clipboard into the document created by other application. The copied

232



ZWCAD User Guide

objects can keep the height resolution as they are copied to the vector format. These objects store on
the clipboard with the WMF (Windows Metafile Format) format. The copies keep unchanged at the

other application even if the original drawing has changed.

To copy objects to the Clipboard

1. Select the objects you want to copy.

2. Choose Edit > Copy from the main menu.

Anything that you can copy to the Clipboard can be pasted into a drawing. The format in which the
program adds the Clipboard contents to the drawing depends on the type of information in the
Clipboard. For example, if you copy ZWCAD drawing entities to the Clipboard, the program pastes
them into the drawing as ZWCAD entities. If you copy items to the Clipboard from other programs,

they are pasted into the current drawing as embedded ActiveX objects.

7.7.3. Paste Objects

The system used all available formats to store information when you copy objects into the clipboard.
The format that stores the most information was used when pasting the objects on the clipboard into the

current drawing.

To paste objects from the Clipboard

1. Choose Edit > Paste from the main menu.

To change the format to paste, you can select the desired format from the Edit menu.

The WMF format contains the screen vector information, which can scale or plot the pasted objects

without decreasing resolution. It can be applied to the application that supports WMF format.

The color of objects keeps unchanged when pasting. However, you can use the system variable
WMFBKGND and WMFFORGND to control whether the background or foreground is transparent or

not, where the pasted objects lie on.

When the objects to be pasted contain links or nest other objects, you can use PASTESPEC command
to insert them from the clipboard into the ZWCAD drawing. When selecting ZWCAD Block, the
objects are processed as a block. And you have to explore them before editing. Converting WMF
format into ZWCAD Drawing format may lead to the scale factor changed. To avoid this situation, you

can convert the selected objects to a block and then insert it into the ZWCAD drawing using INSERT.
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7.8. Correct Mistakes

Various methods can be used to cancel errors until the latest correct operation if perform error

manipulations.

7.8.1. Undo a Single Action

You can reverse to the last operation by pressing Undo button on the Standard toolbar or entering U on
the command line. Some commands contain the Undo option, so you can enter u to reverse to the last
operation without exiting the command. For example, when creating a line or polyline, you can enter U

to undo the latest drawn line segment.

7.8.2. Undo Several Actions at Once

UNDO command helps to abort multiple operations at a time.

When using UNDO command, system groups a number of operations assigned within BEgin and End
so that you can cancel all the steps as a group object at a time. Use Mark and Back to enable users to
cancel all the later operations since the marked step. If you use Back or Number of operations to undo
option, the drawing will be redrawn if necessary. This may happen to the end of UNDO command, and
the frequency of redrawing can be different based on the option you select, for example, enter UNDO 3

to redraw once, while entering U command three times to redraw three times.

7.8.3. Reverse the Effect of Undo

You can use REDO to reverse the effects of previous UNDO or U command. This command is
equivalent to the REDO button on the Standard toolbar.

Undo or Redo Actions Using Undo or Redo button

The Undo or Redo button on the Standard toolbar are displayed in gray if there aren't any operations to

undo or redo, at this moment this function is unavailable.

The Undo button is available as soon as you have operated a certain command, click left part of this
button to undo the last manipulation performed previously. There is a pull-down list beside the undo
button, click here to pop-up a list in which all of the possible operations are displayed, containing up to
6 commands within one list page, if more than 6 operations have been manipulated, you can drag the

scroll bar on the right side of the list page to browse the commands.

The Redo button is available once you have manipulated undo. Like performing Undo operation, click
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the Redo button to perform the last Undo operation, while clicking the pull-down arrow to pop-up a list

in which all of the manipulations available to perform Redo are displayed.

Move the mouse to select manipulations from the pull-down list of Undo and Redo button, highlight
the items on which the mouse stays to illustrate how many items are selected among the manipulations
from the top of the list page, and display a message at the bottom of the list to explain the number of
items being selected. And then click the mouse or press ENTER directly to perform Undo or Redo
command. Move the mouse to the top or button of the pull-down list box to enable it scrolling by itself,

additionally, you can press the direction key to select commands upwards or downwards.

Once you select BEgin option when performing UNDO command, the manipulations displayed in the
pull-down list beside the Undo button will be unavailable, at this time you can only undo the

subsequent manipulations unless you perform the UNDO command again and select the End option.

Erase Objects

You can also use OOPS command to restore the deleted objects except for the objects deleted by
PURGE command. You can use OOPS to remove the selected block objects after performing BLOCK
or WBLOCK.

Cancel a Command

You can click ESC to exit during performing the command.
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8. Notes and Labels

8.1. Create Text

Create text, multiline text (mtext) and text that includes one or more leader lines.

8.1.1. Single-Line Text

You can use TEXT command to create a single or multiline text. Each line text is an independent object

which can be modified.

Before typing text, you can specify the text style and the way to align at the prompt of creating text.
The text style is applied to both of a single and multiline text objects. The justification way determined

which part of text justify with an insert point.

Characters created by MTEXT can be applied to independent text styles, but the single line text cannot
do that.

Press ENTER if you have typed some characters, and then the command line prompts to input
characters for the next row of text. While creating single line text, you are also enabled to extend or
compress certain single line text object in specified space to meet with your need by means of selecting

Align or Fit option from the TEXT command line prompt.

To create text

Choose Draw > Text > Single Line Text from the main menu.
Specify the start point for the text.

Specify the height of the text.

Specify the text rotation angle.

Type the text, and then press Enter at the end of each new line.

I AR S

To complete the command, press Enter again.

TIP If you've already created text and want new text to appear immediately below the previous text,
Choose Draw > Text > Single Line Text. When prompted for start point, press Enter. The new text will

keep the same height and rotation angle as the previous text.

Align Single-Line Text

When you create text, you can set the text alignment before you specify the start point.

You set the alignment by choosing Justify in the command line prompt. By default, the text is left
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You can also align text so that it fits or aligns with two points. The Align option creates text that scales
up or down while maintaining a constant height/width ratio; the Fit option expands or compresses the

text to fit between the two points.
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Left: Text aligned between two points maintains a constant height/width ratio
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Right: Text fit between two points expands or compresses to fit

To specify the line text alignment

1. Choose Draw > Text > Single Line Text from the main menu.

2. Onthe command line, type J (Justify) and press ENTER.

3. Type an alignment option. For example, enter BR to align text at its bottom-right
corner.

4. Type the text, and then press Enter at the end of each new line.

To complete the command, press Enter again.
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8.1.2. Multiline Text

The multiline text consists of one or more lines of text or paragraphs that fit within a boundary width
that you specify. Each multiline text entity you create is treated as a single entity regardless of the

number of individual paragraphs or lines of text it contains.

When you create multiline text, you first determine the paragraph's boundary width by specifying the
opposite corners of a rectangle. The multiline text automatically wraps so that it fits within this
rectangle. The first corner of the rectangle determines the default attachment point of the multiline text.
You can change the location of the attachment point in reference to the rectangle, and you can

determine the direction in which text flows within the rectangle.

After defining the text frame, the system opens the In-Place Text Editor, which is comprised of a text
frame and the Text Formatting toolbar. You can type text in the text frame and change the style from

the Text Formatting toolbar.

The text style can control the style of characters, such as default fonts, line spacing, aligned way, and
color. STANDARD is the default text style.

You can change the value of text objects in the Properties palette that includes the Justify, Direction

and so on.

You can also assign the underline, color or other fonts to the current text to overlap the default style.
Stacked characters (such as fractions and tolerance), special characters and Unicode characters used for
TrueType fonts can be created in the text frame. At the same time, you can also control the appearance

of the text object and create a list by specifying the tap and characters to retract.

To create multiline text

Choose Draw > Text > Multiline Text from the main menu.
Select the first corner of the text area.

Select the second corner of the text area.

In the Multiline Text window, type the text you want.

To create paragraphs, press Enter and continue typing.

IS AR o

On the toolbar, make format changes as follows:

To change the font of the selected text, select a font from the list.

To change the height of the selected text, enter a new value in the Height box.

To format text in a TrueType font with boldface or italics, or to create underlined text for
any font, click the corresponding button on the toolbar. SHX fonts do not support
boldface or italics.

To apply color to the selected text, choose a color from the Color list. Click Select Color
to display the Select Color dialog box.

To save your changes and exit the In-Place Text Editor, use one of the following methods:
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7. Click OK on the toolbar.

8. Press <Ctrl + Enter>.

TIP You can paste text from the Clipboard into the In-Place Text Editor.

Justify Multiline Text

When you create multiline text, you can set the text alignment by specifying the attachment point
location in relation to the multiline text boundary and the direction in which text flows within the
boundary. You can set the multiline text alignment either at the command line prompt displayed after
you specify the first corner of the multiline text boundary or from the In-Place Text Editor. You can
specify the attachment point at the top left, top center, top right, middle left, middle center, middle right,
bottom left, bottom center, or bottom right. The multiline text can flow left to right, right to left, top to

bottom, or bottom to top.

The system provides nine justifications, shown in the following illustrations:

e o e Ziall ikl My oo LAl GO Hel carriaia conglaa
m R
hm'ﬂﬁfn whlmzhl.brrlnn l:"" n‘%whnnmﬁ
“ﬂﬂ%@:?ﬁ',‘ ﬂﬂlr-hﬂlt W reakiria minmkhhz
oA SEEaeE SEmEE
- BT ChARGMEE M
Ty o, S o ST LI P oAl s LT
[y THETT 0 cpre Hrip s Vv oo, CHrTie 10 oam R T mw';l-mwwm_rupm
top left, mmiddle center, rricdle right ,
[eft-justified center-justified right-justified
ey ity e W.J.'..'."s.'fu“:;“?" T S I ST T
Peroer Tman heip b Pma Eean halp sublet ey Zeur, haip
T L RIS TRy S
le?'m . *-m h‘;-” mn b rckdots
e e iy TR e o I R
g it e - E8E ST ST r TR TR
R S EETEE R A S
hattorn left, haottarm center, hattorm right,
|eft-justified center-justified right-justified
mlhﬂ“. :ﬂ:ﬂu“wrh ﬁz&-ﬂ :n:ihrh ﬂ_ Hp carhiho cophrs
ey e T
Hwimx tha Fl bap Halso Hw Fl a rackdcte wiaw Il by b v e
T R e sl riss K age
E‘m‘:‘h;“:‘mﬁ?ﬂ ,ﬁ&" :’Hm e hmﬂmﬁum
E mﬁuﬂ:‘r.h' n m'lmlirb rxem hinl np"v*_rhh' L] ppmmlih rxtm mh:pﬁm b ] ;nm
rridd|e center, top center, top right,
left-justified center-justified right-justified

Format Characters Within Multiline Text

During creating multiline text, you can assign a new value to the selected objects to overlap the default

setting. But the changes only affect the selected texts, leaving the current text style unchanged.

In addition to specifying underlines, bold, color and fonts for single or multiple characters, you can
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also specify a different text height. The text height displayed in the In-Place Text Editor is the one you
specified, the height of the actual characters is displayed with the new height as well. The text height is

measured in drawing unit.

Indent Multiline Text and Use Tabs

On the In-Place Text Editor, you can control the appearance of text objects and create a list by
specifying the tap stops and indenting text. The setting of tap stops and indent made before typing text

are applied to all the texts. You can also assign the settings to the selected paragraphs.

The arrowheads on the ruler are used to define the indent of text. The above one is designed to specify

the first line indent, while the other one is designed to specify the paragraph indent.

While you dragging the indent mark on the ruler, the L mark is displayed to represent the tab stops. You

can delete custom tabs by moving the L mark away from the ruler.

Specify the Line Spacing

The line spacing of multiline texts is the distance between the baseline of one line of text and the
baseline of the next line of text. You can right-click in the textbox and choose Paragraph to specify the
desired line space when the cursor stays on the text frame. The single line space is the 1.66 times the

height of the text characters.

You can specify either At Least, Multiple or Exactly option to specify the line spacing. At Least
increases line spacing automatically when the characters are too large to fit the line spacing you had
specified. Multiple sets the line spacing according to the text height, instead of setting the value of the
line spacing. If the text height is not the same in a line, the line spacing is fixed by the biggest text

height. Exactly specifies the exact line spacing for each line.

Exactly style may result in the text in lines situated above or below lines with large font characters to

overlap the larger characters.

Create Stacked Characters

The stacked text is text or fraction applied to mark tolerance or measure units. Before creating stacked
text, you have to use special characters to indicate the stacked place for the selected text. The following
contents present the special characters and illustrate how to create stacked text:

e Slash (/): Stacks text vertically and separate them with a horizontal line.

e A pound sign (#): Stacks text diagonally and separates them with a diagonal line.

e Carat ("): Creates a tolerance stack, which is stacked vertically as well as not separated by a

line.
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You can also use Stack button on the Text Formatting toolbar to create stacked text.

Import Text from External Files

You can input text (TXT and other) contents into the drawing from an external file by selecting Import
Text option from the right-click menu of the In-Place Text Editor, and display the text in the drawing

that imported from an external file as a mtext object.

Importing text from external files provides users with infinite flexibility while manipulating, you can
operate from creating text file for standard annotations firstly, and then insert these text into the

drawing as mtext objects for subsequent editing and resetting its formats.

Text imported from external files (TXT and other) uses current text style. Additionally, the external
files imported into the In-Place Text Editor retain its source document style for text height, and retain

the original setting for line break and enter symbol.

To Import Text file

1. Select Draw > Text > Multiline Text from the main menu.

2. Specify two corners of the multiline textbox separately to define the width of the
mtext object.

3. Right-click on the In-Place Text Editor, and then select Import Text from the
shortcut menu that pops up.

4. Select the desired text file from the Select File dialog box, and then click Open.
The text contents of the text file will be inserted into the position where the
cursor stays within the In-Place Text Editor.

Modify text contents to be inserted on your demand.

6. Click OK on the In-Place Text Editor to save the modification and exit the editor.
If you drag an external file into the drawing directly, it will be displayed as OLE object. Additionally, if

you use the clipboard to copy text from other applications and paste it into current drawing directly, the

text will be displayed as OLE objects.

241



ZWCAD User Guide

8.1.3. Leaders

A leader is a line or spline with an arrowhead at one end, and annotations (Mtext, blocks as well as

tolerance) at the other end.

Generally, you place an arrowhead at the first point. An annotation, created as dimension text, is placed

immediately adjacent to the last point.

Create a Leader Line

You can use LEADER or QLEADER to create a leader and control the appearance. The color of a
leader is controlled by the color of the current dimension line. The scale is controlled by the global
dimension scale specified on the current dimension style. The appearance of a leader is controlled by

the setting of the first arrowhead on the current dimension style.

Add Text to a Leader

There are two methods to add text to a leader:
e Type text on the command line

e  Create the multiline text using the In-Place Text Editor

When creating text, you can assign the style to an individual character and attach the copies of the

current annotation to the leader.

When the value of variable system DIMGAP is negative, the system creates a box next to the text,
which the distance between them is determined by the value of DIMGAP.

The text is placed automatically at the endpoint of a leader at the specified value, which is stored in the
"Offset from the dim line" on the Text tab of Modify Dimension Style dialog box. If the dimension is
tolerance, the future control frame is placed at the endpoint of a leader as well. A block is inserted at

the specified location with the specified scale value.

To create a leader and an annotation

Choose Dimension > Leader from the main menu.
Specify the starting point of the leader.

Specify the endpoint of the leader line segment.

P W e

Specify additional leader line segment endpoints.
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5. After you specify the last endpoint, press Enter.
6. Type the annotation, and press Enter to enter the next line of annotation text.

7. Press ENTER to complete the command.
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Specify the starting point of the leader (A) and the endpoint of the leader line segment (B)

The following picture shows the text is above the leader. You can set the Text Placement from the Text
tab in the Modify Dimension Style dialog box.

center

8.1.4. Multileader

Multileader is usually composed of four-part, arrowhead, leader, leader landing, and content. Each
multileader can contain more than one leader line, and each leader line can be composed of one or
more segments. Leader content can be set to Mtext or block. That is, a note created by multileader can

point to more than one part of the drawing.
You can create a multileader by Arrowhead First or Content First. The Multileader Style Manager is

also provided for style managing. You can create different styles of multi-leaders in the same view by

setting multileader style.
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Functions of the buttons on multileader toolbar are described in the table below:

Name Function Description
Multileader Creates a multileader object.
Add Leader Adds leaders to the selected multileader object.

Remove Leader

Removes the leader from the multileader object.

Multileader Style

SIBIEIR

Open "Multileader Style Manager “dialog box, in which

you create, modify or delete multileader style.

Create multileader

Enter MLEADER command, according to prompt to create multi-leaders on any location in the

drawing.

Steps for creating multileader with MText.

PN R

Select [Dimension - Multileader].
Specify leader arrowhead's location.
Specify leader landing's location.

Enter multitext in the text box as leader content, and then click "OK" button to

complete the multileader creating.

Steps for creating multileader with Block.
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Select [Dimension - Multileader].
Enter O (option) and set the multileader content type to block, then exit.

Specify leader arrowhead's location.

P w DN e

Specify the location of the multileader to finish drawing.
Multileader style

The leader type of the multileader can set to spline or straight.

/(— TEXT TEXT

Line Spline

The content of the multileader can set to MText or Block.

TEXT @

4206

Multiline Text

eader Landing Leader Landing

a1
Leader Block

leader

More details of multileader style settings, you can modify on Leader Format in Modify Multileader

Style dialog

8.2. Change Text

All of the text objects can be moved, rotated, deleted and copied, just as like other objects. You can

change the properties at the Properties panel.

You can also modify the contents of existing text and create a mirror image. The system variable

MIRRTEXT controls whether the text is reversed or not when you mirror object.

245



ZWCAD User Guide

8.2.1. Change single-line text

You have two methods to modify single-line text:
e  To modify only the content of the text, use DDEDIT command.

e To change text style, location, size and content, use PROPERTIES command to open

Properties palette, from which, you can make the relevant settings.

To edit text

1. Type DDEDIT and then press Enter.
2. Select the single line text.

3. Inthe Edit Text box, edit the text and then press Enter.

To change text properties

1. Select asingle line text object.
2. Right-click the selected object and then click Properties on the shortcut menu.
3. In the Properties palette, enter any new text in the Text Contents, and then

change formatting and other properties as needed.

You can also move, scale or rotate text through grips as like other objects. The grip of a single-line text

is displayed at the lower-left corner of the baseline and the alignment point. As shown in the following

HELL O

grips for right-justified line text

W Q -L)—é alignment paint

grips for middle-justified line text

picture:

Different grips generate different effect even though with the same command.

8.2.2. Change Multiline Text

You can change the properties of multiline text in the Properties palette.

To edit multiline text

1. Type DDEDIT and then press Enter.
2. Select the multiline text.
3. Edit the text in the In-Place Text Editor.
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4. Click OK.

To change multiline text properties

1. Select a multiline text object.
2. Right-click the selected object and then click Properties on the shortcut menu.
3. In the Properties palette, enter any new text and change formatting and other

properties as needed.

Double-clicking opens the In-Place Text Editor, from which, you can modify the contents and formats

of text.

Change Text Location

You can move or change the line width through grips as well.

Generally, the location of grips is displayed at the four grips of the text, in some cases, at the

justification point.

You can also replace the text by entering the coordinate on the Properties palette.
Find and Replace Text

Within the In-Place Text Editor, right-click and select Find and Replace to replace the selected
characters.

The content of the text is replaced, but the properties of the text remain.

8.2.3. Change Text with a Leader

You can change the size of a leader by stretching or scaling it. Stretch changes the distance between the
endpoint and the annotation. The scale only updates the scale of the selected objects. For example,
when scaling a leader, the location of the annotation keeps unchanged. A leader can be used as the

boundary for trimming or extending, but not be trimmed or extended.

8.3. Work with Text Styles

The text style is applied to the text objects. You can use text style to control the text font, size, angle,
direction and other features. By default, the current text style is STANDARD, and you have to make

other text styles current when you want to apply them.

247



ZWCAD User Guide

The STANDARD text style has the following default properties:

Setting Default Description

Style name STANDARD Name with up to 255 characters

Font name txt.shx the file associated with a font (character style)

Big Font None Specjal shape definition file used for a non-ASCII character set, such as
Kanji

Height 0 Character height

Width factor 1 Expansion or compression of the characters

Obliquing angle 0 The slant of the characters

Backward No Backward text

Upside down No Upside-down text

Vertical No Vertical or horizontal text

You can modify the current text style or create a new text style directly. You can also delete the created
text style but not the default STANDARD text style.

8.3.1. Create new text styles

When you apply some settings that the STANDARD does not have to the text, you have to create a

new text style or change the current text style.

Before creating a text style, you have to specify a name which can be up to 255 characters. The name
can contain characters, underscore, hyphen, dollar sign and other special characters that are not used by
Microsoft Windows or ZWCAD.

You can also modify the current text style in the Text Style dialog box.

Some style settings have different effects on single-line and multiline text objects. For example, the

Upside Down and Backwards options are not available for multiline text objects.
You can also rename an existing text style except for the STANDARD.

Except for the STANDARD text style, all text styles can be removed using PURGE command or
deleted from the Text Style dialog box.

Certain formatting applied to individual characters within multiline text may not be retained. The
formatting not to be retained includes bold, font, height and obliquing. The formatting that can be

retained includes color, stack and underscore.

To create a text style
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1. Choose Format > Text Style from the main menu.

2. Click New, type a new text style name and then click OK.

3. Under Text Measurements, specify the Text Height, Width Factor, and Oblique
Angle.

4. Under Text Font, select the name, style, language, and big font you want to use.
Under Text Generation, select the check boxes you want to indicate the direction
for printed text to appear.

6. Click Apply, and then click OK.

8.3.2. Assign Text Fonts

Each character set consists of text characters, which shape is defined by fonts. In addition to the
TrueType font, you can use compiled SHX font in ZWCAD. One font can be used for multiple text
styles as long as you make other settings different. The following illustration shows the same font used

by different text styles that use different settings.

DB,

hrs-l[ﬁ nello

You can specify the desired font from the Text Font field to the current or a newly created text font in
the Text Style dialog box.

Use TrueType Fonts

TrueType fonts always appear filled in the drawing. By default, the system plots the filled-in fonts,
which is controlled by the system variable TEXTFILL.

Use Unicode and Big Fonts

ZWCAD supports the Unicode character-encoding standard. A Unicode font contains 65,535 characters
and shapes for many languages. You can enter characters that are not available from the keyboard
through escape sequence. The escape sequence is of \U+nnnn, where “nnnn” represents the Unicode

hexadecimal value for the character. All of SHX shape fonts are Unicode fonts.

ZWCAD also supports the big font in order to accommodate alphabet text files consisted of thousands
of ASCII characters.

When you use —STYLE command to specify fonts, you can specify two fonts separated by a comma.
The first one is common font and the second is a big font. The specification is shown as follows:
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(specify font and big font on the command line)

Enter this ... To specify this ...

[font name],[big font name]  Both normal fonts and Big Fonts

[font name], Only a normal font (Big Font unchanged)

,[big font name] Only a Big Font (normal font unchanged)
[font name] Only a normal font (Big Font, if any, removed)
ENTER (null response) No change

You should not enter a long file name consisted of commas. The comma is interpreted as a separator.

8.3.3. Replace Font

If the font to be contained in the drawing can't be obtained from the current system, ZWCAD process it

by replacing these fonts with another specified one.
Specify fonts to replace

If the font to be contained in the drawing can't be found in the current system, ZWCAD replaces these
fonts with another specified font automatically. Otherwise, the system uses "simplex.shx" font to
override those unknown fonts instead. To modify the replace fonts by system default, you can modify
the system variable FONTALT which is applied for specifying new font file name. However, the
FONTALT value will be mapped to another font if the big font is used currently. Default font file for

this system variable is "txt.shx"and"bigfont.shx".
Edit Font Mapping File

Font mapping file is the list file for fonts and their corresponding replace fonts. If the specified fonts
can't be found in the current system, you can obtain from a font mapping file to replace them with

specified fonts.

Sometimes, to ensure partial specific fonts or enable fonts conversion in the current drawing, you can

create font mapping file with any text editor.

With these font mapping files, you can stipulate and manage fonts uniformly or use them directly when
off-line printing. If encountering font objects created by other fonts, you can specify replace fonts to
apply in platform through font mapping. It's also available for users to set a font mapping file to
convert each font to the corresponding font, for example, when editing drawings, the SHX which is
easy drawing can be used for replacing other fonts in the drawing, and subsequently switched to more

complex fonts when printing.
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Font mapping file is a type of common ASCII text file with an extension name as .fmp, containing text
file name without extensions or path in each line, the font file name with extension .ttf behind the font
file is replaced font, the two file names are separated by a semicolon. The system uses zwcad.fmp
(used for ZWCAD only) as default font mapping file. Any ASCII text editor is available for changing

the text for replacing specified fonts from the font mapping file.

For example, you can input the following contents in font mapping file, to replace timesnr.pfb font file

with times.ttf font file: timesnr;times.ttf.

If you can't find specified font file when opening a drawing, the system determines how to find the

replace font specific to the font type (single text, Mtext).

If the text is a single text, the system processes it with the following procedures:
e Search for replace font file in ZWCAD .fmp file.
e [terate font style table, search for the font file in the same format.
e  Use default font ZWCAD.fnt.
e Pop-up font file dialog box, in which user can specify replace font file, otherwise uses
ZWCAD.fnt as the default font.

If big fonts are being used, search for corresponding font files in font mapping table (zwcad.alt).

Search for the corresponding codepage in font mapping table (zwcad.ini), and then search for replacing

font file in font mapping table through this codepage.

If the corresponding text can't be found no matter which font is applied, use the mapping font file

found in zwcad.ini, if still unfound, use zwcad.fnt.

If a text object is mtext, the system handles it by subsection through language set so as to judge
whether the font file corresponding to this font file is capable of displaying this text object. If the font
file corresponding to this text object doesn't exist in the current system, the text style corresponding to
this text will be used for displaying this text. Even if the text style corresponding to this text can't be
found, Chinese system will take Song typeface as default, while other language systems take current
font style as default. If the corresponding font file exists but not display, the system reads the specified
font in system configured file (zwcad.alt). If the replacing font is corrupted or useless in some cases,

the fonts will not be replaced.

8.3.4. Set Text Height

Text height is the size of characters, which is measured in drawing unit. With the same height setting,
the displaying height of the TrueType font is usually lower than the one of SHX font. When the font is

not of TrueType font, the value represents the size of the uppercase letters.

When the text height is set to 0 in the text style, the system prompts you to type a height value while
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creating single-line text each time. So you can set text height to 0 in the text style in order to specify a

new height before creating text.

For TrueType fonts, the value of text height represents the height of a capital letter plus an ascent area.
The ascent is reserved for accent marks and other marks used in non-English languages. The relative
portion of text height assigned to capital letters and ascent characters is determined by the font designer

at the time the font is designed; consequently, it varies from font to font.

When you apply a text height to all text in the In-Place Text Editor, the whole multiline text object is

scaled, including its width.

8.3.5. Set Text Obliquing Angle

The obliquing angle determines that the text slant forward or backward. The obliquing angle ranges
from the -85 to 85. Positive value slants forward; negative value slants backward. As shown the

following picture:

30 deqg rntatn:ln U.deg totatioh
\/ 6 -30 deg rotation

AR &

%
/(D 7 / Q/ 66 30 deg rotation

-30 deg rotation

8.3.6. Set Horizontal or Vertical Text Orientation

The text directions include horizon and vertical. Only if the associated font supports dual orientation,
you can create the vertical text. Each sequent text line is drawn to the right of the preceding line.
Generally, the rotation angle for vertical text is 270 degrees. You cannot create vertical text when the

font is TrueType.
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To specify a line text style

w
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Choose Draw > Text > Single Line Text from the main menu.

On the command line, type S (Style) and press ENTER.

Type the name of a previously defined text style, and then press Enter. To display
a list of available text styles, type a question mark (?), and then press Enter.
Specify the text insertion point.

Specify the text height.

Specify the rotation angle.

Type the text line, and then press Enter.

To complete the command, press Enter again.

To specify a multiline text style

N o v ks wDN e

Choose Draw > Text > Multiline Text from the main menu.

Specify the first corner of the Multiline Textbox.

On the command line, type S (Style) and press ENTER.

Type the name of a previously defined text style, and then press Enter.
Specify the opposite corner of the Multiline Textbox.

Type the text.

Click OK.

8.4. Check Spelling

You can use the SPELL command to check the spelling of text in your drawings, use various spelling

dictionaries, and create custom spelling dictionary. It is comprised of the following items.
Checking the spelling of text

You can use the SPELL command to check the spelling of single-line text, multiline text, paragraph

text, attributes, attribute definitions, and dimension text.

Checking the spelling of text
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1. Type SPELL on the command line and press Enter.
2. Select one or more text entities.

3. Inthe Check Spelling dialog box, misspelled words display one at a time.

Do one of the following for each found word:
e Keep text unchanged — Click Ignore to keep the found word unchanged in the drawing, or
click Ignore
e All to keep all instances of the found word unchanged in the drawing.
e Change text — Select or type a word in the Suggestions box, then click Change to change the
found word in the drawing to the new text, or click Change All to change all instances of the
found word in the drawing.

e C(Click Add if you want to add the currently found word to a list of custom spelling words.

The Check Spelling dialog will recognize the added word as spelled correctly the next time the word is
checked for spelling.

8.4.1. Work With Spelling Dictionary

Most drawings contain text that is not recognized as spelled correctly, even though it is spelled
correctly. For example, if your company name Zaffer, Inc. appears in all of your drawings, the
company name will appear as misspelled every time you check the spelling of drawing text. You can
casily add words to a custom dictionary so that any word in the custom dictionary is recognized as

spelled correctly.

The custom dictionary is independent of any spelling dictionary you have chosen to use. You can check
the spelling of text using one dictionary, check the spelling of the same or other text using a different

dictionary, and in both cases, your custom dictionary is used.

TIP You can also add custom words to the custom dictionary directly during spell checking of text. In

the Check Spelling dialog, click Add to add the currently found word to the custom dictionary.

To download and install a new dictionary

1. Execute SPELL on the command line, select one or more text entities, and then in
the Check Spelling dialog box, click Change Dictionaries.

2. Click Download.

3. From the web page that displays (or from a different web page), download the
desired dictionary.

4. Unzip the contents of the downloaded file to \MyDocuments\HunSpell, or the
location where you installed spelling dictionaries for ZWCAD.
Click Change Dictionaries again, which will load the newly installed dictionary.
In Main Dictionary, select the desired dictionary.
Click OK.
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To use a dictionary already installed on your computer

1. Copy the existing dictionary (DIC file) to \MyDocuments\HunSpell, or to the
location where you install spelling dictionaries for ZWCAD. Or add the folder to
the existing dictionary to the list of folders where ZWCAD searches for dictionaries.
Choose Tools > Options from the main menu, and then click Files and add the
folder location to the corresponding paths.

2. Execute SPELL on the command line, select one or more text entities, and then in
the Check Spelling dialog box, click Change Dictionaries.

In Main Dictionary, select the desired dictionary.

4. Click OK.

8.4.2. Create custom spelling dictionary

The SPELL command compares text found in the drawing with correctly spelled words in an installed
dictionary (DIC file). There are many different dictionaries that can be used with ZWCAD, including
dictionaries in many different languages. You can download and install a new dictionary or use a

dictionary already installed on your computer.

To create and manage a custom dictionary

Type SPELL on the command line and press Enter.
Select one or more text entities.

In the Check Spelling dialog box, click Change Dictionaries.

P w N e

To add a custom word, type a word in Custom Dictionary Words, and then click

Add.

5. To delete a custom word, select a word in Custom Dictionary Words, and then
click Delete.

6. Click OK.

8.5. Smart Voice

Smart Voice provides designers a more convenient interactive way for drawings review. The traditional
ways include face to face interaction or adding text annotations in the drawings (such as adding cloud
lines, leads, texts, etc.). However, the former one requires both of the designers in the same place,
which is inconvenient for recording and subsequent accessing to the interactive content; while the latter
one is less efficient, you need to enter a lot of text and may lead to misunderstanding. As to the Smart
Voice function, it can help create voice comments in drawings, which is more conducive to the
communication between designers.
Besides, a lot of other usages can be derived from the smart voice function, such as:

e Auxiliary description for design intent

e Auxiliary tool for design thinking recording
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e Auxiliary tool for review comments description

e Effects enhancement tool for design demonstration

Create voice object

1. Choose Tools » Smart Voice » Smart Voice from the main menu.

2. Input S(Settings) in the command line to specify the way you insert the voice
object.

3. Mouse over the generated record button, press and hold the left mouse button to
start recording.

4. Release the mouse to stop recording and the Record icon will change into the Play

icon.

Command line: SMARTVOICE

You can use the following three ways to insert voice objects:

Insert into Point: Specify a point of absolute location to insert the voice object;

© N o wu

Insert into Region: Bind the voice object to a region, the region will be highlighted
in a dashed frame when you mouse over it;
9. Bind to Entity Object: Bind the voice to an object, the object will be highlighted in

a dashed frame when you mouse over it.

8.5.1. Voice playback

Mouse over the Ul icon of the recorded voice object, click the left mouse button to play the voice.

8.5.2. Delete voice object

Mouse over the Ul icon of the inserted voice object, a Delete button will show in the upper right corner,

click it to delete the voice object.
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9. Dimensions and Tolerances

9.1. Overview of Dimensioning

You can create five basic types of dimensions: linear, angular, radial, diametral, and ordinate.

You can create dimensions for existing entities by selecting them, or you can create dimensions by
selecting points within a drawing. For example, you can create a linear dimension either by selecting

the entity to be dimensioned or by specifying the first and second extension line origins.

Dimensions indicate the measurement values of objects (e.g. length or width), distance or angles
among objects, or the distance between the feature point and the specified origin. You can create
dimensions that can be horizontal, vertical, aligned, rotated, coordinate, baseline, or continued.
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When you create a dimension, the program draws it on the current layer, using the current dimension
style. Each dimension has an associated dimension style, which controls the appearance of the
dimension, such as the types of arrowheads, text style, and colors of various components. You can
modify existing dimension styles by changing any of the dimension variable settings, and the new

dimension style is visible soon after you confirm the modification.

You can use the QDIM command to create or edit a series of non-associative dimensions.

9.1.1. Parts of a Dimension

Dimensions have several distinct elements: dimension text, dimension lines, arrowheads, and extension

lines.
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Dimensions can also contain other optional components. A leader is a line leading from a feature of the
drawing to an annotation. Leaders begin with an arrowhead, and you can use them to place a dimension
away from the dimension line or to add notes. When you create a radial dimension, you can add a
center mark, which is a small cross that marks the center of a circle or an arc, or you can add

centerlines, which are crossing lines that extend out from the center of a circle or an arc.

Duis autem

Leader Center mark Centerlines

e Dimension text: a character string that usually indicates the measurement value, includes
prefixes, suffixes, tolerances, etc.

e Dimension line indicates the direction and extent of a dimension. For linear dimensions, it
displays as a line, for angular dimensions, it displays as an arc segment.

e Arrowhead: usually displayed at both end of the dimension line. You can specify various sizes

and shapes for arrowheads or tick marks.

e Extension line extends from the object to the dimension line, in order to define dimension
ranges.

e  Center mark: a small crossing tag that marks the center of a circle or arc.

e  Centerline: a crossing dashed line that marks the center of a circle or arc.

9.2. Use Dimension Styles

You can control the appearance of dimensions by changing settings. For convenience and to help

maintain dimensioning standards, you can store these settings in dimension styles.

9.2.1. Overview of Dimension Styles

Dimensions that you insert are created using the current dimension style. You can create, save, restore,
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and delete named dimension styles.

The DIMSTYLE command is available when you want to display information about the current

dimension style and all of the named dimension styles.

Dimension styles provide a way for you to change various settings that control the appearance of
dimensions. You can then save those settings for reuse. If you don't define a dimension style before
creating dimensions, the program uses the Standard dimension style, which stores the default
dimension variable settings. You can get Modify Dimension Style dialog started by clicking Modify

button on Dimension Style Manager dialog, for further modification of each dimstyle settings.

You can change the following settings in the Dimension Style Manager.
e Extension lines, dimension lines, arrowheads, center marks or lines, and the offsets between
them
e The positioning of the parts of the dimension in relation to one another and the orientation of
the dimension text
e The content and appearance of the dimension text

e  The units of the dimension value

With the Compare button of the Dimension Style Manager, you can list the difference between any two

named dimension styles.

If there is a dimension contained in the xref being inserted, then dimension style applied in this
dimension is also existing in the current drawing. You can compare externally referenced dimension
styles with other styles, but not allowed to modify them or make them current. An externally
referenced dimension style can be used as a template to create a new dimension style in the current

drawing.

To create a dimension style

1. Choose Dimension > Style from the main menu.

2. Inthe Dimension Style Manager dialog box, click New.

3. Type the name of the new dimension style, and choose which style started with
and what kind of dimension used for.

4. Click Continue.
In the New Dimension Style dialog box, click one of the other tabs, and then
change the dimension settings as necessary. Repeat this step for each tab, as
needed.

6. Toend the command, click OK.

To select a dimension style

1. Choose Dimension > Style from the main menu.

2. Select a dimension style from the Styles list.
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9.2.2.

To rename a dimension style

I AR S

Choose Dimension > Style from the main menu.

In the Styles list of Dimension Style Manager dialog box, do one of the following:
Double click the required style.

Right-click on the required style name, and then choose Rename.

Type the new name.

Click Close to exit.

To delete a named dimension style

Choose Dimension > Style from the main menu.
In the Styles list of Dimension Style Manager dialog box, right click on the
required style name, and then choose Delete.

Click Close to close.

To display information about the current style

Choose Dimension > Style from the main menu.

In the Dimension Style Manager dialog box, click Compare.

In the Compare Dimension Style dialog box, choose the same dimension style
from the Compare and With pulldown list. All properties for specified dimension
style will be displayed.

If you want to know the different information between two styles, choose one
style in the Compare box, choose the other in the With box, and then you will see
the difference in the following tab.

Click Close to close.

Control Dimension Elements

You can modify the appearance of dimension lines, extension lines, arrowheads, and center marks.

Modify Dimension Lines

On the Lines and Arrows tab of the Modify Dimension Style dialog box, you can set the color of

dimension lies, lineweight, ticks beyond extending the line, baseline spacing, and visibility.

Only when the arrowheads are assigned as oblique stroke arrowheads, architectural tick, Integral, dot
small or none arrowheads, you can set the displacement explains how far the dimension line extends
beyond the extend lines, otherwise, this setting is not available.

You can also set the baseline spacing to control the spacing between successive dimension lines.

If text splits a dimension line, you can specify whether each part of the dimension line is visible or not.
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Modify Extension Lines

Extension lines have the following properties: color, lineweight, distance beyond extension lines, offset
from start of extension lines, and visibility. You can set these properties on the Lines and Arrows tab of

the Modify Dimension Style dialog box.

If extension lines are unnecessary or there is not enough space to display extension lines, you can

suppress one or both of them.

The distance beyond extension lines means that how far the extension lines extend beyond the

dimension line.

Start offset is the distance between the extension line origin and the start of the extension line, also
called extension origin offset. Shown as follows:

extension arigin offset
extension line

obligue
extension line

The first extension line lies on the side where you specified the first extension line origin. If you create
a dimension for a line, you do not specify the extension line origin. Because the endpoint of the line
closet to the specified point becomes the origin of the first extension line. Generally, the extension lines
are perpendicular to the dimension line. However, if there is not space, you can make them oblique,

shown in the figure above.

You can control settings affecting dimension lines, extension lines, and center marks. Any changes you
make affect the current dimension style. The image tile on the right side of the Modify Dimension
Settings dialog box shows the appearance of the dimensions based on the current dimension style

settings.
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e A Extend beyond dim lines.
e B Baseline spacing.

e C Offset from the origin.

To set the color for dimension lines

1. Choose Dimension > Style from the main menu.

2. In the Dimension Style Manager dialog box, select the style you wish to change
and choose Modify.

In the Modify Dimension Style dialog box, click the Lines and Arrows tab.

Make your selections under the Dimension Lines.

Click OK.

Choose Close to exit.

o v kW

Choose Dimension Arrowheads

You can control the appearance and size of arrowheads or hook marks placed at the ends of dimension
lines. Any changes you make affect the current dimension style. The appearance of the selected
arrowhead is displayed in the preview frame placed at the upper right corner of the Modify Dimension

Style or New Dimension Style dialog box.

You can specify different arrowheads for both ends of a dimension line and for leader lines. The First
arrow is toward the first extension line; The Second arrow is toward the second extension line. Blocks
defined in the drawing also display in the three Arrowhead lists as user-defined arrows. You can use
these blocks to create and assign your own arrowheads. The Arrow Size value determines the size of

the arrowhead, measured in drawing units. You can also use tick marks instead of arrowheads.

To choose an arrowhead

1. Choose Dimension > Style from the main menu.

2. In the Dimension Style Manager dialog box, select the style you want to change
and click Modify button.

In the Modify Dimension Style dialog box, click the Lines and Arrows tab.

Make your selections under the Arrowheads.

Click OK.

Choose Close to exit.

A A

NOTE You can also specify leader arrow types using the DIMLDRBLK system variable.

Customize Arrowheads

The default arrowheads are stored as block definitions. If you select User Defined as your arrowhead

type, you'll be prompted to assign a name to an existing block definition.
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The overall dimension scale factor determines the arrowhead size. If you assign the User Define
Arrowhead to the arrowhead in the Dimension Style Manager dialog box, the block is inserted where
the arrowheads would normally go when you create a dimension. The X and Y scale factors of the
object are set to "arrowhead size overall scale. You can trim the dimension line with text gap x overall
scale units at each end. If you want to trim the dimension line, insert the rightmost block with a zero
rotation angle for horizontal dimensioning. And rotate the leftmost block at 180 degrees about its

insertion point.

If you use a paper-spacing scale, the scale factor is calculated before you applied it to the arrowhead

size value.

Center marks

While you are creating dimensions for circle or arc entities, you can setup type and size for the center

mark. Three types of marks are provided here: None, Mark, and Line.

9.2.3. Control Dimension Text

You can control the settings affecting the appearance of dimension text. Any changes you make affect
the current dimension style. The preview frame on the upper right corner of the Modify Dimension
Style dialog box shows the appearance of the dimensions based on the current dimension style settings.

Fit Dimension Text Within Extension Lines

When there is not enough space between extension lines to accept both of dimension text and
arrowheads, you have to adjust one or both of their placement. By default, the system fits them best
depending on the available space. You can also specify other methods to place them on the Fit tab of
the Modify Dimension Style dialog box. If there is no room for placing text and arrowheads, however,
you want to keep them together, and then they are both placed outside. If there is room for only text or
arrowheads, you can specify either text only or arrowheads only to be placed between the extension

lines.

You can also choose the "Place text manually when dimensioning" option to place dimension text

manually.

The following illustrations show how system applies a "best fit" for arrowheads and text.
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If there is no space for text between the extension lines, the system creates a leader automatically to
place text. You can set the relationship between them on the Text tab of the Modify Dimension Style

dialog box.

If you choose the "Always draw the dim line between ext lines" option on the Fit tab of the Modify
Dimension Style dialog box, the system creates a line between the extension lines as dimension line

even if neither the arrowheads nor the text is outside of the extension lines. Shown as follows

fel TL03
|—f|:|rc:ed internal line

To format dimensions

1. Choose Dimension > Style.

2. In the Dimension Style Manager dialog box, select the style you wish to change
and choose Modify.

In the Modify Dimension Style dialog box, click the Fit tab.

In Fit Options and Text Placement, select an option.

Click OK.

Choose Close to exit.
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NOTE You can also specify how dimension text and arrows are arranged using the DIMATFIT system

variable. You can specify how dimension text is moved using the DIMTMOVE system variable.

Fit Diameter Dimension Text

You can create various diameter dimensions based on text placement, fit options and the selection of

"Always draw dim lines between ext lines" option on the Fit tab. Shown as follows:
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Control the Location of Dimension Text

ZWCAD provides three justification settings: Horizontal, Aligned with dimension line, and ISO

Standard. You can also specify other location for the text. Most of the settings are interdependent.

= 7123 — . Man g JSTLED
text centered above  text centered text left-justified

the harizantal option  harizontally and ahove the dimension
selected verically line

Align Dimension Text

Whether the text is inside or outside the extension line, it has no effect on the justification of dimension
text. You can choose whether the text is aligned with the dimension lines or remains horizontal. The
following figures show the combination of these two options. The default justification is horizontal.
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text inside extension  text aligned with

lines ariented dimensian line
harizontally

To align dimension text with the dimension line

1. Choose Dimension > Style.

2. In the Dimension Style Manager dialog box, select the style you wish to change
and choose Modify.

In the Modify Dimension Style dialog box, click the Text tab.

Make your selections.

Click OK.

Choose Close to exit.

o Uk w
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Control the Location of Dimension Text

You can place dimension text vertically or horizontally, and give the offset the text from the first

extension line.

Position Dimension Text Vertically

The vertical text placement is the position of the text relative to the dimension. You can place text

above, below, or centered within the dimension line, or use the JIS dimensions.

Above places dimension text above the dimension line; Outside places dimension text on the side far
from the point you specify for the dimension line; Centered places dimension text medially within the

dimension line; JIS places dimension text according to the Japan industry standard.

In the ANSI standards, centered dimension text splits the dimension line. In the ISO standards,
centered text places above or outside the dimension line. In the following illustrations, ISO standards

allow angular dimension text to display in any of the ways shown.

JEm =
AMSI standard text 130 standard text above  text aligned with

centered withinthe  the dimension line and within the
dimension line dimension line

The justification and other settings may affect the vertical alignment of text. If you select Horizontal
Alignment, text inside the extension lines and centered within the dimension is placed horizontally, as

shown in the leftmost figure above.

Position Dimension Text Horizontally

The position of text along the horizon in relation to the extension lines. The settings include Centered,
At Ext Line 1, At Ext Line 2, Over Ext Linel, and Over Ext Line2. The following illustrations show

the examples of Center and Over Ext Line l1applying to dimension text.
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266



ZWCAD User Guide

As you create dimensions, the order you specified the extension line origins determines which
extension line is first. For angular dimensions, the order is defined around the counterclockwise. In the

following figures, the first extension line origin is 1 and the second one is 2.
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text harizontal and text horizontal at text horizontal at secand
centered along first extension line extension line

dimension line

If the "Place text manually when dimensioning" option on the Fit tab of the Modify Dimension Style
dialog box is chosen, as you create dimensions, you can place the dimension anywhere inside or
outside the extension lines along the dimension line. This option is useful when the space between the

extension lines is limited.

Control the Appearance of Dimension Text

Dimension text could be comprised of user-supplied text, prefixes, and suffixes provided by the
dimension style, and generated measurements. For example, you can add a radium symbol as a prefix

to a measurement, or add an abbreviation for a unit beyond the text, such as cm.

You can also set the text style and formats of color, height for the dimension text.

Control the Text Style in Dimensions

You can set the text style for dimension text on the Text tab of the Modify Dimension Style dialog box.
You can also specify a dimension text color and a height irrelevant to the height value set by current
text style. Choose the "draw frame around the text" creates a frame when you create dimension text.

The text styles applied to dimensions are the same as the one applied to all text created in your

drawing.

Supply User Text to Dimensions

Besides of the prefixes and suffixes specified for primary and alternate units, you can provide your
own text. Because the prefix, suffix, and user-supplied text can be treated as a single text string, they
can be used to represent tolerance stacks and the changes can be applied to a font, text size, and other

characteristics using the text editor.

The separator symbol \X is used to separate user text above and below the dimension line.

Text prior to this symbol is aligned with and below the dimension line. Text following this symbol is
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aligned with and below the dimension line.

For example, if you select Text while creating dimensions, and then input user text "<> ZWCAD \X
WELCOME", thus the user text is separated above and below the dimension line. In which, <> stands

for main units, \X separates the text by a dimension line.

9.2.4. Control Dimension Values

Set the display format of dimension values.

Dimension Units

You can determine the appearance and format of the primary and alternate dimension units. The
preview frame on the upper right corner of the Modify Dimension Style dialog box shows the

appearance of the dimensions based on the current dimension style settings.

On the Primary Units of the Modify Dimension Style dialog box, you can set the primary units for
linear and angular dimensions, including unit format, numeric precision and so on. These settings
control the display of dimension values. For linear dimension, you can also specify the prefix or suffix.
The specified prefix replaces the prefixes used for diameter and radius dimensions (@ and R,
respectively).

E30S,LS
2572

224,55
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To round off dimensions

1. Choose Dimension > Style from the main menu.

2. In the Dimension Style Manager dialog box, select the style you wish to change
and choose Modify.
In the Modify Dimension Style dialog box, click the Primary Units tab.

4. In the Linear Dimensions and Angular Dimensions fields, type or select the
nearest value to which you want to round off dimensions.

5. Click OK.

6. Choose Close to exit.

NOTE You can also specify units for linear dimensions using the DIMLUNIT system variable. You
can specify fraction formats using the DIMFRAC system variable.
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Alternate Units

You can create a dimension in two systems of measurement simultaneously in a drawing. This feature
is helpful when you want to add feet and inches dimensions in a drawing created using metric units.
The alternative units appear in square brackets ([]) in the dimension text. Alternative units can be

applied to linear dimensions only.

If you turn alternative-units dimensioning on when editing a linear dimension, the measurement is
multiplied by a specified alternate scale value. This value indicates the number of alternate units per
current unit of measurement. The default fault value for imperial units is 25.4, which represents that
each inch is equivalent to 25.4 millimeters. The default value for metric units is 0.0394, which
represents that each millimeter is equivalent to 0.0394 inches. The precision for alternate units

determines the number of decimal places.

For example, for imperial units, if you specify the default value of 25.4 to the alternate scale setting

and 0.00 to the alternate precision, the dimension is shown in the following figure.

17367 [44.12]

—— 43352 [111.64]—=

To create an alternate dimension

1. Choose Dimension > Style.

2. In the Dimension Style Manager dialog box, select the style you wish to change
and choose Modify.

In the Modify Dimension Style dialog box, click the Alternate Units tab.

Click the Display Alternate Units check box.

Make your selections.

Click OK.

Choose Close to exit.
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Round Off Dimension Values

Except for angle dimensions, all other dimension values can be rounded off. For example, if you
specify a round-off value of 0.75, all distance is rounded to the nearest 0.75 unit. The number of
decimal places is determined by the precision set for primary and alternate units and lateral tolerance

values.
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round-off value set
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Suppress Zeros in Dimensions

Control how to deal with leading and trailing zero in the numeric portion of dimension text. If you
suppress leading zero in decimal dimensions, 0.700 becomes .700; if you suppress trailing zero, 0.7000
becomes 0.7. If you suppress both leading and trailing zeros, 0.7000 becomes .7 and 0.0000 become 0.

The following paragraph shows the effect of selecting zero feet and zero inches using architectural

units style. If feet are included with a fractional inch, the number of inches is always indicated as zero

round-off value set
to default. 25

round-off value set
to default 1

and ignores any option you select. So, the dimension 4'-3/4" becomes 4'-0 3/4".

Option

No options selected

0 Inches selected

0 Feet selected

0 Feet and 0 Inches

selected

Effect

Includes zero feet and zero inches

Suppresses zero inches (includes zero
feet)

Suppresses zero feet (includes zero

inches)

Suppresses zero feet and zero inches

Display Lateral Tolerances

Lateral tolerance represents a value that the amount a measured distance can vary. You can control the

degree of accuracy needed for a future by specifying tolerances in manufacturing. A feature is some

aspect of a part, such as a line, axis, point, or surface.

You can append tolerances to the dimension text directly. These dimension tolerances indicate the

largest and smallest permissible size. You can also apply geometric tolerances to indicate deviations of
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0!_0 1/2" 0"6" 11_0"
1'-0 3/4"

0-0 172" 0-6" 1’
1'-0 3/4"

1/2" 6" 1’_0" 1!_0
3/4"

172" 6" 1'1'-0 3/4"
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form, profile, location, orientation, and runout.

You can specify exact measurements for lateral tolerances theoretically. They are called basic

dimensions and have a box drawn around them.

Deviation tolerances represent the plus and minus values that are appended to the dimension values. If
the deviation tolerances are equal, the + signs precede them and they are known as symmetrical.

Otherwise, the plus value locates above the minus value. Shown in the following figures.

40,5
- 235200405
deviation tolerance sy mmetrical dewiation
tolerance

If you apply the tolerance as a limit, ZWCAD calculates a maximum and minimum value using the
positive and negative values provided. These values replace the original dimension values. The upper

tolerance locates above the lower if you specify deviation tolerances.

*.“6?’

The vertical placement of tolerance values that is relative to the main dimension text can be specified.

For example, you can align the tolerances with the top, middle, or bottom of the dimension text.

46 I0H).S +0.5 +1.5
45 HIFe g 40015
top middle hottarm

You can also control how to suppress zero for tolerance values, as you can with the primary and
alternate units. The effect of suppressing zero in lateral tolerance is the same as suppressing zero in the

primary and alternate units.

9.2.5. Set the Scale for Dimensions

Set the scale for dimensions. Setting dimension scale depends on the method you use to lay out and

plot drawings.

Dimension scale has effects on the size of dimension geometry relative to the objects in the drawing. In
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addition to text height and arrowhead size, dimension scale affects offsets in dimension as well, such as
the extension line origin offset. When you create dimensions, it's recommended to set the size and
offset to values that represent their actual plotted size. However, the tolerances, measured lengths,

coordinates, and angles cannot be applied to the overall scale factor.

The method you lay out your drawing determines how to set the dimension scale. The method of

creating dimensions in a drawing layout is shown as follows:

Dimension in model space for plotting in model space. If you want to create dimensions that are scaled
correctly for plotting, you have to set the system variable DIMSCALE to the inverse of the desired plot
scale. For example, if the plot scale is 1/4, you have to set DIMSCALE to 4.

Dimension in model space for plotting in paper space. If you want to create dimensions that are scaled
automatically for display in a paper space layout, you have to set the DIMSCALE to 0. This method is
useful when you encounter the following situations: the dimensions in a drawing need to be referenced
by other drawings (xrefs); when you create isometric dimensions in 3D isometric views. To prevent the
dimensions in one layout viewport from being displayed in other layout viewports, it's recommended to

create a dimensioning layer for each layout viewport that is frozen in all other layout viewports.

Dimension in layouts. You can create dimensions in paper space by selecting model space objects or by
specifying object snap locations on model space objects. The dimensions created in a paper space
layout do not need additional scaling: there is no need to change the default value of DIMLFAC and
DIMSCALE.

9.2.6. Annotative Dimension

Annotative Dimension can now be displayed, created and edited. Usually, the size of dimension
changes together with the size of the geometry it annotates, resulting in its failing display in the Layout
viewports when plotting to a smaller scale. Now by defining the annotative property to control the way
that the annotative dimension scales, the size of the annotation dimension can be adjusted
automatically according to the specified scale in the Layout viewports and displayed at the correct size,

which is especially helpful for plotting drawings with multiple scales in multiple viewports.
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149

130

Size of the dimension will adjust automatically base on different viewport scale

9.3. Create Dimensions

You can create dimensions by:
e Selecting the entity to dimension and specifying the dimension line location.

e Specifying the extension line origins and the dimension line location.

When you create dimensions by selecting an entity, the program automatically places the extension line
origins at the appropriate definition points based on the type of entity you select. For example, the
definition points are located at the endpoints of arcs, lines, and polyline segments. When you create
dimensions by specifying the extension line origins, the points you specify determine the definition

points. To establish these points precisely, use entity snaps.

9.3.1. Create Linear Dimensions

Linear dimensions annotate linear distances or lengths and can be oriented horizontally, vertically, or
aligned parallel to an existing entity or to the selected extension origin points. After you create a linear
dimension, you can add a baseline dimension or a continued dimension. A linear baseline dimension
inserts an additional dimension from a common first extension line origin of a previous linear
dimension. A linear continued dimension continues a linear dimension from the second extension line

of a previous linear dimension.

TIP To select precise ordinate points, use entity snaps.
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Create Horizontal and Vertical Dimensions

As you create linear dimensions, the system automatically applies a horizontal or vertical dimension
depending on the specified extension line origins or the location where you select an object. However,

you can create a dimension by specifying it be horizontal or vertical.

In the following illustration, by default, a horizontal dimension is created unless you specify a vertical

one.

hotizontal dimension  vertical dimension
created by default specified

To create a horizontal or vertical dimension

1. Choose Dimension > Linear from the main menu.

2. Press Enter and then select the object dimension.

3. Or, you can insert the dimension by specifying the first and second extension line
origins.

4. Specify the dimension line location.

Create Aligned Dimensions

In the aligned dimensions, the dimension line is parallel to the line passing through the extension line
origins. The aligned dimension is also parallel to the objects you specify. The following figure shows
two examples of aligned dimension. Select the object (1), and then specify the location of the aligned

dimension. The system creates the extension lines automatically.

145,00
2%

To create an aligned dimension

1. Choose Dimension > Aligned from the main menu.
2. Press Enter and then select the object dimension.
3. Or, you can insert the dimension by specifying the first and second extension line
origins.
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4. Specify the dimension line location.

e/3481 ]

To insert an aligned dimension by selecting the entity, select the entity (A) to dimension, and then select the

At

dimension line location

A rﬂ

To insert an aligned dimension by selecting the extension line origins, select the first extension origin (A), select the

\¢

L.

second extension origin (B), and then specify the dimension line location (C).

Create Baseline and Continued Dimensions

Both baseline and continued dimensions are multiple linear dimensions. Baseline dimensions are

measured from the same baseline and continued dimensions are placed end to end.

Before creating either baseline or continued dimension, you have to create a linear, aligned, or angular
dimension. If no dimension in the current session, the system prompts for selecting linear, aligned, or
angular dimension. If there are dimensions in the current session, you can create a baseline or
continued dimensions incrementally from the most recently created dimension. Unless you specify
another point as the origin, both baseline and continued dimensions are always measured from the

previous extension line.

The following illustration shows the baseline and continued dimensions.

JE‘J,I]EI

201,00 | 255,00

D700
717,00

To create a linear baseline dimension
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NOTE Before you can use this procedure, you must first create a dimension.

1.
2.

Choose Dimension > Baseline from the main menu.

Specify a second extension line origin or press Enter to select a dimension as a
baseline.

Select the next extension line origin.

Continue selecting extension line origins as required.

To end the command, press Enter twice.

The program automatically places the new baseline dimension above or below the previous dimension

line. The distance between two dimension lines is determined by the Baseline Spacing value on the

Lines and Arrows tab of the New Dimension Style or Modify Dimension Style dialog box.

A

’——1.550—- Y

—
4.400
3050 G -y
1,650 — k 4 =—1.650—= [—

To add a baseline dimension to an existing linear dimension, select the existing dimension (A), select the next

extension line origin (B), and select as many additional points as you want (C).

To create a linear continued dimension

NOTE Before you can use this procedure, you must first create a dimension.

1. Choose Dimension > Continue from the main menu.
2. To select a starting dimension, press Enter.
3. Select the next extension line origin, and then press Enter.
4. Or press Enter and then select an existing dimension to continue.
5. To add continued dimensions, continue selecting extension line origins.
6. Toend the command, press Enter twice.
—1.630—= 1Il
AJ B—
Ii
—1650—f=t400~ ] e 1.650—t= 1400~ 1350 |-
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To add a continued dimension to an existing linear dimension, select the existing dimension (A), select the next

extension line origin (B), and select another extension line origin (C).

Create Rotated Dimensions

You can create rotated dimensions at a rotated angle you specify using DIMLINEAR Rotated option.
An example of a rotated dimension is shown in the following illustration. In this illustration, the

specified angle of the rotated dimension is equal to the angle of the slot.

s

Create Dimensions with Oblique Extension Lines

By default, the extension lines are perpendicular to the dimension line. However, if the extension lines
conflict with other objects in a drawing, you can use Dimension-Oblique menu option to change their
angles measured from the X axis of the current UCS to the extension line. This option is only applied

to the existing dimensions, ignoring the dimensions to be created.

35,00

9.3.2. Create Angular Dimensions

Angular dimensions are used to measure the angle between lines or three points. You can dimension
objects including circles, arcs, and lines. You can also create an angular dimension directly with three
specified points. By selecting the circle and specifying the angle endpoints, you can create the angular
dimension to measure the angle between two radii of a circle. For other objects, you choose the objects
and specify the dimension location. You can also create an angular dimension by specifying the angle

vertex and endpoints.

When you create the angular dimension, you can modify the text content and alignment before placing
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the dimension line.

With the existing angular dimensions, you can also create a baseline and continued angular dimensions.
Baseline and continued dimensions should not be over 180 degrees. To acquire baseline and continued
dimensions that are larger than 180 degrees, you have to stretch the position of the extension line of an

existing baseline or continued dimension using grid editing.

Dimension Lines

Angular dimension lines are typically represented with arc segments. To create an angular dimension
for two nonparallel lines, the dimension line arc spans the angle between the two lines. As you specify
the dimension line arc location, if the dimension line arc does not intersect one or two extension lines
being dimensioned, the system automatically draws them. The dimension line arc is always less than

180 degrees. However, for the circles and arcs, the dimension line arc can be up to 360 degrees.

To dimension an angle between two lines

1. Choose Dimension > Angular from the main menu.
2. Select one line.
3. Select the other line.
4. Specify the dimension line location.
Cc

B

-

120*
1

Select one line (A), select the other line (B), and then specify the dimension line location (C).

Dimension Circles and Arcs

If the object to be dimensioned is circle or arc, the dimension line arc is placed between the extensions.

The dimension line arc is also drawn between the extension lines when you use three points to create

for the dimension line arc.
T3

an angular dimension. The quadrant of the dimensioned angle depends on the location that you specify
I (’

o

3
1
—

circle lines lines specify vertex
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To dimension, an angle encompassed by an arc

1. Choose Dimension > Angular from the main menu.
2. Select the arc.

3. Specify the dimension arc location.

12o0*

b

To dimension, the angle subtended by an arc, Select the arc (A) and then specify the dimension arc location (B).

9.3.3. Create Radial Dimensions

You can create radial dimensions for circles or arcs to measure their radial. The radial dimension is a
radial dimension line with an arrowhead that points to a circle or arc. To display centerlines or a center

mark, set the system variable DIMCEN to nonzero.

If the Text Placement on the Fit tab of the New Dimension Style or Modify Dimension Style dialog
box is set to "Over the dimension line, with a leader", then the dimension is applied along with a leader
line.

Both center marks and lines apply only to radius and diameter dimensions. They are created only when
you place the dimension outside the circle or arc. The size of the centerline is the distance of the

centerline segment that extends outside the circle or arc, shown in the following illustration:

- cerntering
size

certetlines

To create a radial dimension

1. Choose Dimension > Radius from the main menu.
2. Select the arc or circle.

3. Specify the dimension line location.
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A_J« = B- ROSEES

Select the circle (A), and then specify the dimension line location (B).

Jogged Dimension

Jogged dimension is namely jogged radius dimension, which is also called "scaled radius dimension".
The user can specify the center position to place the origin of dimension for replacing center point of
circle or arc within radius dimension. The DIMJOGGED command is useful for creating dimensions in
case that the center of circle or arc to be dimensioned is located outside the layout and can't be

displayed in its actual position either.

You can set the angle of jogged radius from "Other Items" tab either in "New Dimension Style" dialog

box or "Modify Dimension Style" dialog box.

For a jogged radius dimension having been created, you can modify its jog and center position by

means of grip editing, Properties palette and executing the STRETCH command.

To create a jogged radius dimension

Choose Dimension > Jogged from the main menu.
Select a circle or an arc.

Select center position as the dimension origin.

P w N e

Specify a point to position the jog symbol.

9.3.4. Create Diameter Dimensions

You can create diameter dimensions for circles or arcs to measure their diameters. Creating diameter

dimensions resembles creating radial dimensions.

You can create various diameter dimensions based on the location and size of circles or arc, and the
settings of the dimension style. Either drawing a center mark or line is controlled by the dimension
style. If the dimension line is created inside a circle or arc, the center mark or line is not drawn. The

system variable DIMCEN controls whether the center mark or line is displayed.

To create a diametral dimension
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1. Choose Dimension > Diameter from the main menu.

2. Select the arc or circle.

3. Specify the dimension line location.

AT, 4— B #L 1758

Select the circle (A), and then specify the dimension line location (B).
9.3.5. Create Ordinate Dimensions

Ordinate dimensions are used to measure the perpendicular distance from an origin point called the
datum to a feature, such as a hole in a part. Ordinate dimensions are comprised of a leader line with an
X or Y value. These dimensions are called datum dimensions. X or Y value is calculated in the current
UCS, and leaders are drawn along the orthographic direction at the current UCS. The dimension values

are the absolute values. By maintaining accurate offsets of the features from the datum, these
dimensions can prevent escalating errors.

| 114600

F
o

%
-
:

ardinate dimensions

X ordinate dimensions show the distance of a feature from the datum along the X-axis. And Y ordinate
dimensions show the distance along the Y-axis. The system determines whether the dimension is X or
Y ordinate dimension depending on the point you specify. If the distance is greater for the Y value, the

system creates an X ordinate dimension. Otherwise, the system creates a Y ordinate dimension.

Y ordinate

# ordinate
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X and Y ordinate values are determined by the absolute coordinate value of the current UCS. Before

creating ordinate dimensions, it recommends you to reset the UCS origin to coincide with the datum.

ll,_i'i..llll

LICS arigin

LA 0]

0oo

In the ordinate dimensions, the dimension text is always aligned with the ordinate leader line, ignoring
the text orientation defined by the current dimension style. You can also supply your own text or accept

the default one.

To create an ordinate dimension

1. Choose Dimension > Ordinate from the main menu.
2. Select the point for an ordinate dimension.

3. Specify the ordinate leader endpoint.

Liat

.:t‘.....a,
D o

Select the ordinate point (A), and then specify the ordinate leader endpoint (B).

L

e

TIP To select precise ordinate points, use entity snaps.

9.3.6. Create Quick Dimension

Creates or edits a series of dimensions quickly by typing QDIM command.

To create a quick dimension

1. Choose Dimension > Quick Dimension from the main menu.

2. Select the geometry to dimension, and then press Enter.

3. On the command line, it will display "Specify dimension line position, or
[Continuous/Staggered/Baseline/Ordinate/Radius/Diameter/datumPoint/Edit/seT
tings] <Continuous>:".

4. You can perform the operation as desired. The default is Continuous.
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9.3.7. Create Arc Length Dimensions

Arc length dimension is available for measuring the arc length of arc or polyline arc segment. ZWCAD
creates arc length dimension by specifying extension line position directly after selecting arc by default.
And use an arc symbol as arc length dimension logo, which is differing from the linear dimension and

angular dimension.

Arc symbol of arc length dimension displays both in front of the dimension text and above it, which is
adjustable from "Other Items" tab either in "New Dimension Style" dialog box or "Modify Dimension

Style" dialog box.

5. 32

i o

Additionally, orthogonal or radial extension line is available for arc length dimension, only the
included angle of the arc segment selected for creating arc length dimension is smaller than 90 degrees

can display its orthogonal extension line.

To create an arc length dimension

1. Choose Dimension > Arc Length from the main menu.
2. Select an arc or polyline arc segment.

3. Specify a point to position the arc length dimension.

9.4. Modify Existing Dimensions

You can modify all components of the existing dimension objects in a drawing either individually or by

using dimension styles.

9.4.1. Modify Dimension Style

You can modify all of the properties of the existing dimension objects in a drawing using dimension
styles. You can also create a dimension style override to temporarily change a dimensioning system

variable without changing the current dimension style.

As you create dimensions, the system applies the default current dimension style to the dimensions.

The created dimension remains this style unless you apply a new dimension style to it or set up
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dimension style overrides.

You can also modify the current dimension style and apply it to existing dimensions. If a dimension

style is changed, the dimension associated with that dimension style updates automatically.
Override a Dimension Style

Overriding a dimension style changes a dimensioning system variable without changing the current

dimension. You can define dimension style overrides for the following situations:

For individual dimensions, you may want to modify some properties of dimensions, such as
suppressing a dimension's extension lines or modifying text and arrowhead placement so that they do

not overlap drawing geometry, without creating a new dimension style.

Set up overrides to the current dimension style. As you have created a dimension style override, all
dimensions that are created in this dimension style include the overrides, until you delete overrides,
save the overrides to a new style, or make another style current. For example, you can change the
extension lines' color on the Lines and Arrows tab by clicking the Override button in the Dimension
Style Manager, and keep the current dimension style unchanged. However, the new value for color is
stored in the system variable DIMCLRE. The extension lines of the dimension you create will apply

the new color. The dimension style overrides can be saved as the current dimension style.

Dimension style includes some common dimension characteristics that are suited to be saved
permanently, and some are applied on an individual basis that can be applied more effectively as
overrides. For example, a single type of arrowhead is often used in a drawing, so it is suited to be saved
as part of the dimension style. However, suppression of extension lines often applies in individual cases

only and is more suited to a dimension style override.

The overrides apply to the dimension you are creating and all subsequent dimensions that are created

with it until you reverse it or set another dimension style to current.

9.4.2. Make Dimensions Oblique

Extension lines are normally created at a perpendicular angle to the dimension line. You can change the

angle of the extension lines, however, so that they tilt relative to the dimension line.

To make oblique extension lines

1. Choose Dimension > Oblique from the main menu.
2. Select the linear dimension, and then press Enter.

3. Type the obliquing angle, and then press Enter.
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Select the dimension to be made oblique (A), and then type the obliquing angle.

i

— %

TIP To align the oblique angle if you don't know the exact measurement, use snaps to pick two points

on the entity.

9.4.3. Modify Dimension Text

You can change the existing dimension text including text content, location, and orientation.

The existing text in a drawing can be rotated, moved to a new location, or replaced with new text. You
can also move the text back to its home position using Dimension-Align Text-Home menu option. This
default location is defined in the current dimension style. In the following figures, the home position is

specified above and centered on the dimension line.

N

dimension text rotated  dimension text moved
hack to home postion

You can rotate the specified text at an angle using the Dimension-Align Text-Angle menu option, or

change the angle and content in the Properties palette.

When you move text, you have to select a single dimension to move first. You can move the dimension
text anywhere along the dimension line. You can use grips to move text up or down, which does not
change the current vertical alignment of the text placement relative to the dimension line. However, the
dimension and extension lines are modified accordingly. The following figure shows the effect of
moving text up and to the right. The text placement relative to the dimension still remains centered and

vertical.

| —— | Lsps.an
text centered vertically  result of moving text to
on the dimension line  the right and outside the
extension lines
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To rotate dimension text

1. Onthe command line, type DIMEDIT.

2. Type R (Rotate).

3. Type the new dimension text angle, and then press Enter.
4. Select the dimension to be rotated, and then press Enter.
Select the dimension fo be rofated {A), and then Result

type fhe roation angle.

NOTE The dimension text angle is relative to the dimension line. If the dimension text rotation is set

to zero, the text angle is defined by the dimension type and the dimension style.

To move dimension text

1. Onthe command line, type DIMTEDIT.
2. Select the dimension to reposition text.

3. Select the new text position.

A
.._Emn—l_.l. = o f/:_ N 2,000

Select the dimension to be moved (A), and then select the new text position (B).

To restore dimension text to its home position

1. Onthe command line, type DIMEDIT.
2. Type H (Home).
3. Select the dimension text to restore, and then press Enter.

To replace existing dimension text with new text

1. Onthe command line, type DIMEDIT.
2. Type N (New).

3. Type the new dimension text, and then press Enter.
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4. Select the dimension to be replaced, and then press Enter.

9.4.4. Dimension Jogged

The DIMJOGLINE command is available for adding or removing jog symbol for linear dimensions,
showing a dimension value differs from its factual measured dimension value. Generally, the value

displayed here is greater than the actual measurement value.

The jogged line is composed of two paralleled lines and a connecting line with 40 degrees between
them. As for the height of the jogged line, the user can set it from "Other Items" tab either in "New
Dimension Style" dialog box or "Modify Dimension Style" dialog box.

After adding jog symbol to the linear dimension, the jog is defaulted to be placed at the center point
between first extension line and dimension text or center point based on the dimension text. To relocate
jog symbol, you can adjust the position of dimension text or specify the new position to locate jog after

reselecting dimension.

To add a jog to the linear dimension

1. Choose Dimension >Jogged Linear from the main menu.
2. Select alinear dimension.
3. Specify a point on the dimension line to determine the jog symbol, or press ENTER

directly to position the jog symbol in the default place.

- — 2,08 ——=)

9.4.5. Dimension Inspection

You can add or remove dimension inspection for existing dimensions. For transmitting the frequency of
inspecting the part being dimensioned, the dimension value and parts tolerance are ensured to be within

specified range.

Dimension inspection can be added to any type of dimension objects, which is composed of a frame
and internal text. You can specify the shape of inspection frame as round, angular or none. An
inspection dimension contains utmost three kinds of information field: inspection tag, dimension value,

and inspection rate. Using a perpendicular line to divide the dimension information among each field.
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In which, inspection tag, used for mark the text of dimension inspection is located on the left side

within the inspection frame.

Dimension value here is the value before adding dimension inspection, which is located in the central

part of the inspection dimension including tolerance, text and measurement value.

Inspection rate which is expressed by percentage is located at the right side within the inspection frame,

indicates the required frequency of the part being created.

To create an inspection dimension

© N o wu

Choose Dimension > Inspect from the main menu.

In the Inspection Dimension dialog box, click Select Dimensions button.

Close the Inspection Dimension dialog box temporarily to switch to the drawing
area.

Select dimensions to add dimension inspection, and then press ENTER to finish
selection and return to the dialog box.

Select a shape for the frame from the Shape option.

Click Label option to input label in the text box.

Click Inspection Rate option to input a value in the text box.

Click OK.

To remove an inspection dimension

Choose Dimension > Inspect from the main menu.

In the Inspection Dimension dialog box, click Select Dimensions button.

Close the Inspection Dimension dialog box temporarily to switch to the drawing
area.

Select dimensions to remove dimension inspection, and then press ENTER to
finish selection and return to the dialog box.

Click Remove Inspection button.

Click OK.

9.4.6. Dimension Space Adjustment

Once you have created multiple paralleled linear dimensions or angular dimensions, you can adjust the
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space among these paralleled lines with an equal value either default or specified.

Various methods are available for creating paralleled linear dimensions and angular dimensions. Either
using DIMLINEAR and DIMANGULAR to create dimension one at a time or executing
DIMBASELINE and DIMCONTINUE to place other linear dimensions or angular dimensions

according to the linear dimension or angular dimension previously created.

When using DIMBASELINE for creating baseline dimensions, the space between each dimension is
identical, which is controlled by system variable DIMDLI, but the variable is only applied to control
dimension space for the subsequent dimension space. If you adjust dimension space by changing the
size of dimension text is changed only, or adjusting the dimension scale other than changing the

position of dimension line, then the dimension line is likely to be overlapped with text.

DIMSPACE command is also available for adjusting the space among paralleled linear or angular
dimensions or overlapped dimensions automatically in case that the original space is not equal values.

It should be noticed when adjusting dimension space, the dimensions you select must be of the same
type, for example, either all of the linear dimensions or angular dimensions. Additionally, these

dimensions must be paralleled, or share the same origin and placed at the extension line of one another.

If you set the space value to 0 when adjusting space among dimensions, you can align selected
dimensions at the dimension line. If you specify the space as Auto, dimension space among them is
default to twice of the text height. To modify the text height, you can set from the Text tab on the
Modify Dimension Style dialog box.

‘ﬂ—é' %—-—_ 2. 11—
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9.4.7. Dimension Arrow Flip

Sometimes users want to flip over the dimension arrow as it displays awfully under narrow space or the
arrow looks not comfortable in the drawing. You can use command “AIDIMFLIPARROW” or right

click on the dimension to flip the arrow
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(Flip the dimension arrow)

9.5. Add Geometric Tolerances

Geometric tolerances in a drawing show acceptable deviations of form, profile, location, orientation,

and runout of a feature.

You can create geometric tolerances with or without leaders depending on you use the LEADER or the
TOLERANCE command.

9.5.1. Overview

Each feature control frame consists of at least two compartments. The first compartment contains a
geometric tolerance symbol that indicates the geometric characteristic to which the tolerance is applied,
such as location, orientation, or form. For example, a form tolerance may indicate the flatness or
roundness of a surface. The geometric tolerance symbols and their characteristics are shown in the

following.

.. .
Position : Location

Py
£

Concentricity or coaxiality = Location

Symmetry —  :Location

T
L
!

Parallelism * :Orientation
Perpendicularity — :Orientation
Angularity < :Orientation

Cylindricity A : Form

F

Flatness “— : Form
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Circularity or roundness " : Form

Straightness : Form

Profile of a surface £ : Profile

Profile of a line £ : Profile

&
Circular runout : Runout

ot

et

Total runout : Runout

The tolerance value can then be followed by primary, secondary, and tertiary datum reference letters,
along with the material conditions of each datum. Datum reference letters are generally used as
reference tolerances to one of up to three perpendicular planes from which a measurement is made,

although datum reference letters can also indicate an exact point or axis.

A feature control frame contains symbols that represent location, orientation, form, profile and runout
that apply to a tolerance. Form tolerances control straightness, circularity, flatness, and cylindricity;

profiles control surface and line.

Most editing commands can change feature control frames, and these feature control frames can be
snapped to with the object snap. You can also use grips to edit geometric tolerances. Unlike dimensions
and leaders, geometric objects are not associated with geometric objects.

primary and secondary
datum reference letters

tolerance value

| |
geormetric characteristic—-& [#30,056 M| 0,820 [CE [ DM |

symbal-in this case,posion

optional diameter symhbol

material conditions
of tolerance

material conditions
af datums

Material Conditions

The second compartment displays tolerance values. Depending on control type, you can add a diameter
symbol prior to the tolerance value, and specify a material condition symbol behind this value.
You can apply material conditions to features that can vary in size, shown as follows:
e At maximum material condition (symbol M, also known as MMC), a feature contains the
maximum amount of material stated in the limits. At MMC, a hole has a minimum diameter,

whereas a shaft has a maximum diameter.
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e At least material condition (symbol L, also known as LMC), a feature contains the minimum
amount of material stated in the limits. At LMC, a hole has a maximum diameter, whereas a
shaft has minimum diameter.

Regardless of feature size (symbol S, also known as RFS) means a feature can be any size within the

stated limits.

Datum Reference Frames

A datum reference consists of values and modifying symbols. A datum is a theoretically exact
geometric reference that measures and verifies a theoretically exact point, axis, or plane. The system
provides up to three datum reference letters and relative symbols followed by the tolerance value. Two
or three mutually perpendicular planes perform best when you applying these datum references. They

are jointly called datum reference frame.

The following illustration shows a datum reference frame that consists of three perpendicular planes.

econdany—,
daturm plane:

arimany datum plane

Projected Tolerance Zones

Projected tolerance zones control the height of the fixed perpendicular part of the extension area, and

control tolerance accuracy by positional tolerances.

Before you set the symbol to projected tolerance zones, you set a height value to specify the minimum
projected tolerance zone. The following illustration shows the projected tolerance zone height and
symbol appearing in a frame.

|43 0] 435)]
224E)

|

W U
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Composite Tolerances

A composite tolerance consists of two tolerances that applied to the same geometric characteristic of a
feature or for features that have different datum requirements. One tolerance is in relation to a pattern
of features and the other tolerance to each feature within the pattern. The pattern tolerance is less

restrictive than the individual feature tolerance.

datum A—-—

In the illustration above, the axis formed by the point where datums A and B intersect called the datum

axis. The position of the pattern is calculated from that axis.

Before you create a dimension and add a composite tolerance for a drawing, you have to specify the
first line of a feature control frame and then choose the same geometric characteristic symbol for the
second line of the feature control frame. The specified geometric symbol compartment is extended over

both lines. Then you can create a second line of tolerance symbols.
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9.5.2. Adding geometric tolerances

Geometric tolerances indicate the maximum allowable variations in the geometry defined by a drawing.
ZWCAD draws geometric tolerances using a feature control frame, which is a rectangle divided into

compartments.

To add a geometric tolerance
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10.

11.
12.
13.

Choose Dimension > Tolerance from the main menu.

In the Geometric Tolerance dialog box, click the first square under Sym and select
a symbol to insert.

Under Tolerance 1, click the first black box to insert a diameter symbol.

In the Text box, type the first tolerance value.

To add a material condition (optional), click the second black box and click a
symbol in the Material Conditions dialog box to insert it.

Under Tolerance 2, repeat steps 3 through 5 to add a second tolerance value, if
appropriate.

Under Datum 1, Datum 2 and Datum 3, enter the datum reference letter.

Click the black box to insert a material condition symbol for each datum
reference.

In the Height box, type a projected tolerance zone height value, if appropriate.

To insert a projected tolerance zone symbol, click the Projected Tolerance Zone
box, if appropriate.

In the Datum Identifier box, add a datum value.

Click OK.

In the drawing, specify the location of the feature frame.

9.5.3. Controlling dimension tolerance

You can create dimensions as either tolerance or limits dimensions. When creating a tolerance

dimension, you can control the upper and lower tolerance limits as well as the number of decimal

places of the dimension text. The image tile on the right side of the Dimension Settings dialog box

shows the appearance of tolerance and limits dimensions based on the current dimension style settings.

+H0.013 3389
5374 _pooa 3366
Tolerance dimension. Limits dimension.

To create a tolerance dimension

I

Choose Dimension > Style from the main menu.
In the Dimension Style Manager dialog box, select the style you wish to change
and choose Modify.
Click the Tolerances tab.
Make your selections.
Click OK.
Choose Close to exit.
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7.

Dimension toolbar

9.6. Table

The table is a cell collection composed of rows and columns. Tables can be created from table style.

Meanwhile, you also can create table object according to the data in Microsoft Excel spreadsheet.

The existing table can also be edited. Editorial content includes: To edit the text in a table cell, insert

row (column), delete row (column), merged cells, modified cell borders, and so on.

You can control the appearance of the new table by modifying the table style. Table style includes table

direction, background, text style and any other table characters.

9.6.1.

Table Toolbar

When you work in the Classic interface, the Table toolbar displays after you select a table object (if you

work in the Ribbon interface, then the Table Cell contextual tab displays). Functions of the buttons on
the Table toolbar are described in the table below:

Icon Name Function Description
I Insert Row above Insert a row above the specified row or cell.
o

== .

“ Insert Row below Insert a row below the specified row or cell.
—
— Delete Row(s) Delete the current selected row.
—

i | Insert Column to| Insert a column into the left side of the specified column or

D.d’ I Left cell.

-

Insert Column to
Right

Insert a column into the right side of the specified column or

cell

—
x— | =

Delete Column(s)

Delete the current selected column.

Merge Cells

Merge the specified multi-cell into one large cell. There are
three kinds of merging cells.

All: Merge the specified multi-cell into one cell.

By Row: Merge the specified multi-cell into several cells by
removing the vertical gridlines and leaving all the horizontal
gridlines.

By Column: Merge the specified multi-cell into several cells by

removing the horizontal gridlines and leaving all the vertical
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gridlines.

i Unmerge Cells

Separate the previously merged table cells.

Set border options for the selected table cell in "Cell Border

-t Cell Borders ] )
: Properties" dialog box.
MIDDLE . .
.:%. Specify alignment of the cell contents.
CENTER
1]
::'i : Match Cell Apply all properties of the selected cell to other cells.

9.6.2. Edit and Modify Table

Edit column & row

Operating Steps:

1. Select one cell in the table.

2. Click "Insert Row above" button on the Table toolbar to insert a row above the

selected cell. You can also click "Insert Row below" button to insert a row below

the cell, click "Insert Column to Left" button to insert a column on the left side,

and click "Insert Column to Right" button to insert a column to the right side.

Table Table
3 T T 12 1T 11
14 16 18 e - -
13 17 12 13 i =
AR T 13 17
e = E i T 13 17
T 2 15 [ 1 2 2
12 15 11 a - -
12 15 11
Before After

Merge and unmerge cells

Operating Steps:
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1. Select one cell in the table.

2. Hold down the SHIFT key, and select another cell to be merged.

3. Click "Merge Cells" button on the Table toolbar, and select the way you want to

merge the cells. You can use the following three methods for merging: All, By Row

and By Column. Different merged cells will be generated according to different

merging ways.

Table Table
12 17 11 12 17 11
14 16 15 14 16 15
13 17 12 A F g
R T 17 ! & o |
T 15 13 5 13|
17 12 15 I T R 15
12 15 11 12 15 11
Before After

Change the appearance of cell borders

Operating Steps:

1. Select one cell in the table.

2. Click "Cell Borders" button on the Table toolbar to open the "Cell Border

Properties" dialog box.
In this dialog box, set the lineweight and color properties of cell borders.
4. Click OK to finish setting.

Table Table
12 17 11 12 17 11
14 16 15 14 16 15
13 T 12 13 i 12
CETTT TS 17 15 13 I
TR 15 13 11 15 13
17 12 15 17 12 15
12 15 11 12 15 11
Before After

Edit data format and alignment

Operating Steps:
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1. Select one cell in the table.

2. Click "Alignment" button on the Table toolbar to select alignment. Alignment
includes Top Left, Top Center, Top Right, Middle Left, Middle Center, Middle Right,
Bottom Left, Bottom Center and Bottom Right.

Table Table
12 17 11 12 17 11
14 16 15 14 1R 15
13 o 12 13 o 12
15 ! 1 17 15 17
11 Ui T 13 11 i T 13
17 12 15 17 12 15
12 15 11 12 15 11

Before After

Match cell format

Operating Steps:

Click "Match Cell" button on the Table toolbar, and then use the format of a
selected cell (source cell) to replace that of any other cell (destination cell).

The mouse pointer becomes a brush. Then you can match the destination cells by

clicking them.
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10.Blocks, Attribute and Xrefs

10.1. Create, Insert and Edit Blocks

Usually, blocks are several objects combined into one that you can insert into a drawing and
manipulate as a single object. A block can consist of visible objects such as lines, arcs, and circles, as

well as visible or invisible data called attributes. Blocks are stored as part of the drawing file.

Blocks can help you better organize your work, quickly create and revise drawings, and reduce
drawing file size. After you create a block from multiple objects, you save it once, which also saves
disk space. You can change the block definition to quickly revise a drawing, and then update all

instances of the block.

If you insert a block that contains objects originally drawn on layer 0 and assigned color and linetype
BYLAYER, it is placed on the current layer and assumes the color and linetype of that layer. If you
insert a block that contains objects originally drawn on other layers or with explicitly specified colors

or linetypes, the block retains the original settings.

If you insert a block that contains objects originally assigned color and linetype BYBLOCK, and the
block itself has the color and linetype BYLAYER, those objects adopt the color and linetype of the
layer onto which they are inserted. If the block is assigned an explicit color or linetype, such as red or

dashed, those objects adopt those qualities.

A procedure called nesting occurs when you include other blocks in a new block that you are creating.
Nesting is useful when you want to combine and include small components, such as nuts and bolts, into
a larger assembly and you need to insert multiple instances of that assembly into an even larger

drawing.

10.1.1. Create Blocks

ZWCAD provides various methods to create blocks, and insert the block into a drawing more times as
you need. With this method, you can create blocks as soon as possible. You can use several methods to
create blocks:

e Combine objects to create a block definition in your current drawing.

e Create a drawing file and later insert it as a block in other drawings.

Objects drawn on several layers with various colors, linetypes, and lineweight properties can be
combined into a block. Once a block is inserted into the drawing, the block reference preserves
information about the original layer, color, and linetype properties of the objects that are contained in

the block although it is always displayed on the current layer. Whether to retain their original properties
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or inherit their properties such as color, linetype, or lineweight settings from the current layer for

objects is controllable. To remove unused block definitions from a drawing, use PURGE command.

When defining blocks, you should define the block name, objects to be contained in the block, the
coordinate values of the base point to be used for inserting the block, and any associated attribute data.
The block definition in the illustration comprises a name, four lines, and a base point at the intersection

of the two diagonal lines.

v
A

ahjectsin hlock definition
drawing area created from
selected ohjects

The illustration shows a typical sequence for creating a block definition.

ohiects created  insertion paoint ohjects selected hlocks written
selected to block takle

To create a block for use within a current drawing

1. Choose Draw > Block > Make from the main menu.

2. Inthe Block Definition dialog box, enter a block name in the Name box.

3. Click Pick button to specify a point as the insertion point for the block in the
drawing area.

4. Click the Select button to select the objects for the block, and then press Enter
after selection.

5. To restore the original objects to the drawing while retaining the new block, click
Retain.

6. Click OK.

Create Nested Blocks

You can define blocks and other blocks as nested blocks so as to simplify the organization of

complicated blocks.

With nested blocks, you can build a single block out of several components. But you should notice that

blocks that reference themselves cannot be inserted.
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X X

nested hlock hlocksthat are components of the neated hlock

10.1.2. Create Drawing Files for Use as Blocks

You can create a block as a separate drawing file that you can insert into other drawings.

To save a block as a separate drawing file

1. Onthe command line, type WBLOCK.
2. Under Source area, choose one of the following:
3. Block: This option saves existing block object to a separate drawing file. When
prompted, select an existing block name from the pulldown menu of this option.
Entire drawing: This option immediately saves the entire drawing to a separate drawing
file.
Objects: This option saves those objects you select a separate drawing file. When
prompted, specify the insertion point for the block, and select the objects for the block.
4. Under Destination area, type the name of the drawing file you want to create and
choose the saved path.
NOTE When saving the entire drawing as a separate drawing file, the program assigns
the 0,0,0 coordinate as the insertion base point. You can change the base point by

opening the drawing and redefining the block.

Change the Base Point of Drawings to Be Used as Blocks

When inserting a drawing file into another drawing as a block, by default, the system uses the origin
(0,0,0) of WCS as the base insertion point. To specify different insertion point, you can use the BASE

command. Next time you insert the same block, the system uses the new insertion point by default.

Update Changes in the Original Drawing

Once the drawing file has been inserted into another drawing as a block, the original drawing changes
as well. But the block having been inserted will not change. If the block happens to change along with

the original drawing, you should attach it as an external reference but not as a block.

Use Paper Space Objects in Blocks

Objects created in paper space are not contained in the block when it is being inserted into the drawing.
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You can convert the objects in paper space as a block or save as an individual drawing file before

inserting into other drawings.

10.1.3. Insert Blocks

You can insert blocks and other drawings into the current drawing. When you insert a block, it is
treated as a single object. When you insert a drawing, it is added to the current drawing as a block. You
can then insert multiple instances of the block without reloading the original drawing file. If you
change the original drawing file, those changes have no effect on the current drawing unless you

redefine the block by reinserting the changed drawing.

You can also insert blocks from another drawing into the current drawing. Both drawings must be open

at the same time to do this.

When you insert a block or drawing, you must specify the insertion point, scale, and rotation angle.
The block's insertion point is the reference point specified when you created the block.

When you insert a drawing as a block, the program takes the specified insertion point as the block
insertion point. You can change the insertion point, however, by first opening the original drawing and
redefine the block.

You can specify the scale of a block reference using different X, Y, and Z values.

> U = )

defaultvalue  #scale=04 X scale=1  rotation andle=45
Y scale=1 Y scale=0.5

To insert a block

Choose Insert > Block from the main menu.
In the Insert Block dialog box, under Insert, click Block Name.

In the Block Name box, select the name of the block you want to insert.

P w N e

If you want to use the pointing device to specify the insertion point, scale, and

rotation, select Specify On-Screen. Otherwise, enter values in the Insertion Point,

Scale, and Rotation boxes.

5. If you want the objects in the block to be inserted as individual objects instead of
as a single block, select Explode block upon insertion.

6. Click Insert.

Insert a Drawing File as a Block

You are required to specify insertion point, scaling and rotation angle while inserting the drawing file
into the drawing. If external references are included in the block, the xrefs may not be normally

displayed unless it has been inserted or attached to target drawing. You can redefine insertion point,
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scale factor, and rotation angle each time you insert the drawing, as the following picture shows:

hlock  hlock inserted into drawing

To insert an entire drawing into the current drawing

1. Choose Insert > Block from the main menu.

2. Inthe Insert Block dialog box, under Insert, click On File.

3. Type the path and the drawing file name, or click Browse to specify the file from
the Insert Block dialog box.

4. If you want to use the pointing device to specify the insertion point, scale, and
rotation, select Specify On-Screen. Otherwise, enter values in the Insertion Point,
Scale, and Rotation boxes.

5. If you want the objects in the block to be inserted as individual objects instead of
as a single block, select Explode block upon insertion.

6. Click Insert.

NOTE You can specify the insertion point, scale factors, and rotation angle in the Insert Block dialog
box before inserting the block. You can also control whether the block is exploded back into its original
component objects after insertion. If you want to explode the block immediately, select the Explode

Upon Insertion check box.
Insert Blocks at Intervals

You can insert blocks at intervals along a selected geometric object. Use MEASURE to insert a block

at measured intervals. Use DIVIDE to insert a block at proportional (evenly spaced) intervals.
Insert Blocks with DesignCenter

The block definitions created in a drawing file are displayed in DesignCenter. Use Design Center to
insert blocks from the current drawing, right-click the block, and select insert block by specifying its
location, scale, and rotation. You cannot add blocks to a drawing in process of another command, and

you can only insert or attach one block at a time.

10.1.4. Control the Color and Linetype Properties in Blocks

Through controlling properties like color and linetype for objects on the block, the objects in an
inserted block can retain their original properties, can inherit properties from the layer on which they

are inserted, or can inherit the properties set as current in the drawing. When you insert a block, the
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color, linetype, and lineweight of objects in the block retain their original settings regardless of the

current settings in the drawing.

The following three choices are provided for you to determine how the color, linetype, and lineweight

properties of objects are treated when a block reference is inserted.

Objects in the block inherit their original color, linetype, and lineweight properties once inserted into
the drawing. The properties of objects in the block can't be changed until redefined. For this choice, it
is recommended that you set the color, linetype, and lineweight properties individually for each object
in the block definition: which are different from BYBLOCK or BYLAYER color, linetype, and

lineweight settings when creating these objects.

Objects in the block inherit color, linetype, and lineweight properties that assigned to the current layer
only. For this choice, before you create objects to be included in the block definition, set the current

layer to 0, and set the current color, linetype, and lineweight to BYLAYER.

Objects inherit color, linetype, and lineweight properties that have been definitely set, that is, the
properties you have set to override the color, linetype, or lineweight assigned to the current layer. If
you do not definitely specify layer properties for the objects, then use properties of the current layer.
For this choice, before you create objects to be included in the block definition, set the current color or
linetype to BYBLOCK.

10.1.5. Modify a Block Definition

You can redefine all instances of a block within the current drawing. To redefine a block that was
created in the current drawing, you create a new block using the same name. You can update all the
blocks in the current drawing by redefining the block. If the block was inserted from a separate
drawing file that was subsequently updated, reinsert that block to update all other instances in the

current drawing.

There are two methods of redefining block definitions, you can choose to modify block definition in

current drawing or an original drawing.
Modify the block definition in the current drawing.

Modify the block definition in the source drawing and insert it into the current drawing again.

To modify a block definition already inserted into the drawing, you should first create a new block
definition with a new name to replace the existing block definition, and all the references to that block

in the drawing are immediately updated to reflect the new definition.

To save time, you can insert and explode an instance of the original block and then use the resulting
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objects while creating the new block definition.

To redefine a block in the current drawing

Choose Draw > Block > Make from the main menu.

In the Block Definition dialog box, type the name of the block you want to
redefine in the Name box.

Click Pick button to specify a point as the insertion point for the block in the
drawing area.

Click the Select button to select the objects for the block, and then press Enter
after selection.

Click OK.

Click Yes in the prompt box that displays to redefine the block in the current
drawing.

The block is immediately redefined, and all instances of the block in the drawing

are updated.

TIP To restore the original objects to the drawing while retaining the new block, click Retain.

Update a Block Definition That Originated from a Drawing File

To modify the original drawing directly before inserted into the drawing, blocks inserted into current

drawing are not updated automatically unless the block definition from the drawing file is updated

using INSERT command.

Remove Block Definitions

Too many block definitions in a drawing file may affect the drawing size. To reduce the size of a

drawing, you can remove unused block definitions. Erasing a block reference from a drawing may
delete the block reference but retain the block definitions in the block definition table. Using PURGE

command can help removing unused block references from your drawing in order to reduce the

drawing size.

You should erase all references from a block before you can purge the block definition.

Disassemble a Block Reference (Explode)

To modify one or more objects within a block separately, you can use Explode tool from Modify

toolbar, and restore this block after you have modified these objects using one of the following

methods:
[ ]
[ ]

Create a new block definition
Redefine the existing block definition

You can automatically explode block references as you insert them by selecting the Explode
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block upon insertion option in the Insert Block dialog box. Thus, the block reference will be

automatically exploded with each object inserted into the drawingg separately.

To explode a block

1. Choose Modify > Explode from the main menu.
2. Select the block you want to explode.

3. Press Enter.

10.1.6. Edit Blocks

The Block Editor contains an independent area in which you can create and edit block definition as

you would in the drawing area. Click “BEDIT” to enter the block edit modes.

With Block Editor, you can:
e  Update (Redefine) block definition (not support Flexiblock yet) in Block Editor
e Save as Block or write block as a drawing file
*  Define attributes to an edited block

e Edit non uniformly scale block

When you define a block by opening it in Block Editor or select an existing block to open in Block
Editor, the contextual tab or toolbar will be displayed as follows, and the drawing area will turn to
grey color. In Block Editor, you can define the objects for a block definition, and save as new block or

as a drawing file.

BREEFE - - @ 2D Drafting & Annotati ~ ZWCAD 2021 Professional Edition - [Drawing1.dwg]
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10.1.7. Flexiblock

FlexiBlock is a special block reference object. By adding specific parameters and actions to the
block object, the block can be "transformed". Users can freely adjust the shape of the block
according to the parameters set. Currently, FlexiBlock supports actions such as "move", "stretch”,
"scale", and "rotate". The specific parameters and action types are shown in the following figure:

|+ v

Move Point
- Mowe -

Point

Linear 1% Stretch

m Polar Polar Stretch

Xy Scale
Rotation Rotate
Flip Flip
Alignment Array
Visibility

Basepoint

Parameters and actions supported in FlexiBlock
As an advanced function, FlexiBlock can meet more complex design needs of users. The good use
of FlexiBlock can greatly save the time of drawing and improve the work efficiency. For example,
users can create a flexiblock of a door, which can contain the size, style, and other parameters of
the door. According to different working scenarios, users can adjust the shape of the door and
apply it to different drawings, which reduces the time of creating a large number of blocks and
also reduces the cost of data management.

"Door"” made by FlexiBlock
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10.2. Define and Use Block Attributes

An attribute is a particular object that you can save as part of a block definition. Attributes consist of
text-based data. You can use attributes to track such things as part numbers and prices. Attribute values
are either fixed or variable. When you insert a block containing attributes, the program adds the fixed

values to the drawing along with the block, and you are prompted to supply any variable values.

After you insert blocks containing attributes, you can extract the attribute information to a separate file
and then use that information in a spreadsheet or database to produce a parts list or bill of materials.
You can also use attribute information to track the number of times a particular block is inserted into a
drawing.

Attributes can be visible or hidden. Hidden attributes are neitherr displayed nor printed, but the

information is still stored in the drawing and written to a file when you extract it.

10.2.1. Define Attributes

You add an attribute to a drawing by first defining it and then saving it as part of a block definition. To
define an attribute, you specify the characteristics of the attribute, including its tag, prompt, and default
text; insert coordinates and text formatting, and attribute flags (hidden, fixed, validate, defined, lock

position and multiple lines).

To define an attribute

1. Choose Draw > Block > Define Attributes from the main menu.

2. Inthe Define Attribute dialog box, type the tag, prompt, and default text.

w

Under Insert Coordinates, specify the location of the attribute, or click Select to
select a point in the drawing.

Under Attribute Flags, select the optional attribute modes.

Under Text, specify the text characteristics.

To add the attribute to the drawing, do one of the following:

N o v k&

Click Define to add the attribute and keep the dialog box active so you can define
another attribute.
8. Click Define and Exit to add the attribute and end the command.

10.2.2. Modify Attributes

You can edit an attribute definition before you associate it with a block and before it is saved as part of

a block definition.

To edit an attribute definition
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1. Onthe command line, type DDEDIT.

2. Select the attribute definition text to edit.

3. Modify the attribute tag, prompt and default text in the Edit Attribute Definition
that displays.

4. Click OK.

10.2.3. Define Block Attributes

Attributes can be attached to a block. When selecting objects to be included in the block, you can select
all the attributes and then choose the block to be attached.

The order you select attributes determines the prompts displaying when inserting blocks. If you select
attributes by crossing selection or window selection, the prompts for attributes are displayed by the

order of creating attributes.

10.2.4. Modify Block Attributes

You can use the Block Attribute Manager to modify attributes in block definitions. For example, you
can modify the following items:
e  Attributes of blocks can be displayed after modification
e  Text properties that define how attribute text is displayed in the drawing
e Properties that define the layer that the attribute is on and the attribute line's color, weight, and
type
e By default, attribute changes you make are applied to all existing block references in the
current drawing. If constant attributes or nested attribute blocks are affected by your changes,

use REGEN to update the display of those blocks in the drawing area.
Redefine Block Attributes

When you modify the block definitions, the system prompts to select objects that are included in the
block definition, you can attach the attributes to the block by adding the desired attribute to the
selection set. Once the attributes of block definition have been modified, the inserted block reference

may be affected by the following descriptions:
Constant attributes with a fixed value, are lost and replaced by any new constant attributes.

Variable attributes remain unchanged, even if no attributes are included in the new block definition.

New attributes do not appear in the existing block references.

To edit an attribute attached to a block

1. Onthe command line, type DDATTE.
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2. Select the block to edit. The Edit Attributes dialog box displays all the attributes
attached to the block you select.
Edit the attribute values as necessary.

4. Click OK.

10.2.5. Extract Block Attribute Data

Enter EATTEXT to start Attribute Extraction wizard if the blocks in the drawing contain attributes. You
can extract block information according to the wizard prompt and generate a list so as to overview the
attributes information of the blocks. You can get guide information from the wizard until you

accomplish selecting drawings, blocks and block attributes.

With the extracted block attribute data function, you can easily create a list using drawing data by

extracting attribute information and export to external files.
Export to exterior files

When you want to save the extracted information to external files, you can save the external file as
CSV, TXT, XLS and MDB format.

10.3. Reference Other Drawing Files
(Xrefs)

You can link entire drawings to the current drawing as external references. Unlike inserting a drawing
as a block, in which you add all the objects from the separate drawing into the current drawing,
external references attach a pointer to the external file. The objects in the external reference appear in
the current drawing, but the entities themselves are not added to the drawing. Thus, attaching an

external reference does not significantly increase the size of the current drawing file.

External references provide additional capabilities not available when you insert a drawing as a block.
When you insert a drawing as a block, the objects are stored in the drawing. Any changes you make to
the original drawing are not reflected in the drawing in which you inserted it. When you attach an
external reference, however, any changes you make to the original drawing file are reflected in the
drawings that reference it. These changes appear automatically each time you open the drawing
containing the external reference. If you know that the original drawing was modified, you can reload

the external reference anytime you're working on the drawing.

External references are useful for assembling master drawings from component drawings. Use external
references to coordinate your work with others in a group. External references help reduce the drawing

file size and ensure that you are always working with the most recent version of a drawing.
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10.3.1. Attach External References

When a drawing is attached to current drawing an external reference, it will be linked to the drawing,

any changes to the referenced drawing may affect the external reference in the current drawing.

External references are inserted into the drawing as block definitions and used as single objects, But

you should distinguish the external references and blocks.

A xref can be attached to various drawing simultaneously. In the same way, you can attach multiple
xrefs to the same drawing using the full path or relative path that are partly defined. Even without

saving path.

You should notice that xref must be an object created in model space when inserting xrefs, you can

specify the insertion scale, position and rotation angle.

When you attach an external reference, its layers, linetypes, text styles, and other elements are not

added to the current drawing. Rather, these elements are also linked from the referenced file.

There are two ways you can attach an external reference:

e An attachment is an inserted drawing that contains a link to the original file. Attachments can
themselves contain other, nested reference files. When you attach an external reference, any
nested references contained in the file also appear in the current drawing.

e An overlay is also an inserted drawing that contains a link to the original file. Overlays allow
you to lay a drawing on top of another drawing, similar to the way you work manually with
transparencies. When a drawing that contains overlaid external references is itself attached or
overlaid as an external reference in another drawing, the overlays do not appear as part of the
external reference. Use overlaying when you want to see reference geometry in a drawing but
you do not need to include that geometry in drawings that will be used by others (nested

external references).

To attach an external reference

1. Choose Insert > Xref Manager from the main menu.
2. Click Attach.
3. Inthe Select Reference File dialog box, specify the drawing file to attach and then
click Open.
4. Inthe External Reference dialog box, under Reference Type, choose how you want
to insert the drawing:
Attachment - Inserts a copy of the drawing and includes any other drawings that are
externally referenced within the referenced drawing.
Overlay — Lays a copy of a drawing over your original drawing; it does not include any
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nested external references from the externally referenced drawing.
5. Make any additional selections.
6. Click OK.
7. If you marked Specify On-screen for any items, follow the prompts to attach the

external reference.

xatNotification of Attached Xrefs

After inserting external references into the drawing, a xref icon displays at the lower right corner of the
status bar on ZWCAD application window. Click this icon shown below to display External Reference

manager:

AT v A A M 3 2T

If the original drawing to which the xref links has been changed and needs to reload, an exclamation

mark appears on the xref icon.

Attach External References

You can use the following methods to attach xrefs into a drawing:
e  Attach xrefs to the current drawing using XATTACH command.
e  Start Xref Manager using XREF command, and select the xref to be attached to the current
drawing.
e Select the xref drawing you want to insert into the drawing from DesignCenter, and right-click
the drawing to select Attach Xref.

Viewing the list of external references

You can view a list of the external references that are linked to the current drawing two different ways
using the Xref Manager:
e List View - Displays the external references in a list, which allows you to sort the list of
references by name, status, size, type, date, or saved path.
e Tree View - Displays a hierarchical representation of the external references and the
relationships between them. The tree view shows the level of nesting relationships of the

attached external references.

To view a list of external references

1. Choose Insert > Xref Manager from the main menu.
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2. Click List View or Tree View.
Visibility, Color, and Linetype

You can control visibility, color, linetype and other properties by setting the layer on which the xref

locates. You can also assign these changes as temporary or permanent.

If the system variable VISRETAIN is set to 0, layer table stores in the xref have superiority,
modifications based on a layer made for xref of the current drawing are only available for the current
command. These changes will not be saved along with the drawing. When restarting the drawing, layer

table will be reloaded and changes still remain in the current drawing.
If the system variable VISRETAIN is set to 1, modifications based on a layer made of xref of the

current drawing has superiority. Layer settings will be saved in layer table of the current drawing. And

in accordance with current tasks.
Xref Clipping Boundaries

You can control whether to display clipping boundary of xref through setting system variable
XCLIPFRAME.

10.3.2. Nest and Overlay External References

Xrefs can be nested in another xref and attached to the current drawing.

Xrefs that are multiply nested can be attached to the drawing. In the process of attaching, you can

select insertion position, scaling factor and rotation angle for xrefs.

As the following illustration shows, master.dwg contains a.dwg and b.dwg. And drawing a.dwg
contains c.dwg. Thus, In master.dwg, c.dwg is a nested xref.
b. dwg

O

master. dwg a dwg

c.dwg

Specify the type of a xref, including attachment and overlay. Using overlay to exclude any nested xrefs

rather than overlay xrefs. This type is typically used for sharing data in the network. In Xrefs that are

attached in overlay type, you can view relative methods directly between the drawing and other
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grouping drawings.

In the following illustration, attach master.dwg to multiple drawings as xref. Users who are working
with a.dwg need to view and use objects drawn on b.dwg without but not reference the drawing b.dwg
because it would then appear twice in master.dwg. Instead, this may overlay b.dwg but not makes it
included when a.dwg is referenced by master.dwg.

c. dwg

U

mazter. dwg a. dwg

E>
@
©

o erlay

)
b. dwg ,: b. dwz :.

Relative Saved Paths and Nested Xrefs

You can specify saving path individually for the xrefs that are attached to the drawing in Xref Manager

dialog box. You can select the saving path as full path, relative path or no path.

If the xref to be attached is a nested xref, its relative saving path means the position relative to the host

computer.

10.3.3. Update Attached External References

If the xref drawings are changed, you can update the xref to the latest version whenever you want.

To update a xref, start Xref Manager using XREF command. The status of updated xrefs displayed in
the list is "Needs reloading", and you can update these xrefs by clicking the Reload button.

Once the xrefs are reloaded, the system automatically updates each xref when you open the attached

drawing file directly to show the latest xrefs.
Opening external references

From the Xref Manager, you can quickly open the source drawing for any external reference. This is
especially helpful if you are working with nested external references, which you cannot bind or detach.
From the Xref Manager, open the source drawing, make changes, and then save and close the source

drawing. When the Xref Manager displays again, simply reload the external reference.

To open an external reference
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1. Choose Insert > Xref Manager from the main menu.
2. Select the external reference to open.
3. Click Open.

Under the expedite network operations, users can update xrefs by reloading regardless of any changes
happen to the original file of xrefs. But the variance path for the original file may cause the xrefs

updating failed, you must specify the actual saving path for the xrefs.

O NO O

OO OO
O O

xref attached edited xreffie wref updated

Notification of Changed Xrefs

After the xrefs having been attached to the drawing, the system automatically checks whether the
original drawing file is modified in certain intervals since it loaded or reloaded the last time. The xref
icon located at the right lower corner of the status bar appears an exclamatory mark once the xref file
has been modified, and needs to reload. You can click this icon to open xref Manager to reload the
changed xrefs.

Xref notification behavior is controlled by the XREFNOTIFY system variable.

@ External Xref File Has Changed x

External xref changed, use xref manager to reload

Reload Datenextra - Copy

A | A A i

Update Xrefs with Demand Loading Turned On

If system variable XLOADCTL is set to 0, turn off Xrefs with Demand Loading, load the whole
drawing if click the load button.

If system variable XLOADCTL is set to 1, turn on Xrefs with Demand Loading, all other users can't

access the xref file when reloading the file with Demand Loading.

If system variable XLOADCTL is set to 2, load a temporary copy of the latest version of the xref file to
be loaded.
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Reloading external references

When you open or print a drawing, any external references in the drawing are updated automatically. If
a drawing is already open and a referenced drawing is modified, you can update the current drawing
manually to display the latest version of the referenced drawing. You may also want to reload an

external reference that has been unloaded temporarily.

To reload an external reference

1. Choose Insert > Xref Manager from the main menu.
2. Select the external reference to reload.
3. Click Reload.

10.3.4. Edit External References

Edit xrefs that are attached to the drawing, such as clipping, binding or detaching as well as specifying

the full path or relative path for xrefs.

Clip External References and Blocks

You can define a clipping boundary through XCLIP command once a xref has been attached to the
drawing, the clipping boundary defined by users are allowed to display only a part of the xrefs and

compress the displaying of the external geometric objects.

The clipping boundary is composed of coplanar lines and polyline as well. But self-intersecting

polylines are not available for creating clipping boundary.

XCLIP can be used for generating or removing clipping boundaries, generating polylines from clipping
boundary or display the part being clipped for one or more xrefs or blocks. XCLIP only affects the
single object of xref, retain the xref definitions unchanged. The part of xref or block inside the clipping
boundary is still visible, while the remaining parts are invisible. The geometric drawing being
referenced itself is unchanged, only its displaying way is edited.
You can use XCLIP to do the following:

e Create new clipping boundary

¢ Remove existing boundary

e Generate polyline objects that are concurrent with the vertex of clipping boundary.

e Turn on or off xref Clipping

If xclip is turned on, all the clipping boundaries will be started to display the clipped part of a xref. If
the xclip is turned off, the clipping boundaries will not be displayed, only display the drawings in xrefs
containing contents both inside or outside the clipping boundary. The clipping boundary can't be

restored once removed. The xref having been clipped can be modified, moved, or copied as those
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unclipped xrefs. While modifying the xrefs, the clipping boundary moves together with the xrefs. If the
xref attached to the drawing contain nested clipped xrefs, these xrefs will be displayed as it was after

clipping. The nested xref is also clipped if superior xref has been clipped.

Turning clipping boundaries on and off

The clipping boundaries can be controlled whether to display or not through system variable
XCLIPFRAME. If set this system variable to 1, the clipping boundary can be selected and plotted as a
part of the object.

When a clipping boundary is turned off, the boundary does not display and the entire external reference
is visible, provided that the geometry is on a layer that is on and thawed. However, deleting a clipping

boundary is permanent.

To turn clipping boundaries on and off

Choose Modify > Clip > Xref from the main menu.
Select the desired external references.

Press Enter.

P w e

To turn off clipping boundaries, choose OFF. To turn on existing clipping
boundaries, choose ON.

5. Enter an option and then press Enter.

TIP When the XCLIPFRAME system variable is on (set to 1), you can select and print the clipping

boundary frame.

Clipping Boundary Options

When clipping boundaries, you can specify a rectangular or polygonal window or use the polyline to
define clipping boundary through New boundary option. If the selected clipping boundary is a
rectangular window, only xrefs within the rectangular window are displayed. The clipping boundary is

parallel to current UCS, and the clipping boundary will be applied to the normal direction of its plane.

To define a rectangular clipping boundary

Choose Modify > Clip > Xref from the main menu.

Select the external references to clip. If desired, you can also select blocks.

Press Enter.

Type N (New boundary) or press Enter directly to create a new clipping boundary.
If prompted, press Enter to delete any existing boundaries.

Choose R (Rectangular).

Define the first corner of the clipping rectangle.

© N Uk W e

Define the opposite corner of the clipping rectangle.
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9. The selected external references are clipped by the rectangle.

TIP You can first select all external references, right-click the selection, and then select Xref Clip from
the shortcut menu.

When using a polyline to define clipping boundary, the clipping boundary is in accordance with the
polyline. If the selected clipping boundary is a polyline, it can't be self-intersected. The system takes
the open polyline as a closed polyline if the arcs contained in the polyline have been smoothed. The

clipping boundary created this way is located on the plane parallel to the UCS that puts the polyline.

To define a clipping boundary using a polyline

Draw a polyline where you want to clip external references.

Choose Modify > Clip > Xref from the main menu.

Select the external references to clip. If desired, you can also select blocks.
Press Enter.

Type N (New boundary) or press Enter to create a new clipping boundary.
If prompted, press Enter to delete any existing boundaries.

Choose S (Select polyline).

© N Uk WD e

Select the polyline to use as a clipping boundary.

In addition to the rectangular clipping boundary and the clipping boundary using a polyline, you can
also create a clipping boundary by specifying the vertices of a polygon, but you must note that the

polygon sections cannot be intersected themselves.

To define a polygonal clipping boundary

Choose Modify > Clip > Xref from the main menu.

Select the external references to clip. If desired, you can also select blocks.
Press Enter.

Type N (New boundary) or press Enter to create a new clipping boundary.
If prompted, press Enter to delete any existing boundaries.

Choose P (Polygonal).

Define the first corner of the clipping polygon.

© N Uk W e

Define the next corners of the clipping polygon, and then press Enter to end the
selection.

9. The selected external references are clipped by the polygon.

Clip Depth

The front and back clipping planes for xrefs can be set before clipping the xref. To specify a clip depth,
the xref must contain a clipping boundary. The clip depth is always calculated normal to the clipping
boundary. When setting clip depth, you are prompted to specify a front and back point or distance
relative to the clipped plane. Regardless of the current UCS, the clip depth is only available at the
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direction parallel to the clipping boundary.

existing drawings another similar drawing
is refarenced

clip external reference, keep result
a partial ofthe reference resered

Deleting a clipping boundary

If you no longer need a clipping boundary for an external reference, you can delete it.

To delete a clipping boundary

Choose Modify > Clip > Xref from the main menu.
Select the external references to clip. If desired, you can also select blocks.

Press Enter.

P w e

Choose D (Delete), and then press Enter.

Binding a xref to a drawing

External references are not part of the drawing. Rather, they are links to an externally referenced file.
To provide a copy of a drawing containing external references to someone else, you must also provide
all the external reference files. In addition, the user receiving the drawings must either recreate the
same paths you used when linking the external references or change the paths for the external

references.

To provide a copy of a drawing that contains external references, it is often easier to first bind the
external references to the drawing. Binding the external references make them a permanent part of the
drawing, which is similar to inserting a separate drawing as a block. You can bind external references
that are attached directly to the current drawing; you cannot bind nested external references. Xrefs rely
on the naming sentence of named objects from "Block name|Definition name"to"Block
name$n$Definition name". Thus, you can create unique named objects for relative definition tables that

are bind to all the xref in the current drawing.

If select Insert, the xref will be inserted into the drawing after converted to blocks as inserting reference
drawings. Xref relies on named object, using the xref name removed from the names but not using the

"Block name|Definition name" sentence. If internal named objects have the same name with bound xref
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names in the drawing to be inserted, new names will not be added in the symbol table, and the bound

xrefs rely on named objects adopts properties of named objects local defined.

To bind an existing external reference to a drawing

1. Choose Insert > Xref Manager from the main menu.

2. Select the external reference to bind.

3. Click Bind.

4. Inthe Bind Xrefs dialog box, choose one of the following:
Bind Binds the external reference and creates a unique name for each named object,
such as a layer or block, that is located in the external reference. For example, a layer
named Electric in the external reference will be named XrefSOSElectric in the current
drawing. If the current drawing already has a layer or block with the same name, the
name is changed incrementally, for example, Xref$S1SElectric.
Insert Binds the external reference, but does not change the names of any named
objects in the external reference. For example, a layer named Electric in the external
reference will have the same name, Electric, in the current drawing. If the current
drawing has a layer or block with the same name, the named object in the external
reference takes on the properties of the named object in the current drawing.

5. Click OK.

Detach External References

To detach the xref from the drawing, the selected xrefs will be removed from the xref list. Meanwhile,
relative xref in the current drawing will be removed as well. This can be also applied to xrefs directly

attached to current drawing, but the nested xrefs can't be treated like this.

You should distinguish between detaching and remove, which are totally different concepts, removing
a xref will not remove its relative layer definitions. Using Detach option to remove all the associated

information of the xref.

To detach an external reference

1. Choose Insert > Xref Manager from the main menu.
2. Select the external reference to detach.
3. Click Detach.

NOTE Only the external references that are attached directly to the current drawing can be detached;

nested external references cannot be detached.

Set Paths to Externally Referenced Drawings

You can set the saving path for the xrefs that are changed after attached to the drawing when you
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selecting a saving path for the xrefs, three types are provided for you: Full path, Relative path, and No
path.

Full Path
Full path refers to the path that marked by local disk or network server driver. By default, the path for
saving the xref files is a Relative path, but this path lacks flexibility, once the file is changed, the path

becomes invalid.

Relative Path
Relative path refers to path assigned by folders including current driver or original drawing file. The
user can move the original files among multiple drivers within the folder at the same hierarchy without

affecting updating xrefs.

You can't set the relative path in local disk or network server driver. The relative paths for xref original
files are assigned as follows:
e \: Look in the root folder of the host drawing's drive
e path: From the folder of the host drawing, follow the specified path
e \path: From the root folder, follow the specified path
e \path: From the folder of the host drawing, follow the specified path
e _\path: From the folder of the host drawing, move up one folder level and follow the specified
path
e _\.\path: From the folder of the host drawing, move up two folder levels and follow the
specified path

If you have changed the path that includes the xref drawings, such as moving the file or save it to a
different path or disk, then all the relative paths of the xref must be changed individually so as to adapt

to the new position of its references.

No Path
Specifies the path type of inserting xref as No path, the xref will not save the path information, if you
want to search the original file of xref, you can search through the following ways:

e Search for the current folder of the original drawing

e  Search for the Xrefs File Search Path defined in File tab in Options dialog box.

e  Search for the start folder assigned by shortcut of Windows applications

No Path is useful when users want to move their drawings to another or an unknown folder hierarchy.

To change the path for a single external reference

Choose Insert > Xref Manager from the main menu.
Select the external reference whose path you want to change.

In Xref Found At, do one of the following:

P w N e

Enter a new filename or location.
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5. Click "=/, select the xref under a new path in the Select New Path dialog box that

displays, and then click Open.
6. Choose Save Path, and then click OK.

NOTE You cannot recursively reference a drawing from the same original drawing.

10.3.5. Edit External References in Place

Edit xrefs of current drawing without opening the xref drawings.

Edit Selected Objects in Xrefs and Blocks

You can edit or modify the visible text of xrefs attached to the drawing through edit in place. Because
block references and xrefs are different types of reference files, editing and modifying the block

references will be illustrated here.

Generally, one or more xrefs and block references are contained in each drawing; the objects assigned

to be edited must be block references so as to redefine.

When you work with xrefs, you can modify the included objects, and save the modifications back to
xrefs. This may be proper to use when making small changes to the current drawing. But for complex
modifications, you should modify the xref drawing directly, and then update the attached xrefs in the
current drawing. Using edit in place for the xrefs may increase the size of the drawing and lower the

capability of the computer.

Understand the Working Set

Objects contained in the working set are components of selected references. ZWCAD extracts selected
objects from the selected xrefs to edit in the current drawing, these objects having been extracted from
a set called working set. Objects in working set can be changed and saved and the xrefs or block

definitions can be updated.

When constructing the working set, all the excluded objects of the working set may be fading

displayed.

Control the Fading of Objects

When editing references in place, the selected objects are normally displayed except for other
unselected xrefs or block references. The fading degree is controlled by system variable XFADECTL.

This value set the displaying density of objects outside the working set. The greater the value, the more
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fading of the objects outside the working set displayed.
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T drawing selected for editing
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Use the Refedit Toolbar

Buttons on the Refedit toolbar are only available when you use the edit-in-place command, which
contains the following buttons:

e Edit block or Xref

e Add objects to working set

e Remove objects from working set

e Discard changes to reference

e Save back changes to reference
Add or remove objects from the working set

When editing attached references, you can add or remove references by clicking on Add objects to

working set or Remove objects from working set.

If new objects are created when editing references, the new object may be taken as one of the objects in
selected reference, and automatically add to working set, the objects outside the working set may be

fading displayed.

The objects to be edited in-place created in a layer that the reference is locked are also editable. Before
editing the references, you should unlock the layer on which the objects are located, and then modify
this object. After modification, you can save the changes back to references. But the status of layer

keeps unchanged regardless of the lock.

When saving the changes for the references, all the objects in the working set are saved to references.
Objects that are removed from the working set never contained in the reference, subsequently become
other parts of the drawing. Objects that are added to the working set will be removed from its original
position from the drawing. The objects being created or removed will be added or removed from the

working set automatically.
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Save Back Edited Xrefs and Blocks

Changes to the references are optionally saved to the current drawing.

If you choose to save the changes, the system automatically regenerate the drawing, in addition, block
definitions are redefined and all the blocks are regenerated as well. Thus, changes to the xrefs can be
saved also, if the objects in working set inherit its original properties defined in external references,
these objects retain new properties. If you remove some objects from the working set, these objects

will be added to the current drawing.

If you discard the changes, the working set removed as well and return the block references to the
original state. When editing references in-place, if objects excluded from the working set are removed

and you discard the changes to the xref, the objects having been removed can't be restored.

If you have saved the changes for the xref, you can get back the reference file and discard the changes,
use UNDO command.

If objects in current drawing inherit properties defined in xref, these objects will be displayed in new
properties called binding properties. Additionally, you can specify how the xref names are displayed
through system variable BINDTYPE. If the BINDTYPE is set to 0, the xref names will be added a
prefix $#$, if the BINDTYPE is set to 1, keep the xref names unchanged.

It should be noticed that you can't edit or change the referenced drawings when editing in-place, which

are only readable.
Edit Xrefs and Blocks with Nesting, OLE, or Attributes

Edit-in-place set limits for those nested xrefs in the current drawing. When you editing nested xrefs,
references together with their nested references are displayed in Reference Edit dialog box, you can

also change all the nested references. But changes are available for one reference at a time.
OLE objects included in the reference you are editing can be displayed but not edited.

If the block reference to be edited contains attributes, you can edit the attributes while editing the
references by selecting "Display attribute definitions for editing" option on the Settings tab in
Reference Edit dialog box. Attributes are invisible, but attributes definitions and selected geometric
drawing can be edited together. The attributes of original references keep unchanged after saving, and

new attribute definitions only affect the block subsequently inserted into the drawing.

10.4. Flexiblock

Flexiblock is a kind of block contains parameters and actions. It was built based on the block.
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Flexiblock has the properties of the block, which is uniquely flexible and intelligent.

Currently, ZWCAD supports the display of Flexiblocks, the display and editing of Flexiblock custom
grips, and the editing and saving of Flexiblocks.

The property of Flexiblock is "block reference"; the Flexiblock can be partially adjusted by using key

points or via the Properties tab.

You cannot perform "Non-uniform scaling" on the Flexiblock directly if forced to operate, it will
become a common block without "dynamic" characteristics. For example, the following operations will
make Flexiblocks lose "dynamic" characteristics:
e Insert a Flexiblock by using unequal XYZ scale factors in the Insert dialog box via command
INSERT;
e Select a Flexiblock, and then modify it by using unequal XYZ scale factors in the Properties;
e  Modify a Flexiblock by using unequal XYZ scale factors via command BSCALE;

e Refedit a Flexiblock, and then save to exit.

10.4.1. Grip Type of Flexiblocks

Grip icons of Flexiblocks are as follows.

Grip Name Grip Icon
Standard Grip (|
Linear grip =
Rotate grip O
Flip grip @
Alignment grip B
Lookup grip ?

10.4.2. Flexiblock Grip Editing Function

Flexiblock definition must contain at least one parameter. For Flexiblock contains actions and

parameters, the grips associated with the points, objects or regions in the block definition will be

displayed. When you edit a grip, the associated action will be triggered, thereby changing the block
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reference display. You can perform manipulations such as stretch, move, flip, rotate, array, scale, align
and lookup by dragging the grips of Flexiblocks. After you select a Flexiblock with the appropriate
parameters and actions, you can select the Flexiblock grip (the grip color is light blue by default, it can

be modified via the GRIPDYNCOLOR system variable) to edit, the grip will display in selected grip

color, and then you can perform manipulations such as stretch, move, rotate, etc. on the selected
Flexiblock.

Flexiblock grip editing functions are related to specific parameters, so the function of each grip is not

listed separately, the specific relationship between them is as follows:

Parameter Type Grip Type Corresponding Grip Editing Function
Point L] Standard Move, Stretch
Linear = Linear Move, Scale, Stretch, Array
Polar L] Standard Move, Scale, Stretch, Polar Stretch, Array
XY L] Standard Move, Scale, Stretch, Array
Rotate ] Rotate Rotate
Flip 53 Flip Flip
Align B Alignment | None (The action is included in the parameter)
o fF— None (This is a hidden action controlled by the
Visibility v Lookup o
: visibility state)
Basepoint (| Standard None

10.4.3. Use Grip Stretch Function on Flexiblocks

Once you have selected a Flexiblock contains stretch action, click the light blue grip on the Flexiblock

to display command line prompt as follows:
Specify point Location or [Base point/Undo/eXit]:

Under the prompt, you can specify a new position on the drawing area where the grip is expected to be

stretched. Move the selected grip to the new position to stretch the object.
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Stretch Flexiblock by using grip

1. Select the Flexiblock contains stretch action.

2. Click on the light blue grip of the Flexiblock to highlight the selected grip.

3. Command line prompt appears, do either of the following:

4. Specify "B(Base point)" option to locate the base point for stretching.

5. Specify "U(Undo)" option to abort the last stretch.

6. Specify "X(eXit)" option to exit stretch manipulation.

7. Specify target location for grip directly.

8. After specifying the target location, the selected Flexiblock will be stretched.
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10.4.4. Use Grip Move Function on Flexiblocks

You can move the selected Flexiblock by moving its grip. The Flexiblock will be moved according to

the specified orientation and position.

Once you have selected a Flexiblock contains move action, click the light blue grip on the Flexiblock

to display command line prompt as follows:

2

Specify point Location or [Base point/Undo/eXit]:

Move Flexiblock by using grip

Select the Flexiblock contains move action.

Click on the light blue grip of the Flexiblock to highlight the selected grip.
Command line prompt appears, do either of the following:

Specify "B(Base point)" option to locate the base point for moving.
Specify "U(Undo)" option to abort last moving.

Specify "X(eXit)" option to exit move manipulation.

Specify target location for grip directly.
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After specifying the target location, the Flexiblock will be moved towards the
orientation and displacement along the connecting line of the selected grip and

the target point.
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10.4.5. Use Grip Rotate Function on Flexiblocks

You can rotate the selected entity by dragging its rotation grip.

Once you have selected a Flexiblock contains rotate action, click the light blue rotate grip on the

Flexiblock to display command line prompt as follows:
Specify rotation angle or [Base point/Undo/eXit]:

Rotate Flexiblock by using grip

Select the Flexiblock contains move action.

Click on the light blue grip of the Flexiblock to highlight the selected grip.
Command line prompt appears, do either of the following:

Specify "B(Base point)" option to locate the base point for rotating.
Specify "U(Undo)" option to abort last rotation.

Specify "X(eXit)" option to exit rotate manipulation.

Specify rotation angle for grip directly.

O N vk wNe

After specifying the rotation angle, the entity will be rotated centered by the

selected grip (or the new base point).

10.4.6. Use Grip Scale Function on Flexiblocks

You can scale the selected entity relative to the grip. Drag the entity outwards the base grip to enlarge

its size, and drag inwards to decrease the size.
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Once you have selected a Flexiblock contains scale action, click the light blue grip on the Flexiblock to

display command line prompt as follows:
Specify point Location or [Base point/Undo/eXit]:

Scale Flexiblock by using grip

Select the Flexiblock contains move action.

Click on the light blue grip of the Flexiblock to highlight the selected grip.
Command line prompt appears, do either of the following:

Specify "B(Base point)" option to relocate the base point for scaling.
Specify "U(Undo)" option to abort the last scaling.

Specify "X(eXit)" option to exit scale manipulation.

Specify the target location for grip directly.
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After specifying the target location, the Flexiblock will be scaled towards the
orientation and displacement along the connecting line of the selected grip (or

the new base point) and the target point.
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10.4.7. Use Grip Flip Function on Flexiblocks

You can mirror the selected entity in the Flexiblock about a specified reflection line by clicking its flip

grip.

Flip Flexiblock by using grip

1. Select the Flexiblock contains flip action.
2. Click on the light blue flip grip of the Flexiblock, the entity in the Flexiblock will be
flipped.
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10.4.8. Use Grip Array Function on Flexiblocks

You can array the objects in Flexiblocks by dragging and specifying the position of the grips.

Once you have selected a Flexiblock contains array action, click the light blue grip on the Flexiblock to

display command line prompt as follows:
Specify point Location or [Base point/Undo/eXit]:

Array Flexiblock objects by using grip

Select the Flexiblock contains array action.

Click on the light blue grip of the Flexiblock to highlight the selected grip.
Command line prompt appears, do either of the following:

Specify "B(Base point)" option to locate the grip for arraying.

Specify "U(Undo)" option to abort the last arraying.

Specify "X(eXit)" option to exit array manipulation.

Specify target location for grip directly.
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After specifying the target location, the Flexiblock will array objects towards the
orientation and displacement along the connecting line of the selected grip (or

the new base point) and the target point.

10.4.9. Use Grip Align Function on Flexiblocks

You can align the objects in Flexiblocks by dragging and specifying the position of alignment grip.

Once you have selected a Flexiblock contains align parameter, click the light blue alignment grip on
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the Flexiblock to display command line prompt as follows:
Specify point Location or [Base point/Undo/eXit]:

Align Flexiblock objects by using grip

1. Select the Flexiblock contains align action.

2. Click on the light blue alignment grip of the Flexiblock to highlight the selected
grip.

Command line prompt appears, do either of the following:

Specify "B(Base point)" option to locate the grip for aligning.

Specify "U(Undo)" option to abort last aligning.

Specify "X(eXit)" option to exit align manipulation.

Specify target location for grip directly.

© N o v kW

After specifying the target location, the objects in the Flexiblock will be aligned

automatically.

10.4.10.Use Grip Lookup Function on Flexiblocks

You can change the Flexiblock by using its lookup grips. The corresponding parameter of a lookup grip

can be a lookup parameter or a visibility parameter.

If the Flexiblock contains a lookup parameter, then a list of available values will be displayed when
you click the lookup grip. You can choose a desired value from the list to change the Flexiblock. As

shown below:
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If the Flexiblock contains a visibility parameter, then a list of all visibility states in the block reference
will be displayed when you click the lookup grip in the drawing. You can choose a desired state from

the list to change the display of Flexiblock object. As shown below:

10.4.11.Flexiblock Properties Display

In addition, to use grip editing function to change the Flexiblocks, you can also change the Flexiblocks
by modifying the values of custom properties items of the Flexiblocks (block reference display) in the

Properties column.

For a Flexiblock added a linear parameter, you can modify the Flexiblock object by modifying the

distance value in the custom properties.
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11.Hatches and Raster Images

11.1. Hatches

11.1.1. Overview of Hatch Patterns and Fills

Fills an enclosed area or selected objects with a hatch pattern or gradient fill.

Filling the specified area with different material so as to distinguish project parts. These patterns are

both predefined and user-defined.

Solid-filled areas can be created using the following three methods.
e  Hatches with solid patterns (BHATCH)
e 2D solids (SOLID)
e  Wide polylines, traces or donuts (PLINE, TRACE or DONUT)

Gradient hatch refers to a kind of hatch pattern among different gradations within one or two colors.

Which can be used to increase the drawing demonstration effects or use as a background.

To create a hatch, you should specify hatch area first which is so-called hatch boundary, various
methods of creating hatch boundaries are provided as well as creating associative hatch for controlling
the hatch pattern updated along with the boundary changes. If the specified boundary is not a closed
area, you can set maximum gap which is controlled by system variable HPGAPTOL when using the
object as pattern boundary, any gap within this value range will be taken as a closed boundary. But this
gap is only available for lines and arcs, they'll be joined if extended. When creating hatch patterns, you
can specify the draw order of the patterns to decide to hatch before or after the boundaries or set it in
front or at the back of all objects.

Add Hatch Patterns and Solid Fills

You can use BHATCH command to add hatch pattern to the drawing. When defining hatch patterns,
you can specify the options in hatch dialog box: scale, angle, space, ISO pen width, associativity and
double hatch.

Create Associative Hatches

If you select associative hatch properties when hatching the area, the hatched pattern updates
automatically with the boundaries. By default, the hatch pattern created by BHATCH is associative.
The associativity of a hatch pattern can be removed whenever you want.
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The objects that are outside the specified boundary will be ignored when creating hatches.
If the text, properties or solid entities are connected to hatch patterns, only hatches the boundaries of

these objects with the center retained as blank in order to form islands.

Choose a Hatch Pattern

The user can select hatch patterns to distinguish different parts of the object and represent the object
materials during the hatching process. 14 ISO hatch patterns are provided, ISO pen width can be
specified while selecting ISO hatch patterns. Pen width option is set to determine the pen width of the
pattern.

In Hatch and Gradient dialog box, the Pattern option in Type and Pattern area under Hatch tab contains
all the pattern names defined in icad.pat file. You can define new hatch patterns in icad.pat, and apply
them by restarting ZWCAD platform.

Assign a Draw Order to a Hatch

The draw order of hatching and boundaries can be controlled so as to view and select more easily.
When creating hatch patterns, you can specify the draw order of the patterns to decide to hatch before
or after the boundaries or set it in front or at the back of all objects. The value will be stored in system
variable HPDRAWORDER.

Other settings of hatch pattern may not be influenced regardless of changing the draw order of hatch

pattern.

Edit Hatch Boundaries

Hatch boundaries are capable of copy, move and stretch as well as other objects, but for a large number
of object combinations, the geometric drawings for editing hatches may cause unpredictable results. It's

suggested to abort hatch if necessary and remove the hatched blocks to generate new ones.

Create Custom Hatch Patterns

You can define the angle and space of the current hatch by selecting User Defined type from the Type
pull-down box, in Hatch tab of the Hatch and Gradient dialog box, so as to create a customized pattern

to hatch selected objects.

11.1.2. Define Hatch Boundaries

To create a hatch, you should define hatch boundaries first by means of selecting objects to be hatched
or picking a point inside the desired object. A hatch boundary can be any combination of objects, such

as lines, arcs, circles, and polylines, that forms an enclosed area.
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To raise the speed of hatching a small area of a complex drawing, you can define a set of objects in the

drawing. HATCH does not analyze objects that are not included in the boundary set.

Island is a concept representative of the closed area inside the hatched object. You can hatch the island

and also retain its original state.

Objects can be hatched only if they are in a plane parallel to the XY plane of the current UCS. For the
internal area of polylines with width and solid hatching, hatches can't be applied because of its

unacceptable profiles.

Control the Hatching in Islands

You can specify methods of hatching objects in outermost boundary as normal, outer and ignore.
Normal is the default hatch pattern, besides, you can view hatching results of different types in the
Islands area on Hatch tab of the Hatch and Gradient dialog box.

Normal

Hatch the pattern from the outer boundary to inside. Hatching process will be stopped when
encountering inner crossing points and continue hatching until second inner crossing point appears. So
if counter from the outer boundary of hatch area, the area separated by odd number crossing points will

be hatched, on contrary the area separated by even crossing points will not be hatched.

irternal poirt

irternal point selected houndaries detected result

Outer
Hatch the pattern from the outer boundary to inside. For the hatching starts from two points of each
hatch line, the system will hatch from the outer most layer of configuration, and keep the internal blank.

Hatching process will be stopped when encountering inner crossing points.
Ignore

Ignore internal objects, only hatches outer objects. The following example displays the results of

hatching a complex entity with Normal, Outer, Ignore pattern individually:
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Harmal Cuter |gnore

You can also remove any islands from the hatch area.

——— intenal point

houndaries detected islands to remoe result

Define Hatch Boundaries in Large Drawings

Generally, boundaries are defined by analyzing all the closed objects. It's time-consuming to define
boundaries through analyzing all the visible or partly visible objects when encountering complex
drawings. In such cases, you can save time hatching a small area in a complex drawing by defining a

set of objects in the drawing to be used in determining the hatch boundary.

Boundaries are also available for applying different hatch patterns to islands in the different area of the
drawing. To avoid selecting the undesired hatch area, it's required to enlarge the drawing. Once
Existing set in Boundary set option on Other options tab is selected, the objects used for defining

boundaries will be highlighted.

—area for
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Create Unbounded Hatches

You can define a hatch boundary composed by multiple points manipulated from the Boundary option
of -HATCH or -BHATCH command. System inquires for whether to retain boundaries when finish
hatching, if choose not to retain boundaries, then create hatch pattern without boundaries.

For example, to define a boundary by specifying points, only a small part of the large area of the

drawing will be hatched, hatching the large area without boundaries, shown as follows:
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Selecting objects for hatching

A hatch boundary can be defined by means of selecting an object, for example, a circle or rectangle.

You can assign hatching to a single object or several objects at the same time.

You can add hatching to an area enclosed by selected objects to form the hatch boundary. The hatch is
formed within the enclosed area, not the objects themselves. Once a hatch is created, it will be treated
as a single object. And the object being hatched changes along with the hatch boundary if the hatch you

create is associative.

To select objects for hatching

1. Choose Draw > Hatch from the main menu.
2. From the Hatch and Gradient dialog box, click the Island detection option, and
then choose one of the following islands:
Normal Areas separated from the outside of the hatched by an odd number of
intersections are hatched.
Outer Only the outer object and its outer island are considered for hatching.

Ignore The entire object is considered for hatching, the inner area will be ignored.
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Normal islands (A), with outer island (B), and with ignoring islands (C).

3. To keep any new objects that are created for drawing the boundary hatch, select
the Retain Boundaries checkbox under Other options. Existing objects are always
retained.

4. Inthe Boundaries, click Select Objects button.

In the drawing, click the objects to be hatched individually, and then press Enter
when done.

6. Inthe Hatch and Gradient dialog box, click OK.

Select an area for hatching

1. Choose Draw > Hatch from the main menu.
2. From the Hatch and Gradient dialog box, click the Island detection option, and
then choose one of the following islands:
Normal Areas separated from the outside of the hatched by an odd number of
intersections are hatched.
Outer Only the outer object and its outer island are considered for hatching.

Ignore The entire object is considered for hatching, the inner area will be ignored.
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Normal islands (A), with outer island (B), and with ignoring islands (C).

3. To keep any new objects that are created for drawing the boundary hatch, select
the Retain Boundaries checkbox under Other options. Existing objects are always

retained.
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4. Inthe Boundaries, click Pick Points button.
In the drawing, click inside the closed perimeter of a boundary, not on the
boundary itself. If desired, continue clicking inside additionally closed perimeters.
To complete the selection, press Enter.
In the Hatch and Gradient dialog box, click OK.

11.1.3. Choose And Define Hatch Patterns

The user can use predefined hatch pattern or solid hatch and create hatch pattern of your own.

Create Solid-Filled Areas

Methods of creating solid hatch:
e  Hatches with solid patterns (BHATCH)
e 2D solids (SOLID)
e  Wide polylines, traces or donuts (PLINE, TRACE or DONUT)

e ] N°+° € soid flled
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Create Gradient-Filled Areas

Fills the area with gradient appearance, which is a type of solid hatch represents a solid entity as well.
Gradient hatch refers to a kind of hatch pattern among different gradations within one or two colors.

Which can be used to increase the drawing demonstration effects or use as a background.

Like creating other hatch patterns, you can create gradient hatch as well as associative gradient hatch in

the same way. But the color assigned in gradient hatch can't be controlled by print style.

Use Predefined Hatch Patterns

Fills the specified area with different material so as to distinguish project parts. The user can select
hatch patterns to distinguish different parts of the object and represent the object materials during the
hatching process. 14 ISO hatch patterns are provided, ISO pen width can be specified while selecting
ISO hatch patterns. Pen width option is set to determine the pen width of the pattern.

Create User-Defined Hatch Patterns

When selecting hatch patterns, you can define simple patterns by changing angle and space of pattern
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lines based on current linetype. This is so-called User defined.

Specifying a hatch pattern

A hatch pattern consists of a repeating pattern of lines, dashes, and dots. You can select a hatch pattern

from a set of predefined patterns, or you can define a pattern of your own. The hatch pattern you used

most recently is the default pattern the next time you add hatching. The program supplies predefined
standard hatch patterns, which are stored in the ICAD.pat and ICADISO.pat hatch pattern library files.

NOTE The ICAD.pat hatch pattern library files are ANSI (American National Standards Institute)
compliant patterns; the ICADISO.pat hatch pattern library files are ISO (International Standards

Organization) compliant.

To specify a predefined hatch pattern

10.

11.

Choose Draw > Hatch from the main menu.

From the Hatch and Gradient dialog box, click the Hatch tab.

Under the Hatch — Type, and pattern, in the Type list, click Predefined. With
Predefined, you can apply a scale factor to make the pattern larger or smaller
than the default size.

For Scale, enter the scale factor as a percentage of the default.

For Angle, enter the angle of the pattern in degrees (1-360). The default angle is
clockwise, you can change the angle of any hatch pattern by entering a numerical
value.

For ISO Pen Width, enter the pen width. This option is only available if you select
existing ISO hatch pattern in the Pattern option.

To copy the pattern properties from an existing hatch, choose Inherit Properties.
To associate the hatch pattern to its boundary objects, under Other options,
select the Associative check box. Associative hatch updates automatically if you
move any of its boundaries.

To continue, add a hatch by doing one of the following:

In the Boundaries, click Select Objects button to select the objects you want to
add a hatch. Repeat the procedures following step 2.

In the Boundaries, click Pick Points button to select an area or boundary you want

to add a hatch. Repeat the procedures following step 2.

To specify a user-defined hatch pattern

vk W e

Choose Draw > Hatch from the main menu.

From the Hatch and Gradient dialog box, click the Hatch tab.

Under the Hatch — Type and pattern, in the Type list, click User Defined.
For Spacing, enter the line spacing for the pattern.

To copy the pattern properties from an existing hatch, choose Inherit Properties,
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and select a hatch pattern from a hatched object in the drawing.

To associate the hatch pattern to its boundary objects, under Other options,
select the Associative check box. Associative hatch updates automatically if you
move any of its boundaries.

To continue, add a hatch by doing one of the following:

In the Boundaries, click Select Objects button to select the objects you want to
add a hatch. Repeat the procedures following step 2.

In the Boundaries, click Pick Points button to select an area or boundary you want

to add a hatch. Repeat the procedures following step 2.

To use a predefined library pattern

© N Uk W e

Choose Draw > Hatch from the main menu.

From the Hatch and Gradient dialog box, click the Hatch tab.

Select a Predefined type.

To select a predefined pattern, do one of the following:

In the Pattern list, click the pattern name.

Click the graphical representation of the hatch pattern.

To continue, add a hatch by doing one of the following:

In the Boundaries, click Select Objects button to select the objects you want to
add a hatch. Repeat the procedures following step 2.

In the Boundaries, click Pick Points button to select an area or boundary you want

to add a hatch. Repeat the procedures following step 2.

NOTE Hatch patterns are memory intensive and can take a considerable amount of time to draw and

display. To improve performance, add hatching as one of the last steps when you create a drawing or

insert hatches on a separate layer that you can freeze as you continue to work on your drawing.

11.1.4. SOLID

With the Plane tool, you can draw rectangular, triangular, or quadrilateral areas filled with a solid color.

The default method is to specify the corners of the plane. After you specify the first two corners, the

plane is displayed as you specify the remaining corners. The program prompts you for the third point
and then the fourth point.

To draw a quadrilateral plane

I AR S

Choose Draw > Surfaces > 2D Solid from the main menu.
Specify the first point.

Specify the second point.

Specify the third point.

Specify the fourth point.

To complete the command, press Enter.
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After you select the first two points (A) and (B), the sequence in which you select the third (C) and fourth (D) points

determines the shape of the resulting quadrilateral plane.

11.2. Work with Raster Images

You can view and manipulate raster images and associated file paths in ZWCAD drawings.

11.2.1. Attach, Scale, and Detach Raster Images

Raster images consist of a rectangular grid of small squares or dots known as pixels.

As consists of multiple rectangular grids, raster images can be copied, moved, or clipped as well as a
normal object in the drawing. You can change the position and size of the image by dragging its grips.
You can also adjust the contrast, transparency, image quality and image frame visibility as well from

the menu option "Modify-Object-Image".

Image file formats ZWCAD supports most of the frequently used file formats, such as computer
graphics, document management, engineering, mapping, and geographic information systems (GIS)

and an image file of bitonal, 8-bit gray, 8-bit color, or 24-bit color.

Once you have inserted an image with the transparent pixel, the drawing behind the transparent pixel
will be displayed when you turn on the image transparency. If you insert a bitonal image, the
background color pixel is processed by transparency, either gray or color images are assigned to

support transparent pixels.

Additionally, when inserting raster images, the file format depends on the content of the file rather than

the extension name. The following table display all the image file formats supported by ZWCAD:

Type: Description and versions: le:)lclthsion:
BMP Windows and OS/2 bitmap format .bmp

ECW Enhanced Compression Wavelet .ecw

JFIF or JPEG  Joint Photographics Expert Group .jpg or .jpeg
PCX Picture PC Paintbrush Picture .pcx

PNG Portable Network Graphic .png
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TGA True Vision Raster-Based Data Format .tga
TIFF Tagged Image File Format tif or .tiff
GIF Graphics Interchange Format .gif

Attach Raster Images

Use IMAGEATTACH to select and attach raster images, or bitonal, 8-bit gray, 8-bit color, or 24-bit
color image files to a drawing. Attaching an image creates an image definition, loads the image into
memory, and displays the image. Similar to the attach xrefs, attaching a path of the raster image that is
not virtual part of the drawing file, the path linked to the image files can be changed or removed any
time you want. The image file can be inserted as blocks as many times as you like once attached to the
current drawing, you can clip the attached raster image and set up its lightness, contrast, fading, and

transparency.

To attach a raster image

1. Choose Insert > Raster Image from the main menu.

2. Specify a file to attach, and then click OK.

3. In the Image dialog box, in the Insertion point and Scale, click Specify on-screen.
Specify an angle value in Rotation, and then click OK.

4. Specify an insertion point.

Specify a scale.

Scale Raster Images

To attach a raster image to a current drawing, you can specify scale factor in the Image dialog box,
otherwise to attach it to its original size. The raster image will be scaled by the specified factor, the

scale factor is used without unit by default.

If the attached image contains resolution information for defining DPI, the specified scale factor will
be united with a measure to scale attached raster image. If resolution information is not included, then

the original width of the image will be taken as a unit for the scale factor when attaching the image.

Detach Raster Images

Raster images can be detached if it no longer needs to use in the drawing, a specified image detached
from the drawing together with its multiple copies, links, and definitions, but the original image file

will not be influenced.

Unlike detaching an image file, removing the image directly from the drawing retains the image in

Image manager. Only can detaching the image remove the links of the image that connecting the
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drawing.

11.2.2. Modify and Manage Raster Images

Controls the properties such as displaying and clipping boundary of raster images. You can view and

manipulate attached raster image and change its saving path in Image Manager.
Show and Hide Raster Image Boundaries

Controls whether to display image boundary in the current view using IMAGEFRAME command. A
raster image can be displayed without a frame. Usually, users select image entity by clicking image

frame. Setting IMAGEFRAME to Off prevents you from accidentally selecting an image.

Once hide the image frame, the image can't be selected by SELECT command, keep the clipped image
displayed within the specified frame.

All the attached images update as soon as the visibility of raster image frame is set to display or hide.

To turn image frames on or off for all images

1. Choose Modify > Object > Image > Frame from the main menu.
2. Do one of the following to toggle frames off and on:
-Type ON to display and print frames for all images in a drawing.

-Type OFF to hide all frames on the screen and during printing.

Z\WSOFT ZWSOFT

image with boundaries on image with boundaries off

Clip Raster Images

You can get the desired part of the image displayed through image clip, and also improve the redraw

speed so as to define the display and plot area of the image.

Two types of clipping boundary are provided as rectangle composed by lines and polyline. The vertex
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within an image boundary even if self-intersected vertex should be specified when you define new

boundaries. Here rectangle boundary is the default pattern of clipping boundary. Only one clipping

boundary is assigned for each image instance, but multiple instances of the same image can be assigned

with different boundaries.

The clipped image can be displayed within clipping boundary, and also displayed inside its original

boundary.

You can remove the clipping boundary of an image and use the original frame of the image to display

the clipped image instead. But the boundary of the image to be clipped must be visible.

ZWCAD 2020 ZWCAD

Create Amazing Things

Rectangular clipping boundaries off Result

To clip an image in the shape of a rectangle
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Choose Modify > Clip > Image from the main menu.

Select the edge of the image you want to clip.

If prompted, type N (New boundary) to create a new clipping boundary.

Choose Rectangular.

Define the first corner of the clipping rectangle.

Define the second corner of the clipping rectangle. The selected image is clipped

so that only the interior of the rectangle is visible.

To clip an image in the shape of a polygon

vk W e

Choose Modify > Clip > Image from the main menu.

Select the edge of the image you want to clip.

If prompted, type N (New boundary) to create a new clipping boundary.

Choose Polygonal.

Select the points for the polygon, and then press Enter when the polygon is
complete. The selected image is clipped so only the interior of the polygon is

visible.

To turn clipping on or off for an image

1.
2.

Choose Modify > Clip > Image from the main menu.
Select the edge of the image for which you want to turn clipping on or off.
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3. Type ON or OFF.

To remove clipping from an image

1. Choose Modify > Clip > Image from the main menu.
2. Select the edge of the image for which you want to remove clipping.
3. Type D (Delete).

Change Raster Image Brightness, Contrast, and Fade

Use IMAGEADJUST to adjust displaying result and lightness, contrast and fade that are related to the
display and plot effect when plotting drawings. IMAGEADJUST does not affect the original raster

image as well as other instances of the image.
You can set lightness and contrast to better preview images of lower quality.

To change the fade of the image, geometric lines will be clearly viewed and add watermark effects

when plotting the image.

If you attach a bitonal image into the drawing, you can't set the lightness, contrast, and fade. Bitonal

images are displayed as the background color of the current screen and plotted as white.

Modify Color and Transparency for Bitonal Raster Images

Bitonal raster Image contains a foreground color and a background color so that the current color
settings determine the foreground color of the bitonal image as attached to the drawing. Although the
lightness, contrast, and fade are not adjustable for bitonal images, you can modify the foreground color

of the image and control its transparency from the Properties palette.

NOTE Bitonal images and their boundaries are always the same color.

View Raster Image Information

The raster images already attached to the drawing are displayed in list or tree view in Image Manager.

You can click Details button to view the relevant information of the raster image.

List View
System defaults to using List view for displaying the name, status (load, unload or not found), size,

type, last save date and time as well as saving path of the image file.

Click on the column title to rank the images. If the original file of the inserted image is missing, the

image status is displayed as "Not found". Images that are unloaded or not found in the Image Manager
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will not be displayed in the drawing.

Tree View
Sorts the raster images in the tree view and display the hierarchy of the images nested in xrefs and
blocks.

View Image FileDetails
Click DETAIL button to preview a selected image and view image file details, including image name,
saved path, active path (where the image is found), file creation date, file size, file type, color, color

depth, image size (pixel width and height, resolution and default size).

Assign Descriptive Names to Raster Images

You can change the name of an image by double-clicking the file listed on the Image Manager. You can
assign the image name different from the file name, the image is attached to the drawing without

extension name.

To rename an image, any name within 255 characters including letters, numbers, spaces and all the
special characters Microsoft® Windows® or ZWCAD can be used.
If two raster images of the same name originated from different paths are attached to the drawing,

system automatically distinguish them by adding numbers after the image name.

Change File Paths of Raster Images

The raster images already attached to the drawing are displayed in Image Manager and its saving path
is displayed in "Image found at" option at the bottom of Image Manager. Where the saving path is the

virtual path for searching the image file.

If the original image attached to the drawing does not exist in the saving path or any defined searching

path, the status of the image is displayed as Not found and the "Image found at" box is blank.

If the specified extension name of the drawing is not found at the saving path, the system searches for

all the image file extension names.

The path of the image can be removed, or directly edit the path in Image found a box and then select

Save path to specify its relative path. This may be different from the path in Image found a box.

To change the path for a raster image

Choose Insert > Image Manager from the main menu.
Select the desired file.

Click the Browse button.

P w N e

In the Select Image File dialog box, select the file with its new name or in its new
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location, and then click Open.
5. Click Save Path.

Load and Unload Raster Images

If excessive raster images exist in the current drawing, you can unload the undesired images so as to
raise the capability of your computer. Once the raster image is unloaded from the drawing, it'll be
displayed as image boundary disabled for plotting. And the links of the image does not change after
unloaded. If too many images attached to the drawing cause memory lacking in process of opening the

drawing, the system automatically unload part of image files.

Once unloaded, you can reload the images already unloaded from the drawing. If you close the
unloaded drawing after saving it, this drawing file is only available by reloading it next time you open

the drawing.

To unload and reload a raster image

Choose Insert > Image Manager from the main menu.
Select the file you want to unload or reload.

1

2

3. Do one of the following:

4. To unload the image so only its outer edge displays, click Unload.
5

To reload the image so its contents display and print, click Reload.
Improve the Display Speed of Raster Images

The display quality of images may affect its properties directly, the higher the quality, the longer is
displayed. Any changes to the image display speed will be updated immediately rather than redraw the
drawing. System plots the drawing at its high quality.

You can adjust the display speed by setting the raster image quality. The image quality is sorted into
high and draft levels, If the quality is set to draft, the image will be displayed with some granular

materials, however with faster display speed.

If the attached raster image uses true color (24 or 32 bit each pixel), you can adjust relevant options in
Display tab on Options dialog box so as to improve the image quality. The system takes a long time to
redraw the drawing when it displayed at high quality. To improve the capability, it's suggested to

reduce the color number set at the display option.

In purpose of improving the redraw speed, you can hide the undesired images in current drawing
operations through Show image option on the Properties palette. The hidden image will be neither
displayed on the screen nor plotted, only displayed as a boundary. To hide an image, you may ignore

the UCS of the current viewport.
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To change the quality of all images in a drawing

1. Choose Modify > Object > Image > Quality from the main menu.
2. Do one of the following:
3. Type H (High) to use high-quality images.
4. Type D (Draft) to use draft quality images, which require smaller amounts of
system resources.
Use Tiled Images

The tiled image is a series of small parts of large images. Loading tiled images is faster than loading
those untiled images due to the tiled images redraws its modified parts to save time in loading images.
ZWCAD supports TIFF for tiled image file format which is also available for bitonal gray (1 bit per
pixel) and index color (8 bit per pixel), true color (24 or 32 bit per pixel).

Tiled TIFF images can be saved by image scanners. But you must limit the pixel within the range 64 x
64 to 512 x 512 when tiling images. You can get programs that support other tiled file formats from the
third-party program developer.

Suppress Highlighting When Selecting Images

Generally, the image will be highlighted once selected. Set the "Highlight raster image frame only"
option in "Display" tab on "Options" dialog box to turn on or off the highlight mode for the specified
raster image. Besides, system variable IMAGEHLT is also available for controlling the highlight mode
of the image frame. Set the IMAGEHLT to 0, only highlight the frame of the raster image. You should

turn off highlight mode for the whole drawing so as to improve the capabilities of your computer.
Change the Temporary Swap File Location of Raster Images

The temporary swap file is useful when you want to reduce the memory space that image file occupies.
Windows Temp folder is the default saving path provided by the system, you can also specify a new

Temporary File Search Path in Files tab on Options dialog box.

11.2.3. ZwRasterlmageTool

You can use this tool to generate cache files for large images in batch, so as to quickly insert and

operate these images in ZWCAD.
Generate cache files for large images

Run RasterImageProc.exe program under the installation directory to launch ZwRasterImageTool.

Open the ZwRasterImageTool dialog box.

Image paths needing to generate cache files can be chosen by Select Files or Select Directory.
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¢  You can use Select Files to select one or more image files.

e  Subfolders can be included in the Select Directory.

When no image file or folder is selected, the value for Cache Path is empty. When you select an image
file, the default value for Cache Path of a cache file is the path where the image file locates. When you
select a folder, the default value for Cache Path of a cache file is the path where the folder locates. You

can also specify a new cache path by clicking Select Directory.

The naming rule of output cache file is NAME MODIFIEDTIME CREATE
TIME_SIZE.ZWIMG.

Click Start button to generate cache files. What will be displayed in the List box is as follows:
Image path&image file name+status of generating cache files

"Complete!" displays when all cache files have been generated

When you specify a new output path for cache files, the output path specified will be added to

the Rasterlmage Cache File Search Path after all cache files have been generated.

Note When there are more than 10 paths in the Rasterlmage Cache File Search Path, the following
message is displayed after all cache files have been generated: Rasterlmage Cache Search Path More
Than 10, it affects the performance that Search RasterImage Cache. Please Clear it By Command
"OPTION" items "RasterImage Cache Search Path".

Click Quit button to quit the current operation and close the ZwRasterlmageTool dialog box.

Click? button to open ZWCAD 2018 Help.
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12.Layout, Plot, and Publish Drawings

12.1. Create Multiple-View Drawing
Layouts

You can print your drawing directly from the Model tab where you created it, or you can create custom

layouts for printing on Layout tabs.

When printing from the Model tab, you can print your drawing exactly the way it appears, or you can

modify the drawing before printing by adding dimensions, a legend, or a title block.

You typically use the Layout tabs for printing if you require multiple print layouts. You may also want
to use a Layout tab for printing even if you want your drawing printed only one way. For example, if
you want to include large amounts of text on your printed drawing, you can add the text to a Layout tab

so it does not clutter your drawing while you work on the Model tab.

12.1.1. Overview of Layout

A layout represents a plotted page on which one or more model views are displayed. ZWCAD provides
two collateral working environments as Model tab and Layout tab. You can create thematic models on
Model tab. Multiple slides of the model can be set in the Layout tab.

Enable unlimited drawing area on the Model tab. You can draw a picture at the scale of 1:1, and define
which unit to be used as the measurement units of the drawing (here Inch is for brackets and metric is

for bridges).

Virtual drawing paper is accessible on the Layout tab. When setting layouts, the drawing can be

displayed as the paper size. A layout represents a plotted page which is so-called paper space.

You can get the objects created in model space displayed on paper space by creating multiple viewports.
And you can create dimensions as well as other geometric objects in layouts. Each viewport is capable

of displaying objects in model space in a specified proportion.

The system provides two layouts by default, called layout 1 and layout 2. You can create as many
layouts as you want, with various page setup and size for each layout. If you are working with a

template file, default layout configuration may be different.

When you create a drawing, you do most of your work on the Model tab. Each drawing that you create
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can contain numerous layouts that simulate the paper on which you will print a copy of the drawing.

Each of these layouts is created on a Layout tab. You can prepare a separate layout for each way you

want to print your drawing. The layout allows you to organize different views to control which portion

of your drawing prints and at what scale.

Use these general steps to prepare your drawing for printing multiple layouts

On the Model tab, create your drawing.

Create a new layout. You can use an existing Layoutl or Layout2 tab, or you can
create a new Layout tab.

Create at least one layout viewport on the Layout tab. Use each viewport to help
control which portion of the drawing prints and at what scale.

Specify additional settings for the layout, such as the scale of the drawing, print
area, print style tables, and more.

Print or plot your drawing.

You can right click on the Layout tab and select "New " to create a new layout, and also import layout

from the template.

Mew

From Template
Delete
Rename

Move Or Copy
Select All

Activate Model Tab

Page Setup...

Plot...
Publish...

Shortcut menu for layout

Work with Model Space and Paper Space

Model space is generally used for designing drawings, creating and editing drawings. Preparations for

plotting are usually working on paper space for the drawings on layouts are close to the plotting effects.

When you start a drawing session, your initial working area is called model space. Model space is an

area in which you create two dimensional and three-dimensional objects based on either the World

Coordinate System (WCS) or a user coordinate system (UCS). You view and work in model space

while using the Model tab.
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Your view of this area is a single viewport that fills the screen. You can create additional views on the
Model tab, called viewports, which can show the same or different two dimensional or
three-dimensional views, all of which are displayed in a tiled manner. You can work in only one of

these viewports at a time on the Model tab, and you can print only the current viewport.

ZWCAD provides an additional work area, called paper space. The contents of paper space represent
the paper layout of your drawing. In this work area, you can create and arrange different views of your

model similar to the way you arrange detail drawings or orthogonal views of a model on a sheet of

paper.

You view and work in paper space while using a Layout tab. Each view, or layout viewport, that you
create in paper space provides a window of your drawing in model space. You can create one layout
viewport or several. You can place layout viewports anywhere on the screen; their edges can be

touching or not, and you can print them all at the same time.

You do not need to use paper space to print your drawing, but it offers several advantages:

e Print the same drawing with different print settings that you save with each layout, for
example, printer configuration files, print style tables, lineweight settings, drawing scale, and
more.

e For a single layout, create multiple layout viewports that print the model at different views
and scales.

¢ You can toggle the Model space and Paper space by clicking on the tabs, and create viewports
on current layout tab to obtain model space for further manipulations. If the drawing is not
required to plot multiple viewports, you can plot the drawing directly from Model space.

e Layout tab is enabled to make relevant plot settings. Paper space is provided in each layout
option, and you are allowed to create viewports and specify page setups such as paper size,
orientation, and location that can be saved together with the layout.

¢  You can save and name the page setup and apply it to other layouts when setting pages. You

can also create new layouts using existing layout template file (DWT or DWG).

Click on the Model tab, you can view and edit objects in model space. Crosshairs are activated in the

whole drawing. Shown as follows:
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4 4 F ¥ Model Layoutl Layout2

View and edit objects in model space from the Model tab.

4 4 F b HModel Layowutl Layout2

View and edit objects in layout from the Model tab.

To view and edit objects of model space in viewport created in layout tab, you can double-click layout

viewport. The crosshairs and mark will be highlighted in the current viewport.
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Model Layowutl Layout2

Double click viewports to edit

To change the current viewport for another one, click on the desired viewport and press CTRL+R to

iterate all viewports.

12.1.2. View Drawings in Paper Space and Model Space

When you work in paper space on a Layout tab, you can still view your drawings in model space. First
you need to create a layout viewport in paper space; this allows you to view your model space objects

from paper space.

Within a layout viewport, you can modify the model space objects, but it is often more convenient to
modify these objects on the Model tab.

Zooming or panning the drawing in model space or paper space affects the entire drawing unless you

use multiple windows or viewports.

To view a drawing in model space on the Model tab
Do one of the following:
e Click the Model tab.
e Click the Model or Paper Space button on the status bar to switch to MODEL.

To view a drawing in paper space on a Layout tab
Do one of the following:
e  Click one of the Layout tabs.
e Type LAYOUT, choose Set option at the command prompt and then press Enter.

e Type a name for the layout you want to make current, and then press Enter.
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e  Click the Model or Paper Space button on the status bar to switch to PAPER.
e  While using a Layout tab, type PSPACE and then press Enter.
e  While using a Model tab, click the layout viewport.

The first time you switch to a Layout tab, your drawing seems to disappear. This is normal. You must

create at least one layout viewport to see your model.

To view a drawing in model space on a Layout tab

Do one of the following:
e  Click the desired Layout tab, and then create and view a layout viewport.
e  Click the Model or Paper Space button on the status bar.
e  While using a Layout tab, double-click inside of the layout viewport.

12.1.3. Specify Layout Settings

Once created a drawing in Model tab, you can toggle to Layout tab and set up the layout for plotting,

such as paper size, drawing orientation and so on.

You can right-click on the Layout tab to create new layouts or import from template files, and then

click Modify button on the Page Setup dialog box to set the page.

Select a Paper Size for a Layout

The paper size here refers to the size of the drawing. When you start Plot dialog box in Layout tab, you
can assign the paper type from a pull-down list of the Paper Size text box. The Paper size is directly
previewed from the sketch with its size and units. The available paper types provided in the pull-down
list are decided by the current configuration. If you want to configure plotters to export raster images,
you must specify output size by pixels. The paper size can be customized in the Plotter Configuration
Editor.

If you specified a system plotter, the paper size is decided by the default paper settings provided in the
Windows control panel. If any changes have been set to the paper size in Plot dialog box, the new size

will be saved in the layout to be used instead of the size in PCP.

Determine the Drawing Orientation of a Layout

The drawing orientation is sorted into Landscape and Portrait, which decide the plotting orientation of

the drawing to be seen on a paper. If you select Landscape, plots the drawing using the long edge as

horizontal. While selecting Portrait to plot the drawing using its minor edge as horizontal Changing the
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drawing orientation just like rotating the paper under the drawing.

Once specified the drawing orientation, you can control whether to plot the top or the bottom of the

drawing by selecting Plot Upsize-down option.

The changes setup in Page Setup dialog box is still saved in layouts. Certain page settings can be
replaced by customized plot settings, but the settings will not be saved in the layout unless you click

Apply to Layout option.

Additionally, changing the drawing orientation will not affect the position of plot origin which is

located at the left lower corner of the page once rotated.

Adjust the Plot Offset of a Layout

You can offset the geometry on the paper by entering a positive or negative value in the X and Y Offset

boxes. Changing the plotting origin may change the position of drawing on papers.

The plot origin locates at the left lower corner of plotting area with an offset value of 0 relative to X
and Y direction. The drawing will be moved relative to the left lower corner of the paper once you
assigned a positive or negative value to the plot offset. While a negative offset assigns the drawing

plotted under the left lower corner of the paper and results in the plot area being clipped.

Select Center on Paper if the specified plot area is part of the drawing rather than the whole layout,

which changes the position of plot origin.

You can set the area to be plotted in Plot dialog box. When creating new layouts, the default plot option
is drawing limits which means plotting all the objects within the drawing paper. The plot origin is (0,0),
located at the left lower corner of the page. ZWCAD provides the following methods to select a plot
area:

e Display: Plots the contents displayed in the current view.

e Extents: Plots the portion of the current space of the drawing that contains objects.

e Limits/Layout: When printing from model space, the content of specified drawing limits will
be printed. When you plot a layout, entities in the printable area will be printed. The printable
area's origin coordinate is calculated from its (0,0) point, and its print area is determined by
the size of the drawing paper.

e  Window: Plots any portion of the drawing you specify within the rectangle window. Click the
Window button to use a pointing device to specify opposite corners of the area to be plotted,

and then return to the Plot dialog box.
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Set the Plot Scale for a Layout

When you specify a scale to output your drawing, you can choose from a list of real-world scales, enter
your own scale, or choose Fit to Paper to scale the drawing to fit onto the selected paper size.
Usually, the objects in model space are displayed at the scale set in layout viewports. To plot the

objects in model space with the scale specified in layouts, you assign the scale to 1:1.

Set the Lineweight Scale for a Layout

Even if plot scale of layouts is assigned, it's enabled to scale the lineweight at a certain scale. Scaling
the lineweight is nothing to do with the plot scale when plotting drawings, which is mainly used for the

lines included in the objects to be plotted.

In most cases, you choose to plot layouts with default plotting scale of 1:1. However, to plot the layout

scaled by paper size A on another paper size E, you should scale lineweights to fit the new plot scale.

Copy and Move Layouts

You can right-click on the Layout tab to select Move or Copy option, on the Move or Copy dialog box,
select the target moving position and the place to put the copy of the layout and click Create a Copy to
copy the selected layout, otherwise, only the layout position will be moved. You should notice that

Model tab can't be moved or copied.

If multiple layouts are created in the drawing or too long a layout name to be displayed at the bottom of
the drawing area, you can display the tab according to the arrowhead. The arrowhead with a vertical
line represents the first and last tab individually. The current tab may not be displayed when moving
the tabs.

Save time by reusing layouts that you have already created. Within the same drawing, you may want to
make a copy of a layout that contains most of the settings you want, and then make changes to the new
copy. If you created layouts that you want to use again when you create new drawings, you can save

the layouts as a drawing template.

To make a copy of a layout

Type LAYOUT and then press Enter.
On the command line, type C (Copy).

Type the name of the layout you want to copy, and then press Enter.

P w N e

Type a name for the new layout, and then press Enter.
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Creating a new layout

In ZWCAD, you can create multiple layouts for a single drawing. Each layout represents a sheet of
paper. For each layout, you can specify the print area, print styles, print scale, lineweight scale, pen
mappings, and add viewports, dimensions, a title block, and other geometry specific to the layout. The

objects you add to a layout in paper space do not appear in model space.

When you create a new drawing, the drawing automatically contains two default layouts: Layoutl and
Layout2. You can start by using one of the default layouts, you can create your own, or you can create
a new layout from another template (.dwt) file, drawing (.dwg) file, or drawing interchange (.dxf) file.

Each drawing can contain up to 255 layouts.

To create a new layout using the Layoutl or Layout2 tab

1. Right-click the Layoutl or Layout2 tab, and select a New layout.

2. If desired, rename the layout.

To create a new layout using a new Layout tab

1. Choose Insert > Layout > New Layout from the main menu.

2. Type a unique name for your layout and then press Enter.

3. The name can be up to 255 characters in length and can contain letters, numbers,
the dollar sign ($), hyphen (-), and underscore (_), or any combination.

4. Set up at least one layout viewport.

Create Layout from Template
Right-click on the Layout tab to select From template option to import DWG or DWT file directly,

using information from existing template to create new layouts.

Template layout instances are provided for designing new layouts including viewport objects. Objects
of paper space and page setup of the existing template are used by new layouts. Thus, layout objects
will be displayed in paper space as well as viewport objects. The user can retain existing objects
imported from the template and also delete objects. Any object from model space can't be imported

while creating a layout from the template.

The system provides template file with extension name as .dwt. Layout templates from any drawing

templates can be imported into the current drawing.

To create a new layout from an existing file

1. Choose Insert > Layout > Layout from Template from the main menu.

2. In the Select Template From File dialog box, select the desired template file, and
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then click Open.
3. Inthe Insert Layout(s) dialog box, select the layout(s) you want to insert, and then
click OK. You can choose multiple layouts by holding down Ctrl while selecting

layout names.

Save layouts

Any drawing created in ZWCAD can be saved as template drawing file (.dwt) together with all the
objects and layout settings. Using the SAveas option of LAYOUT command to save the layout as new
DWT file. By default, template files are saved in the Templates Search Path located under the
corresponding position in Files tab of Options dialog box. Like drawing template file, Layout template

file go with the same extension name that contains some irrelevant information to the layouts.

When saving a drawing containing new layouts as a template file, all the named objects used in the
layout (such as blocks, layers and dimension styles) will be saved as well. The defined table options are
imported as part of the layout settings together with a template file. Once a template file is saved using
the SAveas option of LAYOUT command, the define table options will not be inserted together with
the layout.

Use PURGE command to clear the undesired define table options.

To save a layout as a drawing template

1. Type LAYOUT and then press Enter.

2. Onthe command line, type SA (SAveas).

3. Type the name of the layout that you want to save, and then press Enter.

4. In the Create Drawing File dialog box, specify a file name and location for the
drawing template file you are saving.

5. In Files of Type, select Drawing Template (*.dwt), and then choose Save.

6. After you save a layout as a template, you can use the template when you create
new drawings.

You can also import the template's layouts into another drawing.

Create and Use Named Page Setups

Once you have set plot device, plot style table and relevant page set up in the plot dialog, you can save
the page as named page setup which is usually used for updating current setting of Plot dialog box.
Applying different page setups to the same layout may obtain specific plot result. For example, you can

create named page setups listed below to control scale factor and drawing size.

360



ZWCAD User Guide

Page setup name Description
. The plot at scale 1:1, E-size
NoScaling
sheet
Scale 1 to 2 Plot at scale 1:2, C-size sheet
The plot to the draft-qualit
Draft P Auattly
plotter
) The plot to the high-quality
Final
plotter
Fit-to-Paper Fit to Paper, A-size sheet

Page setup is saved together with the drawing file, for the convenience of plotting without setting the
page each time. If you want to plot the same layout for several times or specify output options for

multiple layouts, you can use named page settings.

Managing layouts in a drawing

You can rename layouts, delete layouts, and view a list of all layouts available in a drawing. You can

also change the order in which the Layout tabs appear; the Model tab is always stationary.

If you want to rename, delete, or reorder a layout when the Layout tabs are hidden, you can type

LAYOUT to make your changes or choose Screen Menu > Tabs to display the tabs.

To rename a layout

1. Right-click the layout tab for the layout you want to rename and choose Rename
from the shortcut menu.
2. Inthe Rename Layout dialog box, enter the new name for the layout.
3. Click OK.
The name can be up to 255 characters in length and can contain letters, numbers, the dollar sign ($),

hyphen (-), and underscore (_), or any combination.

To delete a layout

1. Right-click the layout tab for the layout you want to delete and click Delete on the
shortcut menu.
2. Inthe warning box, click OK to delete the layout.
3. Any named views associated with the layout are deleted automatically when the
layout is deleted.
NOTE You cannot delete the Model tab or the last remaining Layout tab. To delete all

geometry from the Model tab or a Layout tab, first select all geometry and then use the
361



ZWCAD User Guide

Erase command.

To view a list of all layouts

1. Type LAYOUT and then press Enter.

2. Onthe command line, type? and then press Enter to list all layouts.

12.1.4. Create and Modify Layout Viewports

When you begin working on a drawing on the Model tab, it consists of a single view of your model.
You may have created additional views by dividing the drawing space into multiple windows; each

window is a separate viewport on the Model tab.

On a Layout tab, you must create at least one layout viewport to see your model. However, you can
create multiple layout viewports that display unique views of your model located in model space. Each

layout viewport is created as a separate entity that you can move, copy, or delete.

Click any layout viewport to make it the current viewport, and then add or modify model space objects
in that viewport. Any changes you make in one layout viewport are immediately visible in the other
viewports (if the other layout viewports are displaying that portion of the drawing). Zooming or

panning in the current viewport affects only that viewport.

Create layout viewports

The first time you switch to a Layout tab, all of your model space objects disappear. You must create at

least one layout viewport on the Layout tab to see your work.

You can create layout viewports anywhere inside the drawing area. You can control the number of

viewports created and the arrangement of the viewports.

To create layout viewports

1. Onthe command line, type MVIEW.

2. Type F (Fit), or create 2, 3 or 4 viewports by entering 2, 3 or 4 separately, or
specify two opposing corners to create a custom viewport.

Choose the viewport arrangement, typing H (Horizontal) or V (Vertical).

Do one of the following:

To arrange the viewports to fill the current graphics area, type F (Fit).

o vk~ w

To fit the viewports within a bounding rectangle, specify the corners of a

rectangle.
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TIP When you create a layout viewport, the layout viewport border is created on the current layer. You
can make layout viewport borders invisible by creating a new layer before you create layout viewports

and then turning off that layer after you create the layout viewports.

To select a layout viewport's borders, you must turn that layer back on before you can rearrange or
y Wwp y y

modify the layout viewport.

A B C

You can create a single layout viewport, or you can divide the graphics area into two viewports arranged vertically
(A) or horizontally (B); three viewports arranged left (C), right (D), above (E), below (F), vertically (G), or horizontally

(H); or four equal viewports (I).

Use layout viewports

Create multiple viewports in layout tab to view objects created in model space, move and scale the

objects as well. The multiple viewports created in layouts can be overlapped or separated.
The user can toggle to model space and edit objects in layout viewports within layouts. When ranking
layouts in paper space, you can't edit the model. Methods to toggle to model space are shown as
follows:
Enter Model space by selecting a Model tab.
Double click inside the layout viewport. At the moment, the Model or Paper Space button on the status
[,
| 8
bar changes from L[=_lto =l

Click Model or Paper Space button on the status bar to switch to MODEL.

The layout viewport on which you double clicked will be set as current view and enter model space
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with its frame highlighted. Once a viewport has been changed, all the other viewports display the
modifications simultaneously. Additionally, layout viewport owns the superiorities as: optionally freeze
the layer in each layout viewport. Thus, you can display different objects in the current viewport.

Meanwhile, you can pan and scale the objects in viewports to display different views.

With the grips displayed in the viewport frame, layout viewport is also available for changing the scale
that geometrical drawings of model space display in viewports so as to adjust the viewport size. Each
viewport can be scaled like other objects using SCALE command, which is only effective to the size of

the viewport rather than the scale of the views.

Place Layout Viewports

The user can select to create a viewport fit to the entire layout, and also specify a rectangle area to

create layout viewports.

In the Viewports dialog box, viewports of various standards or named viewport configurations which

determined by the pattern you view the drawing and the plotting results are inserted into layouts.

Viewport configuration that is saved and named in the model tab can be positioned in layouts as well.
The viewport will be saved as soon as new viewports are ranked and named, and the new viewport
names will be added to a list ranked by viewports. Grips on layouts will be displayed once selected,
which are used for changing the display proportion of geometry objects created in model space within
the viewports. Each viewport can be scaled like other objects using SCALE command, which is only
effective to the size of the viewport rather than the scale of the views. To adjust the proportion of views
within viewports, you can scale the view by modifying the scaling factor. You can also specify
proportion in the Standard proportion option on Properties palette, and Customize option is also

available for changing plot scale of viewport objects.

Change the Properties of Layout Viewports

Like common objects, layout viewports are characterized by object properties such as layer, color,

linetype, linetype scale and lineweight. Which are all displayed and changed on properties palette.
Viewports are created on the current layer so as to control the visibility of the boundaries. The user can

freeze or set plot configurations for layers in Layer Property Manager to avoid plotting the viewport.

The visibility of the boundary is non-associative to the viewport if they are located in different layers.
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To modify layout viewport properties

1. Click the border of the layout viewport whose properties you want to modify.
2. Open the Properties palette through the menu option "Tools > Properties" or
"Modify > Properties".
3. In the Properties palette, select Standard Scale, and then select a new scale from
the list. The scale you choose is applied to the viewport.
NOTE You can select only layout viewports for modification. If you click a viewport on

the Model tab, it makes that viewport active, not available for modification.

Lock the Scale of Layout Viewports

Some proportions maybe required for displaying details of different hierarchy when creating viewports.
If you want to scale the viewport once you have set the viewport scale, the scaling factor changes along
with the viewport scales. You can lock the scale factor before scaling to retain the viewport proportion.

Locks the scale set in the selected viewport. You can modify the geometric drawings in the current
viewport without changing the viewport scale once the scale is locked. While unlocking viewport scale

again will disable many commands used for viewing such as VPOINT, PLAN, and VIEW.

Control Visibility in Layout Viewports

Various methods are available for controlling whether to display or hide the layout viewport. All these
methods help to limit the regen and highlight different elements of the drawing having been set the
Visibility.

Screen Objects in Layout Viewports
Screening means plotting with little ink. The screening objects will be displayed diminish on paper and
screen. Whereas the screening value may not affect the color properties of the objects, only limit the

concentration of ink for the convenience of distinguishing objects after plotting.

To specify the screening value, you should specify the plot style first, and then define the screening
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value in plot style editor. The value can be assigned from 0 to 100, if you specify the value to 100, the
screening will not take effect, that is to plot the drawing without screening. While using screening

value as 0 to plot the object without ink, namely make the objects invisible.

Turn Layout Viewports On or Off

The new layout viewport is under status On by default until you select to turn off. The more objects in
model space, the more layout viewports can be created. Thus generating contents of each viewport may
affect system capacity. The user can control the status of the viewport in Properties palette, to save
space by turning off some viewports or limiting active viewports. The following figure shows the

results with two viewports turned off.
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Once the viewport is turned off, you can copy the viewport without regen each viewport, and the
closed viewport will not be plotted. To hide the viewport boundary which you are working on, you can

create a specific layer for viewports and then close or freeze the layer.

To turn layout viewports on or off

Click the desired Layout tab.
Type MVIEW and then press Enter.
Type ON or OFF.

Select the edge of the layout viewport to turn on or off, and then press Enter.
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Manage Layer Visibility in a Layout

You can control the visibility of the layer in each layout viewport, and apply the default visibility

settings to new viewports and layers.

Freeze Specified Layers in a Layout Viewport

Freeze or thaw layers on current layout viewports without affecting others. The frozen layers are
invisible, either reloaded or plotted. You can freeze the layer to control how the objects are displayed.
For example, dimensions can be displayed in the specific viewport, as the figure shows below, only the

viewport with terrain drawing is frozen.
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Once frozen, the layer in the viewport is invisible. With the layer thawing, its visibility can be restored.
The user can control the frozen status of layers by clicking VP Freeze icon in Layer Properties
Manager.

Freeze or Thaw Layers Automatically in New Layout Viewports

Freeze the layer containing those objects that are not expected to display or plot in paper space. For
example, freeze the layer on which viewports are created if layout viewport boundaries are not

expected to display.

Freeze or Thaw Layers Automatically in New Layout Viewports

The newly created layout viewport is also acceptable for layer visibility settings. For example, freeze
DIMENSIONS layer of all new viewports to limit displaying the dimensions. To create viewports with
dimensions, you can change default settings for the current viewport. However, changing default

settings of new viewport may not affect current viewport.

Freeze or Thaw Layers Automatically in New Layout Viewports

The user can create new layers frozen in all of the existing layout viewports by clicking Freeze icon in
Layer Properties Manager. Likewise, cancel the Freeze icon to thaw layers in all viewports. You can
also thaw layers by your decision, with this feature, you can create new layers displayed in single

viewports.

Modify Layout Viewports

Once layout viewports are created in paper space, you can set the viewport as current in which you can
edit model objects. Any changes to the layout viewports reflected model space directly and all other

viewports of the modified objects will be displayed.

Change the layout viewport scale

Specify proportion in the Standard proportion option on Properties tab to determine the proportion of

each viewport relative to paper space. That is to scale each viewport precisely. Scaling or extension for
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layout viewport boundaries will not change the scale of views in viewports.

While working on layouts, the scale factor represents the ratio of the actual size of the model and the
layout size. The ratio generated dividing the model space unit from drawing space unit. For example, a
drawing with a ratio of 1/3 means one drawing space unit equals to three model space units.

Changing the plot scale of viewports is also available through ZOOM command or Viewport toolbar.

To change the layout viewport scale

Make sure you are on a layout tab in paper space.
Click the border of the viewport whose scale you want to modify.

Right-click and choose Properties from the shortcut menu that displays.
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In the Properties palette, select Standard Scale, and then select a new scale from

the list. The scale you choose is applied to the viewport.

Scale Linetypes in Layout Viewports

Scaling linetypes is enabled to be manipulated based on both drawing units and paper space.

System variable PSLTSCALE is used to setup linetype scaling factor for objects displayed in different
proportion. If PSLTSCALE is set to 1, current linetype is set to dash line, and then draw lines in paper
space. Create viewport with the proportion of 1x, set this layout viewport as current and then draw
lines using the dashes linetype. These two dashes are of the same appearance. If the viewport scaling
factor is set to 2x, then the linetype scaling factor of dashes are consistent both in layout and layout

viewports.

Scaling drawing space units if the system variable PSLTSCALE is on, the linetype scale is determined
by viewport scale. If you set system variable TILEMODE to 0, dashes length of objects in model space
is based on drawing units. Linetypes keep the same even if various scaling factors are used for current
views. Dash lines share the same length with that of paper space, thus, you can still use LTSCALE and
CELTSCALE to control the length of dashes.

The following figure shows: linetype scale on the left has been adjusted to dashes scaled to paper space,

regardless of the scale of views. The figure on the right matches the scale of linetype with each view.

_______________ 1

PSLTSCALE=1, dashes scaled to FSLTSCALE=0, dashes scaled to
paper space space where they were created
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Rotate Views in Layout Viewports

You can rotate the entire view within layout viewports using PLAN command to change current UCS.
But the object to be rotated in the view rather than viewport boundary. Using ROTATE command only

rotates single objects of the viewport.
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12.1.5. Create Non-rectangular Layout Viewports

Use Object and Polygonal options of MVIEW to create irregular viewports, Select-Object option to
convert objects created in paper space to viewports. While selecting the Polygonal option to draw
irregular polylines including arcs and lines which are enabled to either intersect or three vertexes at

least, the polyline will be closed automatically to form irregular polygonal viewport.

To define viewport boundaries, the area in which selected objects are contained will be calculated, to
set viewport objects on the corner of the boundary, and then clip the viewport according to the

specified objects.
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The polygonal option is used for creating irregular viewports according to specified points. With the

same command prompts as creating a polyline.

Redefine Viewport Boundary

Boundaries of viewports can be redefined by VPCLIP command.
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Once selected the viewport to be clipped, you can specify existing objects as a new boundary or
specify new boundary point. You should notice that the boundary is neither displayed nor clipped if the
layer on which the boundary of non-rectangular viewport locates. If you close the boundary layer rather

than freeze it, the viewport will be clipped.

Edit Non-rectangular Viewports Using Grips

Like other geometrical objects, grips that are used to change the shape of non-rectangular viewports
will be displayed once selected, with which you can edit the viewport as other objects. Such as move,
rotate, scale and so on. To define viewport boundaries, the area in which selected objects are contained
will be calculated, to set viewport objects on the corner of the boundary. Some geometric drawings

may not be displayed entirely for the different shape of the boundaries.
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Scaling and Panning within Non-rectangular Viewports

Geometric drawings in model space will be clipped according to viewport boundaries when scaling and

panning within non-rectangular viewports.

However, scaling or panning in rectangular viewports may not display objects outside the viewport

boundaries.
If using Extents option in ZOOM command for the objects to be clipped within non-rectangular

viewports, the system scales the drawing according to the extents of clipping boundary, not all the

geometric drawings are visible in the non-rectangular viewport.

12.2. Plot Drawings

When a drawing is completed, you can output it using several methods. You can plot the drawing on
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paper or create a file for use with another application.

12.2.1. Overview of Plotting

To understand relevant concepts to facilitate users setting properties for plotting.
Plotter Manager

Plotter Manager is a window in which all the plotter configuration (PC5) files of user installation are
listed. If you want to use ZWCAD default plotting properties other than that of Windows system
configured, you can also create a new plotter configuration files for Windows system plotter. Plotter
configuration settings contain port information, quality of raster images and vector drawings, drawing

size and customized properties based on the plotter type.
The user can start an Add Plotter - Introduction Page dialog box by selecting Add New Plotters option

from the Name pull-down box in Printer/Plotter area on Plot dialog box, which is available for creating

plotter configuration using relevant information that is imported as this wizard required.
Layouts

Layout displays the results on a plotted page. You can create as many layouts as you need. Each layout

is saved on its own layout tab and can be associated with a different page setup.
All the elements to be displayed on a plotted page, such as title blocks and notes, are drawn in paper

space in a layout. The objects in the drawing are created in model space. To view these objects in the

layout, you should create layout viewports.
Page Setups

Specify page settings for the layout you create through Page Setup and Plot Setup dialog box, controls
whether to display layout tab or Model tab. Page setup can be applied to other layouts once it's saved

with a given name.
Plot Styles

A plot style includes properties such as lineweight, color, hatch pattern, which controls how an object

or layer is plotted. The Plot Style Manager shows all the plot style tables available in ZWCAD.

There are two plot style types: color-dependent and named. Use only one type of plot style table for

plotting a drawing each time.
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For color-dependent plot style tables, an object's color determines how it is plotted. With an extension
of .ctb, these plot style table files are disabled by assigning color-dependent plot styles directly to
objects. Instead, to control how an object is plotted, you should change its color. For example, all

objects assigned the color red in a drawing are plotted the same way.

Named plot style tables use plot styles that are assigned directly to objects and layers. With an
extension of .ctb, these plot style table files enable each object in a drawing to be plotted differently,

independent of its color.

12.2.2. Plot Settings

When you create a drawing, you do most of your work on the Model tab. At any time you can print
your drawing to see how it looks on paper. It's easy to startup printing, and then later create layouts and

custom print settings to enhance your printed output.

To start printing

1. Choose File > Plot from the main menu.

2. Set the printer and relevant parameters, and then click OK.

There are many options that you can set before printing, such as the scale of the drawing, print area,

print style tables, and more.

Before you print, you can set up many aspects of printing:
e Select and configure plotting device.
e Specify paper size and orientation.
e Specify the size of the paper used for plotting, including which portion of a drawing to print
and the origin of the print area.
e Choose whether to print and scale lineweights.
e  Choose whether to implement print style tables to control colors, pen widths, line types, and

lineweights.

Set Paper Size

The paper size here refers to the size of the drawing, needing to be set before plotting regardless of
which working space you select. You can assign the paper type from a pull-down list of the Paper Size
text box in Printer/Plotter area. The available paper types provided in the pull-down list are decided by
current configuration. If you want to setup paper size, you should configure plotters first, all the

available plotters are both system plotters of Windows configured and non-system driven.

You can specify a printer or plotter to be used when printing any drawing. You can print your drawing

on any printer or plotter that is compatible with Windows, including raster printers.
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To select a printer or plotter

1. Choose File > Plot from the main menu.
2. From the Name list in Printer/Plotter area, select a printer or plotter you want to

use, and then click OK.

Default paper size used for creating new layouts through editing PC5 files associative to plotters can be
assigned to the paper. With this technique, you can assign different paper size for Windows and
ZWCAD separately.

If you set the system variable PAPERUPDATE to 0, prompts display if the selected plotter doesn't
support the paper size. If you set the system variable PAPERUPDATE to 1, the paper size will be
updated automatically to default paper size that plotters provide.

To select the paper size and orientation

1. Choose File > Plot from the main menu.
2. From the Paper Size list in Printer/Plotter area, select the desired paper size, and
then click OK.

You can also adjust the orientation by printing a drawing upside down on the paper. Each layout in

your drawing can specify whether to print upside down.

Use a Custom Paper Size

You can also add customized paper size to non-system plotters through Plotter Configuration Editor.
Usually, customized paper size is not able to add to Windows system plotter, but you can modify the

plotted area according to the paper size associated with system plotters.

Position the Drawing on the Paper

You can adjust the position of the drawing to be plotted on a paper before plotting.

Set the Origin of Print Area

You can specify the position of the drawing to be plotted on a paper by entering a positive or negative
value in the X and Y Offset boxes. Select Center on Paper to locate the drawing at the center of the
paper.

The offset value makes a compensation to the page pitch by aligning the left lower corner of the title
bar with that of the drawing paper. The offset is usually negative, determined by measuring the distance

between the page edge and plot information.
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To specify the print area origin

1. If necessary, click the desired Layout tab or the Model tab.

2. Choose File > Plot from the main menu.

3. Do one of the following in the Plot Offset area:

4. To center the specified print area on the printed page, select the Center the Plot
check box.

5. To specify an origin for the print area, type the X and Y coordinates.

6. Select Save Changes to Layout, and then click Apply to Layout.

Set Drawing Orientation

The drawing orientation determines whether to plot a drawing portrait or landscape.

If you select Landscape, plots the drawing using the long edge as horizontal. While selecting Portrait to
plot the drawing using its minor edge as horizontal Changing the drawing orientation just like rotating
the paper under the drawing. Meanwhile, selecting Plot upside-down to control whether to locate the

drawing upside-down on paper.

Set Plot Scale

Plot-scale of the drawing can be specified directly from the Scale pulldown list in Plot Scale area of
Plot dialog box. You can also choose Custom to set desired plot scale or choose Fit to Paper to scale the

drawing to fit onto the selected paper size.

Generally, you draw objects at their actual size. That is, you decide which unit to be applied to the size
(an inch, a millimeter, a meter) and draw objects at a 1:1 scale. For example, if you select the
measurement unit as millimeters, then every unit in your drawing represents a millimeter. When you
plot the drawing, you either specify a precise scale or fit the image to the paper. Plotting is usually

working under precise proportion.

The plot scale set here represents the ratio of plot unit and the actual unit used for drawing models.

Set a Specific Scale

The plot scale together with plot unit and drawing unit must be specified before plotting. For example,
if you select the paper size to mm, entering 1 under mm and 10 under Units blank produces a plotted

drawing with each plotted unit represents 10 actual millimeters.

The following figure shows an instance of plotting objects at three different scales.
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To automatically scale the drawing for printing

If necessary, click the desired Layout tab or the Model tab.
Choose File > Plot from the main menu.

To scale the drawing to fit on one printed page, in Plot Scale, click Fit to Paper.
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Select Save Changes to Layout, and then click Apply to Layout.

To specify the scale factor yourself

If necessary, click the desired Layout tab or the Model tab.
Choose File > Plot from the main menu.

In Plot Scale, do one of the following:
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Select a predefined scale. For example, choose 1:2 if you want 1 printed unit (inch
or millimeter) to equal 2 drawing units.

5. Select Custom, and then under User Defined Scale, type the ratio of printed units
of measure (inches or millimeters) to drawing units.

6. Select Save Changes to Layout, and then click Apply to Layout.

Scale the Drawing to Fit the Page

To plot the view at the largest possible size that fits the paper. The height and width of the drawing will

be adjusted according to the paper size.

Any changes to the ratio of plotted units, drawing size, plotters, plot origin, plot orientation and plot

area will be reflected plot scale.

Set Options for Plotted Objects

The following options show plot patterns with instructions on how to plot objects.

e The plot in Background. Specifies that the plot is processed in the background.

e Plot Object Lineweights. Specifies that lineweights assigned to objects and layers are plotted.

e Plot with Plot Styles. Plots a drawing with specified plot styles. Plots lineweights
automatically once selecting this option automatically. If you do not select this option, objects
are plotted with their assigned properties and not with the plot style overrides.

e Plot Paperspace Last. Plots model space geometry first. Paper space geometry is usually
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plotted before model space geometry.

Hide Paperspace Objects. Suppresses the plotting of objects that are located behind other
objects regardless of how it's displayed on the screen. This option is only available in the
Layout tabs.

Plot Stamp on. Horizontally or vertically placed the plot stamp information on a specified
corner of the drawing. The plot stamp settings can be saved to log file, also cannot be saved.
"Plot Stamp Settings" Button. The Plot Stamp dialog box will be opened by selecting the Plot
Stamp on option in the Plot dialog box,

Save Changes to Layout. All the changes you make in the Plot dialog box will be saved to the
layout if you click OK.

To set lineweight options

1. If necessary, click the desired Layout tab or the Model tab.

2. Choose File > Plot from the main menu.

3. Choose Plot Object Lineweights to plot the lineweights assigned to objects and
layers.

4. Select Scale Lineweights to print lineweights in proportion to the scale you set in
the Plot Scale. If not selected, lineweights print at their assigned size without
adjustments for the print scale. (A Layout tab must be active to scale lineweights.)

5. Select Save Changes to Layout, and then click Apply to Layout.

NOTE Print styles can also affect how lineweights print.

Specify the Area to Plot

To determine where to plot the drawing, you must specify an area for the drawing. The following

options under Plot Area are provided in The Plot dialog box.

Display. Plots the contents displayed in the current view.

View. Plots a view saved previously with the VIEW command. You can select a named view
from the list provided. This option is unavailable if there are no saved views in the drawing.
Extents. Plots the portion of the current space of the drawing that contains objects.
Limits/Layout. When printing from model space, the content of specified drawing limits will
be printed. When you plot a layout, entities in the printable area will be printed. The printable
area's origin coordinate is calculated from its (0,0) point, and its print area is determined by
the size of the drawing paper.

Window. Plots any portion of the drawing you specify within the rectangle window. Click the
Window button to use a pointing device to specify opposite corners of the area to be plotted,

and then return to the Plot dialog box.

To specify a portion of the drawing to print

1. If necessary, click the desired Layout tab or the Model tab.
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Choose File > Plot from the main menu.
Under Print Area, click one of the following:
Display — Plots the current view on the screen.
View — Plots the selected saved view.

Extents — Plots the contents within the specified drawing extents.

No v bk wnN

Limits/Layout — Plots the contents within the specified drawing limits or entities in

the printable area.

8. Window — Plots the portion of the drawing contained in the specified window.
Click the Window button to use a pointing device to specify opposite corners of
the area to be plotted, and then return to the Plot dialog box.

9. Select Save Changes to Layout, and then click Apply to Layout.

Preview a Plot

Viewing a drawing before printing gives you a preview of what your drawing will look like when it is
printed. This helps you see if there are any changes you want to make before actually printing the
drawing. If you are using print style tables, the preview shows how your drawing will print with the

assigned print styles.

The system automatically generates preview results as soon as you setup relevant plotting properties.

To preview a drawing before printing

If necessary, click the desired Layout tab or the Model tab.
Choose File > Plot Preview from the main menu.
Do one of the following:

To print the drawing, click Plot in the top left corner.
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To return to the drawing, click the Close Preview Window button or press Esc.

Print a drawing

The print setting options available under each tab on the Print dialog box were described in the

previous sections.

NOTE You cannot print a rendered image directly to a printer. To print a rendered image, you must

first save the drawing to a different format and then print it from another graphics program.

To print a drawing

If necessary, click the desired Layout tab or the Model tab.
Choose File > Plot from the main menu.

From the Plot dialog box, make any adjustments to the settings.
Click OK.
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NOTE Instead of using the print settings you saved with your layout, you can select Previous Plot

form the Name pull-down list in Page Setup area.

Smart Plot

With Smart Plot, drawings can be plotted from the model space all at once after defining their borders

and selecting the entities to be plotted, enabling more efficient plotting process.

Before starting smart plot, frame of the drawing must be verified. For now there are 3 frame style can

be recognized, they are Layer, Block, Scatter Line.
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12.2.3. Use Plot Styles

ZWCAD uses plot styles to change the appearance of your printed drawing without modifying the
actual objects in your drawing. Assigning plot styles allows you to customize the Color, GrayScale,
Screening, and Lineweight that are used to print your drawing. Plot styles help you control what your

drawing looks like when it is printed.

Because plot styles are saved in plot style tables, which are files located on your computer, disk, or
server, you can reuse them to help eliminate the need to reconfigure your print settings each time you
print a drawing. You can save plot styles in a named file for each of your clients. You can even share
the file with coworkers, or store the files on a network to ensure that everyone in your office uses the

same standards.
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Understanding plot style tables

A plot style table is a collection of plot styles that allows you to change the appearance of your printed
drawing without modifying the actual objects in your drawing. Each plot style table is saved in a file

that can be located on your computer, disk, or server.

A drawing can use one type of plot style table at a time. There are two types of plot style tables:

e  Color-dependent plot style tables (CTB) contain a collection of plot styles based on each of
the 255 index colors available in a drawing. True colors and color books are not applicable to
color-dependent plot style tables.

e Named plot style tables (STB) contain a collection of plot styles that you define. They can

vary regardless of color.

With color independent plot style tables, you cannot assign plot styles to individual objects or layers.
To use these plot styles, you assign a specific color to an entity or layer. When you specify a
color-dependent plot style table at printing time, the entity colors and layer colors map to color based
plot styles in the plot style table that you specify. If you specify a plot style for a specific entity, that

plot style overrides any plot style assigned to the layer on which the entity resides.

Sometimes a named plot style assigned to an entity or layer is not located in the plot style table that is
assigned to a layout or drawing. This can happen if the plot style has been deleted from the named plot
style table or if you assign a different named plot style table to the drawing that does not contain the
named plot style. In this case, the entity is printed using its default properties. If you plan on
interchanging named plot style tables within the same drawing, it's a good idea to coordinate the tables

to use the same plot style names.

If a new drawing is based on a template, the new drawing uses the same type of plot style table as the
template. If a new drawing is created without a template, the type of plot style table is specified in the
New Drawing Wizard; Every drawing is designed to use plot style tables, but you decide whether to

implement them.

Setup plot styles to determine how a drawing is plotted.

Like color and linetype, plot style is also a kind of object property that reflected on the plotted objects
or layer once you plot the object with the plot style assigned. A plot style controls an object's plotted
properties, including color, dither, grayscale, pen, virtual pen, screening, linetype, adaptive, lineweight,
line end, line join and fills style.

If the plot styles conflict with the settings created for objects, use the plot style settings for plotting

other than the settings created for objects. You can close these substitute settings on demand.
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Choose a Type of Plot Style Table

A plot style table is a collection of plot styles assigned to a layout or the Model tab. There are two types
of plot style tables: color-dependent plot style tables and named plot style tables.

Color-dependent plot style tables (CTB)

Color-dependent plot style table determines to plot characteristics such as lineweight using an object's
color. This plot style plot objects with the same color in the same style. For example, every blue object
in a drawing is plotted the same way. While color-dependent plot style table is provided for editing
rather than adding or deleting plot styles. There are 256 plot styles in a color-dependent plot style table,

one for each color.
Once a color-dependent plot style table is assigned to the drawing, you cannot assign a plot style to
individual objects or layers. Instead, to assign plot style properties to an object, you should change the

color of the object or layer.

You can assign color-dependent plot style tables to layouts. You can use several predefined

color-dependent plot style tables, edit existing plot style tables, or create your own.
Color-dependent plot style tables are stored in the print style folder with extensions named as .ctb.

Note that assigning the color-dependent plot style table to a layout is only available when the drawing

has been set to use color-dependent plot style tables.

Named plot style tables (STB)

Named plot style tables contain user-defined plot styles. This plot style plot objects based on the plot
style assigned to the object rather than the color. The named plot style tables can be assigned to objects

or layouts as assigning other properties.

Named plot styles can be assigned to objects or layers in the same way as any other properties.

Assign Plot Style Tables to Layouts

Controls the plotting style for objects in layouts using different plot styles assigned to each layout. The
specified plot style tables affect both model space and paper space objects.

If you specified named plot style for a drawing, each object in the drawing either is assigned a plot

style directly or inherits a plot style from its layer.

If a xref has been inserted into your current drawing, all defined plot style tables will be inserted as
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well.
You can assign plot style tables globally for all layouts (including the Model tab), or individually for
the Model tab or a Layout tab. Assigning a plot style table to an individual layout allows you to further

customize the layouts you use to print a drawing.

However, assigning different named plot style tables to various layouts may result in mismatched plot

style names. In this case, objects are printed using their default properties.

To assign plot style tables

1. |If necessary, click the desired Layout tab, or click the Model tab.
2. Choose File > Plot from the main menu.
3. Under Plot Style Table (pen assignments), select a plot style table in the one of
the following:
None — Applies no plot style table. Objects plot according to their own properties.
Monochrome — Plots all colors as black.
New — Creates a new plot style table.

4. Select Save Changes to Layout, and then click Apply to Layout.

NOTE When your drawing was first created it was set up to use either color-dependent or named plot

style tables.

Manage Plot Style Tables

Color-dependent (CTB) and named (STB) plot style tables are stored in the print style folder by default.
This folder is also known as the Plot Style Manager.

Plot Style Manager is available to add, delete, rename, copy, and edit plot style tables.
Creating new plot style tables

ZWCAD offers several plot style tables to help you get started. If you want to customize your print
output further, you can create your own plot style table. You can customize plot exporting pattern by

import printer configuration file (PCP file).

To create new plot style tables

1. Choose File > Plot from the main menu.

2. Under Plot Style Table (pen assignments), choose New to open the Add Plot Style
Table wizard.

3. On the last wizard page, you can click Plot Style Table Editor to set up the plot
styles for the table.
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Change Plot Style Settings

Double-clicking a CTB or STB file in the Plot Style Manager to open the Plot Style Table Editor. The
Plot Style Table Editor displays the plot styles contained in the specified plot style table.

The General tab lists general information about the table. The Properties area on the Form View tab

provides options for modifying colors or relevant properties of plot styles.

If you are using a color-dependent plot style table, the color-dependent properties (e.g. color, dither,
grayscale, pen, virtual pen, screening, linetype, adaptive, lineweight, line end, line join and fill style)

are available from the Properties area.

While all these plot style properties (e.g. color, dither, grayscale, pen, virtual pen, screening, linetype,
adaptive, lineweight, line end, line join and fill style) are changed for each plot style from the

Properties when using a named plot style table.

In a named plot style table, the NORMAL plot style represents an object's default properties (no plot
style applied). The NORMAL style can't be modified or deleted by yourself.

Color

The plot style color default to Use Object Color. With this setting, the object retains its layer or
individually set color. The color overrides the object's color at plot time if you assign a plot style color

to this plot style.

The system provides 255 Color Index (ZCI) colors, a true color, or a color book color in the plot style
options. While the True color, plot styles should be synchronized with the same color setting for the
plotter configurations. However, the system takes the latest color index as substitute color once the

plotter is unable to update the configuration to True color.

Dither

Enables dithering. A plotter uses dithering to approximate colors with dot patterns, giving the
impression of plotting more colors than available in the ZWCAD Color Index (ZCI). If the plotter does
not support dithering, the dithering setting is ignored.

Dithering is usually turned off in order to avoid false line typing that results from dithering of thin
vectors. Turning off dithering also makes dim colors more visible. When you turn off dithering,
ZWCAD maps colors to the nearest color, resulting in a smaller range of colors when plotting.

Dithering is available whether you use the object's color or assign a plot style color.
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Grayscale

In case that the plotter supports grayscale, the system converts the object's colors to grayscale when
you select Convert to Grayscale. Light colors, such as yellow, are plotted with light gray values. Dark
colors are plotted with dark gray values.

If you set the Grayscale off, the system uses the RGB values for the entity's colors.

The grayscale is available for the entity color or a plot style color.

Pen

Specifies a pen to use when plotting objects that use this plot style. Available pens range from 1 to 32.

Virtual Pen

Specifies a virtual pen number between 1 and 255. Many non-pen plotters can simulate pen plotters
using virtual pens. For many devices, you can program the pen's width, fill pattern, end style, join style,

and color/screening from the front panel on the plotter.

Screening

A color intensity setting determines the amount of ink ZWCAD places on the paper while plotting.
Using valid values from 0 to 100. If set the value to 0, the color will be reduced to white. While
assigning it to 100, the color will be displayed at its full intensity.

Screening is effective only if the plotter is configured to plot colors or grayscale, with dithering

enabled as well.

Linetype

Specifies which linetype to plot style table. The default setting is Use Object Linetype.

Adaptive

You can set the Adaptive option whatever the linetype is object character or plot style. The option can
adjust the scale of the linetype to complete the linetype pattern. The line may end in the middle of the
linetype pattern if the Adaptive is set to OFF.

Lineweight

Uses Object Lineweight is the default setting for plot style lineweight. All the lineweight samples
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together with values are provided in the lineweight dropdown list. You can also modify an existing

lineweight if the one you need is not available in the dropdown list. Clicks Edit Lineweights button to

modify the existing lineweights.

Line End

Specifies the line end style to the plot style. The default setting is Use Object End Style.

Line Join

Specifies the style of the line joint. The default setting is Use Object Join Style.

Fill Style

Specifies the fill style for the polylines, torus and the objects filled with entities. The default setting is
Use Object Fill Style.

To modify plot style tables

7.

Choose File > Plot from the main menu.

Under Plot Style Table (pen assignments), click the plot style table you want to
modify, and then click Edit button.

Click the General tab on Plot Style Table Editor, and then do any of the following:
Enter a new plot style description.

Select Apply Global Scale Factor to Non-ISO Linetypes to apply the scale factor to
non-ISO linetypes used for any plot style in the current plot style table.

Enter a scale factor to apply to non-ISO linetypes used for any plot style in the
current plot style table.

Click the Form View tab, and then do any of the following:

Make changes to a color-dependent plot style by selecting it in the Plot list, and then

make color, linetype, or lineweight changes for the plot style in Properties area. Your

changes are saved automatically for the selected plot style.

Make changes to a named plot style by selecting it in the Plot list, and then make color,

linetype, or lineweight changes for the plot style in Properties area. Your changes are

saved automatically for the selected plot style.

8.

10.

Add a new plot style by clicking Add Style. Enter a new name, and then click OK.
Select the options for the plot style. (Available for named plot styles only.)

Delete a plot style by selecting it in the Plot list, and then click Delete Style.
(Available for named plot styles only.)

Click OK.
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Changing a drawing's plot style table type

When your drawing was created, it was set up to use color-dependent plot style tables (.ctb files) or
named plot style tables (.stb files). A drawing can use one type of plot style table at a time. If necessary,

after a drawing is created you can convert the drawing to use the other type of plot style table.

If you can't remember what type of plot style table is assigned to your drawing, use the
PSTYLEMODE system variable to determine the plot style table type.

To change a drawing to use named plot style tables

1. Open the drawing that uses color-dependent plot style tables (.ctb files).

2. Type CONVERTPSTYLES, and then press Enter.

3. If you have already converted your individual color-dependent plot style tables to
named tables, click OK in the prompt that displays.

4. In the Select File dialog box, select a named plot style table (.stb file) that you
want to use with the drawing.

5. Click Open and a message are displayed to confirm that the drawing is converted.

To change a drawing to use color-dependent plot style tables

1. Open the drawing that uses named plot style tables (.stb files).

2. Type CONVERTPSTYLES, and then press Enter.

3. If you are sure you want to convert the drawing and lose all plot style assignments,
click OK in the prompt that displays.

4. NOTE Converting a drawing to use color-dependent plot style tables will remove
all of the named plot style information from objects and layers. However, the

named plot style tables are not deleted from your computer.

Converting plot style tables

You can convert a color-dependent plot style table to a named plot style table. You cannot convert a
named plot style table to a color-dependent plot style table because color-dependent tables contain only

plot styles that are named after the 255 colors to which they map.

Converting a color-dependent plot style table to a named plot style table can be helpful in the following

situations:
You don't want to create a named plot style table from scratch.
You want to create a named plot style table that has the same settings as a color-dependent plot style

table, but with some new plot styles or other custom settings.
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You want to convert a drawing to use named plot style tables and you want to reuse most of the plot

styles already defined in a color-dependent plot style table.

To convert a color-dependent plot style table to a named plot style table

1. Type CONVERTCTB, and then press Enter.
2. In the Select File dialog box, select the color-dependent plot style table (.ctb file)

that you want to convert.

3. Click Open.

4. Enter a name for the new named plot style table (.stb file).

5. Click Save.

6. The plot styles in the new table are named Style 1, Style 2, and so on. To use

different plot style names, rename the plot styles before you assign them to
objects and layers in your drawing. If you rename the plot styles after assigning

them, they will not match when you print your drawing.

Turning off plot style tables

When you turn off plot style tables, objects print according to their own properties. However, all of the
plot style information is saved so you can easily turn on plot styles again. Actual plot style table files
are not deleted, and for drawings that use named plot style tables, objects and layers retain their

assigned plot styles.

To turn off plot style tables

If necessary, click the desired Layout tab, or click the Model tab.
Choose File > Plot from the main menu.

Under Plot Style Table (pen assignments), select None.

P w e

Select Save Changes to Layout, and then click Apply to Layout.

12.2.4. Plot Files to Other Formats

Plots files of various formats, including DWF, PDF, PLT and other files. You can output drawings in
any image formats with unique plotter driver. In such cases, Non-system plotter driver will be
configured as output file format. Users are capable of controlling customized properties of each
non-system plotter driver in plotter configure editor. You can also obtain specific help for each driver

from the Help topic in plotter configuration editor.
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Raster File Formats

Several raster file formats, including Windows BMP, TIFF, PNG, TGA, SVG and JPEG are supported
by the non-system raster driver. The raster driver is most commonly used when a plot to files for

desktop publishing.

Plot Adobe PDF Files
Adobe PDF file can be created from drawing using PDF driver.

DWF

Export ZWCAD drawings as Web DWF formats using DWFOUT or PLOT command. As a two
dimensional vector file, DWF publishes ZWCAD drawings on Web or Intranet network.
DWF file supports real-time panning or scaling and controls how the layers and named views are

displayed.

To export a drawing to a DWF file

1. Choose File > Plot from the main menu.

2. Choose DWF6 ePlot.pc5 for the Name option from the Printer/plotter area on the
Plot dialog box.
Click OK.

4. Specify the location and the name for the DWF file in Browse for Plot File dialog
box.

5. Click Save.

DWFx

Export ZWCAD drawings as Web DWFx formats using DWFOUT or PLOT command. As a two
dimensional vector file, DWFx publishes ZWCAD drawings on Web or Intranet network.
DWFx file supports real-time panning or scaling and controls how the layers and named views are

displayed.

To export a drawing to a DWF file

1. Choose File > Plot from the main menu.

2. Choose DWFx ePlot(XPS Compatible).pc5 for the Name option from the
Printer/plotter area on the Plot dialog box.
Click OK.

4. Specify the location and the name for the DWFx file in Browse for Plot File dialog

box.
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5. Click Save.

EPS

EPS format is housed PostScript file, a drawing file can be exported as EPS file using PLOT command.

PostScript file formats are most available for desktop publishing applications. With plotting capability of
high resolution, this file format is suited for raster images, such as GIF, PCX, and TIFF. Once you have

converted the drawing into PostScript format, you can use PostScript font.

To export files as EPS from layout tab, you should execute from "File-Plot" menu to start the Plot dialog
box. Choose ZWCAD Virtual Eps Plotter 1.0 from the Name pull-down list in Printer/plotter area, and
then click OK to close the Plot dialog box. Next, the Browse for Plot File dialog box opens, in which
users can specify the saving path and file name, and save the file with extensions .eps.

Controllable Properties of PostScript

When exporting drawing as EPS files in PostScript format, some objects will be rendered. Affects the

following properties:

Text, attribute definitions and attributes. If replace the font supportive of PostScript with the font with
specified conversion text object, the text will be plotted in specified PostScript font. Or else, render the
text with frame character.

Bold font and text control code. If the text with thickness over 0 or contains control code (such as %%0O
or %%D). But the rendered text will not be plotted as PostScript font. International symbol and special
symbol exported as PostScript font.

ISO 8859 Latin/l character set, if use character value among 127 to 255 for text, explain this text
according to ISO 8859 Latin/1. If this character appears in the text reflected PostScript, re-mapping a
version of generating code vector to display ISO character set. The text generated from re-mapping will
be exported in PostScript compatible format.

Circle, arc, ellipse, elliptic arc. Arcs and circles will be converted into corresponding PostScript path
object if they have thickness.

Fill solids. Plot the Fill solids in PostScript path.

2D polyline. Exports the 2D (planar) polyline with unifying width, PostScript restricts system settings as

proximate lines combination with end seal and miter.

SVG

The SVG (Scalable Vector Graphics) file format can be selected from the Add-A-Plotter Wizard. Users can
plot their drawings to SVG file format to create an interactive vector graphics for the web design or the

other specific workflows that require SVG files

To export a drawing to a DWF file
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Choose File > Plot from the main menu.

Choose .pc5 for the Name option from the Printer/plotter area on the Plot dialog
box.

Click OK.

Specify the location and the name for the DWF file in Browse for Plot File dialog
box.

Click Save.

Plot Adobe PDF Files

Adobe PDF file can be created from drawing using PDF driver.

Portable Document Format (PDF) is a standard of the electronic file change. The PDF file can be used

on any system operation like Windows, Unix and so on. More and more document is using PDF now,

such as e-books, product introduction, network information, e-mails. PDF has become a standard for

digitized information.

Note: The Adobe Reader R7 or higher version is needed on view the published PDF file. The version
9.3 is needed for Microsoft Windows 7.

Steps for PDF printing:

Choose File > Plot from the main menu.

Choose DWG To PDF.pc5 for the Name option from the Printer/plotter area on the
Plot dialog box.

Click OK.

Specify the location and the name for the PDF file in Browse for Plot File dialog
box.

Click Save.

Steps for adding PDF plotter

A

o

The drawing can be published as PDF file format if you adding PDF plotter though
Add plotter wizard. Steps for adding PDF plotter as follow:

Select File > Plotter Manager from the main menu.

Select Next after you read the introduction in Add Plotter - Introduction Page.
Select My Computer from the Add Plotter - Begin page, and click Next.

In Add Plotter - Plotter Model page, select Adobe PDF from Manufactures option
and select PDF from Models option. Click Next to continue.

Activate the Plot to File check box from Add Plotter - Ports page, and click Next.

In Add Plotter - Plotter Name page, input your configuration file name, or use the

default name and click Next.
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8. Click Finish in Add Plotter - Finish page to finish your adding.
9. The new Plot Configuration file (PC5) is set up.

PLT&PRN

With the PLTPLOT command, you can perform batch plot function to print multiple PLT or PRN files

at one time in a specified printer.

Select PLT files or PRN files by clicking the Add Sheets button on the Batch Plot dialog box to set the
files you want to plot. Besides, you can also save the files listed in the current plot file list as a ".TXT"
file by using the Save Sheet List button on the Batch Plot dialog box, and then you can load the
saved. TXT file to add all the files it includes to the current list in the future.

The plot list displays name and path of the file, the PLT file or PRN file will be displayed together with
its saving path. While the TXT file will be displayed without its file path.

Before batch plotting, you can set all the files in the plot list, and also selective plot part of the files
from the plot list.

12.3. Publish Drawings

Publish multiple files to a separate single-sheet or multi-sheet PDF, DWF file or a printer in order to
save and plot files. The paper name and page setup will be displayed as soon as you select files to the
file list. Here, the paper name refers to the name of the drawing to be plotted, with a dash joining the
drawing name and layout name, page setup column displays the named page setup of layouts. You can
click the page setup to select another page setup from the dropdown list. The model tab and layout tab
are only applied to the corresponding tab.

You can optionally click on the model tab and layout tab in Add drawings include an option in the
course of importing files into the drawing list. And assemble a collection of drawings to publish and
save the list as a Drawing Set Descriptions (DSD) file. A DSD file is created for illustrating these

drawing files list and selected layout list.

In the Publish dialog box, users can define the way to publish file list. You can choose to publish to
Plotter named in page setup, DWF or PDF.

12.3.1. Publish to Plotter named in page setup

Plots all the drawing files on the published list. You can set plot copies after publishing drawings to a

specified plotter.
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12.3.2. Publish to DWF/PDF

Generates the drawing files that are published to the file list and saves them as a single-sheet or
multi-sheet DWF, PDF file, and specifies the saving path for the output DWF or PDF file in the Publish
Options dialog box.
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13.Share Data with Others

13.1. Save and View Slides

You can save slides of a drawing to view later. A slide saves the current drawing in *.sld format exactly
as it appears on the screen. A slide is not a drawing file. You cannot edit or print the slide; you can only

view it.

You can use slides in the following ways:
e  Make presentations by showing slides of your drawings.
e Reference a slide of a drawing while working on a different drawing.

e Present a number of slides as a slide show by using scripts.

When you view a slide, it temporarily replaces the current drawing. When you refresh the display of
the current drawing (by redrawing, panning, zooming, minimizing, maximizing, or tiling), the slide
image disappears, and you are returned to the current drawing. A slide does not include any invisible

entities on layers.

To create a slide

1. Type MSLIDE and then press Enter.
2. Inthe Create Slide File dialog box, specify the name of the slide file you want to create.
3. Click Save.

Mslide
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To view a slide

1. Type VSLIDE and then press Enter.
2. Inthe Select Slide File dialog box, specify the name of the slide file you want to view.

3. Click Open. ZWCAD displays the slides in the current drawing window.

v HELCOEEE=HE

Vslide

13.2. Link and Embed Data

You can include data from other programs in ZWCAD drawings by using either embedding or linking.
The method you choose depends on the type of object or file you want to include in your ZWCAD

drawing and what you want to do with it after it is there.

13.2.1. Overview of Object Linking and Embedding

The Object Linking can be used for merging data from different applications into a document. For
example, you can create ZWCAD drawing with a Microsoft WORD document included, and also
create an Adobe PageMaker layout containing ZWCAD drawings.

To use OLE, ensure your system supports OLE server and container applications. Source applications
which are called server mainly used for creating embedded or linked OLE objects. Target applications
are a container used for accepting OLE objects. ZWCAD uses OLE as server and container

applications.

Even if ZWCAD objects such as circle or blocks are always taken as OLE objects, they can be varied
393



ZWCAD User Guide

in meaning.

Link and embed information by inserting a document into another, meanwhile, edit objects in container
applications using links and embed OLE objects. However, varied in storing information, the
relationship between linking and embedding is similar to that of inserting blocks and creating xrefs in
ZWCAD drawing.

Embed Objects

The embedded OLE objects come from copies of other documents when embedding objects into files,
the embedded objects have no relations with the original document, they are not updated by changing

the current drawing.

You can execute from "Insert-OLE Object" menu, and select Create from File without clicking on the
Link option to embed objects. Once you have embedded OLE objects into the drawing, you can create
applications of the object for editing, and the original OLE object keeps unchanged while you editing

information of the source document.

Insert Object X

(O Create New )
File: Cancel

(® Create from File C:\Users\Administrator\Documents ‘

Browse... [] Link
[] Display As lcon

Result
Inserts the contents of the file as an object into

i M your document so that you may activate it using
ﬂ the program which created it.
Insert OLE Object

Link Objects

When inserting OLE objects, if you select Create from File and click Link option as well, you can
insert the linked OLE object into ZWCAD drawing. Linking objects is a type of reference to the

information of another document. To use a link object for the same information in multiple documents,
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you just modify the source object and perform OLELINKS command to set automatic or manual

update document containing OLE objects.

You should keep accessing the source document and linked document. If a move or rename the source

object, you should rebuild links in the link file.

13.2.2. Import OLE Objects

Inserts information of other applications that support OLE objects.
ZWCAD provides two ways of inserting OLE objects: embed and link. With the different that a link

can be updated whenever you want, embedding is unable to update because of lack of links.
You can use the following method to control the visibility of the inserted OLE objects:

Insert OLE objects to the drawing on the current layer. Turn off the layer or freeze it to disable

displaying OLE objects in the layer.

To embed an object from an existing file within ZWCAD

1. Choose Insert > OLE Object from the main menu.
2. Inthe Insert Object dialog box, click Create From File.
3. Specify the file by doing one of the following:

a) Type a path and file name in the File box.
b) Click Browse to select a file.
4. Select Display As Icon if you want that program's icon to appear in the drawing instead
of the data.
5. Click OK.

To create a new embedded object within ZWCAD

1. Choose Insert > OLE Object from the main menu.
2. Inthe Insert Object dialog box, click Create New.
3. From the Object Type list, select the type of object you want to create, and then
click OK.
4. The program for creating that object opens within ZWCAD.
5. Create the object in the other program.

6. Choose File > Exit to close the program.
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Link OLE Objects in Drawings

If another program supports ActiveX, you can link its data to ZWCAD drawings. Use linking when
you want to include the same data in many files. When you update the data, all links to other files

reflect the changes.

When you link data from another program, the ZWCAD drawing stores only a reference to the location
of the file in which you created the data. You link data from a saved file, so ZWCAD can find the data
and display it.

Because linking adds only a reference to a file, the data does not significantly increase the file size of
the ZWCAD drawing. However, links require some maintenance. If you move any of the linked files,
you need to update the links. In addition, if you want to transport linked data, you must include all
linked files.

You can update a linked object automatically every time you open the drawing, or you can do so only
when you specify. Anytime a link is updated, changes made to the object in its original file also appear
in the ZWCAD drawing, and the changes also appear in the original file if they were made through
ZWCAD.

Insert an OLE object together with links to update its displaying in drawings through changing source

objects. For example, you may be required to insert a time table into an automatic update drawing.

When inserting OLE objects, you can display the object as an icon, thus you can activate applications

which are supportive of this object by double clicking this icon.

To create a linked object from within ZWCAD

1. Choose Insert > OLE Object from the main menu.

N

In the Insert Object dialog box, click Create From File.
3. Specify the file by doing one of the following:
a. Type a path and file name in the File box.
b. Click Browse to select the file using a file dialog box.
4. Select the Link check box.
5. Select Display As Icon if you want that program's icon to appear in the drawing
instead of the data.
6. Click OK.

Update Links

Display the links contained in current drawing in the Links dialog performed from OLELINKS
396



ZWCAD User Guide

command. With this command, you can setup methods to update links for each setting used for linking

information, either automatic or manual.

By default, the OLE links created in ZWCAD drawing are an automatic update.

Reconnect Links

Source refers to the position where the linked documents are located. Once the position of the
document is changed or renamed, the link source must be changed as well. When replacing information

or objects with links contained, the link source should be changed also.

Break Links

Select Break links option in Links dialog box, OLE objects in ZWCAD drawing will not be removed

rather than its links. Thus, the OLE object never updates when changing its source.

To link a file to a ZWCAD drawing

1. Save the original file. Because a link consists of a reference to the original file, you
must save the file before you can link to it.

2. Inthe original file, select the data you want in the ZWCAD drawing.

3. Choose that program's command to place data on the Clipboard. Usually, you
choose Edit > Copy from the main menu.

4. Display the ZWCAD drawing to which you want to link the file.

5. InZWCAD, choose Edit > Paste Special from the main menu.

6. Inthe Paste Special dialog box, select Paste Link.

7. Click OK.

Embed OLE Objects in Drawings

Embed an object into your ZWCAD drawing when you want to keep all the data you work with in one
file or if you want to transfer the file to other computers. You can embed data from programs that

support object linking and embedding.
When you embed data from another program, ZWCAD becomes the container for that data. The object

embedded in the ZWCAD drawing becomes part of the ZWCAD file. When you edit the data, you
open its program from within the ZWCAD drawing.
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Any changes you make to the embedded data exist only in the ZWCAD drawing, so it is not necessary
to keep that data in a separate file. If the data does exist in a separate file, the original file does not
change when you modify the embedded object in ZWCAD. Also, changes to the original file do not
affect the embedded object in the ZWCAD drawing.

To embed another program's object into a ZWCAD drawing

1. Open the file that contains the data you want.
2. Inthe file, select the data you want to embed in the ZWCAD drawing.
3. Choose that program's command to place data on the Clipboard. Usually, you
choose Edit > Copy from the main menu.
4. Inthe ZWCAD window, display the drawing in which you want to embed the object.
5. Choose Edit > Paste from the main menu, or click the Paste from Clipboard tool on
the Standard toolbar.
6. The data on the Clipboard is pasted into the drawing as an embedded object. The
object appears in the center of the view, but you can select and move it by moving the

cursor.

The OLE objects that are supportive of other applications will not be updated along with the objects in

source document when embedding into ZWCAD drawings.

ZWCAD provides various methods to embed drawings: such as copy the object to the clipboard, paste
it to ZWCAD drawing files, and then embed it to ZWCAD drawing. You can embed a company icon
created by other applications into ZWCAD drawings.

With the embedding feature, you can also embed OLE objects into ZWCAD drawings without
specifying links. A .txt file will be changed into mtext once embedded into the drawing, with its file
name displayed together.

Once embedded into current drawing, you can adjust the object's size according to the proportion of

drawing unit. And also scaling text that is included in OLE objects by specifying point size.

Drag Objects into a Drawing

If you want to link data and drawings to ZWCAD drawings from other applications, besides inserting
OLE objects, you can drag the selected data or drawings into ZWCAD. Both applications must be
running and visible on your screen. To drag information between applications, the other applications

must support ActiveX. Objects dragged into a drawing are embedded, not linked.

As manipulating for cutting and pasting, you do the dragging in the same way. The information is

removed from one document and pasted into the other document when you do the dragging. Holding
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down CTRL while dragging creates a copy of the information without affecting the original document,

as you do copying and pasting in the same way.

Control Objects' Quality

Default quality level of the OLE objects is determined by system variable OLEQUALITY. To illustrate
plotting effects, the quality here is divided into five grades: line quality, text quality, graphics quality,
photo quality and high photo quality.

In which line quality is the lowest grade, plots the drawing in the shortest way and occupies the least

memory. While high photo quality plots the drawing in a longer way and occupies more memory.

Limits for Inserting OLE Objects

ZWCAD set some limits when linking or embedding the OLE objects. All these inherent limits are
used for designing OLE objects.

OLE objects are not displayed or plotted on xrefs or block references.

Modifications made for plotting rotation are not reflected on OLE objects when using Microsoft

Windows system plotter. Change plot orientation in Windows Plotting system configuration dialog box.

ZWCAD limits the size of the spreadsheet that is imported as OLE object. If import too large a
spreadsheet, you can reduce the column width and row height, and reduce the font size or partly paste
the spreadsheet so as to divide the OLE objects into several objects in smaller size. Before importing

OLE objects into other applications, use Windows copyclip viewer to preview OLE object.

13.2.3. Export OLE Objects from Drawings

Export ZWCAD drawings into other applications that are supportive to OLE objects, and then embed

the objects of the drawing into other documents.

Select objects in ZWCAD drawing, and hold CTRL+C or use other copy commands to copy selected
objects, paste or selective paste the copies using copy commands of other applications to embed them
from the ZWCAD into other documents.

Embedding places a copy of the selected objects in the destination document. The object in the original
drawing will not update when you edit the OLE object from within the destination document in a
ZWCAD drawing.
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Dragging ZWCAD drawings into other programs

If the other program in which you want to include ZWCAD drawings is compatible with ActiveX, an
alternative to pasting drawings with menu commands is to drag drawing file icons from Windows
Explorer into the other document. Dragging and dropping drawings does not use the Clipboard, so data

on the Clipboard is not affected.

When you drag a ZWCAD drawing file from Windows Explorer, you link or embed the entire drawing

in the other document. When you drag the file, the cursor changes in response to the action you take.

TIP Before you drag a drawing, position the Windows Explorer window and the other program's

window so you can see the file icon and the document in which you want to drop it.

To drag and embed drawings into another document

Select the icon for the drawing file, and then drag the drawing into the document.

13.2.4. Edit OLE Objects in Drawings

You can modify an embedded or linked object in its original program from within ZWCAD. When you
modify an embedded object, you change the object only in ZWCAD, not its original file (if you pasted
the object from an existing file). When you modify a linked file, however, you open and change the

original file.

Double-click the OLE object to start server applications in which you can edit the OLE objects.
ZWCAD provides two ways to edit OLE objects: one is to link or embed OLE objects which are
supportive of other applications into ZWCAD drawings, or you can embed ZWCAD drawings into

other applications.

Embed ZWCAD drawings into Other Applications

When you want to embed ZWCAD drawings into other applications, you use ZWCAD objects as the
OLE objects while ZWCAD applications are taken as server applications. In the target application,
which is so-called container applications, double clicking the inserted OLE objects to start ZWCAD
application and modify OLE objects. Once you have changed OLE object, only the target application
displays its change, the source OLE object is not changed.
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Link or Embed OLE Objects supportive of other Applications into ZWCAD

When you link or embed OLE objects that are supportive of other applications into ZWCAD, ZWCAD

applications are used as container applications.

If you select objects of ZWCAD using frame selection, the inserted OLE object overlapped with
ZWCAD objects. But the objects to be selected are only provided in ZWCAD, not OLE objects.
Additionally, the edit and snap mode take no effect on OLE objects. To adjust and scale the size of the
OLE objects, you should edit these objects using grips displayed on them.

When you right click on the OLE object, a shortcut menu will be displayed with some editing
properties such as Cut, Copy, Delete object and On.

13.2.5. Embed Drawings

When you embed a ZWCAD drawing, it becomes part of the other program's document file. When you

edit the drawing, you edit only the version that is embedded in the other document.

Embedding is useful when you don't want to maintain a link to the ZWCAD drawing for the data you
include in the other document. Edits made to the new drawing do not affect the original drawing. To
transfer the file to other computers, you can transfer all the data in one file, but embedded objects

increase the file size.

From within a document in a program that supports ActiveX, such as Microsoft® Word, you can either

create a new embedded ZWCAD drawing or embed an existing ZWCAD drawing.

To create a ZWCAD drawing in another document

In the document, choose Insert > OLE Object from the main menu.

In the Insert Object dialog box, click Create New to create a new file.

Under Object Type, choose ZWCAD Drawing, and then click OK.

Create the ZWCAD drawing.

Choose File > Exit from the main menu in ZWCAD.

6. To edit the ZWCAD drawing from within the document, double-click the drawing.

ok W e

TIP You can also embed an existing ZWCAD drawing from within another document.

To embed selected ZWCAD entities

1. InZWCAD, select the entities you want to embed.
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2. Choose Edit > Copy from the main menu (or press Ctrl+C).
3. Open the document in which you want to embed the entities.

4. Choose Edit > Paste from the main menu (or press Ctrl+V).

To embed an entire ZWCAD drawing

Open the document in which you want to embed the drawing.
Choose Insert > OLE Object from the main menu.

Click Create From File.

Click Browse, and then choose the file you want to embed.
Click Insert, and then click OK.
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13.2.6. Link Drawings

When you link a ZWCAD drawing to another document, the other document contains only a reference
to the ZWCAD drawing file, rather than the actual drawing. You link data in a saved ZWCAD file so
that the other program can find the data and display it.

Linking works well when you want to include the same ZWCAD data in more than one document.
When you update the data, you need to update it in only one location. The versions that are linked to

other documents reflect the changes automatically.
Linking a ZWCAD file to another document does not increase the file size the way embedding a

ZWCAD object does. However, links require more maintenance. To transport the data, you must make

sure to transfer all linked files to the other computer.

To link a ZWCAD file to another document

1. Open the drawing you want to link.

NOTE Because a link is a reference to a file, you can link only files that are saved to a
location on a disk.

2. In the other program, open the document in which you want to include the
ZWCAD drawing.

Choose that program's command for inserting objects.

4. In Microsoft® Office programs, choose Insert > Object. In the Object dialog box,
click the Create From File tab. Specify the name of the drawing file you want to
link. Select the Link To File check box, and then click OK. The drawing appears in
the document, with a link to the original ZWCAD file.
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13.3. Work with Data in Other Formats

You can work with many different types of files, including files created with other applications.

13.3.1. Import Files Created in Other Formats

To open and use drawings or graphics generated with other applications in the specified format.
ZWCAD supports mutual conversion between DXF and WMF format. Use the commands relative to
each file types to convert formats among them. You can also convert formats by opening or import
files.

ZWCAD supports the input file format containing: DXF, DWG, DWT, SAT, WMF. In which, DWG,
DXF, DWT are imported using Open command. DXF refers to drawing exchange format, DWG refers
to standard drawing file, and DWT refers to template drawing file. The additional SAT and WMF file

should be imported by relevant commands.

Import DXF Files

As a drawing exchange file, DXF file contains text file of drawing information, which is also an
expression of ASCII or binary system of drawing file. Mainly used for sharing drawing data among

applications.

Select a DXF file from the Files of Type dropdown list to import this file into applications when

performing an Open function in ZWCAD. You can import it into other drawing files and explode it.

To import a DXF or DWT file

Choose File > Open from the main menu.

Choose the folder that contains the drawing.

In Files of Type, choose the type of drawing you want to import.
Choose the file you want to open.

Click Open.
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Import ACIS SAT Files

You can import geometry objects stored in SAT (ASCII) files using ACISIN or IMPORT commands.
SAT (ASCII) files store entities as solids, regions or ACIS. ZWCAD converts the model to a body

object or to solids and regions if the body is a true solid or a true region. After the conversion, ZWCAD
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creates new objects using its ShapeManager modeler and performs 3D operations and solids editing.

To import an ACIS file

Choose Insert > ACIS File from the main menu.
Choose the directory containing the SAT file.
Choose the SAT file you want to open.

Click Open.

Command line ACISIN
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Import WMF Files

As a Windows metafile format, WMF files are frequently used to produce clip art and other
non-technical images that you need for drawings. Use WMFIN or IMPORT command to insert a WMF

file into a drawing file as a block.

To be different from bitmaps, WMF files contain vector information that can be resized and printed
without losing resolution. If 2D solids or wide lines are contained in the WMF file, turn off their
display so as to increase drawing speed.

Both vector and raster information can be contained in WMF files. However, ZWCAD uses only the

vector information from a WMF file. ZWCAD ignores the raster information if using a WMF file

containing raster information.

13.3.2. Export Drawings to Other File Formats

Export and convert ZWCAD drawings as other file formats. ZWCAD supports the output file format
containing: WMF, DXF, BMP, DWG, DWT, PDF, EPS, DWF, SAT.

WMF

Exports drawing files as element files (.wmf) using WMFOUT or EXPORT command. As a Windows
metafile format, WMF file includes lots of vector drawings or raster images. Generally, ZWCAD

creates WMF files in vector drawings which are easy to pan or scale.

DXF

As a drawing exchange file, DXF file contains a text file of drawing information that is accessible for
404



ZWCAD User Guide

all the other CAD systems. If someone else is using CAD applications capable of identifying DXF files,

you can share the drawing by saving the drawing as DXF file.
The user can export files as DXF format using Save or Save As command, select DXF file format from
the Tools button of the Export dialog box when saving the drawing as DXF format. DXF files are also

saved as ASCII or binary format.

Specify precise decimal digits as you saving drawing as DXF file, controls floating-precision up to 16

digits for DXF files. You can also click Select Object option to save some objects as DXF file.

BMP

As bitmap file format, BMP is a kind of raster image format. The object displayed on the screen
together with colored viewport and objects in the rendered viewport will be displayed in raster images

as well.

Export the entire drawing or partly export the drawing to device-independent raster images using
EXPORT command.

To export a drawing to a BMP file

1. Choose File > Export from the main menu.

2. Inthe Export Data dialog box, under Files of Type, choose the Bitmap (*.bmp) file
format.
Specify the name of the file you want to create.

4. Click Save.

Select the objects you want to save, and then press Enter.

DWG

DWG is standard drawing file format generally supported by CAD software.

DWT

You can export drawings as DWT template file using Save or Save As command.
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PDF

The PLOT command is available for exporting the drawing as a PDF file.

PDF files allow you to distribute your drawing to others for viewing in Adobe® Acrobat ® Reader®,
which is free software that users can download. PDF files can also be viewed, reviewed, and edited in
Adobe® Acrobat.

To export a drawing to a PDF file

1. Choose File > Plot from the main menu.

2. Choose DWG To PDF.pc5 for the Name option from the Printer/plotter area on the
Plot dialog box.
Click OK.

4. Specify the location and the name for the PDF file in Browse for Plot File dialog
box.

5. Click Save.

EPS

EPS format is housed PostScript file, a drawing file can be exported as EPS file using PLOT command.

DWF

Export ZWCAD drawings as Web DWF formats using DWFOUT or PLOT command. As a two
dimension vector file, DWF publishes ZWCAD drawings on Web or Intranet network.

SAT

Exports solids, regions, ACIS entities as SAT format using ACISOUT command. Additionally, trimmed
ShapeManager objects of the NURBS face, region and 3D solids are also exported as SAT file.

To export an ACIS file

Choose File > Export from the main menu.
Select the ACIS entities you want to save.
Specify the name of the file you want to create.
Click Save.

e
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13.3.3. Work with Proxy Objects

When the Runtime Extension application that created the custom object is not available to ZWCAD or
other host applications, a proxy object is used as a substitute for a custom object. Later, the custom

object replaces the proxy object if the application is available to ZWCAD.

As compared to corresponding custom objects, Proxy objects are endowed with significantly reduced
capabilities. The extent to which proxy objects can be edited is determined by the parent Runtime
Extension application. For example, to determine whether to erase and move an object or change object

properties, may or may not be possible on a proxy object, depending on the application that created it.

A Proxy Information dialog box will be displayed when you open a drawing. Which shows the total
number of proxy objects in the drawing (both graphical and non-graphical) and the name of the
missing application and provides additional information about the proxy object type and display state.

You control the display of proxy objects with the dialog box.

Edit Proxy Objects

Proxy objects are enabled to be access, display, and also to perform the following manipulations:
e Erase proxy objects
e Quick select proxy objects
e Define block reference with proxy objects, insert drawings and block references with proxy
objects, and explode.
e Export and plot preview proxy objects
e Edit operations such as MOVE, COPY, MIRROR, etc.

13.4. Package Files for Internet
Transmission

With the application of etransmit, you can accomplish transmitting drawing files together with their
associative files through the Internet in forms of transmittal packages. The associative files included in

the transmittal package are xrefs, fonts, raster images, etc.

Generally, all of the included files such as xrefs, raster images, and fonts will be ignored when you
sending drawings to others. The receiver may not be able to display the transmitted drawing because of
lacking these associative files. Using etransmit can help preventing such circumstances and decrease

the error probability to a certain extent.
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13.4.1. Select files to pack

Starts Create Transmittal dialog box, which provides two tabs for viewing and selecting files to be

packed.

Files Tree:

Displays drawing files in a tree structure together with their associative files (xrefs, fonts,
raster images). You can expand or collapse this structure to display or hide the included
dependent files. By default, drawing files and dependent files are included in the transmittal
package automatically. Unless you deselect it by clicking on the check mark in front of each
file.

Files Table:

Displays drawing files in forms of a list together with their associative files (xrefs, fonts,
raster images). In which the detail information of each file such as file name, saving path, type,
version size and date are listed. Transmittal package includes all these files automatically. You
can deselect it by clicking on the check mark in front of each file in order to control the

included contents of each transmittal package.

Once you have performed the eTransmit function for a drawing file, the common file types you can

automatically add to the transmittal package are:

*.dwg (root drawing file and all of its attached xrefs)

Various image file types (raster image files that attach to root drawing or xref externally)

* fmp (font mapping files)

User select or deselect files having been added into the transmittal package by clicking at the
check box in front of the file or manually select files you want to include in the transmittal
package by clicking at the Add File button on Files Tree or Files Table.

The common file types that are not automatically added to a transmittal package are:

* shx (Compiled shape files used for text styles or complex linetypes)

* ttf (True Type font files used for text styles)

All these files generally contain information about the object in initially formatted drawings or some

specific information of applications run with the product, the receiver can still normally view the

transmitted drawing in spite of lacking these files.

13.4.2. Include notes in transmittal package

The report file is automatically generated while generating transmittal package and saved in the

transmittal package together with the files list of the transmittal package as well. Meanwhile, this
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report includes dependent files associative to the drawing file (such as xrefs, fonts) as well as
instructions about how to process these files so as to enable using for included drawing files. The
information that user input in the Enter notes to include with this transmittal is also included in the

report file.

13.4.3. Select Transmittal Setups

Once created a transmittal package, you can create new or modify existing transmittal setup and save it
so that you select it properly from the transmittal setup list on Create transmittal dialog box as you
need when next time you create transmittal package. System default transmittal setup is named as
STANDARD, for which you can change its default settings, but unable to perform rename or delete

operation.

13.4.4. Choose Transmittal Options

You can specify the following transmittal setups when creating transmittal package, which greatly
facilitates using the etransmit function.
e Specify transmittal package type to be created as ZIP file, self-extracting EXE file, and folder
(a specified folder position where the drawing will be packaged or copied)
e Choose options among Use organized folder structure, Place all files in one folder, Keep files
and folders as is, to organize folder structure of transmitted files in a logical structure.
e Add password protection for transmittal package of the ZIP file and self-extracted EXE.
e Select Include fonts option to get all the font files associative to transmittal package (TTF and
SHX), which facilitate receiver to view the drawing file.
e Send the transmittal package and transmittal report in form of an e-mail attachment to relevant

users.
It should be noticed that, regardless of file structure included in the created transmittal package,

absolute path of dependent files that are relative to the drawing file will be converted to a relative path

or not include path, so that you can easily find them while opening or editing drawing files.

To create transmittal package in the specified folder

1. Select File > etransmit from the main menu.

2. Inthe Create Transmittal dialog box, under Files Tree or Files Table area, click Add
File button.

3. In the Open folder, select the file to be added to the transmittal package, and
then click Open. The user can optionally repeat this procedure to add more files

into transmittal package.
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10.
11.

12.

To clear the selection of files being added into the transmittal package, click the
check box marks beside any files on the Files Tree or Files Table.

Click the Transmittal Setups button, select a transmittal setup from the
Transmittal Setups dialog box, and then click Modify button.

In the Modify Transmittal Setup dialog box, set the transmittal package type as
Folder (set of files).

Under Transmittal File Folder, click Browse to specify the folder where the
transmittal package to be created. A standard file selection dialog box is
displayed.

Select the folder where the transmittal package will be created, and then click OK.
In the Modify Transmittal Setup dialog box, click OK to close the dialog box.

In the Transmittal Setups dialog box, click Close.

(Optional) Specify any additional comments to include with the report file from
the text box for Entering notes to include with this transmittal package in Create
Transmittal dialog box.

Click OK to create the transmittal package in the folder you specified.

To create transmittal package for self-extracting executable or ZIP file

10.
11.

12.

Select File > etransmit from the main menu

In the Create Transmittal dialog box, under Files Tree or Files Table area, click Add
File button.

In the Open folder, select the file to be added to the transmittal package, and
then click Open. The user can optionally repeat this procedure to add more files
into transmittal package.

To clear the selection of files being added into the transmittal package, click the
check box marks beside any files on the Files Tree or Files Table.

Click the Transmittal Setups button, select a transmittal setup from the
Transmittal Setups dialog box, and then click Modify button.

In the Modify Transmittal Setup dialog box, set the transmittal package type as ZIP
(*.zip) or Self-extracting executable (*.exe).

Under Transmittal File Folder, click Browse to specify the folder where the
transmittal package to be created. A standard file selection dialog box is
displayed.

Select the folder where the transmittal package will be created, and then click OK.
In the Modify Transmittal Setup dialog box, click OK to close the dialog box.

In the Transmittal Setups dialog box, click Close.

(Optional) Specify any additional comments to include with the report file from
the text box for Entering notes to include with this transmittal package in Create
Transmittal dialog box.

Click OK to create the transmittal package in the folder you specified.
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To unpack a self-extracting executable transmittal package

1. Double-click the transmittal package file in Windows Explorer.

2. In Extractor dialog box, select Browse to specify the folder where you want to
unpack the transmittal files.
Click OK.

4. If the transmittal package is password protected, system prompt for entering the
password.

5. Click OK to close each dialog box.
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14.Programming ZWCAD

ZWCAD supports almost the same list of APIs as does AutoCAD. You can easily port your plugins or
add-ons to ZWCAD.

LISP Provided in Std and Pro and it should run correctly in ZWCAD
without any modification

VBA Provided in Pro only, support 32/64bit

ZRX Provided in Pro only

NET Provided in Pro only

You can get the transferring documents from https://www.zwsoft.com/zwcad/download-center/

14.1. About LISP

LISP is a full-featured, interpretive programming language (full name List Processor, which is list
processing language). It is a sort of independent programming language embedded for ZWCAD
customization. LISP greatly extends most of the available commands and functions of ZWCAD. LISP
is similar to AutoLISP so that you can use the majority of applications written with AutoLISP in
ZWCAD.

A LISP command stands for a function. Lisp function can perform the following actions:

e Load other LISP, DCL, ZDS application or ZWCAD files

e Prompt user to do relevant operations in the certain situation

e Execute standard command in ZWCAD

e Handle character string with arbitrary length

e Do mathematic calculation

e  Store variable value used lately

e Read/write file

e  Test and respond to the given condition.

e The select entity in drawing session.

e  Modify the selected entity in drawing session.

e  Export relevant information into the screen or a file.
You can produce customize resolution with application comprised of compound variant LISP functions.
You can automate your job by extending CAD tools in ZWCAD or apply other applications into
ZWCAD. LISP can be used to produce any application you need in the special industries to intensify
the CAD platform.
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14.1.1. Application of LISP expressions

LISP has its particular functions and syntax. LISP codes are capable of tested directly without
preparing extra procedure. Two syntaxes are provided in LISP. The first one puts the operator in front
of the operating number, in which operators can be taken as functions with specific features, and the

operating number is processed by functions. Each statement is separated by a blank.

The second syntax divides the statement into two items within each bracket: function name as the first

item and the parameters or variables of the function is the second item.

14.1.2. Create a LISP program

Steps to write an application using LISP:

Open a text edited window such as NOTEBOOK.
Write code in the text edited window.
Save the new code file with the desired path and file name from File > Save As menu option.

The extension name is Isp.

14.1.3. Verify the code input.

The following properties are contained in LISP functions:

e The codes are displayed in indent mode as other program languages do, but take no effects on
performing programs.

e Newline is used to facilitate understanding and reading, and place multi-row codes in one line,
which does not affect performing the program.

e  All LISP statements are contained in the brackets which always appear in pairs.

e If multiple brackets pairs are contained in a statement, execute from the interior bracket.

e Text in codes appears behind the semicolon is a kind of annotation. Any text with a semicolon
in front will be ignored by programs.

e All LISP functions return value to the other functions that invoke them. By default, the value
is calculated by the last expression. Generally, the function princ without character string
parameter follows the function that its name precedes with a prefix "c:". This function is

aimed at exiting the program without returning any value.

14.1.4. Load and Run LISP Program

LISP program is available only after loading, while how to apply a LISP program relies on the program
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itself. If functions are created in programs, it can be performed just like executing commands in
ZWCAD. Most of the LISP functions are provided with prompts instructing how to use them. You can
load LISP program to ZWCAD before executing this program as performing APPLOAD command.

14.1.5. Lisp Debugger

Activated by command VLIDE or VLISP, Lisp Debugger is used to debug lisp programs. Developed
based on Visual Studio Code from Microsoft™, it enables developers to debug their lisp programs with

breakpoint inspection and modify it easily.

What’s more, if users have already installed the Visual Studio Code, they can directly download

ZwLisp in Microsoft Extensions Marketplace.

14.1.6. Remarks

The user can reference LISP documents in "Developer's Help", to view LISP functions as well as
relative tutorials that ZWCAD supports (it's recommended to reference specific instructions from

"Help"-"Developer's Help").

14.2. About VBA

VBA is a kind of programming language including a variety of Microsoft applications program
environment (such as WORD, EXCEL, etc.). Microsoft VBA is a type of program environment for
objects, capable of providing developing function as Visual Basic 6 (VB). The main difference between
VBA and VB is that VBA runs together with ZWCAD in the same process space, and provides

intellective and frequent program environment.

VBA provides application integration for those application programs supportive of VBA. That is to say,
ZWCAD (using other applications database) can be Automation controlling programs such as

Microsoft Word or Excel and other applications.

You should purchase an independent developed version of Visual Basic 6, providing ZWCAD VBA

with extra components, such as external database engine and report forms compiling function.

Four advantages of realizing VBA in ZWCAD:
e VBA and its environment are prone to study and apply.

e VBA is capable of running together with ZWCAD in the same process space and facilitate the
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program operating.

e Rapid and effective construction of dialog box, which enables developers to construct
prototype applications and receive design feedback quickly.

e The project is both independent and embedded supported. Which provides developers with

flexible ways to release their applications.

VBA applications are saved in Projects files. ZWCAD® VBA project is a combination of the code
module, class module, and window. All these modules and windows run together to execute specified
function. The project can be stored in both ZWCAD drawings and also can be stored as an independent
file.

You can open VBA manager through ZWCAD menu option "Tools-Macro-VBA Manager" to view

VBA project in which you are allowed to create, load and close projects.

Open VBA environment
VBA has its own interface environment. You can execute from the menu "Tools-Macro-Visual Basic
Editor" to open the Visual Basic program and display VBA environment window which is short for

IDE, i.e. Integrated Development Environment.

ZWCAD VBA project is a collection of code modules, classes, and forms, here module is self-include
program code segment, and a project is capable of containing multiple modules. These modules and

forms run together to perform given functions.

You can add new modules by selecting "Insert — Module" menu option from the Visual Basic project
window. And next to open module file editor window, in which you can write codes. Meanwhile, a new

module icon will be added to the module list in "Project" window with default name as Moduall.

ZWCAD is running while opening VBA environment, you can toggle to ZWCAD platform from the

last option on "View" menu in VBA IDE.

14.3. About ZRX

ZRX®, the ZWCAD® Runtime Extension programming environment, includes C++ libraries that are
the building blocks you can use to develop ZWCAD applications, extend ZWCAD classes and protocol,
and create new commands that operate in the same manner as built-in ZWCAD commands. You can
add new classes and export them for use by other programs. You can also extend the ZRX protocol by

adding functions at runtime to existing ZWCAD classes.
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14.4. About.NET

ZWCAD .NET API allows you to build managed code that runs under the .NET Common Language
Runtime CLR. To start programming, you can create a project in Visual Studio 2010, add a reference to
ZwManaged.dll and ZwDatabaseMgd.dll which you can find in the installation directory of ZWCAD.
Then specify the version of the framework to .NET Framework 4. Finally, you can start to code and run

your programs.
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15.Appendices

Command Name
| FunctionDescripon |

new

gnew

open

xopen

oleopen
save
gsave
saveas
exit
quit
close
closeall
preview
plot
print
-plot
pagesetup

psetup

psetupin
-psetupin

plotstamp

ddplotstamp
-plotstamp

u

undo

redo

mredo

ai_selall

Create a new graphics file

Create a new graphics file from the current default drawing template file and the
"Options" dialog box "File" tab to specify the folder path

Opens an existing drawing file

Open the selected reference (external reference) for editing in a new
independent window

Opens the selected OLE object

Save the graphic with the current file name or a specified name

Use specified default file format for saving the current drawing

Save a copy of the current drawing under a new file name

Exit Software

Exit Software

Close the current document

Close all documents

This graphic will be displayed when you want to print graphics

The graphic print to a plotter, printer, or file

plot command aliases

Command line command execution plot

Controls the page layout, plotting device, paper size and other settings for each
new layout

Display Configuration "Page Setup Manager" dialog box, set the current graphics
file page layout and printing equipment. Specified page layout settings will be
saved with the

The user-defined page setup into a new drawing layout

Command line command execution psetupin

Placing a stamp and print stamp records in the file specified in the corner of each
graph

plotstamp command aliases

Command line command execution plotstamp

Undo the last operation

Undo command effect

Give up on a resume with effect UNDO or U command

Before restoring a few UNDO or U command with abandon effect

Select all objects
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copyclip
cutclip
pasteclip
copybase

pasteblock

pasteorig

pastespec

options

H#NAME?
config

syswindows

regenauto

redraw

redrawall
regen

regenall

point
ddptype
divide

measure

xline

ray

line

circle

arc

pline
rectang
boundary
bpoly
-boundary

revcloud

Copy objects to the clipboard

Cutting the object into the clipboard

Will be copied to the clipboard pasting objects into the location specified pattern
Copy with Base Point object that specifies the exact location of the object copy
An object copied to the clipboard in the drawing as a block to the specified
insertion point

Copy the file with graphic objects and coordinates of the original graphics file and
paste into a new graphic file

Open "Paste" box, copying the data on the clipboard to insert it into the graphic
file, and copy the data format set

Display the "Options" dialog box to specify the default settings used by the
program

Open the "Options" dialog box displays the specified tab

Open the "Options" dialog box "Print and publishing" tab

When the application window is shared with external applications, arrange
windows and icons

Automatic repeat pattern generation control, when the auto-generation open, the
system will automatically re-generated when the current view need to
re-generate a graphical

Update the display, any visible marks on delete unwanted objects or half-hidden
pixels

Refresh Show all viewports

Regenerated current view, and recalculate all the objects on the screen position
Regenerated current view, refresh all viewports, and recalculate all the positions
on the graphics screen

Drawing point objects

Display "Point Style" dialog box

Mark placed on the selected object. Marker objects evenly divided into a
specified number of division

Along the perimeter of the object or by the length of the measurement interval to
create point objects or blocks

Drawing construction lines, line configuration unlimited extension, infinite length
Configured to draw a line extending from the infinite direction specified start point
Drawing a single line length

Draw a circle of any size

Draw an arc

Drawing two-dimensional polylines

To create a rectangular polyline objects

Create a polyline in an enclosed area

boundary command aliases

Command line command execution boundary

Cloud line drawing arcs connected by a plurality of objects polyline
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donut
doughnut
sketch
3dpoly
polygon
ellipse
spline
splinedit
block
-block
insert
ddinsert
-insert

minsert

xref
-xref
xattach
refedit
-refedit

refset

refclose

xbind

-xbind
style
ddstyle
-style
text
dtext
-text
mtext
-mtext
attdef
ddattdef
-attdef
arctext
atext
mtedit
mtprop
field

Draw circle object. Ring is closed polyline of a wide arc segments composed of
Set the radius of the ring

Create a series of line segments freehand drawing

Draw 3D polyline objects

Draw a regular polygon objects

Elliptical arc or an ellipse draw an object

Draw various shapes spline

Spline Edit

Defining a plurality of objects as a whole, creates a block definition
Command line command execution block

Insert a graphic or graphics files in the current block

insert command aliases

Insert the command line command execution

Multiple copies of a block to build a rectangular array. Copy appreciate you
specify the insertion point to the beginning point array

Create an external reference or modify an existing xref

Command line command execution Xref

Create an external reference

Xref or directly edit block defined in the current drawing

Command line command execution refedit

In the external reference or block is in edit mode, the working set is added to the
object or objects from the work Deletes

Referring to save or discard changes (xref or block)

The selected external reference to a named object bound to the current or more
defined graphical

Command line command execution xbind

Create a new text style or modify the current text style

style command aliases

Command line command execution style

Draw a single line of text objects

text command aliases

Command line text command execution

Draw multi-line text

Mtext command line command execution

Defined set of properties

attdef command aliases

Command line command execution attdef

Placement of text along an arc

arctext command aliases

Edit the selected multiline text object

mtedit command aliases

Open the "Field" dialog box, create a field with the multiline text object
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updatefield
hatch
-hatch
bhatch
-bhatch

gradient

hatchedit
-hatchedit
hatchtoback
region
wipeout
dimstyle
ddim
-dimstyle

tolerance

dimlinear
dimrotated
dimaligned
dimangular
dimarc
dimradius
dimdiameter
dimordinate
dimjogged
leader
gleader

image

-image

imageattach

imageclip

Manually update the selected graphic object field

Use hatch pattern, or solid fill, gradient fill enclosed area or selected objects
Command line command execution hatch

Use hatch pattern, or solid fill, gradient fill enclosed area or selected objects
Command line command execution bhatch

Open the "Hatch and Gradient" "Gradient" tab of the dialog box in order to look
gradient color fill

Edit association objects filled

Command line command execution hatchedit

The drawing order of all hatch pattern is set after all other objects

The selected object to a region object

To erase the object designated area within the region

Modify, create dimension style

dimstyle command aliases

Command line command execution dimstyle

Display "geometric tolerances" dialog box to define the geometry of the variable
current drawing. Suitable tolerance specifies the function depicted objects
covered with accuracy

Create a linear dimension

Create a linear dimension line containing the rotational labeling

Create a linear dimension and aligning objects

Creating an angle between the circles, arcs, lines, or two objects is denoted by
Create an arc length or arc segment labeled polyline

Create a circle or arc radius labeled objects

Create diameter dimensions to circles and arcs

Creating ordinate dimensions

A circular arc, or polyline arc segments create the bend radius dimensions
Draw lead

Quickly create and set the lead wires comment

On "Image Manager" dialog box. In this dialog box, a variety of image formats
(including BMP, TIF, RLE, JPG, PNG, PCX and TGA) can be attached to the
drawing file, or to break out from the drawing. You can also reload and unload
image, specify a new path to the image. You can also view details of the selected
image

Command line command execution image

Open "Select Image File" dialog box, the user can view the raster image in this
dialog box, two-color bitmap image, 8-bit grayscale image, eight 24-bit color
image or a color image file, and select an image file to attached to the current
drawing file. Attaching the image creates the image definition, the image is
loaded into memory and displays the image. After the user selects the image file,
it will open the "Image" dialog

Create a new image clipping boundary for the entity selected objects. Must be
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imageframe

insertobj

olelinks

layout

-layout
mline
mistyle
mledit
-mledit
trace
solid

load

shape
ucs
ucsicon

ucsman

dducs

#NAME?
dducsp
layer
-layer
vplayer

linetype

-linetype
Itscale
view
-view
vpoint
ddvpoint
vports
#NAME?

-vports

specified boundary plane parallel to the image object

Control of the image frame drawing is currently displayed and printed

Open the "Insert Object" dialog box, insert OLE objects in the current drawing
file, including linked objects and embedded objects

On "Link" dialog box for an existing OLE links to modify, cancel and other
operations

Create or modify a graphic layout tab. Layout of construction or design can be
used for printing graphic

Command line command execution layout

Draw multi-line. Multi-line is a plurality of parallel lines

On "Multi-line Style" dialog box, define multi-line style

Editing multi-line style, multi-line control of the intersection between the
Command line command execution mledit

Drawing wide lines

Creating an object through a two-dimensional triangular or quadrangular filled
"Select-shaped File" dialog box. Enter the name of a shape file or select a file
name from the list

From the shape file loaded using LOAD shaped insert

Set User Coordinate System

Show or hide the UCS icon, and determine the location of the UCS icon display
"User Coordinate System" dialog box to display and modify the definition but not
the named user coordinate system, restore the naming and orthogonal UCS,
specify the viewport UCS and UCS icon settings

"User Coordinate System" dialog box to display and modify the definition but not
the named user coordinate system, restore the naming and orthogonal UCS,
specify the viewport UCS and UCS icon settings

Open the "User Coordinate System" dialog box, specify tab

Open the "User Coordinate System" dialog "orthogonal UCS" tab

Create or manage layers, colors modify the layer, linear and other characteristics
Command line command execution layer

Layer visibility settings of the viewport

Defined line (line segment, and the successive points are alternately arranged
space), loaded from the library and set the current line

Command line command execution linetype

All linear scale factor setting current drawing

Storing user defined view or retrieve saved views to display

Command line command execution view

Set the graphic visualization of three-dimensional viewing direction

Set three dimensional viewing direction

Creating one or more view ports in a view

Open the "viewport" dialog box, specify tab

Command line command execution vports
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viewports
zoom
rtzoom
pan

-pan
rtpan
plan
erase

move

copy

mirror

stretch

rotate
scale

array

-array

offset

trim
extend
chamfer

fillet

lengthen

align

break
join

explode

vports command aliases

Zoom in or out to display the current drawing

Enlarged or reduced in real-time graphic display of the current

Pan Drag view window to view unseen region

Command line command to execute pan

Real-time translation drag the view to the window to watch the invisible region

A plan view showing the specified coordinate system

Delete graphic files selected objects

The selected object with the specified distance from the original position moves
to a new location

Copy Objects

Reflecting a copy of a line as a reference line, creating an object

Tensile selected graphical object, wherein the moving part, while maintaining the
link with other parts of the pattern. Stretchable and comprises an object selection
window intersecting arcs, elliptical arcs, lines, polyline segments,
two-dimensional solids, radiation, line width, and splines

To rotate an object by specifying the selected point

In certain scaled up or down to select an object

A duplicate copy of the selected object, according to the manner specified order.
In addition operation can be performed on a single object array, the array may
also be operated on a plurality of objects, when the command is executed, the
system as a whole will be a plurality of target objects to be treated

Command line command execution array

Distance specified point or a specified offset the selected object and copy the
target copy of the original object in parallel. If the selected object is a circle,
creating concentric circles

Clean up the selected object exceeds the specified boundary section

Extending a line segment, arc, or 2D polyline ray

Establishing two chamfer lines cross, radial lines or infinitely long line

Of two arcs, circles, ellipses, arcs, lines, polylines, rays, splines or
three-dimensional solid lines and configured to create the fillet radius of the arc
formed by the specified

Modify the length of the selected object, comprising an arc-angle modification
Select the object you want to align in 2D and 3D space, and you want to align
objects to add source, add target point to the object to be aligned with the source
object, so that it is aligned with other objects. To align an object, you can add up
to three pairs of source and destination points to the object

The selected object interrupted between two points

The selected objects are combined to form a new object

Synthetic objects (e.g., tiles, polylines, etc.) formed by combining a plurality of
objects into separate objects

explode command aliases
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purge

-purge

chspace

pspace

mspace

pedit

mleader
mleaderstyle
mleaderedit
aimleadereditremove
aimleadereditadd
table

tablestyle
tabledit
tableexport
ncopy

overkill
draworder

3d

acisin

acisout

box
cone
cylinder
torus
sphere
3dface
3dmesh
pface
wedge
edgesurf

revsurf

rulesurf

Named Item clear the current drawing file is not in use. Such as blocks, layers,
linetypes, text styles, but do not use graphics or recovery dimension styles you
define

Command line execution purge command

Move the object to a different space, i.e. converted into the drawing space model
space object, or convert the object in the model space to paper space. And for
moving objects are properly scaled in the new space.

In the layout, switching from model space to paper space viewport

In the layout, switching from paper space to model space layout viewport

Edit 2D polylines, 3D polylines or 3D grid

Create a multileader objects

Multileader styles create, modify,

Add or delete objects lead to multiple leads

Delete objects lead to multiple leads

Increasing the lead to multileader objects

Create a table object

Table style to create, modify

Form-place editing

The table object output to an Excel file

Referring replication nested in the outside or a tile or more objects

Remove duplicate or partially overlapping drawing objects

Show all objects in the order of drawing file settings

Creating the appearance of the three-dimensional polygon basic shape

Open the "Select SAT File" dialog box, select ACIS file and insert the current
drawing file

The graphics files created entity, or region object output and save it as SAT
(ASCII) files

To create three-dimensional rectangular objects

To create three-dimensional cone

To create three-dimensional solid object cylinder

Rendering three-dimensional solid object ring

Draw three-dimensional spherical objects

Draw three-dimensional surface objects

To create three-dimensional polygon mesh objects

To create three-dimensional polygon mesh by specifying vertices

Rendering three-dimensional objects wedge

Vertex evenly distributed to four boundary dimensional polygon mesh

The rotation shaft linear path curve or contour around the specified object
selected rotation angle, rotation created surfaces. Selected object lines, circles,
arcs, ellipses, elliptical arcs, closed polylines, polygons, spline or a closed ring
Dimensional polygon mesh, it ruled surface approximation between the two

curves
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tabsurf

extrude

revolve

loft

slice

ai_cone
ai_wedge
ai_pyramid
ai_dome
ai_box
ai_dish
ai_sphere
ai_torus
ai_cylinder

union

intersect

subtract

interfere

solidedit

rotate3d

3darray

laymcur
laymch
-laymch

layiso

Establishing a polygon mesh, making it approximately the grid plate developable
surface defined by the path and direction

Height and tilt angle values specified path, or stretched to create a solid
object selected

The two-dimensional object in a selected predetermined rotational axis of
rotation, and finally form a solid

Creating three-dimensional solid or surface in the space between the plurality of
cross-section

Cut or split by an existing object, and creating a new three-dimensional solid
surfaces

Creating three-dimensional conical surface

To create three-dimensional wedge surface

Create a square pyramidal surface

To create three-dimensional hemisphere surface

Create a box surface

To create three-dimensional lower hemisphere surface

Create a three-dimensional sphere

Create a torus surface

Create a cylinder surface

Two or more entities or public domain part of the surface of two or more solids or
domains into a whole. The resulting composition comprises all of the selected
entity entities enclosed space. Compositions obtained surface domain comprises
a subset of all of the surface area enclosed region

Selecting two or more entities or public intersection portion intersecting the
surface region to create a composite solid surface or field, and remove the
portion other than the intersection

A plurality of overlapping solids or domain object through the "Save" operation
target combined as a whole

Select two batches of solid were compared, and creates a three-dimensional
solid composition with a common portion of two or more entities

Edit or modify the selected entity object. Users can use the command
SOLIDEDIT faces and edges of solid objects stretching, moving, rotating,
offsetting, tapering, copying, coloring, segmentation, shelling, cleaning,
inspection or delete operation

About the axis of the three-dimensional objects

Creating three-dimensional array in three-dimensional space, copy the plurality
of objects

The selected object layer is set to the current layer

Layer the selected object's layer and the selected target object resides match
Command line command execution laymch

Close all other layers layers one or more selected object is located and isolated

from other layers
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layuniso
layfrz
layoff
layerstate
layerstatesave
layon
laythw
laylck
layulk
laycur
laycurl
-laydel
-laymrg

copytolayer

laywalk

laymrg

laydel

eattedit
attedit
-attedit
ddatte

battman

attext

ddattext

-attext
eattext
attsync

attdisp

base
color
ddcolor

-color

Open Layers command isolated before use LAYISO

Frozen layer of selected object

Off the layer of the selected object

Save, restore and manage named layer state

Save Layer State

Open all layers

Thaw All Layers

Locked layers of selected object

The layer selected object unlock

One or more layers of objects to the current layer

Set layer entity for the current layer

Command line command execution laydel

Command line command execution laymrg

Copy the selected objects to another layer, the layer where the source object is
not changed

Browsing graphic layer information contained in, dynamic display of objects
selected layer

All objects selected first layer to the Selected second layer. The first layer is
selected from the graphic cleared

Delete specifies that all objects in the layer and the layer is removed from the
drawing

In the Edit Properties block reference

A plurality of attribute values associated with the edit block

Command line command execution attedit

All the attribute information attached to the block edit

On "Block Attribute Manager" dialog box. Users can manage selected block
defined in this dialog box all of the properties and characteristics is provided. Any
changes made to the block definition attributes are reflected in the block
reference

ATTEXT command in the command input, will open "attribute extraction" box, the
user can set the attribute value in this dialog box

ATTEXT command in the command input, will open "attribute extraction" box, the
user can set the attribute value in this dialog box

Command line command execution attext

Attribute information output block as a table or external file

The attribute definition block reference block defined attribute synchronization
Sets whether to display properties in the drawing file. Enter the command "
'ATTDISP", the command can be used transparently

A reference point when setting the current graphic into another file

Sets the color for drawing the new object

Sets the color for drawing the new object

Command line command to execute color
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lineweight
lweight
-lweight
plotstyle

-plotstyle

convertctb

convertpstyles

rename

-rename
properties
propertiesclose

group

-group
ungroup
groupunname
select

pselect

gselect
deselect
ai_deselect
selectsimilar
selectsimilarse
exc

excp

exf

expl

exw

exwp

filter

matchprop
painter

paintprop

change

wblock

Set the current line width, line width and line width unit display options

Set the current line width, line width and line width unit display options
Command line command execution Iweight

Control attached to the current layout, and to specify the name of the print style
object

Command line command execution plotstyle

The color-dependent plot style table (CTB) converted to a named plot style
tables (STB)

The current drawing converted to named or color-dependent print style
Change the name assigned to the project (such as layers and dimension styles)
of

Command line execution rename command

Control of existing objects

Close "properties" palette

Creating and processing individual objects consist. Grouping allows users to
operate the graphic element group units, and can be selected according to need
with editing may be performed separately

Command line execution group command

Ungroup

Create anonymous group

Places selected objects "on a" selection set

The selected objects in the "on a" selection set and highlights the selected
objects

Creates a selection set based on filtering criteria

You can deselect by right-click menu

Cancel is highlighted and selected entity state

The matching characteristics of the selected object is similar to the selection set
Set criteria like objects

The intersection of mode selection

Ring post Options

Fence mode selection

The final mode selection

Window mode selection

Circle around the mode selection

Create a list of requirements, the object must meet these requirements to be
included in the selection set

The properties of the selected object to the other objects

matchprop command aliases

The properties of the selected object to the other objects across documents
execution

Change the properties of existing objects

The block is written to a new object or graphics files
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-wblock

xclip

import

export

hyperlink
-hyperlink
hyperlinkoptions
spell

find

ddedit

dimbreak

dimspace
qdim

dimbaseline

dimcontinue

-diminspect
dimjogline

dimreassociate

dimdisassociate
dimcenter

dim

dim1
dimension
dimedit
dimtedit

dimoverride

aidimprec

aidimtextmove

Command line command execution wblock

Pruning selected display or external reference block reference to a specified
boundary

On "Input File" dialog box, select a variety of formats from the dialog box file into
ZWCAD system

Open "output data" dialog box, the output of the current graphics file to the
selected file type

Setting a hyperlink or modify an existing hyperlink selected objects

Command line command execution hyperlink

Hyperlink cursor and shortcut menus, hyperlinks, tool tips display control

Check the single-line text, multi-line text, property, or attribute defined dimension
text spelling

On "graph search positioning" dialog in "Text Search" tab, find, replace, or select
the zoom text pattern included in the model space object has been loaded or
defined in the current drawing in. If the local open the current graphics, FIND will
not be considered for the object is not loaded

Modify the properties of the selected text object

Interrupt or restore the label size and label in line at the intersection of the
extension lines and other objects

Controlling the spacing between the parallel lines and angular dimensions labels
Quickly create or edit a series of dimensions

A label connected, to continue the establishment of a linear arc length, angle
coordinates or label, the program will label the first reference line extending in a
first extending next line marked

A label connected, to continue the establishment of a linear arc length, angle, or
coordinates of annotation, the program will reference the second extension line
marked as the next first extension line marked

Command line command execution diminspect

For the linear dimension to add or remove bending line

The selected label association or re-association to a point on the object or
objects

Delete Selected relevance tagging

Create a center mark to the selected circle or arc center line or draw

On "mark" mode, in many ways marked on the graph objects

On "mark" mode, in many ways marked on the graph objects

On "mark" mode, in many ways marked on the graph objects

Edit annotation object extension lines and dimension text

Dimension text editing and display angular positions, relocation dimension text
Alternatively the selected set of system variables associated with the object
label, after the replacement, will not change the style label

The selected character size setting accuracy marked

The position of the dimension text in three ways to move the selected callout
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ai_dim_textabove

ai_dim_textcenter

ai_dim_texthome

vpclip

3dorbit

mview
shademode
hide
viewres

toolpalettes

toolpalettesclose

commandline

commandlinehide

copyhist
materials

cui

-toolbar
toolbar
cleanscreenon
cleanscreenoff
aliasedit
ai_editcustfile
reinit

menu
menuload
menuunload
appload

ZRX

netload
netdebug
script

rscript
resume
vbaide

vba

vbarun

-vbarun

Text annotation sized relative to the size of the selected line of the vertical
alignment mode is "above"

Text annotation sized relative to the size of the selected line of the vertical
alignment mode is "middle"

Restore the size of the selected text marked default location

Trimming layout viewport object and adjust the shape of the border of the
viewport

Rotating the view in three dimensions, but only observed the dynamic horizontal
and vertical dynamic observation

Creates and controls layout viewports

Set the current viewport visual style

Hidden lines removed

Set the resolution for objects in the current viewport

Open the "Tools Palette" window

Close the "Tools Palette" window

Show "command line" window

Hide the command line window

Copy command line history text to the clipboard

Shows or hides the "Material" window

On "Customize User Interface" dialog box, edit the custom user interface CUIX
file

Command line command execution toolbar

Show or hide toolbars

Clear toolbar and dockable window screen (except for the command window) of
Restore the display state prior to use of CLEANSCREENON

It provides visual editing interface command aliases

Open the file for editing zwcad.pgp

Re-initialize the digitizer, digitizer port and zwcad.pgp file.

Load File menu

Locally loaded to an existing basic menu files menu file

Unload a partial menu file

Loading and unloading applications, custom applications to load at startup
Load, unload ObjectARX application and provide relevant information
Load .NET applications

Debug .NET applications

Run the script to execute commands

The user operates the recording into a script scr

Continues an interrupted script file

Open the Visual Basic program and displays VisualBasic Editor window
vbaide command aliases

VBA macros run

Command line command execution vbarun
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vbaload
-vbaload
vbaunload

vbaman

laytrans

publish
etransmit
plottermanager
limits
units
ddunits
-units
dwgprops
osnap
snap
-osnap
grid

ortho
isoplane
aperture

dsettings

#NAME?
id
list

dist

area
massprop
status
setvar
undefine
redefine
multiple

delay

elev

fill

xdata

Microsoft VBA project to load a VBA editing environment

Command line command execution vbaload

Uninstall Microsoft VBA project

Open "VBA Manager" dialog box, loading, unloading, save, create, embed and
extract the VBA project

On "Layer Converter" dialog box, specify the layers you want to convert the
current drawing and to be converted to layer

The graphics publish to DWF and PDF files, or publish to a plotter

The packaging a set of files for Internet transmission

Plotter display manager, you can add or edit a plotter configuration

In the current "model" or named layout setting control limits and the raster display
Control coordinates and angle display formats and precision

Control coordinates and angle display formats and precision

Command line command execution units

Sets and displays the current graphics file properties

Set running object snaps mode

Limiting movement of the cursor to specified intervals

Command line command execution osnap

Displaying a grid pattern in the current viewport

Limiting movement of the cursor

Specifies the current isoplane

Control target capture target block size

Sets grid and snap, polar and object snap tracking, object snap modes, Dynamic
Input, and Quick Properties

Open the "Drafting Settings" dialog box to specify tab

UCS coordinate values of the specified display position

Display property data for selected objects

Measuring the distance between angle points, angle formed by two points of the
line segment on the XY plane and the XY plane

Computing objects or regions of the area and perimeter defined

Calculating mass properties of regions or 3D entity

Statistics show graphics, mode and range

Lists or changes the values of system variables

Cancel ZWCAD defined command

Built-in is UNDEFINE retrieve deleted

Commands entered before repeating the user presses the Esc key

After a command is executed, designated for a specific time delay, the next
command during this again after the delay time

Specifies the current spatial view (the model or drawing) with respect to the
height of the user coordinate system,

Open or close the "fill" mode

The data of the selected object is connected to an external object
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smartvoice
voiceman
voiceshow
smartmouse

smartmouseconfig

audit

recover
drawingrecovery
drawingrecoveryhide

layerbrowser

burst

gatte

attout

attin
chgbcol
chgbwid
chgbang
chgbhei
chgblay
blockreplace
textfit

textmask

textunmask
texttofront
txt2mtxt

tjust

torient

tcircle

tcount

tcase
curstyle
chgthei

mathei

Create Smart Objects speech

Open the "Voice Manager" dialog box

Control show or hide all drawing objects voice

Wizard feature turned on or off gesture

Open the "gesture Wizard Settings" dialog parameter gesture wizard function
set, including adding or deleting gestures, as well as modify the CAD command
corresponding to the gesture

Graphic integrity check and correct some errors

Repair damaged graphic files, and then re-open

List display can be repaired after the program or system failure graphic files
Close "Drawing Recovery Manager"

Open the "Layers Browser" dialog box displays thumbnails of objects inside each
layer, and a simple layer operations

Tile decomposition, if the block contains translation attributes, the attribute value
will text to text, otherwise only the tile decomposition

Attribute value modify specific properties of the block

The property value deriving block to an external file using TAB-DELIMITED
ASCII format

The block attribute value input from an external ASCII file

Modify the specified block of color

Modify the specified tile width

Modify the specified block of text angle

Modify the specified block of text height

Modify the specified tile layer

Another tile can replace all of the embedded objects on one tile

Specified length stretched or compressed text object selected

Behind the selected text is placed a multi-line text mask, the mask behind the
blocking entity

To unblock blocked text

Before writing, lead and mark the placement of all other objects in the drawing
One or more rows combined into a single text entity mtext

Align text, without changing the position of the text, may be aligned with a single
line of text objects, attributes and multiple lines of text objects

Text, multiline text labels and attributes tile objects arranged in a new direction
Draw a circle around each selected text object or a multi-line text objects, text as
a rectangular or circular frame groove

Adding consecutive numbers to text objects, numbers can be front, rear or
overlay text

Morphological changes selected text, multiline text, text attributes, and labels
Display font style specifies single text or text objects are used

High select specified word or MTEXT object TEXT

Modify the target height of the text object word high word source text objects
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txtalign
mtexp
txtuline
deluline
dimex
dimim
dimreassoc
dimtxtrev
dimtxtcol
dimasbx
deldim
glattachset
gldetachset
glattach
getsel
smartsel
copym

exoffset

deldupl

extrim

exscale

flatten

breakline

superhatch

joinl

angdiv

arccmp

con2dash

chgltsca

Specified alignment and alignment point specified aligned single-line text object
Converting multiline text object as a single-line text object

Underline single-line text object

Delete a single line of text is underlined

The specified dimension style and set the output to an external file

DIM file specified in the dimension style input into the current drawing

The measured values have been replaced or modified to restore the original
value dimension text

Flip dimension text

Modify the dimension text color

Add or delete extension lines marked

Delete the specified label

Globally attaches leaders line to mtext, tolerance, or block reference objects
Detaches leader line from mtext, tolerance, or block reference object

Attaches leader line to mtext, tolerance, or block reference object

Creates a temporary selection set of objects

Real-time selection of an object satisfying the condition of one or more selection
criteria

After setting the repetition, the array pitch and the number of bulk copy the
plurality of objects

This enhanced shift command superior standard command (including layer
control, cancellation, and multiple options, etc.)

The same layers function to delete overlapping circles, arcs and straight line
Trim intersects the boundary object side of the object based on the specified
boundary object

Specified X, Y scaling designated entity object, while ensuring that all the current
graphic objects are displayed in the current view, other objects can be
automatically scaled according to the ratio of the current view

The selected three-dimensional object into a two-dimensional object

Create a polyline objects, and insert the mark in broken lines in the segment
Use of block objects, external reference raster images and other special object
as a fill pattern to fill the enclosed area

Or a straight line connecting two line segments or circular arcs. Only the
intersection of the line and the circular arc has an intersection or an extension
connected

Two straight lines drawn bisector, if two parallel straight lines, a straight line is
drawn parallel to the angle bisector

According to the existing arc, a circle can be constructed to generate another
portion of the arcuate

If the selection of an object linear line is a solid line, the command to convert it to
a linear broken line, whereas the solid line is converted to linear

Modified linear scale factor of the object
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lockup
unlock
plt2dwg
pltplot

sysvdig

scalelistedit

mkltype
xdlist

explan

delhatch

refmanager

linesum
arcsum
areasum

blocksum

zvalto0
word
excel
notepad

fcmp

-fcmp
mslide
vslide
?

help

about

bcount

block?

browser

For the selected graphic lock, it can not be edited

Use LOCKUP graphics commands to unlock a locked, to restore editable

The plt / hpgl file into the current drawing file

On "Batch Print" dialog box to specify a one-time printer to print multiple files PLT
and PRN files

Browse, edit, and save the system variable is set

Control list of available layout viewport ratio, the user can manage, edit and
modify the viewport scale

Established line on the selected object

External data list associated with the selected object

After painting plan view, may be scaled using the selected object by EXPLAIN,
substituted stretching in the standard version to the objects

The fill color or fill pattern object cleared to restore a state before the unfilled
Open "Referring Manager" dialog box, the user can view a single or a plurality of
reference objects in the drawing (e.g., external reference, raster image, font files,
file and print profile type) without opening the drawings and associated
information (such as saving the path, version information, etc.), and may be
modified and its reference to the object search and replace operations such as
save path

Calculating the total length of the specified line

Calculating the total length of the circular arc specified

Calculating one or more objects of the total area

Current statistics pattern, specified the number of layers or the current selection
in the set of tiles included

The specified object Z coordinate value of zero modified

Open MS Word application

Open MS Excel application

To open the Notepad application

Comparison of two sheets, and displays the results of the comparison with a
different color

Command line command execution fcmp

Create a slideshow file

Show slide file

help command aliases

Window displays online help information

Display copyright information and product information ZWCAD software,
including version information, registration information, and copyright and
trademarks

Calculate and display the selected objects in a list or a block drawing of the entire
insert Number

List object definition block

ZWCAD open the default Web browser
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bscale

cal

chprop
ddchprop

ddrmodes

dragmode

gh2big5

hideobjects

isolateobjects

logfileoff
logfileon
model

mpedit

shell

sSX
stylesmanager
textscr

txtexp

unisolateobjects

wmfin

wmfopts

wmfout
tifout
pngout

dwfout

dwfin
dxfin
dxfout
bmpout
ipgout
xplode

Block insertion point to the starting point, designated X, Y, Z axis direction, the
telescopic type scaling factors and scaling the selected block

A computer calculates the value of the point (vector), an expression of real or
integer

Change an object's properties

Change an object's properties

Sets grid and snap, polar and object snap tracking, object snap modes, Dynamic
Input, and Quick Properties

Set drag objects displayed on, off or automatic

On "simplified conversion" dialog box, graphic text in a document object script
conversion

Temporarily hide the selected objects in the current view, all other objects are
visible

Isolation of the selected object is displayed in the current view and temporarily
hides all other objects

Will stop recording the contents of the text window and close the log file
Enable the log file and in which the content of the text window record
Switching from a named (paper space) layout to the "Model" Layout

This command is similar to the function of command PEDIT, but its advantages
in dealing with the polyline, lines or arcs may convert the object polyline

Call DOS commands in ZWCAD Software

Create a Selection Set Filter List

The Print Style Manager, where you can modify the print style sheet

Open ZWCAD text window

The multi-line text of text is an exploded polyline thickness and height can be
assigned

Before displaying all commands by ISOLATEOBJECTS and HIDEOBJECTS
hidden objects

Insert the Windows Metafile graphics files in the current

Open "WMF input options" dialog box, set the metafile whether to keep the
relative width, as well as a wireframe or solid object input

Save the selected object is a WMF file

Saves selected objects to a file in TIFF file format

The selected object (PNG) Portable Network Graphics format to save to a file
Output current drawing file to the specified DWF file format, and can choose to
be output in the output process layout and DWF file version and format

The selected DWF, DWFx file into the current drawing

Open the DXF file

Output current drawing as a DXF file

In bitmap format (.bmp) graphics objects stored in the current file

Saves selected objects to a file in JPEG file format

To be synthesized into individual member
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xp
vpmax
vpmin

blockextract

dview
checkupdate

configupdate

edit
explorer
pbrush
sh

start
type

gein

geout
verauth

zrxvernum

dgnimport

render

light

planesurf

AIDIMFLIPARROW

CUILOAD
CUIUNLOAD
CUSTOMIZE

IMAGEQUALITY

MVSETUP

0OO0PS
QUICKCALC
SOLPROF
SHADE

3DOPEN

ADCENTER

xplode command aliases

Expands the current layout viewport for editing

Restores the current layout viewport

By picking up a block or a specified layer, or selecting the specified blocks
included in a tile layer as a boundary, the output of block contained therein to a
separate file dwg saved, and the attribute information table to the outside
Defined using the camera and the target parallel projection or perspective view
Online update detection

Online updating configuration parameters, which the user can set up automatic
update detection and the detection time interval

Call dos command to edit the file specified

Call dos command to open windows explorer

Call dos command to open the Paint program

Execute operating system commands by Shell

Specified by Shell to run applications

Call dos command to open the specified file

The Google Earth ZWCAD specified scene introduced in the form of a raster
image

GEIN command and three-dimensional models with output to Google Earth
Query version Authorization type

Display ZRXSDK major version number and the version number of the current
ZRXSDK platform release at the same time, in order to facilitate access to the
information when the user performs a secondary development on ZWCAD

The data input from the DGN file into a new DWG file or the current DWG file
Creates a 3D solid or surface model of photorealistic images or real colored
image

Create a light source

Create a flat surface

Quickly flip the specified dimension arrow

Load the specified customization file (CUIx)

Unload the specified customization file (CUIx)

Customize the short key for commands and the toolbars

Control the display quality of images

Sets the drawing specification, insert the title block, create and adjust layout
viewports

Restore the last objects erased by ERASE command

Open or close the quick calculator

Create the 2D profile for 3D solid object

Get the solid entities shaded and displayed in the current drawing

Converts the current DWG/DXF drawing into Z3 format and starts ZW3D
automatically to open this drawing
Opens Design Center window to manage and insert content
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ADCCLOSE
ADCNAVIGATE
BEDIT

BSAVE
BSAVEAS
BTESTBLOCK
BWBLOCKAS
BCLOSE
BATTORDER
BLKALIGN
LAYERP
LAYERPMODE

DIMINSPECT
HELIX:
MIRROR3D:
TIME
PYRAMID
QCCLOSE
PDFADJUST

PDFATTACH
PDFCLIP
PDFLAYERS
ANNOUPDATE

OBJECTSCALE
CLASSICLAYER
LAYERCLOSE
LAYERPALETTE
DWEFCLIP
DWFLAYERS

DWFADJUST

PDFIMPORT

PDFIMPORTIMAGEP

ATH
DIGITALSIGN
SIGVALIDATE

Closes Design Center window

Loads a specified drawing file or folder in Design Center

Opens the block definition in the Block Editor

Saves the current block definition

Saves a copy of the current block definition under a new name

Displays a window within the Block Editor to test a Flexiblock

Saves an outside copy of the current block definition

Closes the Block Editor

Specifies the order of attributes for a block

Aligns blocks to according to the justification and a point

Restores the last change or set of changes made to the layer settings

Turns on and off the tracking changes made to layer settings for use by the
LATERP command.

Adds or removes inspection information for a selected dimension

Creates a 2D spiral or 3D spring

Creates a mirrored copy of selected 3D objects across a mirroring plane
Displays the date and time statistics of a drawing

Creates a 3D solid pyramid

Closes the Quick Calculator

Adjust the settings for the PDF underlay, such as Fade, Contrast and
Monochrome.

Insert a PDF file into a drawing as an underlay.

Modify the display of the PDF underlay with the specified clipping boundary.
View and set the display of the layers in PDF underlay.

Update selected annotative objects, to make the annotation property of the
objects matches the current properties of their styles.

Add or delete supported scales for specified annotative text objects.

Display the classic Layer Manager as modal dialog box

Close the Layer Manger as palette or modeless dialog box.

Display the Layer Manger as palette or modeless dialog box.

DWEF Underlay can now be clipped by DWFCLIP.

The Layer Manager of DWF Underlay can now be opened by DWFLAYERS to
manage its layers.

Fade, Contrast and Monochrome of the DWF Underlay can now be set and
adjusted by DWFADJUST.

Import the geometric objects, hatch objects, raster images and TrueType text
contained in a PDF to the current drawing.

Specify the path for saving and extracting referenced image file(s) in the
imported PDF.

Attach digital signatures to the current drawings.

Validate whether digital signature is attached to the current drawing file, and

display information about the digital signature certificate.
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JWWIMPORT
JWWVERNO
ALIGNSPACE

VLIDE
VLISP
3DCORBIT

DATAEXTRACTION

DATAEXTRACTIONUP
DATE
TRANSAPRENCY

CLIP
HATCHGENERATEBO
UNDARY

DGNPURGE
TPNAVIAGTE
-DATAEXTRACTION
EXTERNALREFERENCE
S
EXTERNALREFERENCE
SCLSOE

CLASSICXREF
CLASSICIMAGE
OLESCALE

OLERESET

LAYOUTEXPORT

DGNEXPORT
-DGNEXPORT
STLOUT

FCMPINFO

FCMPSETTINGS
FCMPCLOSE
FCMPTOGGLEREFERE
NCE

FCMPDIFFPREV
FCMPDIFFNEXT
BLOCKBREAK
FILETAB
FILETABCLOSE

Import files of JWW format to ZWCAD 2019 SP2 (Japanese version only).
Check the version number of JWW files (Japanese version only).

Adjust the scale and location of drawings in Layout viewport according to the
alignment points which have been specified in Model space and Paper space.
Turn on Lisp Debugger

Turn on Lisp Debugger, the same as VLIDE

Continuously rotate the views in the 3D working space

Extract various properties and data of an object, and insert them to the current
drawing as a table, or export them to a .csv/ .xls file

Update the extracted properties and data according to the actual changes in the
drawing

Control whether the background display of image is transparent.

Clip specified object base on the clip boundary
Create unassociated boundary for specified hatch pattern

Clean DGN data in the drawing
Switch tool palette

Run dataextraction in command line

Open external references manager

Close external references manager

Open old external references manager

Open old image manager

OLE objects can be automatically scaled to be in line with the text size.

Restore the selected OLE object to its original size and shape.

Export all visible entities from a single Layout to the model space in a new
drawing, or multiple Layouts to the model space in multiple drawings.

Export current entities in the DGN format.

Export current entities in the DGN format via the command line.

Export 3D entities and watertight meshes in the STL format.

A dialog box containing the information about the 2 drawings compared will
pop up.

The panel of File Compare Settings will appear in the classic interface.

Quit comparing files.
Show or hide the comparison results.

Enlarge the previous change in the comparison results.
Enlarge the next change in the comparison results.

Insert blocks into entities directly without further breaking.
Display the file tab when it has been hidden.

Hide the file tab when it appears.
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MAIL

MOVEBAK
PUBLISHERASTER
-BLOCKREPLACE
-IMAGEADJUST
RIBBON
RIBBONCLOSE
FLATSHOT

SAVEALL
MEASUREGEOM
IFCIMPORT
IFCSTRUCTUREPANEL
IFCSTRUCTUREPANEL
UPDATE
IFCSTRUCTUREPANEL
CLOSE
CHECKSTANDARDS
STANDARDS
DATALINK
DATALINKUPDATE
ARRAYCLASSIC
ARRAYRECT
ARRAYPATH
ARRAYPOLAR
ARRAYEDIT

ARRAYCLOSE

-OVERKILL
DOSLIB
DOSLIBHELP
DGNMAPPING
-DGNIMPORT

PROPULATE

TRANSAPRENCY
CLIP
HATCHGENERATEBO
UNDARY
DGNPURGE
TPNAVIGATE
-DATAEXTRACTION
Esri_AddData

Attach the current drawing automatically to an opened email client.
Change the saving path of backup drawings.

Trim the edge space of a raster image to be published.

Execute the BLOCKREPLACE command in the command line.
Execute the IMAGEADJUST command in the command line.
Display the Ribbon panel.

Close the Ribbon panel.

Create projected 2D profile lines of all 3D solid models in the model space.
Save all currently opened drawing files.

Measure distance, radius, angle, area and mass properties of objects.
Import IFC files.

Open the IFC Structure Panel.

Refresh the IFC Structure Panel to its initial state.

Close the IFC Structure Panel.

Invoke the “Check Standards” dialog box.

Invoke the “Configure Standards” dialog box.

Invoke the “Data Link Manager” dialog box.

Update the table data from ZWCAD to Excel or vice versa.

Invoke the classic Array daialog box.

Select an object and create a rectangular array.

Select an object and create a path array.

Select an object and create a polar array.

Modify items or source objects of the associative array.

Quit editing the source objects of an associative array with the changes saved or
discarded.

Use the “Overkill” feature in the command line.

Load the DOS Library.

Open the help file for the DOS Library.

Invoke the “DGN Mapping Setups” dialog box.

Use the “DGN Import” feature in the command line.

Modify the values of fields in different drawings all at once. Create new types
of fields.

Control whether the background display of an image is transparent.

Clip the specified object according to the clip boundary.
Create a non-associative boundary for the specified hatch.

Remove the DGN data in the drawing.

Switch the tool palette by entering the full name.
Run DATAEXTRACTION in the command line.
Add GIS data in the ArcGIS module.

437


about:blankCHECKSTANDARDS_dia.htm

ZWCAD User Guide

Esri_AddDataUrl Add GIS data by URL in the ArcGIS module.
Esri_CoordinateSyste . .

Create a coordinate system in the ArcGIS module.
m
Esri_Contents Open the Contents panel in the ArcGIS module.
Esri_lmportSchema Import a scheme in the ArcGIS module.

Esri_ldentifyFeature | Identify features in the ArcGIS module.

Esri_ProjectArea Set a project area in the ArcGIS module.

Esri_SwitchCS Switch the coordinate system in the ArcGIS module.

Esri_ZOOM Zoom in/out to the project area in the ArcGIS module.

Setbylayer Set the properties of the selected object to “Bylayer”.

VOICEMANCLOSE Close the Smart Voice panel.

-TABLE Run “Table” command in command line.

TINSERT Execute the TINSERT command, select the table cell, and open the Insert
Block in Table Cell dialog box.

MATCHCELL Apply selected cell style to other cells

SHEETSET Open sheetset manager.

OPENSHEETSET Open sheetset file.

NEWSHEETSET Create a new sheetset file.

SHEETSETHIDE Close Sheetset manager.

ARCHIVE Archive Sheetset

3DCONNEXION Allow or ban 3D mouse funciton

SPACEMOUSEACTIO

N Synchronize view data to the database

ZW3DXROLLCWVIEW | Twist the view clockwise

ZW3DXROLLCCWVIE . . .
Counterclockwise twist view

w
3DFLY Observe objects in 3D fly mode.
3DFORBIT Observe objects dynamically in 3D space.
3DSWIVEL Observe objects in 3D swivel mode.
3DWALK Observe objects in 3D walk mode.
-BCONVERT Convert the Flexiblock specified in current drawing to a flexi block.
Adjust the fade and contrast of DGN underlays, and whether to use
-DGNADJUST )
monochrome display.
-DGNATTACH Insert a DGN file into current drawing as an underlay.
-DGNBIND Bind the DGN udnerlay as a block reference in the drawing.
-PCEXTRACTSECT
Extract section lines.
ION
-POINTCLOUDATT
Attach point cloud.
ACH
-POINTCLOUDCRO Save/ TN
ave/manage clipping states.
PSTATE St
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AREATABLE

BCONVERT
BPARAMSETFLIPS
ET
BPARAMSETLINE
ARARRAY
BPARAMSETLINE
ARMOVE
BPARAMSETLINE
ARMOVEPAIR
BPARAMSETLINE
ARSTRETCH
BPARAMSETLINE
ARSTRETCHPAIR
BPARAMSETPOIN
TMOVE
BPARAMSETPOLA
RARRAY
BPARAMSETPOLA
RMOVE
BPARAMSETPOLA
RMOVEPAIR

BPARAMSETPOLA
RSTRETCH
BPARAMSETPOLA
RSTRETCHPAIR
BPARAMSETROTA
TESET
BPARAMSETVISIB
ILITYSET
BPARAMSETXYAR
RAY
BPARAMSETXYM
OVE
BPARAMSETXYM
OVECORNER
BPARAMSETXYM
OVEPAIR
BPARAMSETXYST
RETCHCORNER

Display the "Area Table" dialog to add area annotations or create an area

table for closed regions.

Convert specified Flexiblocks in the current drawing to Flexiblocks.

Parameter Set:

Parameter Set:

Parameter Set:

Parameter Set:

Parameter Set:

Parameter Set:

Parameter Set:

Parameter Set:

Parameter Set:

Parameter Set

Parameter Set:

Parameter Set:

Parameter Set:

Parameter Set:

Parameter Set:

Parameter Set:

Parameter Set:

Parameter Set:

Parameter Set:

Flip Set.

Linear Array.

Linear Move.

Linear Move with Pairing.

Linear Stretch.

Linear Stretch with Pairing.

Move Points.

Polar Array.

Polar Move.

: Polar Move with Pairing.

Polar Stretch.

Polar Stretch with Pairing.

Rotate Set.

Visibility Set.

XY Array.

XY Move.

XY Move with Grid.

XY Move with Pairing.

XY Stretch with Grid.
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DGNADJUST
DGNATTACH
DGNBIND
DGNCLIP
DGNLAYERS

FCMPEXPORT
FCMPHIDE

FCMPIMPORT

FCMPSHOW

GRAPHICSCONFIG
LIVESECTION
PCEXTRACTSECTI
ON
POINTCLOUDATT
ACH (PCATTACH)
POINTCLOUDCRO
P
POINTCLOUDCRO
PSTATE
POINTCLOUDMAN
AGER
POINTCLOUDMAN
AGERCLOSE
POINTCLOUDSTYL
IZE
POINTCLOUDUNC
ROP
QUICKPROPERTIE
S

RESETBLCOK
SECTIONPLANE
VPCONTROL

XFCMP

XFCMPCLOSE
REVCLOUDPRO
PERTIES
WORKSPACE

Adjust the appearance of the DGN reference base map.

Attach the DGN reference base map.

Bind the DGN base map as a block reference in the drawing.

Crop the DGN reference base map.

Open the layer dialog for the DGN reference base map.

In file comparison mode, output the current file comparison results as a
snapshot file.

In file comparison mode, hide specified differential objects.

In file comparison mode, input specified differential objects from the

compared drawing into the current drawing file.

In file comparison mode, restore all hidden differential objects to their
initial display state.
Open the graphics hardware settings dialog.

Activate sections.

Extract section lines.

Attach point cloud.

Clip point cloud.

Save/manage clipping states.

Open point cloud manager.

Close point cloud manager.

Adjust point cloud stylization.

Cancel point cloud clipping.

Execute a command and display the quick properties panel for the selected
objects.

Restore one or more Flexiblocks to their default state.

Create a section.

Control whether the viewport control toolbar is enabled.

Compare the attached external reference with a specified drawing file or
the most recent modifications to an external reference.

Exit external reference comparison mode.

Modify the approximate chord length of the selected revision cloud arc.

Save, edit, delete, or specify workspace settings.
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WSSAVE

WSSETTINGS
SHORTCUTS
EXPORTPDF(EP
DF)
STEPIMPORT
STEPIMPORTSE
TTINGS

VSCURRENT
VISUALSTYLES
CHANGEBASE
MAPCS
GEOGRAPHICLO
CATION
GEOREORIENT
MARKER
ADDGEOMAP
ADDGEOSERVIC
E
MAPCATALOGU
E
MAPCATALOGU
ECLOSE
MCTSTATE
MAPCONTENTS
MAPCONTENTS
CLOSE
MCTTSTATE
GEOREGEN
GEOREMOVE
GEOMAPIMAGE
GEOMAPIMAGE
UPDATE
VECTORIZATIO
NOPTIONS
VECTORIZATIO
N
VECTORIZATIO
NRECTIFY

Save the current workspace.

Workplace settings
Pop up the shortcut key node page in CUI
Quickly export PDF files

Input STEP file
STEP file input settings

Configure STEP import settings

Set the visual style of the current viewport
Set the visual style of the current viewport
Change the base point of a block in a drawing
Assign/Remove Coordinate Systems

Set map positioning points, insertion points, and north angles

Set insertion point and north angle

Add map data
Link Map Service

Call up the "Map Link" panel

Close the Map Link panel

Indicates the status of the "Map Link" panel on/off
Call up the "Map Content" panel

Close the "Map Content" panel

Indicates that the "Map Content" panel status is on/off
Refresh all maps in the drawing area

Delete all maps in the drawing area

Region capture of map data

Update area capture

Vectorization parameter configuration

Vectorization of images

Adjusting the vectorization results
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POINTCLOUDC User defined stylization effects

OLORMAP

MESH Used to create basic mesh bodies, including boxes (B), cones (C), cylinders
(CY), pyramids (P), spheres (S), wedges (W), and torus (W)

CONVTOMESH Used to convert 3D solids or surfaces into mesh bodies and smooth them.

MESHSMOOTH | Used to convert 3D solids or surfaces into mesh bodies and smooth them.

MESHSMOOTH @ Used to improve the smoothness of mesh bodies.

MORE

MESHSMOOTHL | Used to reduce the smoothness of mesh bodies.

ESS

MESHREFINE Used to optimize the grid, that is, to increase the number of grids

exponentially without changing their shape (grid subdivision).
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System Variable

T, T

zwcadprefix Stores the directory path, if any, specified by the ZWCAD environment

variable, with path separators appended if necessary.

acadver Stores the CAD version number.

acisoutver Provides a quick guide to which commands were removed in this release.
aflags Determines attribute values which are associate with blocks

angbase Sets the zero (0) base angle with respect to the current UCS.

angdir From angle 0O relative to the orientation of the current UCS, controls

whether the direction of positive angles is measured clockwise or
counterclockwise.
apbox Controls the display of the aperture box in the center of the crosshairs

when you snap to an object.

aperture Set the display size for the target box. Input number of pixels from 1 to
50.

area Stores the last area computed by the AREA command.

attdia Control whether attribute value entries are processed via a dialog box or

command line prompt when using INSERT command to insert blocks.
attmode Controls the visibility of attributes and whether to maintain current
visibility of each attribute
attreq Controls whether default attribute settings are used when using INSERT

command or menu items to insert  blocks

auditctl Controls whether AUDIT creates an audit report (ADT) file.

aunits Sets the angle unit

auprec Sets the decimal precision for angular units

autosnap Controls the display of the AutoSnap marker, tooltip, and
magnet.

backgroundplot Controls whether background plotting is turned on or off for plotting and
publishing.

backz Stores the back clipping plane offset from the target plane for the current

viewport, in drawing units if back clipping of VIEWMODE system variable
ison.
bgripobjsize Sets the display size of custom grips in the Block Editor relative to the

screen display.

bindtype Controls how xref names are handled when binding xrefs or editing xrefs
in place

blipmode Turns on or off point mark

bparametersize Sets the size of parameter text and features in the Block Editor relative to

the screen display.
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cdate

cecolor

celtscale
celtype
celweight

chamfera

chamferb

chamferc

chamferd

chammode

circlerad

clayer
clistate

cmdactive

cmddia

cmdecho

cmdnames
cmleaderstyle
cmljust
cmiscale
cmlistyle
coords
copymode

cplotstyle

cprofile
crossingareacolor

ctab

ctablestyle

cursorsize

cvport

Displays current system time and date.

Assigns a color to new entities without changing the color of existing
entities.

Stores the linetype scale for current entities.

Stores the linetype of new entities.

Sets the lineweight of new objects.

Stores the first chamfer distance associated with the distance-distance
method.

Stores the second chamfer distance associated with the
distance-distance method.

Stores the distance of the chamfer associated with the distance-angle
method.

Stores the angle of the chamfer associated with the distance-angle
method.

Determines whether the chamfer is created based on the input of two
distances or an angle and a distance.

Stores the default radius for circle. There is no default radius if
CIRCLERAD is set to 0.

Stores the current layer.

Indicates whether the command line is open or closed.

Determines whether a script, dialog box, command, or transparent
command is active.

Controls whether the In-Place Text Editor is displayed or not when
executing LEADER or QLEADER command

Determines whether to turn echoing on (debug mode) or off (run mode)
when using the AutoLISP function.

Shows the name of the commands or transparent commands in use.
Setup the current multileader style

Specifies multiline justification.

Determines scale (width) for drawing a multiline

Sets the style when drawing the multiline.

Sets update frequency of coordinates on the left of status bar.
Controls whether the COPY command repeats automatically

Controls the current plot style for new objects.

Displays the name of the current profile.

Controls the color of the selection area during crossing selection.
Determines whether the drawing area displays the Model tab or a
specified layout tab

Sets the name of the current table style.

Specifies the size of the crosshairs cursor as a percentage of the screen
size.

Sets the current viewport's identification number.
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date
dblclkedit

dbmod

dctmain

deflplstyle

defplstyle

delobj

demandload
diastat
dimadec
dimalt
dimaltd
dimaltf
dimaltrnd
dimalttd
dimalttz
dimaltu
dimaltz
dimapost
dimarcsym
dimaso
dimassoc
dimasz

dimatfit

dimaunit
dimazin
dimblk
dimblk1

dimblk2

Stores the current date and time in Modified Julian Date format.

Controls the double click editing operation in the drawing area.

Stores the drawing modification status using bit-code to indicate the
current status.

Displays the three letter keyword for the current main spelling dictionary.
Specifies the default plot style for all layers in a drawing when opening a
drawing that was created in a release prior to AutoCAD 2000, or for Layer
0 when creating a new drawing from scratch without using a drawing
template

Specifies the default plot style for new objects in a drawing when
opening a drawing that was created in a release prior to AutoCAD 2000,
or when creating a new drawing from scratch without using a drawing
template.

Controls whether geometry used to create other objects is retained or
deleted.

Specifies if and when to demand-load certain applications.

Stores the exit method of the most recently used dialog box.

Sets the number of decimal places displayed in angular dimensions
Controls whether the alternate units are displayed or not in dimensions
Sets the number of decimal places used in alternate units

Specifies the multiplier for alternate units

Rounds off the alternate dimension units

Controls the number of decimal places for alternate unit tolerances
Controls suppression of zeros in alternate unit tolerances

Specifies the text format for alternate units

Controls the suppression of zeros for alternate unit dimension

Specifies the prefix or suffix that appears in alternate unit dimension text
Specifies the location of the arc symbol in an arc length dimension
Controls whether to turn on or off the associative dimensions

Controls the associativity of dimension objects

Sets the size of the dimension arrowheads

When space is not sufficient to place dimension text and arrows within
the extension lines, DIMATFIT determines how dimension text and
arrows are arranged

Controls the unit format for angular dimensions

Suppresses zeros for angular dimensions

Sets the arrowhead block type displayed at the ends of dimension lines
Sets the arrowhead block type for the first end of the dimension line
when DIMSAH is on

Sets the arrowhead block type for the second end of the dimension line

when DIMSAH is on
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dimcen

dimclrd

dimclre
dimclrt
dimdec

dimdle

dimdli

dimdsep

dimexe
dimexo

dimfit

dimfrac

dimgap

dimjogang
dimjust
dimldrblk
dimlfac
dimlim
dimlunit
dimiwd
dimlwe

dimpost

dimrnd
dimsah

dimscale

dimsd1
dimsd2
dimsel
dimse2

dimsho

dimsoxd

DIMCEN only can control the center marks and center lines of circles or
arcs created by the DIMCENTER, DIMDIAMETER, and DIMRADIUS
commands

Sets the color for dimension leader lines, dimension lines and
arrowheads

Sets colors for dimension extension lines

Sets colors for dimension text

Sets the number of decimals places displayed for primary dimensions
Controls the distance beyond the extension line that the dimension line
extends when using dimension lines with oblique strokes

Controls the spacing of the dimension lines when drawing baseline
dimensions

Specifies a single-character decimal separator to use when creating
dimensions whose unit format is decimal

Determines how far extension lines stretch beyond dimension lines
Specifies how far extension lines offset the objects

Sets the location for arrowheads, text and extension lines based on the
space between extension lines

Sets the fraction format for main unit linear dimensions

Sets the distance from dimension text to the nearest end of the
dimension line

Specifies the jogged angle in a jogged dimension

Sets the horizontal position of the dimension text

Specifies the arrow type for leaders

Sets a scale factor for linear dimension measurements

Controls whether to use tolerance format of dimension limits

Sets units for all linear dimensions

Sets lineweight to dimension lines

Sets lineweight to extension lines

Specifies a text prefix or suffix (or both) to the dimension text in linear
dimensions

Rounds all dimensioning distances to the specified value

Controls how to display the arrowhead blocks of dimension line

Sets the overall scale factor applied to dimensioning variables that
specify sizes, distances, or offsets

Controls the display of the first dimension line

Controls the display of the second dimension line

Controls the display of the first extension line

Controls the display of the second extension line

Controls the update of dimension measurements while increasing or
decreasing the size of a dimension object

Controls whether to suppress dimension line if dimension line is outside
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dimstyle
dimtad

dimtdec

dimtfac

dimtih

dimtix

dimtm

dimtmove

dimtofl

dimtoh
dimtol

dimtolj

dimtp

dimtsz

dimtvp

dimtxsty
dimtxt
dimtzin
dimunit

dimupt

dimzin

dispsilh

distance
donutid
donutod
dragmode
dragpl
dragp2

of extension lines

current dimension style is displayed

Determines the vertical placement of dimension text in relation to the
dimension line

Sets the number of decimal places to display in tolerance dimensions
Specifies a scale factor for the text height of fractions and tolerance
values relative to the dimension text height

Determines the location of dimension text between extension lines

Controls whether to place the dimension text inside or outside the
extension lines

Specifies the lower tolerance limit for dimension text

Sets dimension text movement rules when dimension text moves,
including whether to move dimension line and whether a leader is added
Determines whether to draw dimension lines between extension lines
when dimension text is placed outside of the extension lines

Sets the position of dimension text outside the extension lines
Determines whether to append tolerances to dimension text

Sets the vertical justification for tolerance values relative to the nominal
dimension text

Specifies the upper tolerance limit for dimension text in tolerance
dimensions

The product of multiplying DIMTSZ by DIMSCALE is the size of oblique
strokes drawn instead of arrowheads

Controls the vertical position of dimension text relative to the dimension
line

Specifies the text style of the dimension text

Specifies the height of dimension text

Controls the suppression of zeros in tolerance dimensions

Sets main units for all linear dimensions

Determines whether to control the location of dimension line or the
location of both dimension line and dimension text

Controls the suppression of zeros in the primary unit value of dimension
Controls display of silhouette edges of 3D solid objects in a 2D Wireframe
or 3D Wireframe visual style.

Saves the last distance calculated by DIST.

Sets the default for the inside diameter of a donut.

Sets the default for the outside diameter of a donut.

Controls whether to display the outline of the object when you drag it.
Sets the regen-drag input sampling rate.

Sets the fast-drag input sampling rate.
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draworderctl

drstate

dtexted

dwgcheck
dwgcodepage
dwgname
dwgprefix
dwgtitled
dynmode

edgemode

elevation

errno

expert

explmode

extmax

extmin

extnames

facetratio

facetres

fielddisplay

fieldeval
filedia
filletrad
fillmode

fontalt

fontmap

fullopen

griddisplay
gridmode

gridunit

Controls the default display behavior of overlapping objects when they

are created or edited.

Indicates whether the Drawing Recovery Manager window is open or
closed

Control the editing mode of a single line text (TEXT)

Checks drawings for potential problems when opening them.
Specifies the system code page specified by operating system.
Stores the current drawing name.

Stores the full path for the drawing.

Determines whether the current drawing has been named.

Controls the cutting and boundary edge for the TRIM and EXTEND
commands.

Stores the elevation of new objects in space view (model or paper)
relative to the current UCS.

Displays the number of error codes when a LISP function call causes an
error that ZWCAD+ discovers.

Controls whether certain prompts are issued.

Determines whether to explode compound objects into nonuniformly
scaled (NUS) blocks.

Stores the upper-right point of the drawing extents.

Displays the world coordinate of lower-left point of the current drawing
in command bar.

Sets the named rules for the objects (such as linetypes, layers, blocks) in
definition tables.

Controls the aspect ratio of faceting for cylindrical and conic solids.
Adjusts the smoothness of shaded and rendered objects and objects with
hidden lines removed.

Controls whether the field is displayed with a gray background. Does not
print the background

Controls field update method

Toggles on and off the display of the file dialog boxes.

Stores the current fillet radius.

Controls whether to fill the solid objects.

Provides an alternate font to be used when a font specified in the
drawing is unavailable

Specifies the font mapping file when replacing one font with another font
Controls whether the current big drawing is partially open (load partially)
or fully open.

Control the display behavior and display extension of grid.

Specifies whether the grid is turned on or off

Specifies the grid spacing (X and Y) for the current viewport
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gripblock
gripcolor
griphot

griphover
gripobjlimit
grips

gripsize
griptips
handles
hideprecision
hidetext
highlight
hpang

hpassoc

hpbound

hpdouble

hpdraworder

hpgaptol

hpinherit

hpname

hporigin

hporiginmode
hpscale

hpspace

hyperlinkbase

Imageframe

Controls the display of grips in blocks.

Controls the color of unselected grips

Controls the color of selected grips

Controls the fill color of an unselected grip when the cursor pauses over
it

Suppresses the display of grips when the selection set includes more than
the specified number of objects

Controls the display of grips on selected objects.

Sets the size of the grip box in pixels.

Controls the display of grip tips when the cursor hovers over grips on
Flexiblocks and custom objects that support grip tips

Controls whether object handles can be accessed by report applications.
Controls the accuracy of hides and shades.

Determines whether to hide text objects created by the TEXT or MTEXT
command during a HIDE command

Controls object highlighting; does not affect objects selected with grips
Sets the angle of the pattern.

Controls whether hatch patterns are adjusted automatically when
boundaries are changed.

Controls whether the object created from a closed area is a polyline or a
region when using BHATCH and BOUNDARY commands to fill the closed
area.

Determines whether to select cross-hatching for user-defined patterns. If
cross-hatching is specified, then a second set of lines are drawn at 90
degrees to the original lines.

Controls the draw order of hatches and fills. You can set the draw order
in "Hatch" dialog box through menu "Draw - Hatch".

Takes a group of objects that almost enclose an area as closed pattern
boundary.

Controls original point of hatch target pattern when using "Inherit
Features" for hatching.

Sets a default hatch pattern name

Sets default pattern origin  point for new pattern objects relative to the
current UCS.

Controls how HATCH determines the default hatch origin point.

Sets a scale factor for the hatch pattern, which must be greater than 0.
Designates the line spacing in user-defined hatch patterns. The range of
value is O or greater.

Specifies the path used for all relative hyperlinks in the drawing

Control whether to show and plot image frame in current drawing.
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Imagehlt

indexctl

insbase

insname

insunits

insunitsdefsource

insunitsdeftarget

intersectioncolor

intersectiondisplay

isavebak

isavepercent

isolines

lastangle

lastpoint

lastprompt

laylockfadectl

lenslength

limcheck

limmax

limmin

lispinit

logfilemode

logfilename
logfilepath
loginname

Itscale

Controls whether the entire raster image or only the raster image frame
is highlighted. Only highlighting the image frame can improve system
performance.

Controls whether layer and spatial indexes are created and saved in
drawing files.

Stores the coordinate of the insertion base point specified by the BASE
command, which is represented as a UCS coordinate for the current
space.

Specifies a default block name for the INSERT command.

Specifies a drawing-units value for automatic scaling of blocks or images
dragged from DesignCenter and inserted into a drawing.

Sets source content units value when INSUNITS is set to O

Sets target drawing units value when INSUNITS is set to 0.

Controls the color of polylines at the intersection of 3D surfaces when
the visual style is set to 2D Wireframe.

Controls the display of polylines at the intersection of 3D surfaces when
the visual style is set to 2D Wireframe

Improves the speed of incremental saves, especially for large drawings.
Determines the amount of wasted space tolerated in a drawing file.
Specifies the number of contour lines for each surface on objects.
Stores the angle of the last arc, line, or polyline entered relative to the XY
plane of the current UCS for the current space.

Stores the value of the last point entered relative to the current user
coordinate system (UCS) for the current space.

Stores the last prompt string displayed on the command line.

Controls the dimming of objects are on locked layer, the range is -90 to
90.

Stores the length of the lens in millimeters used in perspective viewing.
Controls whether you can create entities outside the drawing limits.
Stores the upper-right grid limits for the current space, expressed as a
world coordinate.

Saves the lower-left drawing limits for the current space, represented as
a value of world coordinate system.

In single file interface, controls whether to retain functions and variables
defined by LISP or confirms their validation when starting a new drawing
file.

Controls whether the log file is maintained and the contents of text
window are written to the log file.

Sets the file name of the log file for the current drawing.

Specifies the save path for the log files.

Displays the login name.

Sets the global linetype scale factor.
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lunits
luprec
lwdefault
lwdisplay
Iwunits

maxactvp

maxsort

mbuttonpan
measureinit
measurement
menuctl
menuecho
menuname
mirrtext

modemacro

mtexted

mtextfixed

mtjigstring

mydocumentsprefix

nomutt

obscuredcolor

obscuredIltype

offsetdist

offsetgaptype

oleframe

olestartup

opmstate

orthomode

osmode

osnapcoord

Sets the linear units.

Sets the display precision for linear units and coordinates.

Sets the value for the default lineweight.

Controls whether the lineweight is displayed.

Controls whether lineweight units are displayed in inches or millimeters.
Sets the maximum number of viewports that can be activated at one
time in a layout. MAXACTVP has no effect on the number of viewports
that are plotted.

Sets the maximum number of symbol names or block names sorted by
listing commands.

Controls the behavior when holding or moving the mouse.

Sets default units (imperial or metric) when creating new drawings.
Sets unit (Imperial or Metric) for existing drawings.

Controls the page switching of the screen menu.

Controls display of menu items and system prompts.

Stores the name and path of the menu file.

Sets the text direction when using the MIRROR command to text objects
Sets the string displayed on the status bar, such as the current time and
creator of this drawing.

Sets the application name for editing multi-line text objects

Sets display size and direction of multi-line text in text editor

Sets the sample text content displayed at the cursor position when the
MTEXT command is executed

Stores the full path to the My Documents folder for the user currently
logged on.

Controls whether to display information feedback.

Specifies the color of obscured lines.

Specifies the linetype of obscured lines.

Sets the default offset distance.

Controls how to fill the potential gaps between segments when offsetting
polyline objects.

Sets whether a frame is displayed and printed on all OLE objects in
ZWCAD.

Controls whether the source application of an embedded OLE object
loads when plotting.

Controls whether the current display state of Properties palette is open,
closed or hidden.

Determines whether to turn on "ortho" mode.

Specifies object snap using the bitcode of the sum of the following
values.

Controls whether coordinates entered on the command line override

running object snaps.
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osnaphatch

osnapnodelegacy

oshapz

paperupdate

pdmode
pdsize

peditaccept

pellipse

perimeter
pfacevmax

pickadd

pickauto

pickbox

pickdrag
pickfirst

pickstyle
platform

plinegen

plinetype
plinewid

plotoffset

plotrotmode

plquiet

polaraddang
polarang
polardist
polarmode
polysides
popups

Controls whether to ignore the pattern fill object during object snap
action.

Controls whether the Node object snap can be used to snap to multiline
text objects.

Controls whether the object snap is automatically projected onto a plane
parallel to XY plane at the specified elevation in current UCS.

Controls how to handle the situation if the paper size specified in the
layout is not supported by the plotter.

Controls how point objects are displayed.

Sets the display size for point objects.

Suppresses display of the Object Selected Is Not a Polyline prompt in
PEDIT.

Controls whether the entity drawn with the Ellipse command is a true
ellipse or an ellipse made up of polylines.

Stores the last perimeter value calculated by the AREA or LIST command.
Sets the maximum number of face vertices in a polyface mesh.
Determines adding the new selected objects to the current selection
directly or replacing the previous selected objects in the selection.
Controls whether to display the selection window automatically at the
"Select Objects" prompt.

Specifies the target height for entity selection, in pixels. The range of
value is from 0 to 50.

Controls whether to draw a selection window by "hold and drag "mode.
Determines whether you select entities before or after issuing a
command.

Controls the use of group selection and associative hatch selection.
Displays on which Operating system ZWCAD+ is running.

Controls how linetype patterns generate around the vertices of a 2D
polyline.

Specifies whether optimized 2D polylines are used.

Sets the default polyline width to a value of 0 (the default) or greater.
Controls whether the plot offset is relative to the printable area or to the
edge of the paper.

Controls the orientation of plots.

Controls the display of optional plot-related dialog boxes and nonfatal
errors for scripts.

Stores additional angles for polar tracking and polar snap.

Sets the polar angle increment.

Sets the snap increment when the SNAPTYPE is set to 1 (PolarSnap).
Controls settings for polar and object snap tracking.

Specifies the default number of sides for the polygon command.

Displays the status of the currently configured display driver of dialog
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product
progbar
program
projectname

projmode

propobijlimit

proxygraphics

proxynotice

proxyshow

proxywebsearch

psltscale

pstylemode

pstylepolicy

psvpscale

pucsbase

gtextmode

rasterdpi

rasterpreview

refeditname

regenmode

rememberfolders

roamablerootprefix

rtdisplay

savefile

savefilepath

boxes, menu bar and icon menus.

Returns the product name.

Controls to turn on or off the display of progress bar.

Returns the program name.

Specifies a project name for the current drawing.

Specifies the projection mode used for the trimmed and extended
objects.

Limits the number of objects that can be changed at one time with the
Properties palette

Specifies whether images of proxy objects are saved in the drawing
Displays a notice when a proxy is created

Controls the display of proxy objects in a drawing.

Controls whether ZWCAD+ checks Object Enabler and determines
whether Object Enabler is available.

Controls the linetype scaling of objects displayed in paper space
viewports.

Indicates whether the current drawing is in a Color-Dependent or Named
Plot Style mode.

Controls the plot style mode, Color-Dependent or Named, that is used
when opening a drawing that was created in a release prior to AutoCAD
2000 or when creating a new drawing from scratch without using a
drawing template

Sets view scale factor relative to paper space.

Stores the name of the UCS that defines the origin and orientation of
orthographic UCS settings in paper space only.

Turns on or off "quick text" mode, and determines how text is displayed
Controls paper size and plot scaling when changing from dimensional to
dimensionless output devices, or vice versa.

Controls whether thumbnail preview images are created and saved with
the drawing.

Displays the name of the reference being edited.

Controls automatic regeneration of the drawing.

Determines default path of Select File dialog box when executing find or
save function in ZWCAD+ system.

Stores the full path to the root folder where roamable customizable files
were installed.

Controls whether outline of raster image or content of raster image is
displayed during running ZOOM or PAN command.

Stores the file name and extension when the current drawing is saved
automatically.

Specifies the path to the directory for all automatic save files for the

current session.
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savename

savetime
screenboxes
screenmode
screensize
sdi

selectionarea

selectionareaopacity

selectionpreview

shadedge
shadedif
shortcutmenu

showlayerusage

sketchinc

skpoly

snapang

snapbase

snapisopair

snapmode

snapstyl

snaptype

snapunit

solidcheck

sortents

splframe

splinesegs

splinetype

startup

surftabl

surftab2

Displays the file name and directory path of the most recently saved
drawing.

Sets the automatic save interval, in minutes.

Stores the number of boxes in the screen menu area of the drawing area.
Indicates the state of the display.

Stores current viewport size in pixels (X and Y).

Controls whether ZWCAD+ select multiple-drawings interface.

Controls the display of effects for selection areas.

Controls the transparency of the selection area during window and
crossing selection.

Controls the display of selection previewing.

Controls the shading of edges.

Sets the ratio of diffuse reflective light to ambient light.

Determines whether shortcut menu, including Default, Edit and
Command mode can be used in drawing area.

Displays icons in the Layer Properties Manager to indicate whether layers
are in use.

Sets the record increment for the SKETCH command.

Specifies whether the SKETCH command creates straight lines or
polylines.

Sets the snap and grid rotation angle for the current viewport relative to
the current UCS.

Sets the snap and grid origin point for the current viewport relative to the
current UCS.

Sets the crosshairs to an isometric plane

Determines whether snap mode is on or off for the current viewport
Sets the snap style for the current viewport to either standard (0) or
isometric (1).

Sets the snap type for the current viewport.

Sets the snap spacing in the x and y direction

Turns 3D solid validation on and off for the current session

Controls the order in which entities are sorted

Controls the display of splines and spline-fit polylines.

Sets the number of line segments to be generated for each spline-fit
polyline generated by the Spline option of the PEDIT command.
Determines the type of spline curve created when using the pedit
command to transform a polyline into a spline.

Controls what displays when the application is started, or when a new
drawing is opened

Sets the number of tabulations to be generated for the RULESURF and
TABSURF commands.

Sets the mesh density in the N direction for the REVSURF and EDGESURF
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surftype

surfu

surfv

syscodepage

tabletoolbar

target

tdcreate

tdindwg

tducreate
tdupdate
tdusrtimer
tduupdate

tempprefix

texteval

textfill

textqlty

textsize

textstyle

thickness
tilemode
tooltips
tpstate
tracewid
trackpath
trimmode

tspacefac

tspacetype

commands.

Controls the type of surface-fitting to be performed by the Smooth
option of the PEDIT command.

Sets the surface density for PEDIT Smooth in the M direction and the U
isolines density on surface objects.

Sets the surface density for PEDIT Smooth in the N direction and the V
isolines density on surface objects.

Specifies the system code page specified by operating system

Controls the display of the Table toolbar.

Stores the location (as a UCS coordinate) of the target point for the
current viewport.

Stores the local time and date the drawing was created.

Stores the total editing time, which is the total elapsed time between
saves of the current drawing.

Stores the universal time and date that the drawing was created.
Stores the local time and date of the last update/save.

Stores the user-elapsed timer.

Stores the universal time and date of the last update or save.

Stores the folder name assigned for temporary files, with a path
separator appended.

This system variable can determine whether the responses to prompts
are treated literally or as an LISP expression when executing TEXT
command or -TEXT command

Controls the filling of TrueType fonts while plotting and rendering

Sets the resolution tessellation fineness of text outlines for TrueType
fonts while plotting and rendering

Sets the default height for new text object drawn with current text style
when the current text style has no fixed height

Sets the name for the current text style

Sets the default 3D thickness property when creating 2D geometric
objects.

Controls the switch between the last layout tab (paper space) and the
model space.

Controls whether to display the tooltips when the mouse is moved on the
toolbar buttons.

Indicates whether the Tool Palettes window is open or closed.

Stores the default trace width.

Controls the display of polar and object snap tracking alignment paths
Controls whether selected edges for chamfers and fillets are trimmed.
Controls the multiline text line-spacing distance measured as a factor of
text height

Controls the type of line spacing used in multiline text
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tstackalign

tstacksize

ucsbase

ucsdetect
ucsfollow

ucsicon

ucsname

ucsorg

ucsortho

ucsview

ucsvp

ucsxdir

ucsydir

undoctl

undomarks

undosnapshot

unitmode

updatethumbnail
useril
useri2
useri3
useri4
useri5
userrl
userr2
userr3
userr4
userr5
usersl
users2

users3

Controls the vertical alignment of stacked text

Controls the percentage of stacked text fraction height relative to
selected text's current height

Stores the name of the UCS that defines the origin and orientation of
orthographic UCS settings.

Control whether to enable the function of dynamic UCS.

Generates a plan view whenever you change from one UCS to another.
Controls the display of UCS icon of current viewport and controls
whether to display icon at origin.

Stores the name of the current coordinate system for the current
viewport in the current space.

Stores the origin point of the current coordinate system for the current
viewport in the current space.

Controls whether to restore the related orthographic UCS setting
automatically when an orthographic view is restored.

Determines whether the current UCS is saved with a named view.
Determines whether the UCSs in other viewports are dependent or
independent of the UCS of the current viewport.

Stores the X direction of the current UCS for the current viewport in the
current space.

Stores the Y direction of the current UCS for the current viewport in the
current space.

Displays the state of the Auto, Control options of the UNDO command
Stores the number of marks placed in the UNDO control stream by the
Mark option

Control whether to generate the UNDO snapshot file

Determines whether to display the units based on input format or
previous set format

Controls updating of the thumbnail previews for views and layouts.
Provides storage and retrieval of integer values.

Provides storage and retrieval of integer values.

Provides storage and retrieval of integer values.

Provides storage and retrieval of integer values.

Provides storage and retrieval of integer values.

Provides storage and retrieval of real numbers.

Provides storage and retrieval of real numbers.

Provides storage and retrieval of real numbers.

Provides storage and retrieval of real numbers.

Provides storage and retrieval of real numbers.

Provides storage and retrieval of text string data.

Provides storage and retrieval of text string data.

Provides storage and retrieval of text string data.
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users4
users5
vernum
viewctr
viewdir
viewmode
viewsize
viewtwist

visretain
vpmaximizedstate
vsmax

vsmin
windowareacolor
wmfbkgnd
wmfforegnd

worlducs

worldview

wscurrent

xclipframe

xedit

xfadectl|

xloadctl
xloadpath
Xrefctl
xrefnotify
xreftype

zoomdisphatch

zoomfactor

Provides storage and retrieval of text string data.

Provides storage and retrieval of text string data.

Display the version number of current CAD platform.(Read-only)
Stores the center of the view in the current viewport.

Stores the view settings for the current viewport.

Stores the view settings for the current viewport.

Sets the height value for the current viewport presented in drawing units.
Stores the view rotation angle for the current viewport.

Determines visibility, color, linetype and lineweight of xref-dependent
layers.

Controls whether the viewport is maximized or not.

Stores the UCS coordinate of upper-right corner in current viewport.
Stores the UCS coordinate of lower-left corner in current viewport.
Controls the background color of window selection area

Controls the background display when objects are inserted in Windows
metafile (WMF) format

Controls the assignment of the foreground color when objects are
inserted in Windows metafile (WMF) format.

Specifies whether the user coordinate system (UCS) is the same as the
World Coordinate System (WCS).

Controls whether the input to VPORTS command is relative to default

World Coordinate System or User Coordinate System.

Displays the current workspace name at the Command prompt and sets a
specified workspace to be the current one.

Determines whether xref clipping boundaries are visible or plotted in the
current drawing.

Controls whether the current drawing can be edited in-place when being
referenced by another drawing.

Controls the amount of fading within a reference being edited in place.
This setting affects only the objects that are not being edited in the
reference.

Turns xref demand-loading on and off, and controls whether it opens the
referenced drawing or a copy.

Creates a path for storing temporary copies of demand-loaded xref files.
Controls whether external reference log (XLG) files are created.

Controls the notification for updated or missing xrefs.

Controls the default reference type when attaching or overlaying an
external reference.

Control whether displaying the hatch when using PAN and ZOOM to
Translate and scale.

Controls how much the magnification changes when the mouse wheel

moves forward or backward.
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zoomwheel

zwcmdline

zwribbontabhide

btmarkdisplay

gripdyncolor

layoutregenctl

hpseparate

hpmaxlines

zrxchecknotify

xdwgfadectl

millisecs

ADCSTATE

FRONTZ

GRIDMAIJOR

BLOCKEDITLOCK

BLOCKEDITOR

BLOCKTESTWINDOW

QCSTATE

DYNDIGRIP

DYNDIVIS

Toggles the direction of transparent zoom operations when you use the
the mouse wheel.

Turns on or off dynamic input function

Controls the display of the panels on the Ribbon.

Control whether to display the tickmarks for the value set in Flexiblock
reference.

Determine the color of custom grips for Flexiblocks. The range of value is

from 1 to 255.

Specify how the display list is updated in the Model tab and layout tabs.
When specifying several closed boundaries for hatching, this variable can
be used to control whether a single hatch object or separate hatch

objects are created.

Set the maxmimum number of pattern hatch lines that can be
generated in the pattern hatch. The valid value ranges from 100 to
10,000,000.

Control whether to display a notice when the version of
ZRXSCK does not match with the version of ZWCAD.

Controls the fading display of external reference.

Record the number of millisecond lasted from the system
operation starting until you execute this system
variable.(Read-only)

Controls whether the current state of Design Center window is open or
close
Stores the distance from front clipping plane to the target plane for the
current viewport, in drawing units only when the VIEWMODE system
variable is set to 1 and “the front clip-not-at-eye” is also set to 1
Controls the frequency compared between major grid and minor grid.
The range of effective value is from 1 to 100
Disallows opening of then Block Editor and editing of Flexiblock
definitions

Indicates whether or not the Block Editor is open
Indicates whether or not a test window is current
Indicates whether or not Quick Calculator is open or closed

Controls which dynamic dimensions are displayed during grip stretch
editing
Controls how many dynamic dimensions are displayed during grip stretch
editing
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DYNPICOORDS

DYNPIFORMAT

DYNPIVIS

BLOCKEDITMODE

PDFOSNAP

PDFFRAME

MSOLESCALE

ANNOALLVISIBLE

ANNOAUTOSCALE

ANNOTATIVEDWG

CANNOSCALEVALUE

CANNOSCALE

DIMANNO

HPANNOTATIVE

LAYERDLGMODE

LAYERMANAGERSTATE

WORKSPACELABEL

GRIPADSORB

DWFDELMODE

LENSLENGTH

HPISLANDDETECTIONMODE

GRIPMULTIFUNCTIONAL

WIPEOUTFRAME

Controls whether pointer input uses relative or absolute format for
coordinates

Controls whether pointer input uses polar or Cartesian format for
coordinates

Controls when pointer input is displayed
Controls whether it will use REFEDIT or BEDIT when double-clicks a block

Control whether to enable the object snapping for the geometry in
PDF underlay.
Control whether to display and plot the frame in PDF underlay.

Control the initial size of an OLE object with text which is pasted
on the Model space.
Control the display of the annotative objects which do not support

the current annotation scale.

Control whether annotative objects are updated to support the
annotation scale when you change it.
Control whether the drawing is inserted into another drawing as an

annotative block.

Display the value of the current annotation scale.
Set the name of the annotation scale for the current space.
Indicate whether the current dimension style is an annotative style.

Control whether a newly created hatch pattern is annotative.

Control whether to display the modal dialog box or modeless

dialog box (palette) of the Layer Manager.
Control whether to display or close the Layer Manager.

Controls whether the name of the current workspace is displayed

in the status bar.
Control the display range that grips can adsorb.

Control whether a block reference that generated from a
DWEF/DWFx file can be deleted.
Store the length of the lens used in the active viewport, and the

unit is millimeter.

Control whether island detection is applied to hatches.
Control whether to turn on or off the multifunctional grip menu.

Control the display of frames for wipeout entities.
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DWFFRAME

DWFOSNAP

WBLOCKPATH

FILETYPEASSOC

OSOPTIONS

SIGWARN

PDFIMPORTMODE

PDFIMPORTFILTER

PDFIMPORTLAYERS

INPUTSEARCHOPTIONFLAGS

SELECTIONCYCLING

LAYOUTTAB

TEXTEDITMODE

LOADDWGCONCURRENTLYIFPOSSIBLE

TASKBAR

FRAME

FRAMESELECTION

SMARTMOUSEFIRST

MIRRHATCH

OLEFORMAT

VPLAYEROVERRIDES

Control the display and plot of the DWF underlay frame.
Control whether to snap the objects in DWF underlay.

Custom default export path of wblock.

Control whether to check the association of .dwg files with
ZWCAD at startup.

Control whether the endpoints of dimension extension lines are
ignored when snapping objects.

Control whether the dialog box of Digital Signature Contents is
displayed when you open a drawing file with an attached digital

signature certificate.
Control how to process the data objects in an imported PDF file.

Control which types of data objects in the PDF file to be imported
and converted to CAD objects.

Control which layers the data objects in the imported PDF file will
be placed in.

Control whether to display a list of commands with similar names
while inputting the first few letters in the command line.

Control whether to display the Selection Set dialog box for the

overlapping objects.
Control whether to show or hide the Layout tab.

Control whether the “DDEDIT” command is used to repeat

automatically or edit a single text object
Control whether to load .dwg drawings concurrently

Control whether multiple drawings are displayed as a group or
separately in the Windows taskbar.

Control whether to display and plot frames of images, underlays,
wipeout objects, and clipped xrefs.

Control whether the hidden frame of image, underlay, wipeout,
and clipped xref can be selected.

Control whether right-click function or smart mouse function is
executed first when the value of system variable
SHORTCUTMENU is 0 or greater than or equal to 16.

Control whether hatch pattern direction change when mirroring

hatch pattern.
Control the format of DWG file in which OLE objects are saved.

Indicate whether there are any layer property overrides in current

viewport.
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VPLAYEROVERRIDESMODE

LAYEROVERRIDEHIGHLIGHT

TRANSPARECYDISPLAY

CETRANSPARENCY

HPTRASPARENCY

ERHIGHLIGHT

COLORTHEME

EDUCHECK

EDITNESTEDBLOCK

ZWSWITCHLANGUAGE

FCMPCOLOR1

FCMPCOLOR2

FCMPCOLORCOMMON

FCMPFRONT

FCMPHATCH

FCMPPROPS

Control whether to display and plot the layer property overrides of
layout viewport.

Control whether the layers with property overrides are highlighted
in the Layer Properties Manager. When highlighting is turned on,
the layer with property overrides will be highlighted with
background color, the highlighted content includes layer name and

properties.

Control whether the transparency specified for object is effective.

Set the transparency of new objects.

nn

Set transparency for new hatches. Valid values include ".",
"ByLayer", "ByBlock" and integer values between 0-90. The "."
means to use the current value (specified by the system variable
CETRANSPARENCY). Integer between 0-90 is transparency
percentage, 0 is opaque, and 90 is the most transparent.

Controls whether the reference object or reference name is
highlighted when the reference name is selected in the External
Reference palette or the reference object is selected in the drawing

window.
Control the light or dark display style of the program interface.

Control whether the warning is displayed when opening education
version drawing, and whether there is an watermark when printing
education version drawing.

This system variable setting does not affect ZWCAD education
versions.

Execute BEDIT command or REFEDIT command to edit blocks,
controls the pre-selection when dialog box is open.

It controls whether the system input method is switched to English
when you are using the Chinese version of ZWCAD.

Set the color of the objects which only exist in one of the two
drawings being compared.

Set the color of the objects which only exist in the other of the two
drawings being compared.

Set the color of the same objects that exist in both the two
drawings being compared.

Control the default sequence of displaying the objects overlaid

when comparing files.
Control whether to include hatches when comparing files.

It decides what kind of property changes will be pointed out when

comparing files.
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FCMPRCMARGIN

FCMPPRCSHAPE

FCMPSHOW1

FCMPSHOW2

FCMPSHOWCOMMON

FCMPSHOWRC

FCMPTEXT

FCMPTOLERANCE

FCMPSTATE

FCMPMODE

FCMPFIRSTPATH

FCMPFIRSTSAVETIME

FCMPFIRSTEDITBY

FCMPSECONDEDITBY

FCMPSECONDPATH

FCMPSECONDSAVETIME

FCMPDIFFTOTAL

FCMPDIFFINDEX

FCMPSHOWREFFERCEN

FILETABSTATE

HPLAYER

REPORTERROR

VPROTATEASSOC

It specifies the distance between the contour of the object and the
revision cloud.

It controls whether to mark the differences in the file comparison
results with rectangular or polygonal revision clouds.

It controls whether to display objects that only exist in the datum
drawing.

It controls whether to display objects that only exist in the
reference drawing.

It controls whether to display objects that are the same in both
drawings.

It controls whether to show revision clouds in the file comparison
results.

It controls whether the text objects will be included in file
comparison.

It sets a difference tolerance of File Compare. If the difference
value of compared entities isn’t more than the tolerance, they will

be considered as the same.

It switches File Compare versions, V1.0 and V2.0.
It shows whether FCMP is invoked.

It modifies the saving path of the datum drawing.
It modifies the save date of the datum drawing.

It modifies the information about the editor of the datum drawing.

It modifies the information about the editor of the reference

drawing.

It modifies the saving path of the reference drawing.
It modifies the save date of the reference drawing.

It shows all differences in the file comparison results.

It helps quickly locate a specific difference in the file comparison

results.

It controls whether to show or hide the file comparison results.
Indicate the current status (displayed or hidden) of the file tab.

Place the hatch pattern in a new layer or the current layer.

Control whether to send an error report to ZWSOFT when the

program is closed unexpectedly.

When the viewport is rotated, it controls whether the entities inside
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BLOCKBREAKMODE

MENUBAR

RIBBONSTATE

PLOTTRANSPARENCYOVERRIDE

LINESMOOTHING

ARRAYASSOCIATIVITY

ARRAYEDITSTATE

ARRAYTYPE

DGNIMPORTMODE

DGNMAPPINGPATH

GROUPDISPLAYMODE

CLEARCOPYMARGIN

GRIPS

HPCOLOR

HPBACKGROUNDCOLOR

DISABLEOSNAPLIMIT

PLINEGCENMAX

TEXTSMOOTHING

SOLIDHIST

ZOOMSPEEDLEVEL

SSFOUND

SSLOCATE

it rotate with it.
Control the mode (Wipeout or Break) of attaching blocks to
entities.

Control whether to display the classic menu.

Show the state of the Ribbon: open or closed (Read-only).
Control whether to plot object transparency.

Control whether to turn on the anti-aliasing switch.
Control whether the array created is associative.

Display the state of array editing. (Read-Only)

Indicate the default type when the array is created.

Control the default import mode of the DGNIMPORT command.

Specify the path used to store the DgnSetups.ini file that is set
using the DGNMAPPING command. (Read-Only)

Control how the grips for the selected group are displayed.
Control whether to clear the margin when copying entities.
The new value, “2”, displays midpoint grips of polylines.
Set the default color of the hatch object.

Set the default background color of the hatch object.

Control whether to turn on the precise snap mode when the number of
objects exceeds the limit.
Set the maximum number of line segments allowed in a polyline when

calculating geometric centers.
Control text antialiasing on or off.

Control whether created 3D solids retain the history of original
components.

Control the level of optimization for ZOOM. The optional value is
0-3, the higher the value, the better the efficiency optimization, but
the degradation of block during the ZOOM process will be more
serious.

Display the sheet set path and file name associated with the current
drawing.

Control whether to open associated sheet set when opening a

drawing.
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SSMAUTOOPEN

SSMPOLLTIME

SSMSHEETSTATUS

SSMSTATE

SSKEEPCREATE

TOOLTIPSHOWDELAY

TOOLTIPSHOWDELAYEXT

HARDWAREACCELERATION

DGNFRAME

DGNOSNAP

XFCMPBAKSIZE

XFCMPBAKPATH

XFCMPENABLE

XFCMPCOLORMODE

FCMPSHOWCONTEXT

QPMODE

QPLOCATION

XREFOVERRIDE

VISRETAINMODE

ATEXMODE

STEPSIZE

New System Variables

Control whether the Sheet Set Manager is opened when a drawing

associated with a sheet set is opened.

Set the time interval for automatic refresh of sheet set status data.
Set how sheet set status data is refreshed.

Indicate the current state of Sheet Set Manager, open or closed.

Control whether to prompt to continue creating a subset after

creating a subset.
Controls how long to wait to display simple tooltips.

Controls how long it takes to jump from a simple tooltip to an
extended tooltip.

Control the enabling of hardware acceleration.

Control the display and printing of the DGN reference base map
border.

Control the enabling of object snapping for subobjects of the
DGN reference base map.

Set the folder size for storing backup external reference files.
Specify the path for storing backup external reference files.

Control the enabling of external reference comparison
functionality.

Control the dimming of objects in the current drawing during
external reference comparison.

Control the display of objects in the external reference
comparison result in the current drawing.

Control the opening of the "Quick Properties" palette when
selecting objects.

Set the position of the "Quick Properties" palette.

Control the application of external reference layer properties
overrides in the current drawing.

Set the layer property types to be saved to the current drawing
when layer properties change in the external reference source
drawing.

Control the opening of the area table output after saving.

Set the distance for each step of movement in 3D pan or fly

mode.
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STEPSPERSEC

DRAWINGAREABUTTON

POINTCLOUDPOINTSIZE

POINTCLOUDLOD

POINTCLOUDBOUNDARY

POINTCLOUDDISPLAY

POINTCLOUD2DVSDISPLAY

POINTCLOUDLOCK

LINEEXTRACTCOLOR

LINEEXTRACTCONNECTSEGM

LINEEXTRACTMINSEGMENTLENM

LINEEXTRACTOUTPUTLAYER

LINEEXTRACTOUTPUTTYPE

LINEEXTRACTPOLYLINEWIDTH

LINEEXTRACTPREVIEW

LINEEXTRACTEDUCECOLVERT

PCMSTATE

New System Variables

POINTCLOUDPOINTMAX

LINEEXTRACTTYPE

3DOSMODE

POINTCLOUDPLOT

MTEXTCOLUMN

Set the number of steps per second for movement in 3D pan or
fly mode.

Control the display and hiding of the three buttons in the
upper-right corner of the drawing area.

Set the point size of the point cloud.

Set the level of detail for the point cloud.

Control the display of the point cloud border.

Control the display of the point cloud.

Control the display of the point cloud in 2D wireframe mode.
Lock the point cloud.

Set the color of section lines.

Control the line-to-line tolerance for extracting section lines
from the point cloud.

Control the minimum length of straight lines when extracting
section lines from the point cloud.

Set the output layer for the extracted point cloud section lines.

Control the output type for the extracted point cloud section
lines.

Control the line width of the 2D polylines when extracting
point cloud section lines.

Control the preview of results when extracting point cloud
section lines.

Control the angular tolerance for extracting point cloud section
lines.

Display the current status of the point cloud manager.

Set the maximum number of points to display in the point
cloud.

Control whether to extract the entire cross-section or only the
perimeter when extracting point cloud section lines.

Set the snapping mode for 3D objects, currently only
controlling the snapping to point cloud nodes.

Control the display of relevant prompts when printing point
clouds is not supported in the current mode.

Control the default layout mode.
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MTEXTTOOLBAR

MTEXTDETECTSPACE

CLICKAPPBTN

DEFAULTGIZMO

GTAUTO

REVCLOUDGRIPS

VPSCALEASSOC

BAKMAXFILES

BAKMAXTOTALSIZE

THUMBQUALITY

SYSFLOATING

INREFEDIT

ARRAYCREATION

RIBBONDOCKEDHEIGHT

RIBBONICONRESIZE

LISPSYS

FASTSHADEDMODE

FACETRES

VIEWUPDATEAUTO

GEOLATLONGFORMAT

GEOMARKERVISIBILITY

DIVMESHBOXHEIGHT

DIVMESHBOXLENGTH

DIVMESHBOXWIDTH

DIVMESHCONEAXIS

Control the display of the text editing toolbar.
Control the application of spacing settings for numbering.

Control the single-click or double-click behavior of the
application icon.

Control default Gizmos types

Control whether the Gizmos automatically displays

Control the number of grips displayed on the revision cloud
line.

When controlling viewport scaling, whether the internal views
are scaled together.

Set the maximum number of backup file entries that can be
kept in the automatic save file location.

Set an upper limit in megabytes (Mbs) for all graphic file
entries in the automatically saved backup file.

Control the accuracy of saving graphic thumbnails when saving
graphics.

Control the fixed state of the graphic file tab.

Indicates whether the edit reference tab is displayed
Indicates the type of array creation tab

Determine whether to set the horizontally fixed ribbon to the
height of the current tab or a predefined height.

Control whether to adjust the icon size on the ribbon to
standard size

Control the default encoding runtime environment of Lisp, and
after modification, it must be restarted to take effect

Set whether fast rendering mode is enabled or set the level of
fast rendering mode

Adjust the smoothness of shading and rendering objects,
rendering shadows, and objects with hidden lines removed.
Control whether the model document drawing view will
automatically update when changing the source model.
Control the format of latitude and longitude display

Control the visibility of anchor points

Set the number of subdivisions for the height of the grid box
along the Z-axis.

Set the number of subdivisions for the height of the grid box
along the X-axis.

Set the number of subdivisions for the height of the grid box
along the Y-axis.

Set the number of subdivisions around the perimeter of the

mesh cone base.
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DIVMESHCONEBASE

DIVMESHCONEHEIGHT

DIVMESHCYLAXIS

DIVMESHCYLBASE

DIVMESHCYLHEIGHT

DIVMESHPYRBASE

DIVMESHPYRHEIGHT

DIVMESHPYRLENGTH

DIVMESHSPHEREAXIS

DIVMESHSPHEREHEIGHT

DIVMESHTORUSPATH

DIVMESHTORUSSECTION

DIVMESHWEDGEBASE

DIVMESHWEDGEHEIGHT

DIVMESHWEDGELENGTH

DIVMESHWEDGESLOPE

DIVMESHWEDGEWIDTH

FACETERMESHTYPE
FACETERDEVSURFACE

FACETERDEVNORMAL

FACETERGRIDRATIO

FACETERMAXEDGELENGTH

Set the number of subdivisions between the perimeter and
center of the mesh cone base.

Set the number of subdivisions between the base and vertices
of the mesh cone.

Set the number of subdivisions around the circumference of
the cylinder base.

Set the number of radius subdivisions from the center of the
mesh cylinder base to its circumference.

Set the number of subdivisions between the bottom and top
surfaces of the mesh cylinder.

Set the number of radius subdivisions between the center of
the bottom surface of the grid cold cone and its circumference.
Set the number of subdivisions between the bottom and top
surfaces of the mesh pyramid.

Set the number of subdivisions for each annotation along the
bottom of the mesh pyramid.

Set the number of radius subdivisions around the endpoints of
the mesh sphere axis.

Set the number of subdivisions between the endpoints of the
two axes of the mesh sphere.

Set the number of subdivisions for the path swept by the
contour of the mesh torus.

Set the number of subdivisions in the contour of the swept
mesh torus path.

Set the number of subdivisions between the midpoint of the
perimeter of the mesh wedge and the triangle annotation.

Set the number of subdivisions for the height of the mesh
wedge along the Z-axis.

Set the number of subdivisions along the X-axis for the length
of the mesh wedge.

Set the number of subdivisions from the vertex of the wedge to
the edge of the base.

Set the number of subdivisions for the width of the mesh
wedge along the Y-axis.

Set the mesh type generated by the MESHSMOOTH command.
This setting will affect the mesh converted from another object
using the MESHSMOOTH command.

Set the maximum angle between the surface normal and
adjacent mesh faces in the MESHSMOOTH command.

Set the maximum aspect ratio of the mesh converted from
solids and surfaces in the MESHSMOOTH command.

Set the maximum length of the mesh generated by the
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FACETERMAXGRID

FACETERMINUGRID

FACETERMINVGRID

FACETERSMOOTHLEV

LONGITUDE

LATITUDE

MAPCS

SWITCHCOORDINATE

CGEOCS

MESHSMOOTH command.

Set the maximum number of grid U and V lines generated by
the MESHSMOOTH command.

Set the minimum number of grid U lines generated by the
MESHSMOOTH command.

Set the minimum number of grid V lines generated by the
MESHSMOOTH command.

Set the smoothness of the mesh generated by the
MESHSMOOTH command.

Set the longitude of geographic markers.

Set the latitude of geographic markers.

Set or remove the coordinate system of the current drawing.
Convert the current drawing to the specified coordinate
system.

Display the coordinate system of the current graphic

application.
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